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NetWitness Log Parser Tool

NetWitness Log Parser Tool Overview

The NetWitness Log Parser Tool (NWLPT) is a graphical tool that enables you to create and edit
log parsers that run on the NetWitness Log Decoder. Using the NetWitness Log Parser Tool,
you can define how a NetWitness Log Decoder identifies, parses, and extracts information from
the events of a specific event source. These parser definitions are stored as an XML file, called
a log parser XML file, which is deployed on the NetWitness platform.

You can create a new log parser for an event source that is not currently supported by
NetWitness. You can also edit an existing log parser to add or edit definitions for events, or to
correct errors. You may need to edit an log parser in one of the following situations:

o Upgrade to a new version of an event source that contains new, updated, or deprecated log

messages.
o Include additional definitions in existing events.

o Update the definition for an existing event in a log parser.

Parser Structure

The NetWitness Log Parser Tool uses the device type of the log parser to create the structure
for the parser. The NetWitness Log Parser Tool also appends the device type to the directory
that you specify for your parser.

When you create a log parser, you select a device type for it. The device type must start with a
letter. The RSA naming convention is to make the device type all lowercase and remove the
spaces. For example, Cisco ASA would have the device type ciscoasa. It is not necessary to
follow the RSA naming convention to use this tool.

In your log parser directory, the NetWitness Log Parser Tool creates two files with the correct
name for NetWitness:

o INI file. This is the parser configuration file. (Example: ciscoasa.ini)

o XML file. This is the log parser XML file that contains the parser definitions. (Example:

ciscoasamsg.xml). The device type is appended with msg.

Both of these files are required to deploy your parser in NetWitness.

When you finish creating or updating your parser, you have the option of retrieving the

completed parser in four formats:

o Individual Files: Parser ((XML) and Configuration (.INI) (In the main menu, select File >
Save or Save As). This option creates a device type folder containing an XML file and a

configuration INI file. These individual files are viewable as the raw parser and configuration
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files, but they cannot be imported directly in the NetWitness Log Decoder.

o Parser Package: .envision (In the main menu, select Actions > Export Parser). This option
creates an event source package that consists of the log parser XML and configuration INI

file. This format is used to import the event source to a Log Decoder directly.

o Live Resource: .zip (In the main menu, select Actions > Export Resource). This option
creates an event source package in a .zip format that consists of all the log parser XMLs and
configuration INI files. The .zip format can be used to deploy parsers through RSA Live. It

enables deployment of parsers to multiple Log Decoders simultaneously.

o To deploy a parser on a Log Decoder (In the main menu, select Actions > Deploy Parser).
This option enables you to deploy the parser directly to the Log Decoder. It also supports
deployment of parsers to multiple Log Decoders simultaneously. For more information, see

Deploying Parsers on a Log Decoder.

For more information, see the "Download Log Parsers from Live and Deploy from Local
Network" topic in the RSA Content and Resources on how to upload the event source log parsers
from your local network to the NetWitness Log Decoder.

For more information, see the "Resource Package Deployment Wizard" topic in the Live
Services Management Guide for Version 11.1 for information on how to upload the event source
log parsers from your local network to the NetWitness Log Decoder at the following location:
https://community.rsa.com/docs/DOC-79989

For more information, see the "Enable and Disable Parsers and Log Parsers" topic in the
Decoder and Log Decoder Configuration Guide for Version 11.x at the following location:
https://community.rsa.com/docs/DOC-80190.

Obtaining a Log File

To create a log parser that a NetWitness Log Decoder can use to identify, parse, and extract

information from a specific event source, you must obtain a log file from the event source that
you want to integrate with NetWitness. After you obtain the log file, you can use NetWitness
Log Parser Tool to create a log parser.

Before getting started with NetWitness Log Parser Tool, you must know the log collection
protocol that was configured when the event source was deployed with NetWitness.

If the log collection protocol that you configured when you set up the event source in NetWitness
is Syslog, you can use a log file generated by the event source to create or edit a log parser.

If you configured any other log collection protocol, you must export a log file from NetWitness
in text format.

NetWitness Log Parser Tool Overview 6
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RSA recommends that you compile a log file that contains all the unique events generated by the
event source that you want to integrate with NetWitness. While compiling the log file, ensure
that:

o All the events are from a single event source.
o Each event is listed in a single line, without any line breaks.
o The maximum size of any event is 64 KB.

o The log file contains one or two instances of each unique event.

Note: The recommended maximum size of the log file is 25 MB. A larger file can be used,
but it will take more time to load and parse.

For events transmitted by Syslog, you can put the raw logs directly in the NetWitness Log Parser
Tool. For all other event formats, you need to get the log data from NetWitness.
To get log data from NetWitness, see Understanding Events.

Understanding Events

Typically an event consists of two main elements, a header and a payload. The following figure
shows an example of an event with a header and a payload.

Header

4

Apr 19 2005 124722 WPL-7-72004%9 (VEI-Secondary) FSM action
trace end: state=Dizabled, last event=H& TUNENOWIN EVENT,
return=0, func=wpnfo fam disable.

Figure 1. Payload

In some events, you may define the entire event as payload as shown in the following figure.

Payload

Id = 713129: Group = 10.7.7.134, IF = 10.7.7.134, Received
unexpected Transaction Exchange payload type: payload id

Figure 2.

In some events, you may define the payload to begin from the header, and the header and
payload may overlap.

Header Payload

f

Jun 07 2006 21:01:17: %PIE-6-106025: Failed to determine
Securlity contexXt for packet: wvlanZl udp sre 10.192.5.155/1076
dest 10.193.72.212/358293

Figure 3.
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Header
The header consists of the following elements, which are common across multiple events:

MessagelD . Indicates a unique identifier for the message in the event. In the examples in
the following figures, the MessagelD is unique to the event.

Note: Make sure to define a single MessagelD for each header.

Message ID

Apr 19 2005 194722 %PR-T-720049 (VPN -Secondary) FEW action
trace end: state=Dhsabled, last event=H& TTNEMNCOWI EVENT,
return=0, func=wpnfo fim disable.

Meszage ID

4
Jan 01 11:06:39 [10.5.92.01]1d - 713129 Group = 10.77.7.134, IP =
1077134, Eecetved unexpected Transaction Exchange pavload type:
pavlead 1d

Caution: If you create a header that is too generic and can be used to identify a wide variety
of logs, it could match logs that are currently parsed through other parsers.

. (Optional) Consists of the date and time when the event was generated by the event
source. Some events may not contain an event source time stamp.

Event zource time stamp

A
Apr 19 2005 194722 WMPR-T-720049: (WVPN-Secondary) FS action
trace end: state=Dhsabled, last event=HA TINENCOWI EVENT,
return=0, func=vpnfo fam dizable.

Header Variable. (Optional) Contains a value in the event header that varies across similar
types of events. In the examples in the following figures, 4874 and 4921 are header variables
that indicate the session ID in the events.

Header variakle

Feb 11 04:20:16 [10.10.1.1] Socksd|48747: TCP Connection Eequest: Connect
(17230 214337444 to 172,320,323 2380 for user root

Header variakle

4
Feb 11 04:20:16 [10.10.1.1] Socksd|49217: TCP Connection Eedquest: Connect
(172530 214337445 to 17230 32 92:80) for user root

Payload

NetWitness Log Parser Tool Overview 8
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The payload is everything in the event that is not the header. It contains detailed information
about the event. The payload is the message in the event. NetWitness uses this information for
analysis and reporting. The payload consists of message variables and static text.

A message variable is a value in the payload that varies across similar types of events. In the
examples in the following figures, Up and Down are message variables that indicate the link
status of the INTNAME interface.

Tan 01 11:06:39 [10.5.92.51] %PD-1- 105006: (Primary) Link status Tp
on mterface TNTHADE.
Meszage
Figure 4. variable
Jan 01 11:37:09 [10.2.92.51] “P1C-1-105006: (Pamary) Link status Down
on intetface INTHAME.
Meszage
Figure 5. variahle

NetWitness Log Parser Tool classifies all the values in the payload that are not message
variables as static text. The following figure shows an example of values that NetWitness Log
Parser Tool classifies as static text.

Tan 01 11:06:39 [10.5.92.51] %PTH-1-105006 (Primary) Link status Tp

on mterface INTH AME.
Static text

“Watiable text

How Logs are Parsed in NetWitness

The following figure shows an example of how you can create an XML definition that makes the
event data available for analysis and reporting in NetWitness. It also shows the various elements
in an XML definition.

9 NetWitness Log Parser Tool Overview
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Jun 30 2007 20:03:13: %PIX-6-109005: Authentication succeaded for user bdavls from 20.20.20.2/20 ta 10101001710,
Header ¢

Jun 30 2007 20:03:13: %PIX-6-109005
Event analysis

Payload ¢

Authentication succeeded for user bdavis from 20.20.20.2/20 to 10.10.10.1/10

| Jun 30 2007 20:03:13

HPIX | 108005 |

Authentication succeeded for user| bdavis |frum | 20.20.20.2 | ! o | 10.10.10.1 | |
. y Header Event Message Message Message Message Message
Elements in the event Time stamp variabla I} variabla variabla variabla variabla variabla
[ I I I ]
Header Severity Event
User-defined elements I} A, Message ID level categary
L ¥ ‘ ‘ + * r
_ - || Message variable=username,
o atrues o | | Tos st || er || et B magio-oonesar | | Sovety || Evrcaeooy | ™ s stanr
T ) dtransaddr, diranspaort
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Getting Started with NetWitness Log Parser Tool

The following table provides a high-level overview of the tasks that you can perform using
NetWitness Log Parser Tool.

T

Integrate an 1. Create a Creating a Log Parser File
event parser file that
source that  contains
is not definitions for
supported the events
by generated by
NetWitness. the event
source.
2. (Optional) Viewing Parsed Events and Associated Definitions

View events
that are parsed
by a header or
message
definition.

3. (Optional) Viewing Parsed Events and Associated Definitions
View the

header and

message

definition that

parse a selected

event.

4. Create an Parser Structure
event source

package for

deployment to a

NetWitness

Log Decoder.

5. In Deploying Parsers on a Log Decoder

NetWitness, See the "Add or Update Supported Event Source Log
deploy the Parsers" topic in the RSA Content and Resources

SVEL SENTOE documentation. The "Download Log Parsers from Live and
package.

Deploy from Local Network" section provides information on
how to upload the event source log parsers from your local
network to the NetWitness Log Decoder.
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N T

Upgrade an 1. Edit the Editing a Log Parser File
event existing log

source that  parser file.

is already

supported )
by View events

that are parsed
by a header or
message
definition.

2. (Optional) Viewing Parsed Events and Associated Definitions

NetWitness.

3. (Optional) Viewing Parsed Events and Associated Definitions
View the

header and

message

definition that

parse a selected

event.

4. In Deploying Parsers on a Log Decoder
NetWitness,

See the "Add or Update Supported Event Source Log

deploy the Parsers" topic in the RSA Content and Resources
EyentiSource documentation. The "Download Log Parsers from Live and
package.

Deploy from Local Network" section provides information on
how to upload the event source log parsers from your local
network to the NetWitness Log Decoder.

Getting a Log File from NetWitness

1. In the NetWitness menu, go to Investigate > Events.

2. In the Investigate dialog, select a Log Decoder, Archiver, Concentrator, or Broker service
and click Eventsin the Events view, select the events and in the Actions menu, select
Export > Export All Logs.

3. Inthe Enter file name for extraction dialog, enter a name for your log file and click OK.

4. In the Export Log Format dialog, select Text and click Export.

You will receive a Scheduled Job notice.

5. Check the Job Notifications tray to view the status of the log file. Click the View link to go
the Jobs panel in the Profile view to download the log file.

Getting Started with NetWitness Log Parser Tool 12
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Creating a Log Parser File

Creating a log parser file involves creating a definition for each type of event in the log file
generated by an event source. Creating an event definition involves the following tasks:

o Selecting an Event from the Log File

e Defining a Header

e Defining a Message

Selecting an Event from the Log File

Select an event from the log file to define the various elements of the header and message in the
event.

Defining a Header

Define the header by assigning the values in the event to header elements. The purpose of
defining a header is to identify the event source from which the event is generated. When you
define a header with all its elements, the definition can parse similar types of events in the log
file.

RSA recommends that you define a generic header definition that will parse multiple events that
follow similar formats. The NetWitness Log Parser Tool generates a unique identifier, the
HeaderID, for each header definition to identify the header definitions available in the log parser
XML file. However, you can change the generated identifier to provide a unique HeaderID of
your choice.

You can include the following elements when defining how to locate the MessagelD in the
header:

o MessagelD, used in the Event ID lookup, which enables you to specify one of the following

options:
o MessagelD variable
o Variable suffix

o Concatenation

Header Order

Header order determines the precedence of the headers. In general, headers should be ordered
from specific to generic (see Validating the Precedence of Pattern Definitions ).

13 Getting Started with NetWitness Log Parser Tool
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A header's position can be changed by selecting the header and using Move Up/Down menu
items on the Edit menu (or using the keyboard shortcuts for the up and down arrow keys

(Ctrl+Up f and Ctrl+Down ‘" ). You can also right click on a header or message to bring
up a popup Context menu that has options to move up and down.

For more information on these elements, see Understanding Events.

Defining a Message

Define the message by assigning the values in the payload to message variables and defining
message elements. A single message definition may parse one or more similar events in your log
file.

The following table lists the message elements that you must define.

MessagelD

Indicates the identifier by which NetWitness identifies the event uniquely. The MessagelD can
be defined in one of the following ways:

¢ Same as the event ID.

o A combination of the event ID defined in the header definition and a unique variant. For
example, if the event ID is 109801, the MessageID can be defined as 109801:02.

o A brief description that identifies the event. For example, in the following event, the event ID
is 187698, and the MessagelD can be defined as CableFailover.

Jan 01 11:06:39 [10.5.92.51] %PIX-1-101001: (PRIORITY) Error
reading failover cable status.

Note: Make sure to define a single MessagelD for each header.

Event category

Indicates the category to which the event belongs, based on the NetWitness taxonomy.

Functions (Optional)

Define actions to be performed on variables in an event to generate user-defined values.

The following figure shows the list of functions supported by Log Parser Tool.

Getting Started with NetWitness Log Parser Tool 14



NetWitness Log Parser Tool

File Actions Edit View Help

v20_junosroutermsg.xmi= [

He Messages

"
S [ process | trens ip | process_id | url | event type | saddr | action | : ] resuit | FD4 | HFLD3 | Reytes | soytes I Bytes
DFWD_PARSE_STAT... o o

| Assignthevalue | $TD1 3 1
ECCD_DUPLICATE ‘Assign the header variable |+ 111 | [

ECCD_LOOP_EXIT_F... [Assion thevariable [ 2R o7} i 3
L e |
ECCD_NOT_ROOT

Assign the event text up to the first occurance of

Content.Web Traffic v ‘ Name Value Pairs Allow Missing H

ECCD_DAEMONIZE ...

ECCD_PCI_FILE_OP...

ECCD_PCI_READ_FA...
< ECCD_PCI_WRITE_F...
ECCD_PID_FILE_LOCK

ECCD_PID_FILE UP...  [Remove outer quates from | o & 5" ‘and assign the resultto | 1010 |

ECCD_TRACE_FILE. '~ part of the URL in the variable

ECCD_usage

EVENT
EVENTD_AUDIT_SH...
FLOW_REASSEMBLE...

FLOW_REASSEMBLE...

v

ALL EVENTS (6)

|Headers: 42, Messages: 736 Last Auto Saved At: 15:10:18 Custom Parser : Disabled |

To access this page, log in to Log parser Tool.

1. Go to Messages > Message ID.

2. Click

3. Right click on the screen > select Add functions.

Note: Make sure all the meta values are in lower case.

Below is the list of the NetWitness Log Parser Tool functions:

Serial Number Description
1 Assign Constant It assigns user-defined values to variables.
2 Assign Header It assigns the value of a header variable to another
Variable variable.
3 Assign Message It assigns the value of a message variable to
Variable another variable.
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4 Assign System vari- It assigns the value of a system variable to another
able variable.
5 Assign Context It assigns the event text up to the first occurrence

of the variable

6 Calculation It performs a calculation on values and variables in
the event.

7 Convert [P It converts IP addresses.

8 Convert Domain It converts domain names to IP addresses.

9 Direction Check It assigns direction to a variable

10 Duration It extracts value for specific time.

11 Event Time It assigns the date and time information in the

event to a message variable.
12 Remove Quotes It removes quotes from a variable.

13 URL Part It extracts parts of a URL string.

Message Order

All messages are displayed in order by message group. Messages with differing message group
values cannot be re-ordered. However, messages with the same group can be re-ordered, as
order determines the precedence within the group. In general, messages within a group should be
ordered from specific to generic (see Validating the Precedence of Pattern Definitions

When applicable, a message's position within its message group can be changed by selecting the
message and using the Move Up/Move Down menu items on the Edit menu (or using the

keyboard shortcuts for the up and down arrow keys (Ctrl+Up ' and Ctrl+Down "" ). You
can also right-click to open a context menu with the Move Up/Move Down options.

When creating a new message or editing the group of an existing message, the message is
(re)positioned based on the new message group value. If there are existing messages with that
group value, the message is positioned at the end of the message group.

Getting Started with NetWitness Log Parser Tool 16
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Editing a Log Parser File

Before you edit a log parser file, identify and analyze the events in the corresponding log file.
You can edit a log parser file that was created by the NetWitness Log Parser Tool or any other
source.

Editing a log parser file involves the same header and message definition tasks as creating a log
parser file. However, you may not need to define the header pattern if the headers are all
defined. For example, you may want to edit a parser to add new messages to Windows or other
platforms. You may also want to adjust an existing parsed message. For example, you may need
to change IP source to IP destination in a particular event.

Validating the Precedence of Pattern Definitions

It is important to consider the precedence of pattern definitions when defining headers and
messages with the same event ID.

Y ou must arrange the definitions in the log parser file in order from specific to generic so that
events are parsed against the specific header or message definition.

For example, suppose that a log parser file contains the following message definitions:

o Message 10123 <A B C >, where A, B, and C are elements in the message

e Message 10124 <A B C D >, where A, B, C, and D are elements in the message

If the order of the message definitions is as shown, NetWitness parses an A B C event from the
event source using the Message 10123 definition. NetWitness also parses an A B C D event
from the event source using the Message 10123 definition. The A B C D event must be parsed
against the Message 10124 definition, which is specific. Therefore, you must ensure that the
specific definition, Message 10124, appears before the generic definition, Message 10123, in the
log parser file, as follows:

o Message 10124 <A B C D>

e Message 10123 <A BC>

After validating the log parser for data pattern warnings, you must validate the precedence of the
header and message definitions in the log parser file.

The NetWitness Log Parser Tool displays the errors that occur in the header and message
definition order. For better analysis and reporting, you must resolve all the precedence errors.

Viewing Parsed Events and Associated Definitions

After defining the log parser , you can view the highlighted header and message definitions in
the parsed logs within the NetWitness Log Parser Tool. You can also view the header and
message definition for a selected event in the log file.

17 Getting Started with NetWitness Log Parser Tool
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While defining the log parser, you can view parsed events and the associated header and
message definitions. For example, if you have defined two header definitions and one message
definition in the log parser file, you can view parsed events for these definitions, and then
continue to define more header and message definitions depending on the parsed events already
viewed.

Custom Table Map Files

If you changed the table map file (table-map.xml) or created a custom table map file (table-
map-custom.xml), get the changed table mapping files from NetWitness. You can add these
custom table map files to the NetWitness Log Parser Tool.

GitHub Community Link

The GitHub Community link provides access to a repository where you can share and contribute
event source log parsers for the NetWitness Log Decoder.

To access the GitHub Community Link:

1. From the GitHub Welcome screen, go to Help > Parser Community. You can also use the

keyboard shortcut F3 to access the GitHub Community Link.
The GitHub Welcome screen is displayed.

O Features Business Explore Marketplace Pricing This repository Sign in o/ Sign up

[ netwitness / nw-logparsers ©watch 14 Ksar 8 | YFork 3

<> Code Issues 0 Pull requests 1 Projects 0 Insights

E:I Join GitHub today Dismiss

GitHub is home to over 20 million developers working together to host and
review code, manage projects, and build software together.

Netwitness Log Parsers

D 151 commits ¥ 2 branches © 0 releases 22 4 contributors &s Apache-2.0

GitHub members can contribute to the repository by adding or editing a log parser by raising a
Pull Request that is reviewed by NetWitness Engineers. As a member of the GitHub community,
you can create a new log parser for an event source that is not currently supported by
NetWitness and share it with the NetWitness community. You can also edit an existing log
parser to add or edit definitions for events, or to correct errors.

Y ou may need to edit an log parser in one of the following situations:

e You upgrade to a new version of an event source that contains new, updated, or deprecated

event messages.

Getting Started with NetWitness Log Parser Tool 18
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e You want to include additional definitions for existing events.

e You want to update the definition for an existing event in a log parser.

19 Getting Started with NetWitness Log Parser Tool
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The following figure shows the workflow of the NetWitness Log Parser Tool 1.1 user interface.

Create/ Edit an Event

Define Messages for Export/Save and

Open a Log File Define Headers for Events —— Deploy the Parser Files

Source Log Parser

This workflow shows the procedures to install LPT and create a log parser.

Set Up Create a Log Customize a

Preferences Parser Log Parser

What do you want to do?

Administrator Install LPT Installing the NetWitness Log Parser Tool
Administrator Set up Preferences Setting Preferences

Content Expert ~ Create a Log Parser Creating a Log Parser

Content Expert Customize a Log Parser (For 1.1 version) Creating a Custom Parser

Installing the NetWitness Log Parser Tool

Y ou can download the Windows and MacOS versions of the NetWitness Log Parser Tool. Also,
if you are using a Beta version of the Event Source Integrator Tool, you need to uninstall and
download the new NetWitness Log Parser Tool installer.

In either case, the RSA NetWitness Log Parser Tool downloads are available on RSA Link at
the following location: https://community.rsa.com/docs/DOC-85202

Note: The Recent Parsers and Open Recent sections are empty, since this is a new installer.

Setting Preferences

The Preferences dialog allows you to provide paths for logs and parsers, and to select a parsing
mode for the application.

Note: The default path is your Documents folder and the default parsing mode is Auto.
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To access the Preferences settings:

o For Windows systems: From the main menu, go to File > Preferences.

o For MacOS systems: From the NetWitness Log Parser Tool menu, select Preferences.

An example of the Preferences settings is shown below.

Preferences

PREFERRED DEVICE LOCATION *
PREFERRED LOG FILE LOCATION *

Parse On Demand (Use To Parse)
Save Modifications to Custom Parser

Cancel

The default paths and modes are explained in the following table.

oo~

Preferred Device o Default directory that is opened when you open an existing parser.
Location o The default directory is the location where a new parser is created.

o Imported parsers are saved in this directory by default.

Preferred Log File ~ Directory that the NetWitness Log Parser Tool opens when you want to

Location load a log file.

Parsing Mode By default, the NetWitness Log Parser Tool uses Continuous Parse
mode, which means the log file is reparsed whenever there is a change
to the parser.

Note: You can change the mode to Parse On Demand if you notice
that it is taking a while to parse the log file. A Play icon () is dis-

played in the middle divider that can be used to parse the log when a suf-
ficient number of changes is complete. You can also use the F5

keyboard shortcut to facilitate log file parsing.
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e et

(For 1.1 version) When this check box is enabled, all the changes in the log parser file
Save will be saved in custom parser file. This option will be ignored if the

Modifications to custom parser already exists and all the changes are saved in the

Custom Parser custom file.

Note: When a custom parser file is opened, the tool displays the merged entries of the log
parser and the custom parser.

Caution: A user cannot open a custom parser file when log parser file is not available.

Creating a Log Parser

Note: All parsers opened in the tool are automatically saved at 30 seconds intervals as serves
as a backup. You can view the last saved time in the Status Bar.

To create a new parser, follow these steps.

1. Select Create New Parser.

NETWITNESS LOG PARSER TOOL

Create New Parser Recent Parsers

[=] ciscosecureacsmsg.xml
Open Existing Parser [=] v20_ciscopixmsg.xml

[= 41msg.xml

[=] newdevicelmsg.xmi

[=] v20_ldos-junasroutermsg.xm

[=] ciscowecsmsg_test.xml

[=1 v20_avectomsg.xml

[=) taagvaltabmsg.xm

The Create New Parser dialog is displayed.
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Create New Parser X

The Device Type will determine the file and directory name of the parser.
DEVICE TYPE *

DEVICE DISPLAY NAME

DEVICE CLASS *

DEVICE LOCATION *

Cancel

2. Inthe Create New Parser dialog:
a. Enter the Device Type. The Device Type must start with a letter. The RSA naming
convention is to make the device type all lowercase and remove the spaces. For example,
Cisco ASA would have the device type ciscoasa and Actiance Advantage would be
actianceadvantage. It is not necessary to follow the RSA naming convention to use this tool.

The device type provides additional information about the event.

Note: Special characters are not allowed for the Device Type.

b. Enter the Device Display Name. For example, Cisco ASA.

c. Select a Device Class from the drop-down menu. For example, Firewall.

d. In the Device Location field, specify the directory where you want to create the
parser. In the directory that you specify, the NetWitness Log Parser Tool creates
two files with the correct name for NetWitness:

INI file (Example: ciscoasa.ini)

XML file (Example: ciscoasamsg.xml) The device type is appended
with msg.

Note: The parser path that is set in the Preference page is auto-
populated here.
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3. Click Create to create a new parser, or click Cancel to return to the Welcome page.

e. In the Log File field, select a log file. This field is optional and can be selected

at a later time.

The following screen is displayed after you select Create New Parser.

ciscoasamsg.xml £

er Details

HEADER ID

ALL EVENTS (0)

PATTERN

Headers

Get Started

In order to define your parser you need to open a log file with
the data to be parsed.

You can either click on the Open/Change the Log File button
or drag and drop files or text here.

Headers 10, Messages 10

Lost Auto Saved At: 200600

4. Click the Open/Change Log File icon (I'.'I). Browse to find the log file that you want to open
and click Open.

For more information, see Opening a Log File

All the events in the selected log file are displayed, as shown in the following example.

May 14 08:

May 14 08:

May 14 O8:

May 14 O8:

May 14 08:

May 14 08:

May 14 08:

May 14 08:

May 14 08:

May 14 O8:

May 14 08:

May 14 08:

May 14 08:

May 14 08:

May 14 0s:

® vay 14 0s:

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

00:00

[10.172.

110.172.

110.172.

110.172.

110.172.

110.172.

[10.172.

[10.172.

110.172.

110.172.

110.172.

[10.172.

[10.172.

[10.172.

110.172.

110.172.

e

s

s

..

e

e

s

..

e

e

5.

May 14

Moy 14

Mey 14

May 14

May 14

May 14

May 14

Moy 14

Mey 14

May 14

May 14

May 14

May 14

Moy 14

Mey 14

May 14

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

2013

11:59:58:

11:59:59:

11:59:50:

11:59:50:

11:59:59:

11:58:58:

11:58:58:

11:59:59:

11:59:50:

11:59:50:

11:59:59:

11:58:58:

11:58:58:

11:59:59:

11:59:50:

11:59:50:

ASA-6-302013:

*85A-6-302013:

+n3A-6-302013:

AASA-6-302013:

ASA-6-302013:

AASA-6-302013:

ASA-6-302013:

*85A-6-302013:

+hSA-6-302013:

AASA-6-302013:

4ASA-6-302013:

AASA-6-302013:

ASA-6-3020131

85A-6-302013:

+nSA-6-302013:

Built outbound TCE connection 3442210868

Builc outbound TCP connection 3442210863

Built outbound TCP connection 3442210872

Built outbound TCP connection 3442210878

Built outbound ICP connection 3442210885

Built ourbound TCE connection 3442210886

Built ourbound ICE connection 3442210891

Builc outbound TCP connection 3442210892

Built outbound TCP connection 3442210893

Built outbound TCP connection 3442210895

Built outbound ICP connection 3442210901

Built ourbound TCB connection 3442210302

Built outbound ICE connection 3442210903

Built outbound TCP connection 3442210904

Built outbound TCP connection 3442210906

Built outbound TCP connection 3442210908

for outside:

for oucside

for oucside:

for outside:

for outside:

for outside:

for oucside:

for oucside

for

£ enter textorrecex o it

170.146.234.214/443 (170.146.234.214/443) To inside:10.173.9.44/58066 (170.146.225.4/61196)

£170.146.234.26/443 (170.146.234.26/443) to inside:10.206.9.178/58730 (170.146.225.4/61198)

159.53.52.106/443 (159.53.52.106/443) o inside:10.172.9.42/52952 (170.146.225.4/61200)
170.146.247.8/443 (170.146.247.8/443) o inside:10.85.2.216/51975 (170.146.225.4/61201)

208.84.66.197/443 (208.84.66.197/443) to inside:10.172.9.67/39279 (170.146.225.4/61202)

for outside:66.196.116.162/80 (66.196.116.162/80) to inside:10.172.9.45/52390 (170.146.225.4/61203)

50.116.194.28/80 (50.116.194.28/80) to inside:10.172.9.41/55328 (170.146.225.4/61205)

74.63.51.119/80 (74.63.51.118/80) To inside:10.172.9.44/59746 (170.146.225.4/61208)

£50.116.194.28/80 (50.116.194.28/80) To inside:10.172.9.44/55289 (170.146.225.4/59448)

443 (66.133.120.125/443) to : 4.241.100/32630 4/61209)

for

20 80) to : 42/58053 4/61211)

for

71.124.125/80 (208.71.124.125/80) to inside:10.172.9.42/62535 (170.146.225.4/61212)

for outside:70.109.223.164/25 (70.109.223.164/25) to per0:172.26.243.106/34022 (170.146.224.16/34022)
for oucside:

for outside:

for

170.201.60.143/443 (170.201.60.143/443) to inside:10.172.9.45/50385 (170.146.225.4/61214)
170.146.247.8/443 (170.146.247.8/443) to inside:10.172.74.96/54028 (170.146.225.4/61215)

143/443 (170.201.60.143/443) to - .9.42/56286 61216)

Headers: 0, Messages

0

Last Auto Saved At: 20:00:00

(For 1.1 version) Creating a Custom Parser

Log Parsers can be customized by adding new parser elements or modifying existing ones. On

customization, you can save it as a separate custom parser file, such that the base parser can be
updated independently and customizations are applied on top of it.

NetWitness Log Parser Tool Workflow
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Note: The custom parser is not deleted or overwritten during Log Decoder upgrades or RSA
Live Content updates.

By default, log parser files of Log Decoder are located at
/etc/netwitness/ng/envision/etc/devices

The custom parser files are saved in the respective folder where the log parser files exists. For
example, ciscoasa parser file will be saved in following folder.

/etc/netwitness/ng/envision/etc/devices/ciscoasa

The custom parser file is an XML file and should be saved with a device name followed by "-
custom". For example ciscoasamsg-custom.xml

Note: Custom Parser is not supported in 11.0 version and is available in 10.6.5 or later and
11.1 and later versions.

Make sure you have enabled "Save Modifications to Custom Parser". For more information see
Preferences section

For more information, see "Log Parser Customization" at https://community.rsa.com/docs/DOC-
83425

Editing an Existing Parser

To edit an existing parser, follow these steps.

Note: If you opened your parser previously in the NetWitness Log Parser Tool, you can open
the parser from the Recent Parsers section of the Welcome screen.

1. Select Open Existing Parser and click Open.
The directory which is set as the default device location under Preferences is opened when
Open Existing Parser is selected.

The directory for NetWitness Log Parser Tool parsers is displayed.
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| ™ ciscopix
Home Share View
* U & Cut X J; g “1 New item ~ ok 14 Open ~ FH select all
W\ Copy path ﬂ Easy access ~ Edit = Select none
Pin to Quick Copy Paste Move Copy @ Delete Rename New Properties i 0 )
access [#] Paste shorteut " T - olior " @ History [ Invert selection
Clipboard Organize New Open Select
« v A > T
O Name Date modified Type Size
st Quick access
| ciscopix 3/20/2018 5:25 PM  Configuration setti... 6 KB
m Desktop »* = P /20, g
£ v20_ciscopixmsg 3/20/2018 4:58 PM XML Document 412 KB
4 Documents »* & N i
= v20_ciscopixmsg-custom 3/20/2018 5:25 PM XML Document 1KB
&= Pictures »*
Q’Syncplicity Folder #
4 Downloads *
ARCD

2. Type or select the name of the parser that you want to edit and click Open. For example,

ciscoasamsg.xml.

3. Edit the parser entries such as headers, messages or tagval for customization.

4. Go to File and click Save.

Note: All the custom parsers entries are highlighted in blue color as displayed in the image

RSA NetWitness Log Parser Tool - 5  x
file Actions Edit View Help
\20_iscoiportwsamsg.xml £

Headers

ser Details

HEADERID  PATTERN [22 Jafj ~
[ $CISCOTPORTWSA-4: | [

0003 (%CISCOIPORTNSA load:
Parser Version
In the Parser Details section there is a Parser Version field. If there is a specific version
associated with the parser, that version is displayed in the Parser Version field. You can also
manually change the Parser Version in the Parser Version field.
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Parser Details Headers Messages

Deploying Parsers on a Log Decoder

Using the NetWitness Log Parser Tool, you can deploy parsers on a Log Decoder by following
these steps:

1. Open the parser that you want to deploy on the Log Decoder.

2. Go to Actions > Deploy Parser.
The following pop-up dialog is displayed.

5| NwLPT

LOG DECODER IP *
USERMAME *

PASSWORD *

Cancel

3. Enter the IP address of the Log Decoder where you want to add the parser, along with the
credentials of the Log Decoder.
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4. Click Deploy to add the parser to the Log Decoder, or click Cancel to return to the previous

screen. After you click Deploy, the parser is added to the Log Decoder. And subsequently,
all log parsers are reloaded.

Note: These entries are not retained, all the fields must be re-entered every time this dialog is
opened.

Opening a Log File

Note: The first time you open the log file for a parser, the location that is set in Preferences
is the default location.

In the Log Data section, do one of the following to add a log file for parsing:

o Click Open/Change Log File icon.
o Drag and drop the log file.

o Drag and drop the text of a plain log.

Note: When a log file is open, you can change to a different log file using the Open/Change
Log File icon.

Auto Splitting Log Files

When you upload a log file, the following dialog is displayed if your log file exceeds 25 MB.
i Log File Size x

.

| Log File size is larger than the recommended limit, working with this application

¥ may perform a bit slow.
We can create srnaller chunks for you to continue,

Create Chunks| |Load Original File| | Cancel

The Log File Auto Splitting option allows you to split the size of a log file that exceeds 25 MB.

o Ifyou select Create Chunks, the log file is split into smaller sized files without affecting the
original log file.

o Ifyouselect Load Original File, the log file may load slowly, because it exceeds the

recommended maximum size of 25 MB.

o If you select Cancel, you can select a different log file to load.
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Note: If a file larger than 25 MB is used, it is recommended that you use On-Demand Parsing
so that the parser does not attempt to parse a large log file after every change.

Generating Parsing Summary Report

You can generate a report on the parsing details of the parser and log file that you loaded. This
report provides detailed information about the parsed messages and headers, as well as
information about unused headers and messages and top 10 meta values. The report opens
automatically in your default browser and is saved your Documents folder on your computer.

Note: Each time you generate a Parsing Summary Report, the existing report is overwritten. If
you want to retain the existing report, it is recommended that you re-name the generated
report.

To generate a report, follow these steps:

1. Open the parser associated with the report that you want to generate.

2. Open the log file that is associated with your selected parser. Note that if your log file is
extremely large, a dialog is displayed that asks if you want the log file broken into smaller
chunks.

3. Go to Actions > Generate Parsing Summary.

An example of the Generate Parsing Summary Report is shown below.
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NwLPT Parsing Summary Report

Device Parser : C:/
Device Log File : C:/

Overall Parsing Summary

This section gives the summary of the overall parsing for the selected log file against the device parser

Total Log(s) ed Log(s) rsed Log(s)

Header Parsing Summary

This section gives the summary for the Header(s) in the device parser. Primarily it summarizes the Top 10 used Headerld(s) and the list of Headerld
(s) that were unsed for this selected log file

Header Utilization = 18.18%

ing Log Count Matching Log Perc:
1 19 95.00
2 1 5.00

Unused HeaderTd(s)
0002, 0003, 0005, 0006, 0007, 0008, 0009, 0010, 0033

|
Message Parsing Summary

This section gives the summary for the Message(s) in the device parser. Primarily it summarizes the Top 10 used Messageld(s) and the list of
Messageld(s) that were unsed for this selected log file

Message Utilization = 1.73%

# Messageld Matching Log Count Matching Log Percentage
1 104002:01 2 10.00
2 101001 1 5.00
3 101002 1 5.00
4 101003 1 5.00
5 101004 1 5.00
6 101005 1 5.00
7 102001 1 5.00
8 103001 1 5.00
9 103002 1 5.00
10 103003 1 5.00

Unused Messageld(s)
105001, 105002, 105003, 105004, 105005, 105006, 105007, 105008, 105008, 105010, 105011, 105020, 105021, 105031, 105032, 105034,

Metas Parsing Summary

This section gives the summary for the metas in the device parser. Primarily it summarizes the Top 10 used metas

1 context 20
2 event_description 20
3 level 20
4 messageid 20
5 result 5
6 day 1
7 month 1
8 resultcode 1
9 time 1
10 year 1
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Status Bar

Within the NetWitness Log Parser Tool user interface, there is a status bar located at the bottom
of the page that displays the following information:

o Header and Message count
o Latest auto-save time

o Progress Bar that displays that Custom Parser is enabled or disabled.

The following example Status Bar shows the most recent time that a log file was auto-saved.

Headers: 12, Messages: 10 Last Auto Saved At: 15:38:13 Custom Parser: Enabled

Understanding the Log Data Section Workflow

The following figure shows the workflow of the Log Data section.

Undefined Header Defined Completely

Defined

After you have defined a new parser or opened a parser to edit, work from the Log Data section
to define the headers and messages. Events move from Undefined (Header and Message not
defined) to Header Defined (Message not defined) and then to Completely Defined (Header
and Message defined).

Note: All defined Headers and Messages can be duplicated. This allows a simplified parser
development where a similar pattern is needed for a Message or Header.

Determining the Parser Definition Method

There are two main methods to specify a parser definition depending upon the type of
information that you need to collect in the logs:

o Identify events with a specific type and extract generic information.

o Extract as much detailed information as possible from an event.

Example: Extract Generic Information

The following example shows how to create a parser that extracts generic information from a
Cisco ASA log. It uses the following event from the Cisco ASA log:
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$ASA-1-101001: (PRIORITY) Failover cable OK.

Defining the Header Pattern

To define the header pattern, follow these steps:

1. Select an undefined event.

2. Identify the text as the MessagelD and highlight it.

3. Click Create Header to create the header.

4. If you want to change the log file, then click the Open/Change Log File icon.

+PIX-1-101001: (PRIORITY) Failoves cable OK:

©  aPIX-1-101002:| (PRIORITY) Bad failover cable:
PIX-1-101003:  (PRIORITY) Failover cable not connected (this unit)

©  APIX-1-101004: (PRIORITY) Failover cable not comnected (other unit)
%PIX-1-101005: (PRIORTTY) Error reading failover cable status.

©  PIX-1-102001:f (ERIGRITY) Bower failure/System reload Geher side.

$PIX-1-103001: (BRIORITY) No respomse from other firewall (reason code = RESULT).

©  PIX-1-103002: (BRIORITY) Other firewall necwork interface 100 OK.
+PIX-1-103003: (BRIORITY) Other firewall necwork interface 100 failed.

© $PIX-1-103004: (BRIORITY) Other firewall reports this firewall failed.
$PIX-1-103005: (BRIORITY) Other firewall reporting failure.

©  sPIX-1-103006:| (Secondary) Mate version 5.2(9) is not compavible with ours 6.3(5)113.

> Sep 10 2007 20:56:12: PIX-1-103007: (Primary) Mate version 8.0(2) is not identical with ours 7.2(2)10.

©  APIX-1-104001: (BRIORITY) Switehing te ACTIVE  (cause +(REASON) .

> pIX-1-104001: (BRIORITY) Switehing to ACTIVE - REASON.

©  sprx-1-104007: (PRIGRITY) Suitching to STNDSY (cause: : CRESUER) .

Headers: 11, Messages : 1100 Lost Auto Saved At: 2008:37 c sktop/ESI_TESTING/ ity logs.bt

5. To start the payload, select the text to be marked as payload, right-click, then click Set as
Payload. Alternatively, place your cursor at the start of the payload, right-click, and select

Set as Payload.

HEADER ID | zpix-1- |[Ll | : (PRIORITY) Failover cable OK.
Create Vaniable  Ctrl+K

i " Sl As Messageld
'® Message ID messageid R

) Suffix: Starting offset: 3

() Concatenation:

6. Define a variable for anything that can change. To define a variable:

a. Highlight the text that you want to change to a variable.

b. Press CTRL+K (COMMAND+K for MacOS). You can also right-click to get a context

menu that provides an option to create a variable. The background changes to orange,

NetWitness Log Parser Tool Workflow 32



NetWitness Log Parser Tool

which indicates a variable.

This example shows changing 1 to a variable.

HEADER ID sprx—pi- | PN

Create Variable  Ctrl+K

= HDR1 Set As Messageld
©Message |, ioad Rewind
() Suffix: Starting offset: -
() Concatenation:

c. Start typing the name of the variable in the variable field, use the down and up arrow

keys to select the variable, and press ENTER or you can also double-click the variable

to select it.

ser Details Headers

R -

M level

= HDR1

OLC B0 messageid
() Suffix: Starting offset: =

) Concatenation:

7. To change where the payload starts, or to start at the header, right-click a variable and select
Payload Rewind. For example, right-click the Level variable and select Payload Rewind.
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The red box indicates a complete payload with a Message Header.

Parser Details Headers Messages

TEADERID messageid | payload
< HDR1
(® Message ID (@R o= e!

O Suffix: Starting offset: = =2

() Concatenation:

8. To change the MessagelD to a generic value:

a. Select Concatenation, type a generic text string in the text field, and press ENTER.

Parser Details Headers

HEADERTD  (“aprx- RN - )|

= HDR1 =
OMessage D (SRR

() Suffix: Starting offset: -

(® Concatenation: generi c'.—header|

Note: Each Header needs a MessagelD and a payload. Make sure to define a single
MessagelD for each header.

Note: The Create Message button in the log section is only enabled when the MessagelD and
Payload are defined.

Note: If you want to change your MessagelD, you may need to delete the header and recreate
it.
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Defining the Message Pattern

1. After the MessagelD and payload are defined in the event, the Create Message button is
enabled.
Click on the Create Message button. This takes you to the Messages tab with the payload

populated as the message.

2. In the message pattern, define variables for the values that you want to extract as meta. To

define a variable:

a. Highlight the text that you want to change to a variable and press CTRL+K
(COMMAND+K for MacOS). Or you can select the Create Variable option from the

context menu. The background changes to orange, which indicates a variable.

b. Start typing the name of variable in the variable field, use the down and up arrow keys to
select the variable, and press ENTER.

Parser Details Headers Messages

MESSAGE ID [ (PRIORITY) ] = cable OK. ]

B ec_activity |
Group: |generic—header |  EventCategory: |

= generic-header

Note: The variables that you define create meta in the Log Decoder.

3. Inthe Event Category field, select a generic category for the message. For example,
Other.Default.

< generic-header Group: Event Category: |Olher‘Defau\ﬁ d

The Group field populates from the header. The event shows as completely defined in the

Select an Event section.

4. To save your changes, select File > Save or File > Save As, or press Ctrl+S
(COMMAND+S for MacOS).

5. After you complete and save your changes, retrieve the completed parser.

You have a choice of three formats:
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« .envision (In the menu, select Actions > Export Parser) This option creates an event

source package that consists of the event source XML and configuration (INI) file.

o .zip (In the menu, select Actions > Export Resource) This option creates an event
source package in a .zip format that consists all the event source XMLs and configuration
INI files.

o Deploy the parser directly deployed from the Log Parser Tool to the Log Decoder.

From the main menu, select Actions > Deploy Parser.

6. Deploy the event source package in the NetWitness platform to integrate the event source.
RSA recommends that you first deploy the parser to a test system to verify that it parses log

traffic correctly.

Defining a Throw-away Variable

To add a throw-away field variable for information that you do not care about, create a variable

and give it a name that is not defined in the variable list, such as fld1, fld2, or fld3.

1. Highlight the text that you want to change to a variable and press CTRL+K
(COMMAND+K for Mac). You can also right-click to get a context menu that provides an

option to create a variable. The background changes to orange, which indicates a variable.

2. Type the name of the throw-away field. For example, fld1
Since throw-away fields are not in the mapping, the information contained will be removed

when parsing.

Security,rn= m cid= m aid= m

Adding a Constant Function

1. Right-click the box below the Group field and select Add Function > Assign Constant.
2. In the value field, type the value that you want to assign to the variable.

3. Inthe Set Variable field, type the name of a variable that was not previously selected.

Assign the value [ ] S Set Variable

Adding an Event Time Function

Use the Event Time function to change the format of an event source timestamp.
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Right-click the box below the Group field and select Add Function > Event Time.

2. Inthe Set Value field, type the format that you want to assign to the time variable. For
example, %0B %F %W %N:%U:%O0, which appears in the format Jan 27 2015 23:55:29.

3. Inthe from field, select whether to parse event time in this format from the message (MSG)
or from the header (HDR).

4. Right-click the Select Variable fields and select a variable from the list. To add additional

variables as required, right-click a variable and select Add.

Event time example:

Parseeventﬂmeas[ %B %F %W &N:%U:%0 ]MMMandaﬁgnmm

Event Time Function Formatting Characters

The following table shows the format characters that Log Decoder supports for the Event time
function.

%C Dates of this format: 04/20/05 14:01:57

%R Full Month Name (in English language), fixed width field: January,
February, March, April, May, June, July, August, September,
October, November, December

%B Abbreviated Month Name (in English language), fixed width field:
Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec

%M Numeric Month, fixed width field: 01, 02, 03, 04, 05, 06, 07, 08, 09,
10, 11, 12

%G Numeric Month Variable width field: 1, 2, 3, 4, 5, 6, 7, 8§, 9, 10, 11,
12

%D Numeric Month Day, fixed width field: 01, 02, 03, 04, 05, 06, 07, 08,

09, 10, ..... , 23, 24, 25, 26, 27, 28, 29, 31

%F Numeric Month Day Variable width field: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
..... , 23,24, 25, 26, 27, 28, 29, 31

%H Hour, fixed width field: 00-23
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%I Hour, fixed width field: 01-12

Note: Always use %P or %Q with this function to identify the time
is in AM or PM.

%N Hour: Variable width field: 1-12

%T Minute, fixed width field: 00-59

%U Minute: Variable width field: 0-59
%]J Julian day, fixed width field: 001-365
%P Alpha, fixed width field: AM or PM
%Q AM./P.M.

%S Seconds, fixed width field: 00-59
%0 Seconds, variable width field: 0-59
%Y Year: 00-99

%W Year, fixed width field: 0000-9999
%Z Time in 24 hour format, variable width field, Hours:Min:Sec (for

example: 4:23:49 or 16:23:00)
%A Number of days from the event time

%X Unix Time-Stamp (for example: 1424849941)

Adding a Custom Table Map

Note: If you changed the table mapping file (table-map.xml), or created a custom table
mapping file (table-map-custom.xml), you can upload this updated file to the NetWitness Log
Parser Tool.

To create a custom table map:

From the Welcome screen, select Actions > Import TableMap and choose the table-map that
you want to upload.
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File = Actions Edit View Help

Import Parser

Import TableMap

Export Parser

Export Resource

Parse Mow

Deploy Parser

Generate Parsing Summary

Note: Before your file is overwritten, a confirmation message is displayed in the dialog box if
you have already created a custom table map with the same name. This message does not
display if you are a uploading a table-map-custom.xml file for the first time.

Using Delete for a header or message

The Delete option allows you to delete a single header or message.

o To delete a header or message, press Ctrl+Del for Windows and Fn+Ctrl+Del for Mac OS

or from the main menu, select Edit>Delete.

o Select a log you want to delete, right click and select Delete

Using Move Up or Move down

The Move up and Move down options allow you to move a header or a message up and down as
per requirement. Using a Move Up option allows a message or a header to jump a position.
Using a Move Down option allows a message or a header to step down.

o To Move Up a header or a message, press Ctrl+Up for Windows and Fn+Ctrl+Upfor Mac

OS or from the main menu, select Edit>Move Up.

o To Move Down a header or a message, press Ctrl+Down for Windows and

Fn+Ctrl+Downfor Mac OS or from the main menu, select Edit>Move Down.

o Select a message definition or header definition, you want to move up or move down, right

click and select Move Up or Move Down

Using Duplicate for a header or message

The Duplicate options allows you to create a new message or header with identical information
to the original record.
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o To duplicate a header or message, press Ctrl+D for Windows and Fn+Ctrl+D for Mac OS

or from the main menu, select Edit>Duplicate.

o Select a log you want to duplicate, right click and select Duplicate

Using Undo and Redo

The Undo and Redo options allow you to undo and redo any number of commands while the
parser is being built or updated. Using the Undo option reverts to the last change that you made
to a single message or header. Using the Redo option allows you to make changes to a single
message or header.

o To Undo your changes, press CTRL + Z, or from the main menu, select Edit > Undo.

o To Redo your changes, press CTRL + Y, or from the main menu, select Edit > Redo.
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Log Filter Functionality

The following example shows the filter options that are available from the Log Filter drop-down
menu.

L Enter text or regEx to filter

Search For: A
T A

Logs (Default)
[Imeta

|:| Regex
[]Header 1d

[ Message Id

Log filter options are described in the following table.

Log Filter Option Description

Logs Searches for the selected value for log search. Searches for any
log that contains the selected search text. For example, you can
search for Bangalore. Search results include any logs that con-

tain Bangalore as part of a log.

Meta Searches for any meta in the logs section. For example, you can
search for the term username. Search results include logs that

contain username as part of a log.

Regex Searches for the selected regex pattern in the logs section. For
example, you can search for \d+\.\d+.* and the search results

include logs that contain IP addresses as part of the logs.

Header ID Searches for the selected HeaderID. For example, you can
search for a HeaderID that is listed as 0008. The search results
include the number of headers that contain 008* defined as part

of the header.
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Message ID Searches for the selected MessagelD. For example, you can

search for a MessagelD such as 04 TACACSAcc. The search

results include the number of messages that contain 04 _

TACACSAcc* defined as part of the message.

All

Searches for any logs, HeaderIDs, MessagelDs, variables,
meta, or regex that matches the selected search text. For
example, you can search for the text syslog, and the search

results include any logs, HeaderIDs, MessagelDs, variables,

meta, or regex that matches syslog.

The following example shows the search results for logs. The Search field and the Status Bar
Message Count fields are highlighted.

HEADER: HDR1  MESSAGE:
©  PIX-1-101002: [(PRIORITY) Bad failover cable.
® $PIX-1-101003: |(PRIORITY) Failover cable not connected (this unit)

® sPIX-1-101004: |(PRIORITY) Failover cable not comnected (other unit)

©  SPIX-1-101005: [(PRIORITY) Error reading failover cable status.

©  PIX-1-102001: |(PRIORITY) Power failure/System reload other side.

® PIX-1-103002: |(PRIORITY) Other firewall network interface 100 OK.
© PIX-1-103003: [(FRIORITY) Other firewall necwork interface 100 failed.
©  SPIX-1-103004: (PRIORITY) Other firewall reports this firewall failed.

® sPIX-1-103005: |(PRIORITY) Other firewall reporting failure.

©  SPIX-1-104001: [(PRIORITY) Switching to ACTIVE (cause: REASON) .
® =PIX-1-104001: |(BRIORITY) Switching to ACTIVE - REASON.

(PRIORITY) Switching to STNDBY (cause: RESULT).

®  +PIX-1-103006: (Secondary) Mate version 5.2(9) is not compatible with ours

® PIX-1-103001: |(PRIORITY) No response from other firewall (reason code = RESULT).

6.3(5)113.

10f19 Av| 7]

Headers: 1, Messages : 1 Lost Auto Saved At: 203322

TWiatching s

|

Log Filter Functionality
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Parser Header and Message Search Functionality

Within the Parser section, you can search on a HeaderID or Message Group by entering the

value in the search field.

Header Search Functionality

The following example shows the search options that are available from the Header Search

drop-down menu.

L+ Enter text to search

Search For:

[ al

Literal (Default)
[] variable

[ ] Header ID

Header Search options are described in the following table.

Header Search Option

Literal

Variable

HeaderID

All

Description

Default search option that matches literals. This option searches
for any literal within the Header section. For example, you can
search for Bangalore with this option selected. The search results
include the number of headers that contain Bangalore as part of a
literal.

Searches for any variable or meta defined in the Header section.
For example, you can search for saddr with this option selected.

The search results include the number of headers that contain

saddr defined as part of the header.

Searches for the selected HeaderID. For example, you can search
for a HeaderID that is listed as 0008. The search results include
the number of headers that contain 008* defined as part of the

header.

Searches for any selected text. For example, you can search for
the text syslog, and a search is performed on any literal, Head-

erlD, or variable that matches the selected search text.
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The following example shows the header search results.

HEADERID ~ PATTERN [ ooce 1of1avial

RN o | coy | ver ] time | peccr JREE] 1cve JOB] oot JEB] poios |
CE o | cov | ver ] e [RGB eve JGB] rsesoec JUBY poviond
CA - |2 (o JEB] esoo JEB] povioss |

> 0008 3 (Grese ) (D () D ()

Message Search Functionality

The following example shows the message search drop-down menu with the Literal option
selected.

¥ Enter text to search Q

Search For:

(] al

Literal {Default)
[] variable

[] category

|:| Message ID

[] Meszage Group

Message Search options are described in the following table.

Message Search Description
Option
Literal Default search option that matches literals. Default selected value

for Message searches. This option searches for any literal within
the Message section. For example, you can search for Bangalore
with this option selected. The search results include the number of

messages that contain Bangalore as part of a literal.

Variable Searches for any variable or meta defined in the Message section.
For example, you can search for saddr with this option selected.
The search results include the number of messages that contain

saddr defined as part of the message.
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Category Searches for a particular event category that is part of the selected
message. the search results include the number of messages that

contain Auth.Successful.* defined as part of the selected message.

MessagelD Searches for the selected MessagelD. For example, you can search
for a MessagelD such as 04 TACACSAcc. The search results
include the number of messages that contain 04 TACACSAcc*

defined as part of the message.

Message Group Searches for the selected Message Group. For example, you can
search for the text syslog. The search results include any literal,
MessagelD, variable, category, or Message Group that contain sys-
log.

All Searches for any selected text. For example, you can search for the
text
syslog, and a search is performed on any literal, MessagelD,

variable, category, or Message Group that matches the selected
search text.

The following example shows message search results.

Messages

MESSAGE ID MESSAGE GROUP PATTERN [ 0100 10f5Av[Q]
> 101001 101001 ) ™

101002 101002 J ()

101003 101003 - )

o108 o100 @3] o JOB] cor oo o

101005 101005 J O]
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Advanced Search Options

Note: To perform an advanced search, use &&, which is an AND condition that helps drill
down to your exact search pattern. This applies to all three advanced header and message
search options.

Note: When you are performing a combination search, it is an OR condition for the search.
The search begins after you press ENTER.

Note: The context menu for Headers and Messages has a new option called Parsed Logs that
displays all the logs parsing from the selected Header or Message.

Note: All search options listed below can be used individually, as well as with other search
options. The advanced search options can be used also be used in the logs section.

Advanced Log Filter Options

Note: When using the Advanced Search, you must select All from the Log Filter drop-down
menu.

The following table shows the advanced log filter options.

Message
Description

Search Option

Header Search If you need to filter logs that parse with a specific header, use the @hid
option, followed by the HeaderID (for example, @hid:0001).

Message Search If you need to filter logs that parse with a specific header, use the @hid
option, followed by the HeaderID (for example, @hid:0001).

Variable Name If you want to filter logs that contain a specific variable or meta item,
Search use the @<Variable-name> @saddr option. This option lists all logs

that contain saddr meta keys.

Variable Value If you want to filter logs that have a specific variable value, use the

Search @<variable-name>:<variable-value> option (for example,
@dport:10). This option lists all logs with a value of meta key dport as
10.
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Message
Description

Search Option

Regex Search If you want to search the logs using a regex, use the @regex option (for
example, @regex:\d+\.\d+.* This option displays all logs that contain

an IP address.

Free Text Search  If you use this option, any text provided will be searched in the logs.
If two words are provided, both of them are searched separately
(similar to the way that Google performs text searches). As an
example, if you enter the words rsa bangalore, rsa and bangalore
are searched separately and all logs containing either word are
displayed.

Note: If you want to search on terms as though they are in a sentence, you need to enclose
your search query in quotation marks (for example, ""rsa bangalore").

If the search query is not properly enclosed within quotation marks, the error is not
automatically corrected, and no error message is displayed.

Note that when you search on a header, message, variable name or variable value, by default all
searches only perform a contains match. For example, if you enter the search text @hid:0001,
all headers containing id 0001, 0001:01, 0001:02, and so on will be displayed. If you want an
exact match, the query should be entered as @hid:"0001" so that only logs that match header-
id 0001 are displayed.

Advanced Header Search

The following table shows the advanced header search options.

Advanced Header
Description

Search Option

@id: Searches for the selected HeaderID.
Syntax: @id:<header>id>, where header_id is the HeaderID
that you are searching for.
For example, @id:0008 displays the number of headers that
contain 0008* defined as headers that you can search.
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Advanced Header

Search Option

Description

@var:

@literal:

Searches for any variable or meta defined in the header section.
Syntax: @var:<variable>, where variable is the variable or meta
to search.

For example: @var:saddr displays the number of headers that

contain saddr defined as a part of the header that you can search.

Searches for any literal content in the header section.
Syntax: @literal:<text>, where text is the literal to search.
For example, Bangalore displays the number of headers that
contain Bangalore as part of the literal that you can search.

Advanced Message Search

Advanced message search options are explained in the following table.

Advanced Message

Search Option

Description

@id:

@var:

@literal:

Searches for the selected MessagelD.

Syntax: @id:<message id>, where message id is the MessagelD
that you are searching for.

For example, @id:04_TACACSAcc displays the number of
messages that contain 04 TACACSAcc* defined as messages
that you can search.

Searches for any variable or meta defined in the header section.
Syntax: @var:<variable>, where variable is the variable or meta
to search.

For example: @var:saddr displays the number of headers that
contain saddr defined as a part of the header that you can search.
Searches for any literal content in the message section.

Syntax: @literal:<text>, where text is the literal to search.

For example, Bangalore displays the number of messages that
contain Bangalore as part of the literal that you can search.

Advanced Search Options
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TAGVALMAP Feature

The <TAGVALMAP> feature is an advanced feature that enables easy parsing of event logs
using the <TAGVAL> format. The parsing of <TAGVAL> logs is different from other logs, as
the Log Decoder allows listing all Tag=value in a single MessagelD where the tags can display
in any order in the log.

Using the TAGVALMAP Feature

Using the <TAGVALMAP> feature saves you from writing different messages for the same
MessagelD if your log messages only differ in the order of variables within the payload, or if
some parameters do not show up in the payload.

When you define your delimiters, the parser does not work the same way by matching the
payload character by character, but the payload string is split around the delimiters into ><key-
value pairs. For every <key-value> pair, the static text is matched against the appropriate key
and the value goes to the corresponding parameter in the table.

There are types of event logs where the part logs have a pattern of <tag-value> (<name-value),
which means the the tag parts remain the same, but the value is changed.

The Entry Separator has a maximum limit of three characters, while Entry Escape and Name
Value Escape allow only one character.

The following example shows a TAGV AL parameter in the Parser Details section.

Parser Details Headers Messages

DEVICE

After you save the data, the corresponding XML file content looks similar to the following
example:

<TAGVALMAP
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pairdelimiter=","
encapsulator="""
valuedelimiter="="
escapeValueDelim=" "

escapePairDelim=" "/>

Note: Press ENTER after you change each delimiter.

Setting Up a Header and Creating a Message

The following example shows a header and message that is created.

HEADER 1D event.time JEEXSB] messageid |id JEEICEB] endtime JEEETTEC ication: Authenticati )| payload

< HDR3
O besoae 0
O suffix: Starting offset:

O Concatenation:

cex to fiter i |
D, 9

o & 5200 NoOTICE ceeded, Ta=29, Device TP

Gun 28

HEADER: HDR3  MESSAGE:

Jun 28 17:48:39 ace CSCOacs_Passed & s 0000000086 2 0 2010-06-28 17:48:38.251 $00:00 0000014018 5200 NOTICE

, Device 1P S,

® Jun 29 14:40:17 acs CSCOacs i 's 0000000193 2 0 2010-06-29 14:40:17.402 400:00 0000015222 5200 NOTICE , Device IP i

succeeded, 3

The corresponding Header XML definition is shown below:

<HEADER
id1="HDR3"
id2="HDR3"

content="&lt;event time&gt; acs&lt;messageidé&gt; &lt;idé&gt; 2 0
&lt;endtime&gt; 5200 NOTICE Passed-Authentication: Authentication
succeeded, &lt;!payload&gt;"/>

Create Message

When you create a message, the Name Value Pair check box should be checked in order for the
messages to be parsed. Note that if you do not select the Name Value Pair check box, the
parser does not parse <TAGVAL> messages with a different order. The Name Value Pair is
disabled by default and it is enabled for user input only if the message definitions satisfy the
<TAGVAL> format, as shown in the following examples.

The TAGVAL format is either:

<literal><valuedelimiter><variable><pairdelimiter>...<literal><valuedeli
miter><variable> format

Or
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<literal><valuedelimiter><variable><pairdelimiter>...<literal><valuedeli
miter><variable><pairdelimiter> format

The Allow Missing Fields option is used to parse event logs that missed some <TAGVALUE>
pairs defined in the message definition. This means not all <TAGVALUE> pairs defined in the
message definition need to be parsed.

Parser Details  Headers  Messages

“N( . Protocol= [

LESEE (‘configversionia= |[ZE( , Device IP Address= | )

()

< CSCDacs_Passed_Authentications

Group: _passed Authentications  Event Category: ~ [ZIName Vakue Pars (] Aow Mising Filds

|

© GUN28117:48¢45 acs BB

HEADER: HDRI  MESSAGE: C5:

© Jun 28 17:48:39 acs CsCOa s 0000000086 2 0 2010-06-28 17148138251 40000 0000014016 5200 NOTICE Passed-Authentication: Authentication succee ded, , Device TP ST,

® A28 14340117 acs CSCOacs Passed Auchentications 0000000183 2 0 2010-06-29 14140:17,402 #0100 0000015222 5200 NOTICE Passed-Authentication: Authentication succee ded, p , Device IP T

The corresponding Message XML definition is shown below:
<MESSAGE

1id1="CSCOacs Passed Authentications"
1d2="CSCOacs_ Passed Authentications"
tagval="true"

missField="true"

content="ConfigVersionId=&lt;versioné&gt;, Device IP
Address=&lt;saddr&gt;, UserName=&lt;uidé&gt;,
Protocol=¢&lt;protocol&gt;,"/>

Listed below are sample payload parts of event logs that are parsed:

ConfigVersionId=29, Device IP Address=201.1.37.7, UserName=sgadmin,
Protocol=Radius,

ConfigVersionId=29, Device IP Address=201.1.37.7, UserName=sgadmin,

Authentication succeeded, UserName=sgadmin, ConfigVersionId=39, Device
IP Address=201.1.37.7, Protocol=Radius
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(For 1.1 version) VALUMAPS

VALUEMAPS functionality allows mapping of a value that is parsed in a meta to another
corresponding meta.

For example, if you have a new event saved with a code “404” and a relevant information
defined is “page not found error.” With VALUEMAPS, you can map 404 to "page not found
error" so that whenever 404 is seen, it also shows another mapped meta key.

File Actions Edit View Help
oracleammsg.xml* (£

Parser Details H ] \

DEVICE AGVAL VALUEMAPS

Name Default Value Value Map
getDispobition O=Failure[-| 1=Success|-| 404=Page Not Found|-|

VALUEMAPS consists of three columns.

s o

Name It is a unique identity of a VALUEMAPS.
Default When there is no value relevant to a defined specific key, it will use default
Value value

Value Map  Itis a set of key value pair where a meta is found in the parser it is replaced by

the value.

VALUEMAPS can be edited as per the requirements, you can insert new VALUEMAPS
containing the default values and delete any unwanted VALUEMAPS.

To edit an existing VALUEMAPS click on it to make changes.

o Add - Click on [*! button to add a new key value pair

o Delete- click on "= to delete an existing key value pair

To delete an unwanted VALUEMAPS right click on the name column and select the “delete”
option you want to delete.
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File Actions Edit View Help

oracleammsg.xml* (£

Parser Details Headers

DEVICE T/ VALUEMAPS

Name Default Value Value Map
getDisposition +| O=Failure[=] 1=Success|-| 404=Page Not Found -

To Insert a new VALUEMAPS right click on the name column and select the Insert option you
want to insert.

File Actions Edit View Help

oradeammsg.xmi* [

Parser Details Headers
DEVICE T VALUEMAPS

Name Default Value Value Map
getDisposition +| O=Failure[-| 1=Success|-| 404=Page Not Found|-

New VALUEMAPS will be created with new name VALUEMAPS 1, VALUEMAPS 2 and so
on which will contain default values.
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NwLogPlayer is a troubleshooting tool that simulates syslog traffic. NwLogPlayer.exe is a
command line utility located on the Log Decoder host in /usr/bin.

At the command line, type nwlogplayer.exe -h to list the available options, as reproduced
here:

oion oo

--priority arg set log priority level

Slal [ ==laEdle) show this message

-f [ --file ] arg input message; defaults to stdin
(=stdin)

-d [dir ] arg input directory

-s [ --server ] arg remote server; defaults to localhost
(=localhost)

-p [ --port ] arg remote port; defaults to 514
(=514)

-r [ —-raw ] arg (=0) Determines raw mode.

o 0 =add priority mark (default)

o 1= File contents will be copied line by line to the server.
o 3 =auto detect

e 4 =enVision stream

o 5 =binary object

-m [ --memory ] arg Speed test mode. Read up to 1 Megabyte of messages from the file content and
replays.
--rate arg Number of events per second. This argument has no effect if rate > eps that the

program can achieve in continuous mode.

--maxcnt arg maximum number of messages to be sent
-c¢ [ --multiconn ] multiple connection
-t [ --time ] arg simulate time stamp time; format is yyyy-m—-d-hh :mm: ss
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o o

-v [ --verbose ] If true, output is verbose

--ip arg simulate an [P tag

--ssl use SSL to connect

--certdir arg OpenSSL certificate authority directory
--clientcert arg use this PEM-encoded SSL client certificate
—-—-udp send in UDP
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