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About Log Collection

This guide describes the high-level steps and subtasks for setting up and configuring log collection for
event sources that include:

What Log Collection does, how it works from a high level, and provides high-level deployment
diagrams.

How to start collecting events.

Where to find instructions to set up more complex deployments.

How to start any collection protocol.

Which tools to use to troubleshoot Log Collection issues and lists global troubleshooting instructions.

How to fine tune and customize Log Collection in your environment.

How to configure individual collection protocols. Instructions are in the individual Log Collection
sections.

Workflow

This workflow depicts the basic tasks needed to start collecting events through Log Collectors.

Set Up Start Configure Verify that
Lockbox Collection Collection Log Collection

Perform Basic

Implementation Services Protocols and is Working

Event Sources

Configure the
following
collection
protocols and
event sources:

AWS
(CloudTrail)
Azure
Check Point
File

Netflow
ODBC

SDEE

SNMP
Syslog
Vmware
Windows
Windows
Legacy and
NetApp
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High-Level Procedures

At a high level, these are the procedures you must follow for log collection:

L.

IL.

III.

IV.

VI.

Add local and remote collectors to RSA NetWitness Platform.

Set up a Log Collector locally on a Log Decoder (that is a Local Collector). You can also set up Log
Collectors in as many remote locations (that is Remote Collectors) as you need for your enterprise.
For details, see Basic Implementation.

Download the latest content from RSA Live. You must perform this task periodically, as the content
provided on RSA Live is updated regularly.

Log Collection content is marked as one of the following resource types:

o RSA Log Collector - content enabling the collection of event source types.

o RSA Log Device - the latest supported event source parsers.

You can also subscribe to content on Live. For details, see the Live Services Management Guide.
Configure Settings: set up the lockbox and Certificates.

For details, see Set Up a Lockbox and Configure Certificates.

Configure Event Sources.

You configure all the event sources on your network to send their log information to

RSA NetWitness Platform. Whenever you add new event sources, you need to perform this
procedure as well. All event source configuration guides are found in the RSA Supported Event
Sources space in RSA Link.

Start and stop services for configured protocols. Occasionally, you may be required to stop and
restart services, based on new event sources that you add to RSA NetWitness Platform.

Verify that Log Collection is working.

Whenever you set up a new event source or add a new collection protocol, you should verify that the
correct logs are being sent to RSA NetWitness Platform.

About Log Collection
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Log Collection Architecture

This topic describes how NetWitness Platform performs log collection.

How to Deploy Log Collection

You can deploy Log Collection according to needs and preferences of your enterprise. This includes
deploying Log Collection across multiple locations and collecting data from varying sets of event
sources. You do this by setting up a Local Collector with one or many Remote Collectors.

Components of Log Collection

The following figure shows all the components involved in event collection through the NetWitness
Platform Log Collector.

Intranet " Open Database _
Windows S Connectivity (ODBC)
event sources - - event sources

wmdows Lsgacy
event sources

MS5QL

| -
y Qracle .
Other DBs
Sybase o

Wmclows

Nethpp 2003 / S

j Netflow
| event sources

=
e
/
" / Plugins
T SMB . \ (AWS, Azure
T e http or https / opBC — Audit, etc.)
T Netflow ™ / http or https
VMware (2055, 4739, __ -
event sources 6343, 9995) - o -
' — " Check Point
Log Collection —
(Local and . event sources
— LIS o ~ OPSECLEA |
Gl (18184) —
i ftp (TCP22) Syslog
ESX Server sftp Tep/UDP o
SNMP SDEE ep (1cP22} ( P/

(UDP162)  (443)
- - .

ftps (TCP20 TCP21)

SNMP < - File

|
event sources event sources

- ' / spee log file f |E

1 | event sources | | " |

| | = | | :
.. # eg e

IDS/IPS

S &

Syslog event
sources

*In Log Collection, Remote Collectors send events to the Local Collector and the Local Collector sends events to the Log Decoder.
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Local and Remote Collectors

In this scenario, log collection from various protocols like Windows, ODBC, and so on, is performed
through both the Remote Collector and Log Collector service. If the log collection is done by the Local
Collector, it is forwarded to the Log Decoder service, just like the local deployment scenario. If the log
collection is done by a Remote Collector, there are two methods in which these are transferred to the
Local Collector:

o Pull Configuration - From a Local Collector, you select the Remote Collectors from which you want
to pull events.

o Push Configuration - From a Remote Collector, you select the Local Collector to which you want to
push events.

Note: Typically, the Push configuration is used. Pull is available if you have a DMZ in your
environment. Less secure network segments are not allowed to make connections to more secure
network segments. With Pull, the Log Collector (or Virtual Log Collector) in the secure network
initiates the connection to the VLC in the less secure network, and the logs are then transferred
without breaking the connection rules.

You can configure one or more Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from one or more Remote Collectors.

Additionally, you can set up a chain of Remote Collectors for which you can configure:
o One or more Remote Collectors to push event data to a Remote Collector.

o A Remote Collector to pull event data from one or more Remote Collectors.

The following figure illustrates how the Local and Remote Collectors interact to collect events from all
of your locations.

11 Log Collection Architecture
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Local Collector (LC)*

Pull Configuration:
LC Pulls Event Data from RC —

Full Configuration:
Parent RC Pulls Event
Data from RC :

‘Push Configuration:
IRC Pushes Event
to Parent RC

P ‘\("
..
/" Remote Collector (RC) ™.
Log Collector
Service on
Virtual Machine

RC

* The Lecal Collectar (LC) is the Log Collector service an the Log Decoder appliance.

Windows Legacy Remote Collector

‘Push C
{RC Pushes Event Datato LC

Remote Collector (RC)
Log Collector
Service on
Virtual Machine

The RSA NetWitness® Platform Windows Legacy Collector is a Microsoft Windows based remote log
collector (RC) which can be installed on a Windows domain.

It supports collection from:
m Windows 2003 and earlier event sources

m NetApp ONTAP host evt files

The following figure illustrates the deployment required to collect events from Windows Legacy event

sources.

Log Collection Architecture
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Event Source Domains

Domain 1
Event Sources
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Nethpp Ontap |

. Windows 2003
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Domain
Event Sources

NetApp Ontap

[} L8 ri NetApp Ontap |
| Windows 2003 AN / |
ar earler E
\\ Remote Legacy
b Windows Collector
on 64-Bit

Log Collectar
on Log Decoder

]

Windows Sarver
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Setup

Basic Implementation

This topic tells how to perform the initial setup of Local Collectors and Remote Collectors.

Prerequisites

Verify that the Log Decoder is set up and:
e is capturing data.
« has the current content loaded.

o is properly licensed.

Roles of Local and Remote Collectors

A Local Collector (LC) is a Log Collector service running on a Log Decoder host. In a local deployment
scenario, the Log Collector service is deployed on a Log Decoder host, with the Log Decoder service.
Log collection from various protocols like Windows, ODBC, and so on, is performed through the Log
Collector service, and events are forwarded to the Log Decoder service. The Local Collector sends all
collected event data to the Log Decoder service.

You must have at least one Local Collector to collect non-Syslog events.

A Remote Collector (RC), also referred to as a Virtual Log Collector (VLC), is a Log Collector service
running on a stand-alone Virtual Machine. Remote Collectors are optional and they must send the events
they collect to a Local Collector. Remote Collector deployment is ideal when you have to collect logs
from remote locations. Remote Collectors compress and encrypt the logs before sending them to a Local
Collector.

Deploying and Configuring Log Collection

The following diagram illustrates the basic tasks you must complete to deploy and configure Log
Collection. To deploy Log Collection, you need to set up a Local Collector. You can also deploy one or
more Remote Collectors. After you deploy Log Collection, you need to configure the events sources in
NetWitness Platform and on the events sources themselves. The following diagram shows the Local
Collector with one Remote Collector that pushes events to the Local Collector.
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)] Local Collector (LC)*

Local Deployment

Remote Locations

___ Push Configuration: RC
Pushes Event Data to LC

Remote Collector (RC)
Log Collector
Service on
Virtual Machine

*The Local Collector (LC) is the Log Collector service on the Log Decoder appliance.

Set up Local and Remote Collectors.
The Local Collector is the Log Collector service running on the Log Decoder host.

A Remote Collector is the Log Collector service running on a virtual machine or Windows server in a
remote location.

(2]

Collection Protocols

Event Sources

Configure event sources:

o Configure collection protocols

o Configure each event source to communicate with the NetWitness Platform Log Collector.

For details on these procedures, see Configure Collection Protocols and Event Sources.
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Adding Local Collector and Remote Collector to NetWitness Platform

To add a Local Collector and Remote Collector to NetWitness Platform:
1. Goto ADMIN > Services.

2. Click + and select Log Collector from the menu.
The Add Service dialog box is displayed.

3. Define the details of the Log Collection service.

4. Select Test Connection to ensure that your Local or Remote Collector is added.

Configuring Log Collection

You choose the Log Collector—that is a Local Collector (LC) or Remote Collector (RC)—for which
you want to define parameters in the Services view. The following figure shows how to navigate to the
Services view, select a Log Collector service, and display the configuration parameter interface for that
service.

To configure log collection:
1. Goto ADMIN > Services.

2. Select a Log Collection service.

3. Click ¥ * View > Config to display the Log Collection configuration parameter tabs.
4. Define global Log Collection parameters in the General tab.

5. The Ul presents tabs, depending on whether the current service is Local or Remote.

o For a Local Collector, NetWitness Platform displays the Remote Collectors tab. Select the
Remote Collectors from which the Local Collector pulls events in this tab.

o For a Remote Collector, NetWitness Platform displays the Local Collectors. Select the Local
Collectors to which the Remote Collector pushes events in this tab.

Edit configuration files as text files in the Files tab.
Define collection protocol parameters in the Event Sources tab.

Define the lockbox, encryption keys, and certificates in the Settings tab.

o ® N

Define Appliance Service parameters in the Appliance Service Configuration tab.

Data Flow Diagram

You use the log data collected by the Log Collector service to monitor the health of your enterprise and
to conduct investigations. The following figure shows you how data flows through NetWitness Platform
Log Collection to Investigation.
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..
Check Point ‘

Windows File

Windows Legacy,
NetApp Netflow

EE'_-’: Event Sources

L WMware ODBC

Flugins {e.g. AWS)

i =5
| aysiog g_'_};‘,’_,;] SDEE

" Remote
Log
Collector

Remute‘““.“
Log ey

Collector Log Collector

aon Log Decoder

]

Concentrator

]

Security
Analytics

]

Investigation

Provision Local Collectors and Remote Collectors

G '

The NetWitness Platform server verifies if an appliance has a Log Decoder service. If there is a Log

Decoder service, it becomes a Local Collector. If a Log Decoder service is missing, it becomes a

Remote Collector. A local Log Collector has an Event Destination and by default goes to the Local Log

Decoder service. A Remote Collector does not have an Event Destination. The NetWitness Server

identifies a Legacy Windows Collector as a Remote Collector.
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To edit a Local Collector or Remote Collector:
1. Goto ADMIN > Services.

2. Select a Log Collector service.

3. Inthe Services view, select |ﬁ in the toolbar.

The Edit Service dialog is displayed.

Edit Service

Service Log Decoder
Host MWAPPLIANCE277
MName MWAPPLIANCE277 - Log

Connection Details

Port 56002

S5L ™

IUsername

FESSWDI"d ik

Test Connection

Cancel

4. In the Edit Service dialog, provide the following information.

ey femmew

Service Select Log Collector as the service type.

Host Select a Log Decoder host.

Name Type name you want to assign to the service.

Port Default port is 50001 for clear text and 56001 for SSL encrypted.

SSL Select SSL if you want NetWitness Platform to communicate with the host

using SSL. The security of data transmission is managed by encrypting
information and providing authentication with SSL certificates.

(Optional) Type the username of the Local Collector.
Username

(Optional) Password Type the password of the Local Collector.

5. Click Test Connection to determine if NetWitness Platform connects to the service.

Setup 18
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6. When the result is successful, click Save.

If the test is unsuccessful, edit the service information and retry.

Configure Local and Remote Collectors

This topic describes how to configure Local and Remote Collectors.

When you deploy Log Collection, you must configure the Log Collectors to collect the log events from
various event sources, and to deliver these events reliably and securely to the Log Decoder service,
where the events are parsed and stored for subsequent analysis.

You can configure one or more Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from one or more Remote Collectors.

This topic describes how to:

o Configure Local Collector to Pull Events from Remote Collector

If you want a Local Collector to pull events from Remote Collector, you set this up in the Remote
Collectors tab of the Local Collector's Configuration view.

o Configure Remote Collector to Push Events to Local Collectors

If you want a Remote Collector to push events to a Local Collector, you set this up in the Local
Collector tab of the Remote Collector's Configuration view. In the Push configuration, you can also:

o Configure Failover Local Collector for Remote Collector

You set up a destination made up of local collectors. When the primary Local Collector is
unreachable, the Remote Collector attempts to connect to each Local Collector in this destination
until it makes a successful connection.

o Configure Replication

You set up multiple destination groups so that NetWitness replicates the event data in each group.
If the connection to one of the destination groups fails, you can recover the required data because it
is replicated in the other destination group.

o Configure Log Routing for Specific Protocols

You set up multiple destinations in a destination group to direct event data to specific locations
according to protocol type.

o Configure Chain of Remote Collectors

You can set up a chain of Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from a chain of Remote Collectors.

o You can configure one or more Remote Collectors to push event data to a Remote Collector.

e You can configure a Remote Collector to pull event data from one or more Remote Collectors.

Failover, Replication and Load Balancing

This section describes failover, replication, and load balancing work in how RSA NetWitness Platform.

The following figure illustrates a Remote Collector configured for load balancing, failover
and replication.
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Destination 1 Destination 2

RC-10.101.214.8

RC-10.101.214.9 RC-10.101.214.105

Primary

Failover Scenario

Failover Primary

RC-10.101.214.7 | Replication Scenario

Load Balancing Scenario

Group 1

Destination 3

RC-10.101.214.106

Primary

Group 2

« Failover is achieved by setting up multiple collectors in the same Destination. Destination 1 has a
primary Collector, and second, failover Collector. This is done in NetWitness Platform by adding

multiple Log Collectors to the same Destination.

Destination Name *  Destination1
Group Name Group'
Collections Windows Legacy v
Log Collectors Addresses
=
Ll Name+
O 10.101.2148

[0 10.101.2149

Cancel 0K

Since 10.101.214.8 is listed first, that becomes the primary collector, and 10.101.214.9 becomes the

failover. To make 10.101.214.9 the primary, use the up arrow to change the order.

Below, you can see the two collectors both listed for Destination 1. The primary (10.101.214.8) is in

bold.

Setup
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General Local Collectors Files Event Sources Settings
Select T v
Configuration: e natons
Destination Groups Destination Collectors
+ - +
T4 Name ~ J Destination Name ~ Address Collections
10.101.214.8, 10.101.214.9 windowslegacy

¥ Group1 [0 ® Destination

o Replication is accomplished by having multiple Destination Groups: each group receive the entire set
of message data.

RC-10.101.214.7

Group 2

In the following screen, you can see that message data is sent to the collectors in Group 1 and Group
2.

Local Collectors Files Event Sources Settings

Select inati v
Cz:t"':iguration: Destinations
Destination Groups Destination Collectors
+ - +
Name ~ Destination Name ~ Address Collections
[0 Group1 [0 @ Destination3 10.101.214.106 windowslegacy
™  Group2
« Load balancing is achieved by setting up multiple Destinations within a Group.
Setup
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Destination 2

Destination 1

RC-10.101.214.8 RC-10.101.214.9 RC-10.101.214.105

Primary Failover

Failover Scenario

Load Balancing Scenario

Group 1

In the following screen, you can see that Group 1 has two destinations, Destination 1 and Destination
2. The message data is divided up equally among the Destinations in the group.

Local Collectors Files Event Sources Settings

Select

Configuration: Destinatans Y

Destination Groups Destination Collectors

+ - +

™~ Name ~ Destination Name ~ Address Collections

™ Group1 [0 @® Destination! 10.101.214.8,10.101.214.9 windowslegacy
[J @ Destination2 10.101.214.105 windowslegacy

With two Destinations, each destination receives half the message data. With three Destinations,
each would receive 1/3 of the total message data. Keep adding Destinations to further reduce the load
on the collectors in each destination.

Note: You can also set up log routing so that event data for specific protocols is sent to specific
destinations.

Configure a Local Collector or Remote Collector

You choose the Log Collector, that is a Local Collector (LC) or Remote Collector (RC), for which you
want to define deployment parameters in the Services view. The following procedure shows you how to
navigate to the Services view, select a Local or Remote Collector, and display the deployment
parameter interface for that service.

To configure a Local Collector or Remote Collector:
1. Goto ADMIN > Services.

2. Select a Local or Remote Log Collection service.
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3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Depending on your selection in step 2:

o Ifyou selected a Local Collector, the Remote Collectors tab is displayed. Select the Remote
Collectors from which the Local Collector pulls events in this tab.

o Ifyouselected a Remote Collector, the Local Collectors are displayed. Select the Local
Collectors to which the Remote Collector pushes events in this tab.
Remote Collectors Tab

The following figure depicts the Remote Collectors tab for a Local Collector that is configured to pull
events from a Remote Collector. NetWitness Platform displays this tab when you have selected a Local
Collector in Admin > Services.

= Change Service [l - Log Collector | Config &

General Remote Collectors Files Event Sources  Event Destinations Settings  Appliance Service Configuration

Remote Collector
+

| Name ~ Group Name Address

| Page of 0 | | C

Local Collectors Tab for a Remote Collector

The following figure depicts a Local Collectors tab for a Remote Collector that is configured to push
events to a Local Collector or another Remote Collector.

%, Change Service | D Log Collector | Config

General Local Collectors Files Event Sources Settings Appliance Service Configuration

Select

. . Destinaticns v
Configuration:

Destination Groups
+

O Name =

LC

The following figure depicts the Local Collectors tab for a Remote Collector that is configured to pull
events from a Remote Collector. NetWitness Platform displays this tab when you have selected a
Remote Collector in Admin > Services.
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&, Change Service | - Log Collector | Config &

General Local Collectors Files Event Sources Settings  Appliance Service Configuration
Select -

Configuration: |Sources

“ Sources

Remote Collector

+
O Name ~ Group Name Address

| Page of 0 | | C

Parameters

Remote/Local Collectors Configuration Parameters

Configure Failover Local Collector

This topic tells you how to set up a Failover Local or Remote Collector.

Set up a Failover Local Collector

You can set up a Failover Local Collector that RSA NetWitness® Platform will fail over to if your
primary Local Collector stops operating for any reason.

1. Goto ADMIN > Services.
2. In Services, select a Remote Collector service.
3. Click ¥ * View > Config.
The Service Config view is displayed with the Log Collector General tab open.
4. Select the Local Collectors tab.

5. Inthe Destination Groups panel section, select +
The Add Remote Destination dialog displays.
6. Setup a Destination Group and select a primary Local Collector (for example, LC-PRIMARY).
7. 'S_Ijelect the Group (for example, Primary_Standby LCs) in the Destination Groups panel and click
The Group you selected is displayed in the Local Collectors panel.
8. Add the Failover Local Collector (for example, LC-STANDBY).
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The following examples show the newly added primary and failover Local Collectors showing the
primary Local Collector as Active and the Failover Local Collector as Standby. The active Local
Collector is highlighted (for example, LC-PRIMARY).

9. (Optional) Add, delete, and change the order of Local Collectors to each Remote Destination.

a. Click + to add a Log Collector as a failover Remote Destination.
b. When connecting to a Remote Destination, the Remote Collector will attempt to connect to each

Local Collector in this list in order, until it makes a successful connection.

c. Select a Local Collector and use the up ( L) ) and down (") arrow buttons to change the order
of connection.

d. Select one or more Local Collectors and click . to remove them from the list.

The selected Local Collectors are added to the Log Collector section. When the Remote Collector
starts collecting data, it pushes data to these Log Collectors.

Set up a Failover Remote Collector

You can set up a Failover Remote Collector that RSA NetWitness® Platform will fail over to if your
primary Remote Collector stops operating for any reason.

To set up a failover remote collector:
1. Goto ADMIN > Services.

2. In Services, select a Remote Collector service.

3. Click ¥ ' View > Config.
The Service Config view is displayed with the Log Collector General tab open.

4. Select the Local Collectors tab.

5. Select Sources in Select Configuration drop-down menu.

6. Click + to display in Add Source dialog.
7. Define the failover Remote Collector and click OK.

Parameters

Remote/Local Collectors Configuration Parameters

Configure Replication

This topic tells you how to replicate event data sent by a Remote Collector.

You can specify multiple Destination Groups so that the event data is replicated to each group.
To replicate event data to multiple Local Collectors:

1. Goto ADMIN > Services.

2. Select a Remote Log Collection service.
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3. Under Actions, select ﬁ “ > View > Config.
The Service Config view is displayed with the Log Collector General tab open.

4. Select the Local Collectors tab.

5. Inthe Destination Groups panel section, click +
The Add Remote Destination dialog is displayed.

Add Remote Destination

Destination Mame * Destination
Group Name DestinationGroup

Collections Check Point, File, Metflow, ODBC, SDEE, SMMF ~

Log Collectors Addresses

+ -1+ 4
Mame *
M LC1

6. Setup a separate Destination for each Local Collector and designate the protocols for which you
want to push event messages to that Local Collector. The following examples shows the addition of
two Destination Local Collectors (Destinationl and Destination2) for the Check Point, File,
Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection protocols:
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Add Remote Destination

Destination Name * Destinationt

Group Name DestinationGroup1

Collections Check Point, File, Netflow, ODBC, SDEE, SNMF v~

Log Collectors Addresses
+ -1
L)) Name *

™ LC1

+ Change Service | ErC199 | Confige
General Local Collectors Files Event Sources Settings
Select 7
Sler q Destinations v -
Configuration: s
a

Destination Groups /Desfination Collectors

-4
+ - A *
— ra i
| Mame ~ vyl Destination Mame ~ | Address
; .
™ DestlnatlonGrour_ﬂ', Destination1
DestinationGroup2
| Page |1 | oft | | Page |1 | oft |

4 sdmin | €9 English (United States) GMT=00:00

I C

.

Add Remote Destination

E Y

Destination Mame * Destination2

Group Name |Destinati0nGroup2| |

Collections Check Point, File, Netflow, ODBC, SDEE, SNMF v~

Log Collectors Addresses
L 4
[ name=*

™ Lc2

Appliance Service Configuration

Collections

checkpoint file netflow odbc sdee snmptrap syslog vmware windows

Items 1-10f1

Send Us Feedback | 10.5.0.0.15688-1

a. Type the Destination Name.

b. Type the Group Name. If you do not type a Group Name, the Destination Name is taken as the

Group Name.

o

d. Select a Local Collector (for example, LC1).
e. Click OK.

Select the collection protocols in the drop-down list.

f. Select the new group (for example, DestinationGroup2) group in the Destination Groups

panel and click + in the Local Collector panel.

g. In the Local Collector panel, click + and complete the Add Remote Destination dialog as
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illustrated in the following figure.

Add Remote Destination

Destination Mame * Destination2

Group Name |DE5tinatiDnGrDup2| |

Collections Check Point, File, Metflow, ODBC, SDEE, SMMF ~

Log Collectors Addresses

+ -1+ 4
Name *
M Lcz

The Check Point, File, Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection protocols are
sent to two Local Collectors (LC1 and L.C2). Both Local Collectors are active and collecting event data.

3. ChangeSerun:e | & rC199 | Cnnl‘ug v

Local Collectors Files Event Sources  Settings  Appliance Service Configuration

Select
Configuration:

Destination Groups Destination Collectors
+ - -

Name ~ Destination Name =~ Address Collections

Destinatians v

¥ DestinatlonGroup1 B Destination? 1 checkpoint file netflow odbc sdee snmptrap syslog vmware windows

DestinationGroup2

| Page 1 of1 | | Page 1 of1 | | C Iltems 1-1 of 1
|

Configure Chain of Remote Collectors

This topic describes how to chain Remote Collectors (also referred to as VLCs).

You can set up a chain of Remote Collectors to push event data to a Remote Collector, or you can
configure a Remote Collector to pull event data from a chain of Remote Collectors.

+ Remote Collectors to push data. Push data from a Remote Collector to other Remote Collectors or
Local Collectors.

« Remote Collector to pull data. Use a Remote Collector to pull data from one or more Remote
Collectors.
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Configure Remote Collector to Push Event Data to Remote Collector
1.
2.

Configure Remote Collector to Pull Event Data from a Remote Collector

Go to ADMIN > Services.

In Services, select a Remote Collector.

Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration

parameter tabs.

The Log Collector Service Config view is displayed with the Log Collector General tab open.

Select the Local Collectors tab.

Select Destinations in the Select Configurations drop-down menu.

In the Destination Groups panel section, select +

The Add Remote Destination dialog is displayed.

Set up a Destination Group:

a. Enter a Destination Name.

b. (Optional) Enter a Group Name. If you leave Group Name blank, NetWitness Platform sets it

to the value that you specified in Destination Name.

c. Select one or more collection protocols in the Collections drop-down list.

d. Under Log Collectors Addresses, click + to select a Remote Collector.

Add Remote Destination

Destination Mame * Branch1
Group Name BranchOffices
Collections Windows w

Log Collectors Addresses

+-1 9
¥ Name*
™| - Log Collector

Cancel 0K

protocols to the Remote Collectors.

Note: If you do not select a collection protocol, the Remote Collector pushes all collection

. Go to ADMIN > Services.

In Services, select a Remote Collector.

Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration

parameter tabs.

The Service Config view is displayed with the Log Collector General tab open.
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4. Select the Local Collectors tab.

5. Select Sources in the Select Configurations drop-down menu.

£ Change Service | -Log Collector | Config &

General Local Collectors Files Event Sources Settings  Appliance Service Configuration
Select -

Configuration: |50urces

+ Sources

Remote Collector

+
O Name ~ Group Name Address

| Page of 0 | | &

6. Inthe Remote Collectors panel, select 4.
The Add Source dialog is displayed.

7. Inthe Add Source dialog:
a. Select one or more collection protocols.

If you do not select a collection protocol, the Remote Collector pulls all collection protocols from
the Remote Collector.

b. Click OK.

The Remote Collector is added to the Remote Collector section. When the Log Collector starts
collecting data, it pulls event data from this Remote Collector.

Throttle Remote Collector to Local Collector Bandwidth

To improve performance, you can throttle the bandwidth to control the rate that the Remote Collector
sends event data to Local Collector or between Message Brokers. To do this, you configure the Linux
kernel's filtering and [PTable functionality.

This works for both push and pull Remote Collector configurations. The set-shovel-transfer-limit.sh
shell script located on the /opt/netwitness/bin automates the configuration of the kernel filter and
iptables related to this port.

This topic describes how to throttle Remote Collector to Local Collector bandwidth using the set-shovel-
transfer-limit.sh shell script. It contains the following sections:

o The set-shovel-transfer-limit.sh shell script command line help.

Note: The filter value that you need to set depends on the rate at which remote log collector is
sending events to the Local Collector.

o An example that sets the Filter to 4096 kilobits per second.
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Command Line Help for Set Shovel Transfer Limit Script

Issue the —h command to display help for set-shovel-transfer-1imit.sh shell script.

cd /opt/netwitness/bin
./set-shovel-transfer-limit.sh

Usage:
set-shovel-transfer-limit.sh -s|-c|-d|[-1 interface] [-r rate]

where:

e -c =clear existing
o -d =display filter

o -s =set new values

o -1=Iinterface is the name of the network interface. Default value is ethQ

-r = rate is the bandwidth rate. Default value is 256kbps

Bandwidths and rates can be specified in:
« nolimit: disables throttling

« kbit: Kilobits per second

o mbit: Megabits per second

o kbps: Kilobytes per second

o mbps: Megabytes per second

« bps: Bytes per second

Set the Filter to 4096 Kilobits per Second

This example sets the Filter to 4096 kilobits per second.
[root@<hostname> bin]#./set-shovel-transfer-limit.sh -s -r 4096kbit

RATE=4096kbit
PORTNUMBER=5671
DEVICE INTERACE=ethO

iptables: No chain/target/match by that name.
iptables: No chain/target/match by that name.
iptables: Saving firewall rules to /etc/sysconfig/iptables:[ OK ]

Current/new values...

iptables -t mangle -n -v -L
Chain PREROUTING (policy ACCEPT 2 packets, 161 bytes)

pkts bytes target prot opt in out source destination

Chain INPUT (policy ACCEPT 2 packets, 161 bytes)

pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0O packets, 0 bytes)

pkts bytes target prot opt in out source destination
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Chain OUTPUT (policy ACCEPT 2 packets, 248 bytes)

pkts bytes target prot opt in out source destination

0 0 MARK tep —- * ethO 0.0.0.0/0 0.0.0.0/0 multiport
dports 5671 MARK set Oxa

0 0 MARK tcp -- * ethO 0.0.0.0/0 0.0.0.0/0 multiport

sports 5671 MARK set Oxa

Chain POSTROUTING (policy ACCEPT 2 packets, 248 bytes)
pkts bytes target prot opt in out source destination

tc -s -d class show dev ethO

class htb 1:1 root rate 10000Kbit ceil 10000Kbit burst 1600b/8 mpu 0b
overhead 0b cburst 1600b/8 mpu 0b overhead 0b level 7

Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)

rate Obit Opps backlog 0b Op requeues 0

lended: 0 borrowed: 0 giants: O

tokens: 20000 ctokens: 20000

class htb 1:2 parent 1:1 prio 0 quantum 51200 rate 4096Kbit ceil 4096Kbit
burst 1599b/8 mpu 0b overhead 0b cburst 1599b/8 mpu Ob overhead 0b level 0
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
rate Obit Opps backlog 0b Op requeues 0
lended: 0 borrowed: 0 giants: O
tokens: 48828 ctokens: 48828

Set Up a Lockbox

What Is a Lockbox

A lockbox is an encrypted file that you use to store confidential information about an application. The
NetWitness Platform Lockbox stores an encryption key for the Log Collector.

The encryption key is used to encrypt all event source passwords and the event broker password.
When you create the Lockbox, you need to define a password for the Lockbox.

The Log Collector operates the Lockbox in a mode during data collection that does not require you to
specify the password (the Log Collector uses the host system fingerprint instead).

These are the lockbox security settings.

o o

Old When you set up a Lockbox for the first time, this field is blank. NetWitness Platform
Lockbox  populates this field after you enter a New Lockbox Password and click Apply.
Password

New Initial or new lockbox password. To maximize lockbox security, specify a password that
Lockbox is eight or more characters in length with at least one numeric character, uppercase
Password character, and non-alphanumeric character such as # or !

Apply Click Apply to save the changes to the lockbox password.

Set Up a Lockbox

To set up a lockbox you need to set a password, as follows:
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1. Goto ADMIN > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Settings tab.

= SERVICES

¢ Change Service | LogCollector |  Config =

General Remote Collectors Files Event Sources  Event Destinations CEWLECEE  Appliance Service Configuration

Lockbox
Certificates

Lockbox Security Settings

Set or change the lockbox password. You will be required to enter this password o perform any laockbox management.

Old Lockbox AT
Password
Mew Lockbox P
Password

Apply

Reset Stable System Value

This eperation sets the system fingerprint in the lockbowx, This is typically only required after changing the host hardware.

Lockbox b el ek
Password

Apply

Generate New Encryption Key

Generates a new internal encryption key and re-encrypts the log collectors encrypred configuration values with it.

Apply

5. In the options panel, select Lockbox to configure Lockbox settings.

6. Under Lockbox Security Settings, enter a password in the New Lockbox Password ficld and click
Apply.

Start Collection Services

If a collection service stops, you may need to start it again. You can also enable the automatic start of
collection services.

Start a Collection Service

1. Goto ADMIN > Services.

2. Select a Log Collector service and click ﬁ “ under Actions.
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3. Click View > System.

4. Click Collection > service (for example File) and click Start.

Enable Automatic Start of Collection Services

1. Go to Admin > Services.

2. Select a Log Collector service and click ﬁ' “ under Actions.
3. Click View > Config.
The General tab is displayed.

4. In the Collector Configuration panel, select Start Collection on Service Startup for the individual
collection services that you want to start automatically. Alternatively, select Enable All to
automatically start all collection services.

Config =

Event Sources  Event Destinations  Settings  Appliance Service Configuration

System Configuration

Name Config Value

Compresslan o
Port 50001
S5L FIPS Mode

S5L Port 56001
Stat Update Interval 1000

Collector Configuration DlsableAll

Name Config Valus

= Check Point Collection

I Start Collection on Service Startup I

& Flle Collection

I Start Collectlon on Service Stariup I

& Netflow Collection

Apply

5. Click Apply for your changes to take effect.

Verify That Log Collection Is Working

This topic tells you how to verify that you have set up Log Collection correctly.

The following methods verify that Log Collection is working.

o Verify that there is event activity the Event Source Monitoring tab of the Administration > Health
& Wellness view.

o Verify that there are parsers in the device.type field in the Details column in the
Investigation > Events view for the collection protocol you configured.
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Please refer to the topics for each Collection Protocol for steps on how to verify that the protocol is set
up correctly.

Configure Certificates

You manage certificates by creating trust stores on the Log Collector. The Log Collector refers to these
trust stores to determine whether or not the event sources are trusted.

Add a Certificate

To add a certificate:
1. Goto ADMIN > Services.

2. Inthe Services grid, select a Log Collector service.

3. Click ﬂ “ under Actions and select View > Config.
4. Click the Settings tab.

5. In the options panel, select Certificates.

6. Click + in the Certificates tool bar.
The Add Cert dialog is displayed.
7. Click Browse and select a certificate (*.PEM) from your network.
8. Specify a password (if required).
9. Click Save.

Certificates Panel

The following table describe the buttons and columns available in the Certificates panel.

S

+ Opens the Add Cert dialog in which you can add a certificate and
password.
— Deletes the selected certificates.
Selects certificates.
Trust Store Name Displays the name of the trust store.

Certificate Distinguished ~ For Check Point event source only, displays the distinguished name for
Name the certificate.

Certificate Password For Check Point event source only, displays the password name for the
Name certificate.
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Add Cert Dialog

The following table describes the parameters available in the Add Cert dialog.

row o

Trust Store Name Enter a trust store name.

File Click Browse to select a certificate (*.PEM file) file from your network
Password Specity the password for this certificate.

Close Closes the dialog without adding a certificate.

Save Adds the certificate.
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How Log Collection Works

The Log Collector service collects logs from event sources throughout the IT environment in an
organization and forwards the logs to other NetWitness Platform components. The logs and the
descriptive content are stored as meta data for use in investigations and reports.

Event sources are the assets on the network, such as servers, switches, routers, storage arrays, operating
systems, and firewalls. In most cases, your Information Technology (IT) team configures event sources
to send their logs to the Log Collector service and the NetWitness Platform administrator configures the
Log Collector service to poll event sources and retrieve their logs. As a result, the Log Collector
receives all logs in their original form.

Collection Protocols
RSA NetWitness Platform can collect logs from a wide variety of event sources. When you are

configuring log collection for a specific event source, you need to know, first and foremost, the protocol
that is used to collect the logs.

Collection

Description

Protocol

Check Point Collects events from Check Point event sources using OPSEC LEA. OPSEC LEA is
the Check Point Operations Security Log Export API that facilitates the extraction of
logs. For details, see Configure Check Point Event Sources in NetWitness Platform.

File Collects events from log files. Event sources generate log files that are transferred
using a secure file transfer method to the Log Collector service.

For details, see Configure File Event Sources in NetWitness Platform.

Netflow Accepts events from Netflow v5 and Netflow v9. For details, see Configure Netflow
Event Sources in NetWitness Platform.

ODBC Collects events from event sources that store audit data in a database using the Open
Database Connectivity (ODBC) software interface. For details, see Configure ODBC
Event Sources in NetWitness Platform.

Plugins The Plugins collection is a generic collection framework for collecting events using external scripts written in
other languages. RSA currently provides collection for Amazon Web Services (AWS) CloudTrail and
Microsoft Azure.

o AWS: Collects events from Amazon Web Services (AWS) CloudTrail. Specifically
CloudTrail records AWS API calls for an account. For details, see Configure AWS
(CloudTrail) Event Sources in NetWitness Platform

o Azure: Collects events from Microsoft Azure. For details, see Configure Azure
Event Sources in NetWitness Platform.

Customers can use this framework to develop their own collection protocols.
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Collection -
Description

Protocol

SDEE Collects Intrusion Detection System (IDS) and Intrusion Prevention Service (IPS)
messages.

For details, see Configure SDEE Event Sources in NetWitness Platform.

SNMP Trap Accepts SNMP traps. For details, see Configure SNMP Event Sources in NetWitness
Platform.

Syslog Accepts messages from event sources that issue syslog messages. For details, see
Configure Syslog Event Sources.

Note: You do not configure Syslog Collection for Local Log Collectors. You only
need to configure Syslog Collection for Remote Collectors.

VMware Collects events from a VMware virtual infrastructure. For details, see Configure
VMware Event Sources in NetWitness Platform.

Windows Collects events from Windows machines that support the Microsoft Windows model.
Windows 6.0 is an event logging and tracing framework included in the operating
system beginning with Microsoft Windows Vista and Windows Server 2008. For
details, see Configure Windows Event Sources in NetWitness Platform.

Windows Collects events from:

LLeE0] e Older Windows versions such as Windows 2000 and Window 2003 and collects
from Windows event sources that are already configured for enVision collection
without having to reconfigure them.

o NetApp ONTAP appliance event source so that you can now collect and parse
NetApp evt files.

o For more information, see. Windows Legacy and NetApp Collection Configuration.

Note: You install the NetWitness Platform Windows Legacy Collector on a physical
or virtual Windows 2008 R2 SP1 64-Bit server using the
SALegacyWindowsCollector-version-number.exe.

Basic Procedure
The basic procedure is the same for all of the supported Collection Protocols.

To configure collection for an event source:

1. Set up your Event Source for collection. Each supported event source has a configuration
document available in the RSA Supported Event Sources space on RSA Link

a. Navigate to the RSA Supported Event Sources space on RSA Link.

b. Find the Instructions for your Event Source.
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The Overview page lists all of the currently supported Event Sources, as well as information
about the collection method, device class, and supported versions.

c. Download the configuration instructions for your event source, and follow them.

2. Configure collection on RSA NetWitness Platform. The event source configuration guide contains
these instructions. However, this guide also provides these instructions, based on the collection
method used by your event source. See Collection Protocols for details.

3. Start the Service for your Collection Method. Normally, you only need to do this for the first event
source that uses this collection method. For example, the first time you configure an event source that
uses File Collection, you may need to start the File Service in NetWitness Platform.

4. Verify that Collection is working for your Event Source.

The remainder of this topic discusses steps 2, 3, and 4 in more detail.

Configure Collection in RSA NetWitness Platform

The process to configure event sources is dependent upon the collection method they use. Note,
however, that they are very similar. The following procedure is generic: more details for individual
collection methods are available in topics that cover the details for each specific collection method.

Basic procedure to configure an event source in RSA NetWitness Platform:
1. Goto ADMIN > Services from the NetWitness Platform menu.
2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

&+ Change Service i Log Collector |  Config

[ELEEL Remote Collectors Files Event Sources JESUAESsET{]E Settings Appliance Servicg

|| V| Config hd

Check Point

File S
Metflow

ODEC

Plugins

SDEE

SNMP

Viware

Windows
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10.

In the Log Collector Event Sources tab, select your collection method from the drop-down menu.

In the Event Categories panel toolbar, click +
The Available Event Source Types dialog box is displayed.
Select an event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

Select the new type in the Event Categories panel and click + in the Sources toolbar.
The Add Source dialog is displayed.

Enter values for the available parameters.

Refer to the Parameters section of the specific collection method that you are configuring.

Click OK.

Start the Service for your Collection Method

To start the service for your collection method:

1.

2.
3.

Go to Admin > Services.

Select a Log Collector and select ﬁ “ > View > System.
Click Collection > protocol > Start

where protocol is the protocol that you wish to start, for example Netflow.

Verify that Collection is working for your Event Source

You can verify that a collection method is working from the Admin > Health & Wellness > Event
Source Monitoring tab.

To verify that collection is working for an event source:

1.

Go to ADMIN > Health & Wellness

2. Click the Event Source Monitoring tab.
3.
4

In the grid, find the Log Decoder, Event Source, and Event Source Type.

. Look for activity in the Count column for an event source to verify that collection is accepting

events.

Configure Event Filters for a Collector

This topics tells you how to create and maintain Event filters across all collection protocols.

Note: Prior to 11.3, you could not configure Syslog Collection for Local Log Collectors. You can
configure Syslog for local Log Collectors that are on version 11.3 or later.

Log Collection Basics

40




Log Collection Configuration Guide

Configure an Event Filter

To configure an event filter for an event source:

1.
2.

3.

6.

7.

Go to ADMIN > Services.
Select a Log Collection service.

Under Actions, select ﬁ “ View > Config to display the Log Collection configuration parameter
tabs.

Click the Event Sources tab.
In the Event Sources tab, select any collection method / Filter from the drop-down menus.

The following screen shows Syslog selected.

-+ Change Service Config

General Local Collectors Event Source

Syslog ~ | Filters ™

Note: Syslog configuration is only available on Remote Collectors prior to 11.3: if you are working
with a Local Collector service, Syslog is not available from the drop-down menu for Log
Collectors on version 11.0, 11.1, or 11.2.

The Filters view displays the filters that are configured for the selected collection method, if any.

In the Filters panel toolbar, click +
The Add Filter dialog displays.

Add Filter

Filter100

Mame *

Description * Syslog Leve

Cancel

Enter a name and description for the new filter and click Add.

The new filter displays in the Filter panel.
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& Change Service | -Log Collector | Config &

General Local Collectors Files Event Sources Settings  Appliance Service Configuration
Syslog ~ | Filters i
Filters

+
Ll Mame
[ Filter100

| Page 1 of1 |

8. Select the new filter in the Filters panel and click + in the Filter Rules panel toolbar.
The Add Filter Rule dialog is displayed.

9. Click + under Rule Conditions.
10. Add the parameters for this rule and click Update > OK.

Add Filter Rule

Filter Name * Filter100

Rule Description * SysloglLevel100

Rule Conditions

™ Key * Operator * Use Regex | Value Ignore Case Action
Match * Mo Match *
Syslog Level (syslog.level) ~ Equals v £ 1-2 O Accept « ||Drop

NetWitness Platform updates the filter with the rule that you defined.

Note: Rules are processed in order from top down until an Action type aborts the processing, or the
final rule is checked. Default behavior is to accept the rule if no matches are found.

The following tables describe the parameters for adding a filter rule.

Event Filter Rule "Key" Parameter

The values for the Key field depend on the Collection method to which the filter applies.
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Collection Method Values for the Key Field

Checkpoint, File, Netflow, Plugin,
SDEE SNMP and VMware

ODBC

Syslog

Windows

All Data Fields
Event Source Type
Event Source Name
Source 1P

Raw Event

All Data Fields
Event Source Type
Event Source Name
Source 1P

Message 1D

Message Level

All Data Fields
Event Source Type
Event Source Name
Source 1P

Syslog level

Raw Event

All Data Fields
Event Source Type
Event Source Name
Source 1P

Event ID

Provider

Channel

Computer
UserName

DomainName
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Collection Method Values for the Key Field

Windows Legacy o All Data Fields

o Event Source Type
o Event Source Name
e Source IP

e Event ID

Other Event Filter Rule Parameters

The following table describes all the other available fields for creating an event filter rule.

e

Operator Valid values are:

o Contains

o Equal
Use Optional. You can select this if you want to use Regex.
Regex
Value Value depends on the key value you selected.

For example if you choose Syslog level for Key, the value will be a number that denotes the
syslog level.

Ignore Optional. Select this to ignore the case sensitivity.
case

Action Choose actions for message data that matches a condition, or that does not match a
condition. See below for more details.

Actions
You can choose a ‘match’ and ‘no-match’ action for each rule condition.
The available actions are as follows:

o Accept: the filtered event is included in event logs, and no further rule processing is done for the
event: the event will display in the NetWitness Platform user interface during Investigation.

o Drop: the filtered event will not be included in event logs, and no further rule processing is done for
the event: the event will not display during Investigation.

o Next condition: the filtered event moves on to the next rule condition in the rule. If there are no more
rule conditions in the current rule, it moves on to the next rule.
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o Next rule: the filtered event moves on to the next rule. If there are no more rules in the filter, the
filter event is included in event logs, and no further rule processing is done for the event (same as
Accept).

Modify Filter Rules

To modify existing filter rules:

1. Goto ADMIN > Services.

2. Select a Log Collection service.

3. Under Actions, select View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Sources tab.

5. Inthe Event Sources tab, select any collection method / Filter from the drop-down menus.

The following screen shows Check Point selected.

-+ Change Service

General Local Collectors

Syslog ~ | Filters ™

The Filters view displays the filters that are configured for the selected collection method, if any.

..-"-"

6. In the Filter Rules list, select a rule and click b=,
The Edit Filter Rule dialog is displayed.
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Edit Filter Rule

Filter Name *

Rule Description *

Rule Conditions

Filter100

Sysloglevel100

7. Select the rule condition that you want to modify.

+
O Key * Operator * Use Regex = Value * Ignore Case Action
Match * No Match *
[ sysloglevel Equals true 1-2 true Accept Drop
Cancel OK

Edit Filter Rule

Filter Name *

Rule Description *

Rule Conditions

Filter100

Sysloglevel100

+
O Key * Operator * Use Regex  Value * Ignore Case Action
Match * No Match *
[ sysloglevel Equals true 1-2 true Accept Drop
Cancel OK

8. Modify the condition parameters that require changes and click Update > OK.

NetWitness Platform applies the condition parameter changes to the selected filter rule.

Import, Export, Edit, and Test Event Sources in Bulk

This topic describes how to import, export, edit, and test event sources in bulk.

You can use the bulk export option to export the event source details of your current set up and store
it. This data can be imported in bulk when you face a problem with your current set up and require the
event source data you had.

You can use the bulk edit feature when you have multiple event sources that need a specific
modification. You can select all the sources and apply the edit option across them at a time and avoid
applying the change one by one.
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Import Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some data
fields like numbers and dates can be re-formatted into the spreadsheet program’s native field types.
This can cause issues when re-importing this information, as some data fields may be garbled or
formatted incorrectly. This can be avoided by importing the CSV file into the spreadsheet program, and
specifying all data fields as text values.

To import multiple event sources at once:
1. Go to Admin > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

5. Select Check Point, File, Netflow, ODBC, Plugins, SDEE, (Syslog for Remote Collectors)
only, VMware, Windows, or Windows Legacy (SNMP does not have an Import function.).

6. In the Sources panel toolbar, click Import Source.

The Bulk Add Option dialog is displayed.

Bulk Add Cption

0 Import C5V File
( Paste CSY Content

Close

7. Select either Import CSV File or Paste CSV Content. If you select:
o Import CSV File:
a. Click Next.
The Import dialog is displayed.

b. Click Add and select a .esv file from your network.
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Import
+ -—

File Name =

newFileEventSources. csv

c. Click Import.
The event sources are added to the Event Source list.
o Paste CSV Content
a. Copy the contents of the .csv file and paste them into the dialog.

Bulk Add Cption

7 Import C5V File
(®) Paste C5V Content
FileDir1,%5E. ¥ 24 FALSE, TRUE, TRUE,UTF-

8,10 FALSE FALSE1.10E+121.10E+12,65536,10,10, TRUE,O,
TRUE

b. Click Import.

The event sources are added to Event Source List.

Export Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some data
fields like numbers and dates can be re-formatted into the spreadsheet program’s native field types.
This can cause issues when re-importing this information, as some data fields may be garbled or
formatted incorrectly. This can be avoided by importing the CSV file into the spreadsheet program, and
specifying all data fields as text values.

To export event source information:
Go to Admin > Services.

Select a Log Collection service.

Select ﬁ' “ > View > Config to display the Log Collection configuration parameter tabs.
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4. Click the Event Sources tab.

5. Select Check Point, File, Netflow, ODBC, Plugins, SDEE, (Syslog for Remote Collectors)
only, VMware, Windows, or Windows Legacy (SNMP does not have an Export function.).

6. In the Sources panel, select one or multiple event sources and click Export Source.

The Bulk Export dialog is displayed.

Bulk Export

Export all rows or selected rows?

Selected Cancel

7. Based on your selection:
o All: NetWitness Platform exports all event sources to a time-stamped CSV file.

o Selected: NetWitness Platform exports the event source or sources you selected to a time-stamped
CSV file.

o Cancel: NetWitness Platform cancels the export.

The following is an example of a time-stamped CSV file that gets created with the event sources that
you selected from the list.

R E’c'_'x B - -xported-file-config-Feb-28-2013-13-31.csv - Microsoft Exce C=rE )
L e e B ——
Home Insert Page Layout Formulas Data Review View Acrobat @ - 2 X
= ) Ll " e . .
j & T ) P |AA A.| |§ = El |§ Ger!eral Condltlonal Formatting S= Insert x % [ﬁ
n 53 ) : | $ -~ % » | [ Format as Table - 5 Delete - Ev
Past - i = - e Sort & Find &
e |t i 12 %o 370 (5} Cell Styles ~ [5 Format - ~ Filter~ Select~
Clipboard ™ Font (Fi Alignment (F] Mumber M Styles Cells Editing
Al - fe | fileDirectory
A B C D E F G H 1 J K L M N
1 [fileDirectdeventSoufileSpec  fileSaveO fileSaveO fileSeque fileEncodifileDiskQu manageEr manageSz errorFiles savedFile: errorfiles savedFile: [£]
2 |Eur_Londc¢127.0.0.1 %5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 11E+12 1.1E+12 65536 65536
3 |US_Chicag127.0.0.1 %5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 11E+12 1.1E+12 65536 65536
4 |US_New_'127.0.0.1 %5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 11E+12 1.1E+12 65536 65536
M 4 » ¥ | exported-file-config-Feb-28-201 73 o m ]
Ready | 00% (U

Edit Event Sources in Bulk

To edit multiple event sources at once:

1. On the Log Collector Event Sources tab, select Check Point, File, Netflow, ODBC, Plugins,
SDEE, Syslog, VMware, Windows, or Windows Legacy (SNMP does not have an Edit function.).

2. In the Sources panel, select multiple event sources and click lﬁ

The appropriate Bulk Edit dialog for the selected event source is displayed. The following figure is
an example of Bulk Edit Source dialog for File event source parameters.
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3.

4.
5.

Bulk Edit Source

Basic
Select fields for bulk edit operation. Only selected fields will be updated.

+ Enabled [

) Advanced

O
O

Cancel 0K

Select the checkbox to the left of the fields that you want to modify (for example, Debug).

Modify the selected parameters (for example, change Debug from Off to On).
Click OK.

NetWitness Platform applies the same parameter value change to all of the selected event sources

Test Event Source Connections in Bulk

To test multiple event source connections at once:

1.
2.

3.

Go to Admin > Services.

In the Services grid, select a Log Collector service.

Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.

Select the Event Sources tab, select Plugins, ODBC, or Windows (the other protocols do not have
a bulk test connection function).

Select one or more:
o sources from the Sources panel for Plugins or ODBC

o hosts from Hosts panel for Windows

The Test Connection button is enabled.
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&+ Change Service | @ -Log Collector |  Config ©

General Remote Collectors

Event Sources

Windews v Config v

Event Categories

+ = @ & importSource [ Export Source

Allas Authoriza: Channel = Max Durai Max Even! User Name

#  Windows1 basic Securi... 120 150000  scott

Windows2 basic Systemn 120 150000  templarKnig...

| Page 1 of 1 |

I c

Event Destinations

Settings  Appliance Service Configuration

Hosts

+ = @ & mportSource @ Export Source] [ Test Connection

Read All E' Polling Int ™ Event Source Addres Port Event Filt Transpor Debug Enabled Validate £ Render Lt Windo

false 180 o 5985 http Off true false en-Us Nen-.
false 180 ™ 5985 http Off true false en-Us Non-..
Items 1-20f 2 | Page 1 of1 | | ¢ Items 1-2 of

M Test Connecticn

6. Click

The Bulk Test Connections dialog is displayed showing the current status of the test for each
source. The status can be waiting, testing, passed or failed.

If you choose to close the testing before it is completed, the testing stops and the Bulk Test

Connections dialog closes.

After the testing is complete, the results are displayed in the Bulk Test Connections dialog.

See Also

You can use the Event Sources module (Administration > Event Sources) to create groups of event
sources, typically imported from a CMDB, and to monitor event sources based on those groups. For
details, see the following topics in the Event Source Management Guide:

o Import Event Sources
o Export Event Sources

o Bulk Edit Event Source Attributes
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Configure Collection Protocols and Event Sources

This topic tells you how to configure collection protocols and the event sources using those protocols.
You configure the Log Collector to collect event data from your event sources in the Event Sources tab
of the Log Collection parameter view.

To configure a collection protocol:

1. Goto ADMIN > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

&+ Change Service i Log Collector | Config &

General Remote Collectors Files Event Sources JESGAMNESENTE Settings Appliance Servicg

|| V| Config hd

Check Point

File =
Metflow

ODEBEC

Plugins

SDEE

SMNMP

Viviware

Windows

5. Select a collection protocol (for example, File) and select Config.
6. Click + and select an event source.

7. Select the newly added category and click +

8. Specify the parameters for the event source. For details, see the individual collection protocol topics.

The following guides provide detailed instructions on how to configure the collection protocols and their
associated event sources in NetWitness Platform. Each guide includes an index to configuration
instructions for the event sources supported for that collection protocol.

To configure individual collection protocols, see the following topics:

o Configure AWS (CloudTrail) Event Sources in NetWitness Platform

Configure Collection Protocols and Event Sources 52



Log Collection Configuration Guide

Configure Azure Event Sources in NetWitness Platform

Configure Check Point Event Sources in NetWitness Platform

Configure File Event Sources in NetWitness Platform

Configure Netflow Event Sources in NetWitness Platform

Configure ODBC Event Sources in NetWitness Platform

o Configure Data Source Names (DSNs)

o Create Custom Typespec for ODBC Collection

« ODBC Event Source Configuration Parameters

« ODBC DSNs Event Source Configuration Parameters

Configure SDEE Event Sources in NetWitness Platform

Configure SNMP Event Sources in NetWitness Platform

Configure Syslog Event Sources

Configure VMware Event Sources in NetWitness Platform

Configure Windows Event Sources in NetWitness Platform

Windows Legacy and NetApp Collection Configuration

o Set Up the Windows Legacy Collector

o Configure Windows Legacy and NetApp Event Sources

o Troubleshoot Windows Legacy and NetApp Collection
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Configure AWS (CloudTrail) Event Sources in NetWitness Platform

This topic tells you how to configure the AWS collection protocol, which collects events from Amazon
Web Services (AWS) CloudTrail.

Note: The AWS plugin is meant only for collecting from AWS CloudTrail logs, and not for collecting
from arbitrary logs in S3 buckets (under arbitrary directories). The AWS CloudTrail logs are sent in
JSON format, as detailed in the AWS documentation here:
http://docs.aws.amazon.com/awscloudtrail/latest/userguide/cloudtrail-event-reference.html.

How AWS Collection Works

The Log Collector service collects events from Amazon Web Services (AWS) CloudTrail. CloudTrail
records AWS API calls for an account. The events contain the identity of the API caller, the time of the
API call, the source IP address of the API caller, the request parameters, and the response elements
returned by the AWS service. The AWS API call history provided by CloudTrail events enables security
analysis, resource change tracking, and compliance auditing. CloudTrail uses Amazon S3 for log file
storage and delivery. NetWitness Platform copies the log files from the cloud (S3 bucket), and sends the
events contained in the files to the Log Collector.

Deployment Scenario

The following figure illustrates how you deploy the AWS Collection Protocol in NetWitness Platform.
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AWS
(CloudTrail)

AWS
http or https

Log Collection

(Local and
Remote
Collectors)

*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configuration

To configure an AWS (CloudTrail) Event Source:
1. Goto ADMIN > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Select ﬁ > View > Config to display the Log Collection configuration parameter tabs.
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4.

10.

11.

Click the Event Sources tab.

& Change Service i Log Collector | Config &

[eREE] Remote Collectors Files Event Sources ST aESaEN{ES Settings Appliance Servicg

|| V| Config hd

Check Point

File 5
Metflow

ODBC

Plugins

SDEE

SNMP

WVMware

Windows

In the Event Sources tab, select Plugins/Config from the drop-down menu.

=

In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
Select cloudtrail) and click OK.

The newly added event source type is displayed in the Event Categories panel.

Select the new type in the Event Categories panel and click in the Sources toolbar.

The Add Source dialog is displayed.

Define parameter values. For details, see AWS Parameters below.

Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness Platform displays an error message.

If the test is successful, click OK.

The new event source is displayed in the Sources panel.

AWS Parameters

The following table describes the Basic configuration parameter for AWS collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.
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Name *

Account Id *

Enabled

S3 Bucket
Name *

Access Key *

Secret Key *
Region *

Region
Endpoint

Use Proxy
Proxy Server
Proxy Port
Proxy User

Proxy
Password

Name of the event source.

Select the check box to enable the event source configuration to start collection. The check box is selected by
default.

Account Identification code of the S3 Bucket

Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS (CloudTrail) region in which you create
the bucket. You specify the name at the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for DNS-compliant bucket names are:

o Bucket names must be at least three and no more than 63 characters long.

o Bucket names must be a series of one or more labels. Adjacent labels are separated by a single period “.”.
Bucket names can contain lowercase letters, numbers, and hyphens. Each label must start and end with a
lowercase letter or a number.

o Bucket names must not be formatted as an IP address (for example, 192.168.5.4).

The following examples are valid bucket names:

e myawsbucket
e my.aws.bucket

e myawsbucket.1l

The following examples are invalid bucket names:

e .myawsbucket - Do not start a Bucket Name with a period
e myawsbucket. - Do notend a Bucket Name with a period

e my..examplebucket - Only use one period between labels.

Key used to access the S3 bucket. Access Keys are used to make secure REST or Query protocol requests to
any AWS service API. Please refer to Manage User Credentials on the Amazon Web Services support site
for more information on Access Keys.

Secret key used to access the S3 bucket.

Region of the S3 bucket. us—east -1 is the default value.

Specifies the AWS CloudTrail hostname. For example, for an AWS public cloud for us-east region, the
Region Endpoint would be s3.amazonaws.com. More information can be found at

http://docs.aws.amazon.com/general/latest/gr/rande.html#s3 region. This parameter is
necessary to collect CloudTrail logs from AWS Government or Private clouds.

Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Enter the proxy name you want to connect to access the AWS server.

Enter the port number that connects to the proxy server to access the AWS server.
Enter the user name to authenticate with the proxy server.

Enter the password to authenticate with proxy port.
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Start Date * Starts AWS (CloudTrail) collection from the specified number of days in the past, measured from the current
timestamp. The default value is 0, which starts from today. The range is 0—89 days.

Log File Prefix ~ Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure to enter the same prefix in
this parameter.

Cancel Closes the dialog without adding the AWS (CloudTrail).

OK Adds the current parameter values as a new AWS (CloudTrail).

The following table describes the Advanced configuration parameter for AWS collection.

Ree Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an

event source and you need to investigate this problem. Enabling debugging will adversely affect the
performance of the Log Collector.
Enables or disables debug logging for the event source.

Valid values are:
o Off = (default) disabled

On = enabled
e Verbose = enabled in verbose mode - adds thread information and source context information to the
messages.
This parameter is designed to debug and monitor isolated event source collection issues. The debug logging is
verbose, so limit the number of event sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).
Command Args  Arguments added to the script.

Polling Interval  Interval (amount of time in seconds) between each poll. The default value is 60.

For example, if you specify 60, the collector schedules a polling of the event source every 60 seconds. If the
previous polling cycle is still underway, it will wait for it to finish that cycle. If you have a large number of
event sources that you are polling, it may take longer than 60 seconds for the polling to start because the
threads are busy.

SSL Enabled Select the check box to communicate using SSL. The security of data transmission is managed by encrypting
information and providing authentication with SSL certificates.

The check box is selected by default.

Test Connection  Validates the configuration parameters specified in this dialog are correct. For example, this test validates that:

o NetWitness can connect with the S3 Bucket in AWS using the credentials specified in this dialog.

o NetWitness can download a log file from the bucket (test connection would fail if there were no log files
for the entire bucket, but this would be extremely unlikely).
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Configure Azure Event Sources in NetWitness Platform

This topic tells you how to configure the Azure collection protocol. Microsoft Azure is a cloud
computing platform and infrastructure for building, deploying, and managing applications and services
through a global network of Microsoft-managed data centers.

Configuration in NetWitness Platform

For complete details about configuring Azure as an event source, see the Azure Event Source
Configuration Guide, available on RSA Link.

To configure an Azure Event Source:
1. Go to ADMIN> Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Sources tab.

& Change Service o] Log Collector |  Config &

[eEREE] Remote Collectors Files Event Sources JESUIARESE{]Es Settings Appliance Servicyg

|| V| Config v

Check Point

File S
Metflow

ODEC

Plugins

SDEE

SNMP

VMware

Windows

5. Inthe Event Sources tab, select Plugins/Config from the drop-down menu.

=

6. Inthe Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select azureaudit) and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.
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The Add Source dialog is displayed.

9. Define parameter values. For details, see Azure Parameters below.

10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness Platform displays an error message.

11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Azure Parameters

This section describes the Azure event source configuration parameters.

Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

N

Name *

Enabled

Client ID *

Client Secret
*

API Resource
Base URL *

Federation
Metadata
Endpoint *

Subscription
ID *

Tenant
Domain *

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

The Client ID is found the Azure Application Configure tab. Scroll down until you see
it.

When you are configuring the event source, the client secret is displayed when you are
creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it cannot be
retrieved later.

Enter https://management.azure.com/. Be sure to include the trailing slash

).

In your Azure application, click the View Endpoints button (near the bottom of the
pane).

There are a lot of links that all begin with the same string. Compare the URLs and
find the common string that begins most of them. This common string is the endpoint
that you need to enter here.

You can find this in the Microsoft Azure dashboard: click on Subscriptions at the
bottom of the list on the left.

Go to the active directory and click on the directory. In the URL, the tenant domain is
the string directly following manage.windowsazure.com/. The tenant domain is the
string up to and including the .com.
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am o

Resource In Azure, select Resource groups from the left navigation pane, then select your
Group Names group.

*

Start Date *  Choose the date from which to start collecting. Default's to the current date.

Test Checks the configuration parameters specified in this dialog to make sure they are
Connection correct.

Advanced Parameters

Click © next to Advanced to view and edit the advanced parameters, if necessary.

Neme lpwscrpn

Polling  Interval (amount of time in seconds) between each poll. The default value is 180.

Interval  For example, if you specify 180, the collector schedules a polling of the event source every
180 seconds. If the previous polling cycle is still underway, the collector waits for that
cycle to finish. If you have a large number of event sources that you are polling, it may take
longer than 180 seconds for the polling to start because the threads are busy.

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Duration
Poll

Max The maximum number of events per polling cycle (how many events collected per polling
Events  cycle).
Poll

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Idle

Time

Poll

iommand Optional arguments to be added to the script invocation.
rgs
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oo

Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a
problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:

o Off = (default) disabled

e On =enabled

o Verbose = enabled in verbose mode - adds thread information and source context

information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues. If
you change this value, the change takes effect immediately (no restart required). The debug
logging is verbose, so limit the number of event sources to minimize performance impact.

Configure Check Point Event Sources in NetWitness Platform

This topic tells you how to configure the Check Point collection protocol, which collects events from
Check Point event sources.

This protocol collects events from Check Point event sources using OPSEC LEA. OPSEC LEA is the
Check Point Operations Security Log Export API that facilitates the extraction of logs.

How Check Point Collection Works

The Log Collector service collects events from Check Point event sources using OPSEC LEA. OPSEC
LEA is the Check Point Operations Security Log Export API that facilitates the extraction of logs.

Note: OPSEC LEA (Log Export API) supports extraction of logs from Check Point event sources
configured with a SHA-256 or SHA-1 certificate.

Deployment Scenario

The following figure illustrates how you deploy the Check Point Collection Protocol in NetWitness
Platform.
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Intranet

~ CheckPoint
y event sources

OPSEC LEA
(port: 18184)

Log Collection
(Local and

Remote
Collectors)

*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configuration in NetWitness Platform

To configure a Check Point Event Source:
1. Goto ADMIN> Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
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4.

10.

11.

Click the Event Sources tab.

& Change Service i Log Collector | Config &

[eREE] Remote Collectors Files Event Sources ST aESaEN{ES Settings Appliance Servicg

|| V| Config hd

Check Point

File 5
Metflow

ODBC

Plugins

SDEE

SNMP

WVMware

Windows

In the Event Sources tab, select Check Point/Config from the drop-down menu.

=

In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
Select a check point event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

Select the new type in the Event Categories panel and click in the Sources toolbar.
The Add Source dialog is displayed.

Define parameter values. For details, see Check Point Parameters below.

Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness Platform displays an error message.

If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Check Point Parameters

This section describes the Check Point event source configuration parameters.
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Basic Parameters

Name* Name of the event source.

Address* IP Address of the Check Point server.

Server Name of the Check Point server.

Name*

Certificate Certificate name for secure connections to use when the transport mode is https. If set,

Name the certificate must exist in the certificate trust store that you created using the Settings
tab.

Select a certificate from the drop-down list. The file naming convention for Check
Point event source certificates is checkpoint_name-of-event-source.

Client Enter the Client Distinguished Name from the Check Point server.

Distinguished

Client Entity ~ Enter the Client Entity Name from the Check Point server.

Name

Server Enter the Server Distinguished Name from the Check Point server.

Distinguished

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

Pull Select the checkbox to pull a certificate for first time. Pulling a certificate makes it

Certificate available from the trust store.

Certificate IP Address of the server on which the certificate resides. Defaults to the event source

Server address.

Address

Password Only active when you select the Pull Certificate checkbox for first time. Password

required to pull the certificate. The password is the activation key created when adding
an OPSEC application to Check Point on the Check Point server.

Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to stay open
for a specific time and specific event volume (transient connection). RSA NetWitness Platform defaults
to the following connection parameters that establish a transient connection:

o Polling Interval = 180 (3 minutes)

o Max Duration Poll = 120 (2 minutes)

o Max Events Poll = 5000 (5000 events per polling interval)
o Max Idle Time Poll =0
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For very active Check Point event sources, it is a good practice to set up a connection that stays open
until you stop collection (persistent connection). This ensures that Check Point collection maintains the
pace of the events generated by these active event sources. The persistent connection avoids restart and
connection delays and prevents Check Point collection from lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters to the
following values:

« Polling Interval =-1

e Max Duration Poll = 0
o Max Events Poll =0
o Max Idle Time Poll =0

Port

Collect Log
Type

Collect Logs
From

Polling
Interval

Max
Duration
Poll

Port on the Check Point server that Log Collector connects to. Default value is 18184,

Type of logs that you want to collect: Valid values are:
o Audit - collects audit events.

o Security - collects security events.

If you want to collect both audit and security events, you must create a duplicate event
source. For example, first you would create an event source with Audit selected pulling
a certificate into the trust store for this event source. Next you would create another
event source with the same values except that you would select Security for the Collect
Log Type and you would select the same certificate in Certificate Name that you pulled
when you set up the first set of parameters for this event source and you would make
sure that Pull Certificate was not selected.

When you set up a Check Point event source, NetWitness collects events from the
current log file. Valid values are:

o Now - Start collecting logs now (at this point in time in the current log file).
o Start of Log - Collect logs from the beginning of the current log file.
If you choose "Start of Log" for this parameter value, you may collect a very large

amount of data depending on how long the current log file has been collecting events.
Note that this option is effective only for the first collection session.

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event source
every 180 seconds. If the previous polling cycle is still underway, it will wait for it to
finish that cycle. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are busy.

The maximum duration of polling cycle (how long the cycle lasts) in seconds.
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Max Events = The maximum number of events per polling cycle (how many events collected per
Poll polling cycle).

Max Idle Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is the
Time Poll default value.

Forwarder Enables or disables the Check Point server as a forwarder. By default it is disabled.

Log Type Logs from the event source in Name Value format. By default it is disabled.
(Name
Value Pair)

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you

have a problem with an event source and you need to investigate this problem.
Enabling debugging will adversely affect the performance of the Log Collector.

Enables and disables debug logging for the event source.

Valid values are:

o Off = (default) disabled

o On = enabled

o Verbose = enabled in verbose mode - adds thread information and source context

information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).

Verify Check Point Collection is Working

The following procedure illustrates how you can verify that Check Point collection is working from the
Administration > Health & Wellness > Event Source Monitoring tab.

To verify Check Point collection from the Event Source Monitoring tab:
1. Access the Event Source Monitoring tab from the Administration > Health & Wellness view.
2. Find checkpointfw1 in the Event Source Type column.

3. Look for activity in the Count column to verify that Check Point collection is accepting events.

To verify Check Point collection from the Investigation > Events view:

The following procedure illustrates how you can verify that Check Point collection is working from the
Investigation > Events view.
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1. Access the Investigation > Events view.

2. Select the Log Decoder (for example, LD1) collecting Check Point events in the Investigate a
Device dialog.

3. Look for a Check Point event source parser (for example, checkpointfw1) in the device.type field in
the Details column to verify that Check Point collection is accepting events.

Note: If the logs from the VSX Checkpoint firewall server are collected by the Log Collector
checkpoint service, to translate the VSX IP in the logs to ip.orig meta, you must add the VSX
hostname and the VSX IP address to the /etc/hosts file in the Log Collector.

Configure File Event Sources in NetWitness Platform

This topic tells you how to configure the File collection protocol.

Configure a File Event Source

To configure a File Event Source:

1. Goto ADMIN > Services from the NetWitness Platform menu.
2. Select a Log Collection service.

3. Under Actions, select ﬁ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

& Change Service | i Log Collector | Config ©

General Remote Collectors Files Event Sources JESGELANESEN{E Settings Appliance Servicd

|| V| Config w

Check Point

File S
Meatflow

ODEC

Plugins

SDEE

SNMP

ViMware

Windows

5. Inthe Event Sources tab, select File/Config from the drop-down menu.
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6. Inthe Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select a file event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.
The Add Source dialog is displayed.

9. Add a File Directory name and modify any other parameters that require changes. For details, see
File Collection Parameters below.

10. To get the public key and enter it into the dialog box, do the following:
a. Select and copy the public key from the Event Source by running: cat ~/.ssh/id rsa.pub
b. Paste the public key in the Eventsource SSH Key field.

11. Click OK.

You need to restart file collection for your changes to take effect.

Stop and Restart File Collection

After you add a new event source that uses file collection, you must stop and restart the NetWitness
Platform File Collection service. This is necessary to add the key to the new event source.

File Collection Parameters

The following table provides descriptions of the File Collection source parameters.

The following table describes the Basic configuration parameter for File collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

o

File Collection directory (for example, Eur_London100) into which the File event source
Directory* places its files. Valid value is a character string that is conforms to the following regular
expression:

[ a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores. Do not modify this parameter after you start collecting event data.

After you create the collection, the Log Collector creates the work, save, and error sub-
directories under the collection directory.

Address* 1P address of the event source. Valid value is an IPv4 address, IPv6 address, or a
hostname including a fully-qualified domain name.

File Spec  Regular expression. For example, *.*$ = process everything.
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o

File Character encoding used by the syslog senders to this port. Defaults to UTF-8.
Encoding

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as well,
and most senders have their encoding set to UTF-8.

RSA has tested the following values:
o EUC-KR

« SIIS

« GB3212/GBK

o ISO 8859-1 (German)

o ISO_8859-7 (Greek)

Cancel Closes the dialog without making adding an event source type.
OK Adds the parameters for the event source.

The following table describes the Advanced configuration parameter for File collection.

Nere _JDesctpten

Ignore Select the check box to ignore encoding conversion errors and ignore invalid data. The
Encoding check box is selected by default.

Conversion

Errors Caution: This may cause parsing and transformation errors.

File Disk Determines when to stop saving files regardless of the Save On Error and Save On
Quota Success parameter settings. For example, a value of 10 indicates that when there is less

than 10% available disk left, the Log Collector stops saving files to reserve enough
space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection directory is
mounted. If the Log Decoder server has a 10TB disk size and 2TB is allocated to base
collection directory, then setting this value to 10 causes log collection to stop when
less than 0.2TB (10% of 2TB) of space is left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential ~ Sequential processing flag:

Flasssaig o Select the check box (default) to process event source files in collection order.

o Do not select the checkbox to process event source files in parallel.
Save On Save on error flag. Check the checkbox to retain the eventsource collection file when
Error the Log Collector it encounters an error. The check box is selected by default.
Save On Save eventsource collection file after processing flag. Check the checkbox to save the
Success eventsource collection file after processing it. The check box is not selected by default.
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o

Eventsource SSH public key used to upload files for this event source. Please refer to the Generate

SSH Key

Manage
Error Files

Error Files
Size

Error Files
Count

Error Files
Reduction
%

Key Pair on Event Source and Import Public Key to Log Collector section in the Install
and Update the SFTP Agent Guide for instructions on generating keys.

Note: If File collection is stopped, NetWitness Platform does not update the
authorized keys file with the SSH public key that you add or modify in this parameter.
You must restart File collection to update the public key.

You can add or modify the value of the public key in this parameter in multiple File
event sources without File collection running, but NetWitness Platform will not update
the authorized_keys file until File collection is restarted.

By default, the Log Collector uses the File Disk Quota parameter to ensure that the disk
does not fill up with error files. If you set this parameter to true, you can specify one of
these:

« Maximum space allotted to error files in the Error Files Size parameter.

o Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Select the check box to manage error files. The check box is not selected by default.

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Specifies to what extent NetWitness Platform saves error files. The value that you
specify is the maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. Y ou specify these values in
either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default. If you
change this parameter, the change does not take effect until you restart collection or
restart the Log Collector service.

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Maximum number of error files allowed in the error directory. Valid value is a number
in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Percent amount by size or count of the error files that the Log Collector service removes
when the maximum size or count has been reached. The service removes the oldest files
first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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Manage Select the check box to manage saved files. The check box is not selected by default.
Saved Files By default, the Log Collector uses the File Disk Quota parameter to ensure that the disk
does not fill up with saved files. If check this check box, you can specify one of these:

o Maximum space allotted to saved files in the Saved Files Size parameter.

o Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Saved Files Only valid if the Manage Saved Files and Save On Success parameters are set to true.

Size Maximum total size of all the files in the save directory. Valid value is a number in the
0 to 281474976710655 range. Y ou specify these values in either Kilobytes, Megabytes,
or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Saved Files Only valid if the Manage Saved Files and Save On Success parameters are set to true.
Count Maximum number of saved files in the save directory. Valid value is a number in 0 to
65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Saved File  Percent amount by size or count of the saved files that the Log Collector service
Reduction removes when the maximum size or count has been reached. The service removes the
% oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Debug Caution: Only enable debugging (set this parameter to On or Verbeose) if you have a

problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source.
Valid values are:

o Off = (default) disabled
e On = enabled

o Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).
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Configure Netflow Event Sources in NetWitness Platform

This topic tells you how to configure the Netflow collection protocol.

Configure a Netflow Event Source

To configure a Netflow Event Source:
1. Goto ADMIN > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Sources tab.

RVICES

& Change Service | i Log Collector | Config &

[ELEEL Remote Collectors Files Event Sources JESUAESsET{]E Settings Appliance Servicg

|| V| Config hd

Check Point
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SDEE

SNMP

Viware

Windows

5. Inthe Event Sources tab, select Netflow/Config from the drop-down menu.

=+

6. Inthe Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select the netflow event source type and click OK.
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Available Event Source Types

Cancel

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.
The Add Source dialog is displayed.

9. Enter a port number in the Port field, and ensure the Enabled box is checked.

Note: NetWitness Platform opens the 2055, 4739, 6343, and 9995 ports on the firewall by default.
You can open other ports for Netflow if required.

For details of other parameters, see Netflow Collection Parameters below.

10. Click OK.

The new event source is displayed in the list.

Netflow Collection Parameters

The following table provide descriptions of the basic Netflow Collection parameters.

Namo Dsserpuen

Port Specify the port number configured for the Netflow event source.
NetWitness Platform opens the 2055, 4739, 6343, and 9995 ports for Netflow by default.
You can open other ports for Netflow if required.

Enabled Select the check box to enable the event source configuration to start collection. The check
box is selected by default.

Cancel Closes the dialog without making adding an event source type.
OK Adds the parameters for the event source.

The following table provide descriptions of the advanced Netflow Collection parameters.
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InFlight  Establishes a threshold that, when reached, NetWitness Platform generates a log message

Publish to help you resolve event flow issues. The Threshold is the size of the netflow event
Log messages currently flowing from the event source to NetWitness Platform .
Threshold

Valid values are:
o 0 (default) - disables the log message.

o 100-100000000 - generates a log message when this Log Collector has
processed the specified number of netflow events. For example, if you set this
value to 100, NetWitness Platform generates a log message when 100 netflow
events of the specific netflow version (v5 or v9) have been processed.

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you have a

problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector .

Enables or disables debug logging for the event source.

Valid values are:
o Off = (default) disabled

e On = enabled

e Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).

ODBC

Configure ODBC Event Sources in NetWitness Platform

This topic tells you how to configure ODBC collection protocol which collects events from event
sources that store audit data in a database using the Open Database Connectivity (ODBC) software
interface.

Deployment Scenario

The following figure illustrates how you deploy the ODBC Collection Protocol in NetWitness Platform.
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*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configure an ODBC Event Source

To configure an ODBC event source, you need to configure an event source type, and also choose a
DSN template.

Configure a DSN

The following procedure describes how to add a DSN from an existing DSN template. For other
procedures related to DSNs, see Configure Data Source Names (DSN5s).

Configure a DSN (Data Source Name):
1. Go to Administration > Services.

2. In the Services grid, select a Log Collector service.

3. Click ﬁ “ under Actions and select View > Config.
4. Inthe Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
5. The DSNs panel is displayed with the existing DSNGs, if any.
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Click + to open the Add DSN dialog.

Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use the

name when you set up the ODBC event source type.) If required, click (4 Manage Templates ¢ ;44 op

delete DSN templates.

Fill in the parameters and click Save.

Add an Event Source Type

For details on parameters used in the following procedure, see ODBC Event Source Configuration

Parameters.

To configure an ODBC Event Source Type:

1. Goto ADMIN > Services.

2. Select a Log Collection service.

3. Under Actions, select 'ﬂ' “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

& Change Service | ) Log Collector | Config &
[eEREE] Remote Collectors Files Event Sources JESUIARESE{]Es Settings

|| v | Config v

Check Point

File S

Metflow
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Plugins

SDEE

SNMP

VMware

Windows

In the Event Sources tab, select ODBC/Config from the drop-down menu.

=

In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

Appliance Servicyg
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Available Event Source Types

L] MName ~
IBMDEZ
actiance
actividentity
asels

bigfix

bitg

bitgv72
bmcremedyitsm
ciscolmsaudit

ciscolmsfault

O oogoooogogno

cisconcm

Cancel

OK

7. Select an event source category (for example mssql and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click

The Add Source dialog is displayed.

Add Source

Basic
DSN *
Username *

Password

®

Enabled
Address *

(~) Advanced

Max Cell Size 2048
Nil Value (ruall)
Polling Interval 180
Max Events Poll 5000
Debug Off

Initial Tracking Id

Test Connection

Cancel

0K

v

<»

¢ <r <>

in the Sources toolbar.
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9. Select a DSN from the drop down list, specify or modify the other parameters as required, and click
OK.

10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the
DSN information and retry.

Note: Log Collector takes approximately 60 seconds to return the test results. If it exceeds the
time limit, the test times out and the NetWitness Platform server displays an error message.

11. If the test is successful, click OK.
The newly defined DSN is displayed in the Sources panel.

Configure Data Source Names (DSNs)
This topic tells you how to create and maintain DSNs for ODBC Collection.
Context

Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you need to
define DSNs with their associate value pairs for ODBC event source configuration.

Navigate to the DSN Panel
To add or edit DSNs or DSN templates, first navigate to the appropriate screen.

To navigate to the DSN templates panel:
1. Goto ADMIN > Services.

2. Inthe Services grid, select a Log Collector service.

3. Click ﬁ ' under Actions and select View > Config.

4. Inthe Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
The DSNs panel is displayed with the DSNs that are added, if any.

. Change Service LC - Log Collector | Config
General Remote Collectors Files Event Sources [RAYIABESTETelst Settings Appliance Service Col
0ODBC v~ | DSNs v
s 4 = Manage Templates
0| psN - Parameters

[] DSNSample Database=MSSQLHost, Driver=/opt/netwitness/odbc/lib/R3sqls27.s0, PortNumber=1433, HostName=localhost

From this screen, you can perform the following actions:

o Add anew DSN template
o Add a DSN from an existing template
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o Add a DSN by editing an existing DSN template

o Remove a DSN or DSN template

Add a New DSN Template

If none of the predefined DSN templates fit your needs, use this procedure to add a DSN template.

1. From the DSNs panel, click [4 Manage Templates

The Manage DSN Templates dialog is displayed.

Manage DSN Templates

+ =

|

ooooooooooooooag

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DB2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Templ...
MySQL_Server_Unix_Template
Cracle_Server_Windows_Template
Cracle_Server_Unix_Template
Cracle_Native_Windows_Template
Cracle_Native_Unix_Template
PostgressQL_Windows_Template

PostgressQL_Unix_Template

Close

Note: RSA provides default templates on the left side panel that you can use while adding a new
DSN.

o

2. Click .
The right panel is activated.

3. Specify a template name and click

on the right panel to add parameters.
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4. Specify the parameters. Click Save.

Manage DSN Templates

Template Mame : MSSQL_Server_ Windows_Template + =
[ Name Value
[ HostName ’ http://testServer/home
[ PortNumber 1433
[[] Database MSSQLHost
[ Driver Jopt/netwitness/odbc/lib/R3sqls27.s0

Cancel Save Close

The new DSN template is added in the Manage DSN Templates list.

Add a DSN from an existing template

You can select an existing template, and fill in the parameters for your needs.

1. From the DSNs panel, click + to open the Add DSN dialog box.
The Add DSN dialog is displayed with existing DSNs, if any

2. Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use the
name when you set up the ODBC event source type.)

3. Fill in the parameters and click Save.
Your DSN is added to the list of DSNs.

Add a New DSN by editing an existing DSN template
You can add a DSN by updating an existing DSN template to fit your needs.

1. From the DSNs panel, click (4 Manage Templates

The Manage DSN Templates dialog is displayed.
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Manage DSN Templates

+

OO0 oooo0ooooooogoo O

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DB2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Templ...
MySQL_Server_Unix_Template
Cracle_Server_Windows_Template
Cracle_Server_Unix_Template
Cracle_Native_Windows_Template
Cracle_Mative_Unix_Template
PostgresSQL_ Windows_Template

PostgresSQL_Unix_Template

Close

2. Select the existing template that you want to modify.

The right panel is activated, and the default parameters for the selected template are displayed.
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Add DSN

O5M Mame*

Parameters
= -
Mame
PortMumber
HostName
Database

Diriver

D5SM Template | EMC_Greenplurn_Unix_Template

= |

value
5432
GreenplumServer

Gplumdb

ODBCHOME/ibsoxgplmnn.zz

Cancel Save

SN O

Specify a name in the DSN Name field.

Add, delete or edit the default parameters.

7. Fill in the parameters and click Save.

Your DSN is added to the list of DSNs.

Remove a DSN or DSN template

If you no longer use a DSN or a DSN template, you can remove it from the system.

To remove an existing DSN:

1. From the DSNs panel, select an existing DSN.

2. Click ==.

A Warning message appears, asking whether you are sure you want to delete the DSN.

3. To delete the DSN, click Yes. Alternatively, to cancel the deletion, click No.

If you confirmed the deletion, the selected DSN is removed from the system.

Once you have the set of required parameters, click Save, then Close.

Choose the DSN Template that you updated from the drop down menu and enter a name for the
DSN. (You use the name when you set up the ODBC event source type.)
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To remove an existing DSN Template:

1. From the DSNs panel, click (4 Manage Templates

The Manage DSN Templates dialog is displayed.

Manage DSN Templates

+ -

|

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DB2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Templ...
MySQL_Server_Unix_Template
Cracle_Server_Windows_Template
Cracle_Server_Unix_Template
Cracle_Native_Windows_Template
Cracle_Native_Unix_Template

PostgresSQL_Windows_Template

Ooooooooooooogogao

PostgresSQL_Unix_Template

Close

2. From the DSNs panel, select an existing DSN Template.
3. Click =.

A Confirmation message appears, asking whether you are sure you want to delete the DSN
Template.

4. To delete the DSN Template, click Yes. Alternatively, to cancel the deletion, click No.
If you confirmed the deletion, the selected DSN Template is removed from the system.
Configure device.ip meta for ODBC Data Source

For any ODBC event source, you can choose to have the ODBC collector populate the device.ip meta
value with either the event source IP address or the actual source IP on which logs are being collected.

To view or set this parameter:
1. Goto ADMIN > Services.

2. Inthe Services grid, select a Log Collector service.

3. Click ﬁ “ under Actions and select View > Explore.
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4. Navigate to logcollection > odbc > eventsources.

There are entries for each ODBC event source that you have configured in NetWitness. For
example, for this installation, the only ODBC event source currently configured is MS SQL:

| Log - Collector

-+ Change Service

Explore &

Elog- Collector (Log C...

L) LSS Ty =gl e e T

rHE'Icg:{:nllec:'\::lr' 1

B checkpoint
B[] emdscript
B[ fle
B[] netflow
B edbe
B[] destinations
B eventsources

-

! Log - Collector {Log Collector)

conneciions
event-broker
EVent-processors
logcollection

logs

rest

sdk

services
storedproc

]

users

5. Click + next to an event source to expand it and see its DSN entry.

| Log - Collector

+ Change Service

|  Explore &

¥ Log - Collector (Log C...

LR~ IL"JI ULESSUTS
B logeollection
B[] checkpoint
B[] cmdscript
@A Tile
B[] netflow
B odbe
B[] destinations
B S eventzources

B mssql

[ Test_DsN

flogcollectionfodbo/eventsources/mssql Log - Collector {Log Collector)
Test_DSN
created_at 20180205T125526
created_by User admin (session 255620, 10,10

eventsource_type ITIEEC”

6. Click the DSN entry (in this example Test DSN) to show the parameters.

7. The use_eventsource address parameter is listed.
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& Change Service | Log - Collector

|  Explore @

= log - Collector (Log C... <l

e R L LA [ FIpe T "
B logcollection
[ checkpoint
B [ cmdscript
B[ TJfile
B[] netflow
B edbe
B[] destinations
B S eventsources
B mssql
[ Test_DsN
B[ stats
[Jworkmanager
B[ sdee
[Jsnmptrap
[ syslog
B[ vmware
B [windows
B[ Jlogs

flogcollection/odbc/eventsources/mssql/ Test_DSN

created_at
created_by

debug

dsn

enabled

event_filter
event_filter_debug
eventsource_address
file_name
initial_tracking_id
max_cell_size
max_events_per_cycle
name

nil_value

node_type

password
polling_interval

typespec_version

Log - Collector {Log Collector)

20180205T125832

User admin (session 255774, 10.101.32.172:52140)
0

Test_DSN

trus

0
1.1.11

file_template

Test_DSN
{(null)
workgroup
*hhkHAhEh
180

1.0

use_eventsource_address

falsej

Username

test-user

o False: actual source IP address is used. This is the default value.

e True: event source IP address is used.

8. Click on the value (in this case False), and type in the new value.

Note: If you type anything other than true or false (case does not matter), you receive an error
saying that the value you entered cannot be set.

Any changes you make take effect immediately.

Create Custom Typespec for ODBC Collection

RSA NetWitness uses type specification (typespec) files for ODBC and file collection. These files act

on raw log files, and are used for two main purposes:

o Define where in the log file data resides. For instance, some log files contain header information that
is not considered data to be parsed.

o Replace certain types of characters that the log parser cannot parse correctly. For instance, the tab
character can sometimes cause problems.

This topic tells you how to create a custom typespec for the Log Collector. The topic includes:

o Create Custom typespec procedure

o« ODBC Collection typespec syntax
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o Sample ODBC Collection typespec files

Create Custom Typespec

To create a custom typespec file:

1.

4.
5.

Open an SFTP client (for example, WinSCP) and connect to a Log Collector or remote Log
Collector.

Navigate to /etc/netwitness/ng/logcollection/content/collection/odbc, and copy an
existing file, for example bit9.xml.

Modify the file according to your requirements. See ODBC Collection Typespec Syntax for details.
Rename and save the file to the same directory.

Restart the Log Collector.

Note: You will not be able to see new Event Source type in NetWitness Platform until you restart the
Log Collector.

ODBC Collection Typespec Syntax

The following table describes the typespec parameters.

name The display name of your ODBC event source (for example, activeidentity). NetWitness Platform displays

this name in the Sources panel of the View > Config > Events Sources tab.

Valid value is an alphanumeric string. Y ou cannot use - (dashes), _(underscores), or spaces. The name
must be unique across all typespec files in the folder.

type Event source type: odbc. Do not modify this line.

prettyName User-defined name for the event source. You can use the same value as name (for example, apache) or use

a more descriptive name.

version Version of this typespec file. Default value is 1.0.

author Person who created the typespec file. Replace author-name with your name.

description Formal description of the event source. Replace formal-description with your description of the event
source.

<device> Section

parser This optional parameter contains the name of the log parser. This value forces the Log Decoder to use the

specified log parser when parsing logs from this event source.

Note: Please leave the field blank when unsure of the log parser to be used.

name Name your ODBC event source (for example, Actividentity ActivCard AAA Server).
maxVersion The version number of the event source (for example, 6.4.1).
description Description of the event source.

<collection> Section
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odbc The syntax under <odbc> is used for event collection and processing. You can provide multiple queries
for the same event source type by adding <query> tags.

query This section contains the details of the query used to collect information from the event source.
tag The prefix tag you want to add to events during transformation (for example Activldentity).
outputDelimiter Specity the delimiter to use to separate fields. Specify any of the following values:

o || (piping)

o " (caret)

e , (comma)
e : (colon)
o 0x20 (to represent a space)
interval Specify the number of seconds between events. Default value is 60.

dataQuery Specity the query to fetch data from the ODBC eventsource database for SQL-syntax. For example:

SELECT acceptedrejected, servername, serveripa, sdate,
millisecond, suid, groupname, ipa, reason, infol, info2,
threadid FROM A AHLOG WHERE sdate > '3TRACKING%' ORDER BY sdate

maxTrackingQuery The query used on the initial pull of events to identify the starting point within the data set to begin pulling
logs from. After the initial pull, this query is no longer used, unless the maxTracking value has been reset
or altered. For example:

SELECT MAX (Event Id) from ExEvents

trackingColumn The tracking column value used when the ODBC collector pulls a new set of events.

Sample ODBC Collection Typespec Files
The following sample is the typespec file for the IBM ISS SiteProtector event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

<name>siteprotector4 x</name>
<type>odbc</type>
<prettyName>SITEPROTECTOR4 X</prettyName>
<version>1.0</version>
<author>Administrator</author>

<description>Collects events from SiteProtector</description>

<device>
<name>Internet Security Systems, Inc. RealSecure SiteProtector v 2.0</name>
<maxVersion>2.0</maxVersion>
<description></description>

<parser>iss</parser>
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</device>

<configuration>

</configuration>

<collection>
<odbc>
<query>
<tag></tag>
<outputDelimiter></outputDelimiter>
<interval></interval>
<dataQuery></dataQuery>
<maxTrackingQuery></maxTrackingQuery>
<trackingColumn></trackingColumn>
<levelColumn></levelColumn>
<eventIdColumn></eventIdColumn>
<addressColumn></addressColumn>
</query>
</odbc>
</collection>

</typespec>
The following sample is the typespec file for the Bit9 Security Platform event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

<name>bit9</name>
<type>odbc</type>
<prettyName>BIT9</prettyName>
<version>1.0</version>
<author>Administrator</author>

<description>Bit9 Events</description>

<device>
<name>Bit9</name>
<parser>bit9</parser>

</device>

<configuration>

</configuration>

<collection>
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<odbc>

<query>
<tag>BIT9</tag>
<outputDelimiter>| |</outputDelimiter>
<interval>10</interval>
<dataQuery>
SELECT
Timestamp,
Event Id,
Computer Id,
File Catalog Id,
Root File Catalog Id,
Priority,
Type,
Subtype,
IP Address,
User Name,
Process,
Description
FROM
ExEvents
WHERE
Event Id > '$TRACKINGS'
</dataQuery>
<trackingColumn>Event Id</trackingColumn>
<maxTrackingQuery>SELECT MAX (Event Id) from ExEvents</maxTrackingQuery>
<eventIdColumn></eventIdColumn>

</query>

</odbc>
</collection>

</typespec>

Troubleshoot ODBC Collection

Y ou can troubleshoot problems and monitor ODBC collection by reviewing the ODBC collector log
informational, warning, and error messages to during execution of collection.

Each ODBC log messages includes the:
o Timestamp
o Category: debug, info, warning, or failure

o collection method = OdbcCollection
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« ODBC event source type (GOTS-name) = Generic ODBC Type Specification name that you
configured for the event source.

« collection function completed or attempted (for example, [processing])

o ODBC event source name (DSN-name) = Data Source Name that you configured for the event
source.

o description (for example, how many events the Log Collector collected)
« tracking ID =the Log Collector position in the target database table.

The following example illustrates the message you would receive upon successful collection of an
ODBC event:
2014-July-25 17:21:25 info (OdbcCollection) : [event-source] [processing]

[event-source] Published 100 ODBC events: last tracking id: 2014-July-25
13:22:00.280

The following example illustrates a message you may receive upon unsuccessful collection of an ODBC
event:

timestamp failure (OdbcCollection: [event-source] [processing]
[event-source-type] Failed during doWork: Unable to prepare
statement: state: S0002; error-code:208; description: [RSA] [ODBC-
driver] [event-source-type]Invalid object name 'object-name'.

ODBC collection failed while accessing the ODBC Driver or the target database.

Validate the DSN value pairs for the events source.

Configure SDEE Event Sources in NetWitness Platform

This topic tells you how to configure the SDEE collection protocol.

To add an SDEE Event Source:
1. Goto ADMIN > Services.
2. Select a Log Collection service.

3. Under Actions, select ﬂ “ > View > Config to display the Log Collection configuration
parameter tabs.
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4. Click the Event Sources tab.

Log Collector |  Config

[eREE] Remote Collectors Files Event Sources ST aESaEN{ES Settings Appliance Servicg

Check Point

File 5
Metflow

ODBC

Plugins

SDEE

SNMP

WVMware

Windows

5. Inthe Event Sources tab, select SDEE/Config from the drop-down menu.

The Event Categories panel displays the SDEE event sources that are configured, if any.

=

6. Inthe Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select an event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
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8. Select the new type in the Event Categories panel and click in the Sources panel toolbar.

The Add Source dialog is displayed.

Basic

Mame * ApacheSimulatorHost

Username * admin

Password *

Address * sirnvi

Enabled ™

Certificate Name w
mAOvanied

Port 443 o

S5L Version tlswl >

Imclude Raw Event Data |

Save Raw XML Files

Saved File Quota 100 Megabyte ~

Subscription Event evidsAlert

Types

Force Subscription #

Subscription Severity

Filter

Subscription Time -~
N 0 w

Offsat

Polling Interval 180 o

Max Events Poll 5000 b

Query Timeout 0 o

URL Parameters

UBL Path fcgi-bin/sdee-server

URL Protocol https hd

Debu B on e

9. Add a Name, Username, Address, and Password, and modify any other parameters that require
changes, and click OK.
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Configure SNMP Event Sources in NetWitness Platform

This topic tells you how to configure the SNMP collection protocol.

Configure the SNMP Trap Event Source

To add the SNMP Event Source:

Note: If you have previously added the snmptrap type, you cannot add it again. You can edit it, or
manage users.

1. Goto ADMIN > Services from the NetWitness Platform menu.
2. Select a Log Collection service.

3. Under Actions, select 'ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

& Change Service | @) Log Collector |  Config &
General Remote Collectors Files Event Sources RESEAREEl]yls Settings Appliance Servicg

|| V| Config A

Check Point

File 3

Metflow

ODEBEC

Plugins

SDEE

SNMP

VMware

Windows

5. Inthe Event Sources tab, select SNMP/Config from the drop-down menu.

o

6. Inthe Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.
7. Select the snmptrap event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
8. Select snmptrap in the Event Categories panel.

9. Select snmptrap in the Sources panel and then click the Edit icon,
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10.

|ﬁ, to edit the parameters.
Update any of the parameters that you need to change and click OK.

(Optional) Configure SNMP Users

If you are using SNMPv3, follow this procedure to update and maintain the SNMP v3 users.

To configure SNMPv3 Users:

L.
2.

Go to Admin > Services.

In the Services grid, select a Log Collector service.

3. Click ﬂ “ under Actions and select View > Config.

In the Log Collector Event Sources tab, select SNMP/SNMP v3 User Manager from the drop-
down menu.

The SNMPv3 User panel is displayed with the existing users, if any.

Click + to open the Add SNMP User dialog.

Fill in the dialog with the necessary parameters. The available parameters are described below.

SNMP User Parameters

The following table describes the parameters that you need to enter when you create an SNMPv3 user.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Username * User name (or more accurately in SNMP terminology, security name). NetWitness

Platform uses this parameter and the Engine ID parameter to create a user entry in
the SNMP engine of the collection service.

The Username and Engine ID combination must be unique (for example,
logcollector).

Engine ID (Optional) Engine ID of the event source. For all event sources sending SNMP v3

traps to this collection service, you must add the username and engine id of the
sending event source.

For all event sources sending SNMPv3 informs, you must add just the username with
a blank engine id.
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Authentication (Optional) Authentication protocol. Valid values are as follows:

Type o None (default) - only security level of noAuthNoPriv can be used for traps sent to
this service

¢ SHA - Secure Hash Algorithm
o MDS - Message Digest Algorithm

IMPORTANT: DO NOT USE: do not select MDS5, as it conflicts with the Log
Collector running in FIPS mode.

Authentication Optional if you do not have the Authentication Type set. Authentication passphrase.
Passphrase

Privacy Type  (Optional) Privacy protocol. You can only set this parameter if Authentication Type
parameter is set. Valid values are as follows:

o None (default)
o AES - Advanced Encryption Standard
« DES - Data Encryption Standard

IMPORTANT: DO NOT USE: do not select DES, as it conflicts with the Log
Collector running in FIPS mode.

Privacy Optional if you do not have the Privacy Type set. Privacy passphrase.

Passphrase

Close Closes the dialog without adding the SNMPv3 user or saving modifications to the
parameters.

Save Adds the SNMPv3 user parameters or saves modifications to the parameters.

Configure Syslog Event Sources

This topic tells you how to configure Syslog event sources for the Log Collector.

Note: Prior to NetWitness Platform 11.3, you did not configure Syslog Collection for Local Log
Collectors: syslog collection was only configurable for Remote Collectors. You can configure Syslog
for local Log Collectors that are on version 11.3 or later.

Configure a Syslog Event Source

For Remote or Virtual Log Collectors, syslog listeners for UDP on port 514, TCP on port 514 and SSL on
port 6514 are created by default. You should not change the SSL settings on the TCP and SSL listeners.
If you need SSL certificate verification, create a new event source type to listen on a different port.

Note: For local Log Collectors, you cannot create syslog listeners on ports 514 and 6514: these ports
are used by the Log Decoder service.
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To configure the Log Collector for Syslog collection:

1. Goto ADMIN > Services.

2. Inthe Services grid, select a Log Collector, and from the Actions menu, choose ﬁ “ > View >
Config.

3. Select the Event Sources tab.
4. Select Syslog/Config from the drop-down menu.
The Event Categories panel displays the Syslog event sources that are configured, if any.

Note: For RSA NetWitness Platform, some Syslog event sources are available by default. In this
case, you can proceed to step 6.

5. In the Event Categories panel toolbar, click .

The Available Event Source Types dialog is displayed.

6. Select either syslog-tep or syslog-udp. You can set up either or both, depending on the needs of your
organization.

7. Select the new type in the Event Categories panel and click in the Sources panel toolbar.
The Add Source dialog is displayed.

8. Enter the port number, and select Enabled. Optionally, configure any of the Advanced parameters as
necessary.

Click OK to accept your changes and close the dialog box.

Once you configure one or both syslog types, the Log Decoder or Log Collector collects those types of
messages from all available event sources. So, you can continue to add Syslog event sources to your
system without needing to do any further configuration in RSA NetWitness Platform.

Character Encodings

For each protocol (TCP, UDP), you need to instantiate a separate syslog listener for each character
encoding.

For example, assume that you have legacy event sources sending syslog in UDP and TCP with EUC-KR
and EUC-JP encodings. You would need to configure four listeners for the Log Collector, and configure
the syslog event sources to send to separate ports as follows:

o UDP <portI> for EUC-KR
o UDP <port2> for EUC-JP
o TCP <port3> for EUC-KR
o TCP <port4> for EUC-JP

Alternatively, you could use separate Remote/Virtual Log Collectors, each using the default port 514.

Syslog Parameters

The following tables describe the available basic and advanced parameters for Syslog configuration.
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Note: Required parameters are marked with an asterisk. All other parameters are optional.

Basic Parameters

o

Port* Enter the port number that you configured for your event sources.

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

SSL Receiver | Note: This parameter applies to RSA NetWitness® Platform version 11.1 and

newer. It is available only for the syslog-tcp Event Category.

If you select the check box, the event source accepts SSL/TLS connections only. Also,
if you change this setting, you must stop and restart Syslog collection for the change to
become effective.

Encoding Character encoding used by the syslog senders to this port. Defaults to UTF-8.

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as
well, and most senders have their encoding set to UTF-8.

RSA has tested the following values:
« EUC-KR

« SIIS

« GB3212/GBK

o ISO_8859-1 (German)

o ISO_8859-7 (Greek)

Advanced Parameters

e T

Inflight Establishes a threshold that, when reached, NetWitness generates a log message to help
Publish you resolve event flow issues. The Threshold is the size of the syslog event messages
Log currently flowing from the event source to NetWitness.

Threshold  v51id values are:
o 0 (default) - disables the log message

o 100-100000000 - generates log message when the syslog event messages currently
flowing from the event source to NetWitness are within the 100 to 100000000 byte
range.

Maximum Maximum number of receiver resources used to process collected syslog events. The
Receivers default value is 2.
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N

Event
Filter

Debug

SSL
Verify
Mode

Select a filter.

Please refer to Configure Event Filters for a Collector for instructions on how to define
filters.

Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you have
a problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source.

Valid values are:
o Off = (default) disabled
¢ On = enabled

e Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).

Note: This parameter applies to RSA NetWitness® Platform version 11.1 and newer. It
is available only for the syslog-tcp Event Category.

This setting is relevant only if the SSL Receiver setting is selected. If you change the
SSL Verify Mode, you must stop and restart Syslog collection for the change to become
effective.

Available options:

o verify-none: (default) The server does not verify the client's certificate, if any. A client
can connect without presenting a certificate.

o verify-peer: The server verifies the client's certificate, if any. A client can connect
without presenting a certificate.

Note: If verification fails, a warning is logged but the messages will still be
accepted.

o verify-peer-fail-if-no-cert: The client must present a certificate and the server will
verify it.

Note: If you use this mode, the client's CA certificate must be uploaded to the Log

Collector's truststore using the REST API at http://LC-ip-
address:50101/sys/caupload
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Configure VMware Event Sources in NetWitness Platform
This topic tells you how to configure the VMware collection protocol.

To add a VMware Event Source:
1. Goto ADMIN > Services.
2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

& Change Service | @) Log Collector |  Config &
General Remote Collectors Files Event Sources [ESERAMA ]k Settings

|| V| Config A

Check Point

File S

MNetflow

ODEC

Plugins

SDEE

SNMP

Wihware

Windows

5. Inthe Log Collector Event Sources tab, select VMware/Config from the drop-down menu.

The Event Categories panel displays the VMware event sources that are configured, if any.

6. Click + to open the Available Event Source Types dialog.

Available Event Source Types

D Name =~
[ wmware-events

[l wmware-tasks

Cancel 0K
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10.

Select vmware-events or vmware-tasks from the Available Event Source Types dialog and click
OK.

The VMware available event source types are as follows:

o vmware-events: Setup vmware-events to collect events from vCenter Servers and ESX/ESXi
Servers.

o vmware-tasks: (Optional) Setup vmware-tasks to collect tasks from vCenter Servers.
Select the new type in the Event Categories panel, and click + in the Sources toolbar.

Add a Name, Username and Password, and modify any other parameters that require changes.
Caution: If you need to enter the domain name as part of the Username, you must use a double-
backslash as a separator. For example, if the domain|username is corp\smithj, you must specify

corp\\smithj.

Click OK to save your changes.

Configure Windows Event Sources in NetWitness Platform

This topic tells you how to configure the Windows collection protocol.

In RSA NetWitness Platform, you need to configure the Kerberos Realm, and then add the Windows
Event Source type.

To configure the Kerberos Realm for Windows collection:

L.
2.

3.

Go to ADMIN > Services.

Select a Log Collection service.

Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

Click the Event Sources tab.
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& Change Service LC Log Collector |  Config

General Remote Collectors Files Event Sources RESEAREEl]yls Settings Appliance Servicg

|| V| Config A

Check Point
File 3
Metflow
ODEBEC
Plugins
SDEE
SNMP

Viware

Windows

5. Select Windows/Kerberos Realm from the drop-down menu.

6. Inthe Kerberos Realm Configuration panel toolbar, click to add a new realm.
The Add Kerberos Domain dialog is displayed.

7. Fill in the parameters, using the guidelines below.

Kerberos Enter the realm name, in all caps. For example, DSNETWORKING.COM. Note that the Mappings
Realm Name parameter is automatically filled with variations on the realm name.

KDC Host Enter the name of the Domain Controller. Do not use a fully qualified name here: just the host name for the
Name DC.

Note: Make sure that the log collector is configured as a DNS client for the corporate
DNS server. Otherwise, the Log Collector will not know how to find the Kerberos
Realm. You may need to edit the entries in the
etc/netwitness/platform/resolv.dnsmasq file and then restart the dnsmasq

service. For details, see Log Collector DNS in the Troubleshooting topic.

Admin Server  (Optional) The name of the Kerberos Administration Server in FQDN format.

Mappings This parameter is automatically filled after you enter the realm name.
8. Click Save to add the Kerberos domain.
To add a Windows Event Source:

1. Goto ADMIN > Services.

2. Select a Log Collection service.
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3. Under Actions, select ﬂ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.
5. Inthe Log Collector Event Sources tab, seclect Windows/Config from the drop-down menu.
The Event Categories panel displays the VMware event sources that are configured, if any.

Next, continue from the current screen to add a Windows Event Category and type.

To configure the Windows Event Type:
1. Select Windows/Config from the drop-down menu.

2. Inthe Event Categories panel toolbar, click to add a source.
The Add Source dialog is displayed.

3. Fill in the parameters, using the guidelines below.

Alias Enter a descriptive name.

Authorization ~ Choose Negotiate.

Method

Channel For most event sources that use Windows collection, you want to collect from the Security, System, and
Application channels.

User Name Enter the account name for the Windows user account that you set up earlier for communicating with
NetWitness. Note that you need to enter the full account name, which includes the domain. For example,
rsalog@DSNETWORKING.COM.

Password Enter the correct password for the user account.

Max Events (Optional). RSA recommends that you set this value to 0, which collects everything.
Per Cycle

Polling (Optional). For most users, a value of 60 should work well.
Interval

4. Click OK to add the source.
The newly added Windows event source is displayed in the Event Categories panel.
5. Select the new event source in the Event Categories panel.

The Hosts panel is activated.

6. Click + in the Hosts panel toolbar.
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7. Fill in the parameters, using the guidelines below.

Event Source Address Enter the IP address for the Windows host.
Port Accept the default value, 5985.

Transport Mode Enter http.

Enabled Ensure the box is checked.

8. Click Test Connection.

Note: You should be able to successfully test the connection, even if the Windows service is not
running.

For more information on any of the previous steps, see the following Help topics in the NetWitness
Platform User Guide:

o Configure Windows Collection: https://community.rsa.com/docs/DOC-43410
o Microsoft WinRM Configuration Guide: https://community.rsa.com/docs/DOC-58163
o Test and Troubleshoot Microsoft WinRM Guide: https://community.rsa.com/docs/DOC-58164

Windows Legacy and NetApp Collection Configuration

This Windows Legacy protocol collects events from Windows Legacy (Windows 2003 or earlier event
sources) and CIFS Auditing events from NetApp ONTAP event sources.

You must deploy Log Collection, that is set up a Local Collector and Windows Legacy Remote
Collector, before you can configure the Windows Legacy collection protocol.

How Legacy Windows and NetApp Collection Works

You use the Windows Legacy collection protocol to configure NetWitness Platformto collection events
from:

o Legacy Microsoft Windows event sources (Window 2003 and earlier event sources)

o NetApp event sources

Window 2003 and Earlier Event Sources

Legacy Windows event sources are older Windows versions (such as Windows 2000 and Window 2003).
The Windows Legacy collection protocol collects from Windows event sources that are already
configured for enVision collection without having to reconfigure them. You set up these event sources
under the windows event source type.

NetApp Event Sources

NetApp appliances running Data ONTAP support a native auditing framework that is similar to
Windows Servers. When configured, this auditing framework generates and saves audit events in
Windows.evt file format. The Windows Legacy collection protocol supports collection of events from
such NetApp.evt files. You set up these event sources under the netapp_evt event source type.
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The NetApp Data ONTAP appliance is configured to generate CIFS Auditing events and save them
periodically as.evt files in a format that includes the timestamp in the filename. Refer to the Network
Appliance Data ONTAP Event Source Configuration Guide on RSA Link for details. The collection
protocol saves the timestamp of the last processed.evt filename to keep track of collection status.

Net App Specific Parameters

Most of the parameters that you maintain in Add/Edit Source dialog apply to both Windows Legacy and
Net App events sources.

The following two parameters are unique to NetApp event sources.
« Event Directory Path - The NetApp appliance generates event data and saves it in.evt files in a

shareable directory on the NetApp appliance. NetWitness Platform requires you to specify this
directory path in the Event Directory Path parameter

o Event File Prefix - Similar to the Event Directory Path, NetWitness Platform requires you to specify
the prefix (for example, adtlog.) of the event data.evt files so that NetWitness Platform can process
this data.

In each polling cycle, NetWitness Platform browses the configured NetApp shared path for the .evt files
that you identified with the Event Directory Path and Event File Prefix parameters. NetWitness Platform:

o Sorts Files matching the event-file-prefix. Y Y MMDDhhmmss.evt format in ascending order.

o Uses the timestamp of the last file processed to determine the files that still need processing. If
NetWitness Platform finds a partially processed file, it skips the events already processed.

Deployment Scenario

The Windows Legacy collection protocol collects event data from Windows 2003 or earlier, and NetApp
ONTAP appliance, event sources. The Windows Legacy Remote Collector is the SA Legacy Windows
Collector installed on physical or virtual Windows 2008 64-bit server in your event source domain.
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Set Up the Windows Legacy Collector

This topic tells you where to find the executable and instructions required to install or upgrade the
Windows Legacy collector in your Windows Legacy domain or domains.

You install the NetWitness Platform Windows Legacy collector on a physical or virtual Windows 2008
R2 SP1 64-Bit server using the NWLegacyWindowsCollector-11.version-number.exe. Y ou download
the NWLegacyWindowsCollector-11.version-number.exe from RSA Link. Please refer to the
NetWitness 11.x Windows Legacy Collection Upgrade & Installation Instructions for the details on how
to install or upgrade Windows Legacy collection.

Note: The Microsoft Management Console (MMC) should be closed during the installation process.

Configure Windows Legacy and NetApp Event Sources

This topic tells you how to configure Windows Legacy event sources in NetWitness Platform.

The Windows Legacy collection protocol collects event data from Windows 2003 or earlier event
sources, and from NetApp event sources.

Prerequisites

Before you configure a Windows Legacy event source, make sure that you have:
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I.

2.

Installed the NetWitness Platform Windows Legacy Remote Collector on a physical or virtual
Windows 2008 64-bit server.

Added this Windows Legacy Remote Collector to NetWitness Platform.

Add a Windows Legacy Event Source

1.
2.

Access the Services view by selecting Admin > Services from the NetWitness Platform menu.
In the Services grid, select a Windows Legacy Log Decoder service.

Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

Click the Event Sources tab.

5. Inthe Event Sources tab, select one of the following options from the drop-down menu.

o Windows Legacy/Windows.

o Windows Legacy/NetApp.
Configure the alias:

a. Click +

The Add Source dialog is displayed.

in the Event Categories panel toolbar.

b. Specify values for the parameters and click OK.

Basic
Alias * Domain-Alias
User Mame * usert@domain.com

Password *

-{\-Advanced

Use Remote Registry
Initialization

Note: By default, Remote Registry Initialization is selected. For details, see Remote
Registry Access below.

The newly added windows event source type is displayed in the Event Categories panel.
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7. Add the event source:

a. Select the new alias in the Event Categories panel and click

The Add Source dialog is displayed.

in the Source panel toolbar.

b. Specify values for the event source parameters and click OK.

Basic

Mame * Domainsource

Event Source Address *

Event Log Mame * Security
Enabled ™
-f:\-Ad\.fan:ed

Event Buffer Size 100

Ewvent Too Large Result  fail
Maximum Event Data 16
Wax Events Per Cycle 0
Polling Interval 180

Debug Off

Kilobyte

Kilobyte

Cancel

£

<

OK

For details, see Windows Legacy Configuration Parameters below.

The newly added Windows event source is displayed in the Event Categories panel.

Sources

v

T

= 4 & importSource

Name Event Source Addr Event Log Name Event EventBuffer5 Maximum Eve

Domainsource

Remote Registry Access

® Export Source

Security

fail

100 KB

16 KB

Windows Legacy Collector performs an initial verification of the event source before collecting data. By

default, Windows Legacy Collector uses Windows Management Instrumentation (WMI) method to
perform this initial verification. If you enable Remote registry access method, Windows Legacy

Collector performs a remote registry query to verify the event source.
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Configure Push or Pull between Log Collector and Windows Legacy Collector

You can configure the Windows Legacy Collector to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from the Windows Legacy Collector.

To configure a Local Collector or the Windows Legacy Collector:
1. Goto ADMIN > Services.
2. Select a Local Collector or the Windows Legacy Collection service.

3. Under Actions, select ﬂ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Depending on your selection in step 2:

o If you selected a Local Collector, the Remote Collectors tab is displayed. Select the Windows
Legacy Collector from which the Local Collector pulls events in this tab.

o Ifyouselected a Windows Legacy Collector, the Local Collectors are displayed. Select the
Local Collectors to which the Windows Legacy Collector pushes events in this tab.

Windows Legacy Configuration Parameters

The following table describes the basic parameters for a Windows Legacy event source.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

o owemn

Name* The name of the event source. Valid value is a name in the [_a-zA-Z] [_a-zA-Z0-9]* range. You can use a dash "-
" as part of the name.

Event IP address of the event source. Valid value is an IPv4 address, IPv6 address, or a hostname including a fully
Source qualified domain name. NetWitness Platform defaults to 127.0.0.1,
Address* Log Collector converts the hostname to lower-case letters to prevent duplicate entries.

Event Log The name of the event log from which to collect event data (for example, System, Application, or Security).
Name The following are examples of some of these channels:

o System - applications that run under system service accounts (installed system services), drivers, or a
component or application that has events that relate to the health of the system.

e Application - all user-level applications. This channel is unsecured and it is open to any application. If an
application has extensive information, you should define an application-specific channel for it.

e Security - the Windows Audit Log (event log) used exclusively for the Windows Local Security Authority.

Enabled Select this checkbox to collect from this event source. If you do not check this checkbox, the Log Collector does
not collect events from this event source.
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o o

Event NetApp .evt or.evtx files directory path. This must be the UNC path.
Directory
Path

The NetApp generates event data and saves it in.evt or.evtx files in a shareable directory on the NetApp appliance.

o In each polling cycle, Log Collector browses the configured NetApp shared path for the.evt files that you
identified with the Event Directory Path and Event File Prefix parameters. Log Collector :

o sorts files that match the event-file-prefix. Y YMMDDhhmmss.evt format in ascending order.

o uses the timestamp of the last file processed to determine the files that still need processing. If Log
Collector finds a partially processed file, it skips the events already processed.

o In each polling cycle, Log Collector browses the configured NetApp shared path for the .evtx files that you
identified with the Event Directory Path and Event File Prefix parameters. Log Collector :

o sorts files that match the event-file-prefix. Y YMMDDhhmmssms.evtx format in ascending order.

o uses the timestamp of the last file processed to determine the files that still need processing. If Log
Collector finds a partially processed file, it skips the events already processed.

EventFile  Prefix of the -evt files (for example, adtlog.) saved in the Event Directory Path,

Prefix
Cancel Closes the dialog without adding the Windows Legacy event source.
OK Adds the current parameter values as a new event source

The following table describes the advanced parameters for a Windows Legacy event source.

Fews puserpn

Event Maximum size of the data the Log Collector pulls from the event source for each request.

Buffer Size Valid value is a number in 0 to 511 Kilobytes range. You specify this value in Kilobytes.

Event Too Tells Log Collector what to do if an event is too large for the event buffer.
Large
Result

Maximum  Maximum size of event data to include in the output. Valid value is a number in 0 to 511Kilobytes range. You
Event Data  specify this value in Kilobytes or Megabytes.

o 1 Kilobyte - 100 Megabytes

e 0= do not include event data in the output.

Max Events  The maximum number of events per polling cycle (how many events collected per polling cycle).
Per Cycle

Polling Interval (amount of time in seconds) between each poll. The default value is 180.

Interval For example, if you specify 180, the collector schedules a polling of the event source every 180 seconds. If the

previous polling cycle is still underway, it will wait for it to finish that cycle. If you have a large number of event
sources that you are polling, it may take longer than 180 seconds for the polling to start because the threads are
busy.
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o o

Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an event
source and you need to investigate this problem. Enabling debugging will adversely affect the performance of
the Log Collector.

Enables or disables debug logging for the event source. Valid values are:
o Off = (default) disabled

e On = enabled

e Verbose = enabled in verbose mode - adds thread information and source context information to the
messages.

This parameter is designed to debug and monitor isolated event source collection issues. If you change this value,
the change takes effect immediately (no restart required). Limit the number of event sources for which you use
Verbose debugging to minimize performance impact.

Troubleshoot Windows Legacy and NetApp Collection

This topic highlights possible problems that you may encounter with Windows Legacy Collection (LWC)
and suggested solutions to these problems.

Note: In general, you receive more robust log messages by disabling SSL.

Protocol Restart Problems

Possible
Problem
Causes
You restart the Legacy Windows collection The Restart the logcollector service.
protocol, but NetWitness Platform is not logcollector L L he Wind
receiving events. service is o LG EIID U9 AT D0
stopped. Legacy Remote Collector.

2. Go to Start > Administrative Tools
> Task Scheduler and click on
Task Scheduler Library.

3. In the right panel, look for
the restartnwlogcollector task and
make sure that it is running.

4. 1If this is not the case, right-click
restartnwlogcollector
and select Run.

Installation Problems

If you see any of the following messages in the MessageBroker.log, you may have issues.

- Any message that contains "rabbitmq"
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RabbitMQ service may not be running.

Port 5671 may not be opened.

Make sure that the RabbitMQ service is running.
Make sure that port 5671 is open.

Error: Adding logcollector user account.

Error: Adding administrator tag to logcollector account.
Error: Adding logcollection vhost.
Error: Setting permissions to logcollector account in all vhosts.

rabbitmq-server was not running when installer tried to create users and vhosts.

Make sure that the RabbitMQ service is running and run below commands manually.

rabbitmgctl -q add user logcollector netwitness

rabbitmgctl -q set user tags logcollector administrator
rabbitmgctl -q add vhost logcollection

rabbitmgctl -g set permissions -p / logcollector ".*™" " &m w v
rabbitmgctl -q set permissions -p logcollection logcollector ".*"

L LB LR LRSS 1]

Windows Legacy Federation Script Issues

If you see any of the following messages in the federation script log, you may have issues.

Federation NetWitness Platform log shows connection This issue is fixed automatically after restarting
script started, but the failure exceptions with Windows the Windows Legacy service.
LWC service went down.  Legacy Collector.
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Run the federation.bat script manually at LWC.
To run the federate.bat script manually, perform
the following steps:

LWC is running, but
RabbitMQ service is
down or restarting.

Federation log file at Windows Legacy side
displays an error message about RabbitMQ
service being down.

The log file to look at is: 1. Go to folder C:\Program
C:\NetWitness\ng\logcollector Files\NwLogCollector where the Windows
Th . . . Legacy instance is installed.

e following error message is logged in case
RabbitMQ is not running: 2. Locate the file federate.bat in this

"Unable to connect to

folder. Select the file and right click.

node 3. Select Run as Administrator.
logcollector@localhost:
Aodedenn ™ 4. To monitor the log file, navigate to

The following diagnostics messages are

C:\NetWitness\ng\logcollector\federate.log
while the federate.bat script is being

displayed: executed.
attempted to contact:

[logcollector@localhost]

Note: Make sure the log file does not show
any errors while the script is being executed.

logcollector@localhost:

* connected to epmd (port
4369) on localhost

* epmd reports: node
'logcollector' not running
at all other nodes on

localhost: ['rabbitmgctl-
4084 "]

* suggestion: start the
node

RabbitMQ service is
down on the NetWitness
Platform side.

NetWitness Platform User Interface pages do Restart RabbitMQ service.

not work.

If the Federate.bat script did not run correctly,
run it manually as described previously.

Customer receives Federate.bat script failed to run successfully.
a Health and Wellness
notification, or the
following Health and
Wellness Alarm is
displayed:
"Communication failure
between Master
NetWitness Platform Host
and a Remote Host" with
LWC Host as the Remote
IP.
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AWS Parameters

This topic provides an overview of the AWS collection configuration parameters for deploying a remote
log collection service (VLC) in an Amazon Web Services (AWS) environment.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

Log Collection
is Working

I
Configure : Verify that
Perform Basic Setupa Start Collection |

Implementation Lockbox Collection Protocols and
Services Event Sources |

What do you want to do?
Administrator  Perform basic Log Collection implementation Basic Implementation

Administrator ~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator ~ Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics
o Configure AWS (CloudTrail) Event Sources in NetWitness Platform

The following table describes the Basic configuration parameter for AWS collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Name * Name of the event source.
i Select the check box to enable the event source configuration to start collection. The check box is selected by
Enabled default.
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Account Id *

S3 Bucket
Name *

Access Key *

Secret Key *
Region *

Region
Endpoint

Use Proxy

Proxy Server

Account Identification code of the S3 Bucket

Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS (CloudTrail) region in which you create
the bucket. You specify the name at the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for DNS-compliant bucket names are:

e Bucket names must be at least three and no more than 63 characters long.

o Bucket names must be a series of one or more labels. Adjacent labels are separated by a single period “.”.
Bucket names can contain lowercase letters, numbers, and hyphens. Each label must start and end with a
lowercase letter or a number.

o Bucket names must not be formatted as an IP address (for example, 192.168.5.4).

The following examples are valid bucket names:

e myawsbucket
e my.aws.bucket

e myawsbucket.1l

The following examples are invalid bucket names:

e .myawsbucket - Do not start a Bucket Name with a period
e myawsbucket. - Do not end a Bucket Name with a period

e my..examplebucket - Only use one period between labels.

Key used to access the S3 bucket. Access Keys are used to make secure REST or Query protocol requests to
any AWS service API. Please refer to Manage User Credentials on the Amazon Web Services support site
for more information on Access Keys.

Secret key used to access the S3 bucket.

Region of the S3 bucket. us—east -1 is the default value.

Specifies the AWS CloudTrail hostname. For example, for an AWS public cloud for us-east region, the
Region Endpoint would be s3.amazonaws.com. More information can be found at

http://docs.aws.amazon.com/general/latest/gr/rande.html#s3 region. This parameter is
necessary to collect CloudTrail logs from AWS Government or Private clouds.

Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Enter the proxy name you want to connect to access the AWS server.

Proxy Port Enter the port number that connects to the proxy server to access the AWS server.
Proxy User Enter the user name to authenticate with the proxy server.
Proxy Enter the password to authenticate with proxy port.
Password
Start Date * Starts AWS (CloudTrail) collection from the specified number of days in the past, measured from the current
timestamp. The default value is 0, which starts from today. The range is 0—89 days.
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Log File Prefix ~ Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure to enter the same prefix in
this parameter.

Cancel Closes the dialog without adding the AWS (CloudTrail).

OK Adds the current parameter values as a new AWS (CloudTrail).

The following table describes the Advanced configuration parameter for AWS collection.

LDE0T3 Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an

event source and you need to investigate this problem. Enabling debugging will adversely affect the
performance of the Log Collector.

Enables or disables debug logging for the event source.

Valid values are:

o Off = (default) disabled

On = enabled
e Verbose = enabled in verbose mode - adds thread information and source context information to the
messages.
This parameter is designed to debug and monitor isolated event source collection issues. The debug logging is
verbose, so limit the number of event sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).
Command Args  Arguments added to the script.

Polling Interval ~ Interval (amount of time in seconds) between each poll. The default value is 60.

For example, if you specify 60, the collector schedules a polling of the event source every 60 seconds. If the
previous polling cycle is still underway, it will wait for it to finish that cycle. If you have a large number of
event sources that you are polling, it may take longer than 60 seconds for the polling to start because the
threads are busy.

SSL Enabled Select the check box to communicate using SSL. The security of data transmission is managed by encrypting
information and providing authentication with SSL certificates.

The check box is selected by default.

Test Connection ~ Validates the configuration parameters specified in this dialog are correct. For example, this test validates that:

o NetWitness can connect with the S3 Bucket in AWS using the credentials specified in this dialog.

o NetWitness can download a log file from the bucket (test connection would fail if there were no log files
for the entire bucket, but this would be extremely unlikely).
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Azure Parameters

Microsoft Azure is a cloud computing platform and infrastructure for building, deploying, and managing
applications and services through a global network of Microsoft-managed data centers.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

Verify that
Log Collection
is Working

Configure
Perform Basic Setupa Start Collection

Implementation Lockbox Collection Protocols and
Services Event Sources |

What do you want to do?
Administrator Perform basic Log Collection implementation Basic Implementation

Administrator ~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator  Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics

o Configure Azure Event Sources in NetWitness Platform

Azure Event Source Configuration Parameters

This topic describes the Azure event source configuration parameters.

Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e —Jowemn

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.
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am o

Enabled

Client ID *

Client Secret
k

API Resource
Base URL *

Federation
Metadata
Endpoint *

Subscription
ID *

Tenant
Domain *

Resource

Group Names
%

Start Date *

Test
Connection

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

The Client ID is found the Azure Application Configure tab. Scroll down until you see
it.

When you are configuring the event source, the client secret is displayed when you are
creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it cannot be
retrieved later.

Enter https://management.azure.com/. Be sure to include the trailing slash
().

In your Azure application, click the View Endpoints button (near the bottom of the
pane).

There are a lot of links that all begin with the same string. Compare the URLs and
find the common string that begins most of them. This common string is the endpoint
that you need to enter here.

You can find this in the Microsoft Azure dashboard: click on Subscriptions at the
bottom of the list on the left.

Go to the active directory and click on the directory. In the URL, the tenant domain is
the string directly following manage.windowsazure.com/. The tenant domain is the
string up to and including the .com.

In Azure, select Resource groups from the left navigation pane, then select your
group.
Choose the date from which to start collecting. Default's to the current date.

Checks the configuration parameters specified in this dialog to make sure they are
correct.

Advanced Parameters

Click * next to Advanced to view and edit the advanced parameters, if necessary.

o

Polling  Interval (amount of time in seconds) between each poll. The default value is 180.

Interval  For example, if you specify 180, the collector schedules a polling of the event source every
180 seconds. If the previous polling cycle is still underway, the collector waits for that
cycle to finish. If you have a large number of event sources that you are polling, it may take
longer than 180 seconds for the polling to start because the threads are busy.
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o

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Duration
Poll

Max The maximum number of events per polling cycle (how many events collected per polling
Events  cycle).
Poll

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Idle

Time

Poll

gommand Optional arguments to be added to the script invocation.
rgs

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you have a

problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:

o Off = (default) disabled

e On =enabled

o Verbose = enabled in verbose mode - adds thread information and source context

information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues. If
you change this value, the change takes effect immediately (no restart required). The debug
logging is verbose, so limit the number of event sources to minimize performance impact.
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Check Point Parameters

The Check Point Collection protocol collects events from Check Point event sources using OPSEC LEA.
OPSEC LEA is the Check Point Operations Security Log Export API that facilitates the extraction of
logs.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here |

Configure Verify that
Perform Basic Start Collection Log Collection

Implementation Collection Protocols and is Working
Services Event Sources

What do you want to do?

Administrator  Perform basic Log Collection implementation Basic Implementation

Administrator ~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator  Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics
o Configure Check Point Event Sources in NetWitness Platform

Check Point Collection Configuration Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Basic Parameters

Name* Name of the event source.

Address* IP Address of the Check Point server.
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Server Name of the Check Point server.

Name*

Certificate Certificate name for secure connections to use when the transport mode is https. If set,

Name the certificate must exist in the certificate trust store that you created using the Settings
tab.

Select a certificate from the drop-down list. The file naming convention for Check
Point event source certificates is checkpoint_name-of-event-source.

Client Enter the Client Distinguished Name from the Check Point server.

Distinguished

Client Entity ~ Enter the Client Entity Name from the Check Point server.

Name

Server Enter the Server Distinguished Name from the Check Point server.

Distinguished

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

Pull Select the checkbox to pull a certificate for first time. Pulling a certificate makes it

Certificate available from the trust store.

Certificate IP Address of the server on which the certificate resides. Defaults to the event source

Server address.

Address

Password Only active when you select the Pull Certificate checkbox for first time. Password

required to pull the certificate. The password is the activation key created when adding
an OPSEC application to Check Point on the Check Point server.

Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to stay open
for a specific time and specific event volume (transient connection). RSA NetWitness Platform defaults
to the following connection parameters that establish a transient connection:

o Polling Interval = 180 (3 minutes)

o Max Duration Poll = 120 (2 minutes)

o Max Events Poll = 5000 (5000 events per polling interval)

o Max Idle Time Poll =0

For very active Check Point event sources, it is a good practice to set up a connection that stays open
until you stop collection (persistent connection). This ensures that Check Point collection maintains the

pace of the events generated by these active event sources. The persistent connection avoids restart and
connection delays and prevents Check Point collection from lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters to the
following values:
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¢ Max Duration Poll = 0
¢ Max Events Poll =0
o Max Idle Time Poll =0

Polling Interval = -1

Port

Collect Log
Type

Collect Logs
From

Polling
Interval

Max
Duration
Poll

Max Events
Poll

Max Idle
Time Poll

Forwarder

Port on the Check Point server that Log Collector connects to. Default value is 18184.
Type of logs that you want to collect: Valid values are:
o Audit - collects audit events.

o Security - collects security events.

If you want to collect both audit and security events, you must create a duplicate event
source. For example, first you would create an event source with Audit selected pulling
a certificate into the trust store for this event source. Next you would create another
event source with the same values except that you would select Security for the Collect
Log Type and you would select the same certificate in Certificate Name that you pulled
when you set up the first set of parameters for this event source and you would make
sure that Pull Certificate was not selected.

When you set up a Check Point event source, NetWitness collects events from the
current log file. Valid values are:

o Now - Start collecting logs now (at this point in time in the current log file).

o Start of Log - Collect logs from the beginning of the current log file.

If you choose "Start of Log" for this parameter value, you may collect a very large
amount of data depending on how long the current log file has been collecting events.
Note that this option is effective only for the first collection session.

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event source
every 180 seconds. If the previous polling cycle is still underway, it will wait for it to
finish that cycle. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are busy.

The maximum duration of polling cycle (how long the cycle lasts) in seconds.

The maximum number of events per polling cycle (how many events collected per
polling cycle).

Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is the
default value.

Enables or disables the Check Point server as a forwarder. By default it is disabled.
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Log Type Logs from the event source in Name Value format. By default it is disabled.
(Name
Value Pair)

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you

have a problem with an event source and you need to investigate this problem.
Enabling debugging will adversely affect the performance of the Log Collector.
Enables and disables debug logging for the event source.

Valid values are:
o Off = (default) disabled
e On = enabled

e Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).
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File Parameters

This topic describes the File Collection configuration parameters.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.
You are here I

Configure Verify that
Perform Basic Setupa Start Collection Log Collection

Implementation Lockbox Collection Protocols and is Working
Services Event Sources

What do you want to do?
oo
Administrator Perform basic Log Collection implementation Basic Implementation
Administrator  Set up a lockbox to maintain lockbox settings. Set Up a Lockbox
Administrator ~ Start Log Collection services. Start Collection Services
Administrator  *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources Sources
Administrator  Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics
» Configure File Event Sources in NetWitness Platform

File Collection Event Source Parameters
The following table provides descriptions of the File Collection source parameters.

The following table describes the Basic configuration parameter for File collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

(o om0
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e o

File
Directory*

Address*

File Spec

File
Encoding

Cancel

OK

Collection directory (for example, Eur_London100) into which the File event source
places its files. Valid value is a character string that is conforms to the following regular
expression:

[ a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores. Do not modify this parameter after you start collecting event data.

After you create the collection, the Log Collector creates the work, save, and error sub-
directories under the collection directory.

IP address of the event source. Valid value is an IPv4 address, IPv6 address, or a
hostname including a fully-qualified domain name.

Regular expression. For example, *.*$ = process everything.

Character encoding used by the syslog senders to this port. Defaults to UTF-8.

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as well,
and most senders have their encoding set to UTF-8.

RSA has tested the following values:

o EUC-KR

« SJIS

« GB3212/GBK

o [ISO 8859-1 (German)

o ISO_8859-7 (Greek)

Closes the dialog without making adding an event source type.

Adds the parameters for the event source.

The following table describes the Advanced configuration parameter for File collection.

o

Ignore
Encoding

Conversion

Errors

Select the check box to ignore encoding conversion errors and ignore invalid data. The
check box is selected by default.

Caution: This may cause parsing and transformation errors.
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File Disk Determines when to stop saving files regardless of the Save On Error and Save On

Quota Success parameter settings. For example, a value of 10 indicates that when there is less
than 10% available disk left, the Log Collector stops saving files to reserve enough
space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection directory is
mounted. If the Log Decoder server has a 10TB disk size and 2TB is allocated to base
collection directory, then setting this value to 10 causes log collection to stop when
less than 0.2TB (10% of 2TB) of space is left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential ~ Sequential processing flag:

Piigiosietig o Select the check box (default) to process event source files in collection order.

o Do not select the checkbox to process event source files in parallel.
Save On Save on error flag. Check the checkbox to retain the eventsource collection file when
Error the Log Collector it encounters an error. The check box is selected by default.
Save On Save eventsource collection file after processing flag. Check the checkbox to save the
Success eventsource collection file after processing it. The check box is not selected by default.

Eventsource SSH public key used to upload files for this event source. Please refer to the Generate
SSH Key Key Pair on Event Source and Import Public Key to Log Collector section in the Install
and Update the SFTP Agent Guide for instructions on generating keys.

Note: If File collection is stopped, NetWitness Platform does not update the
authorized keys file with the SSH public key that you add or modify in this parameter.
You must restart File collection to update the public key.

You can add or modify the value of the public key in this parameter in multiple File
event sources without File collection running, but NetWitness Platform will not update
the authorized keys file until File collection is restarted.

Manage By default, the Log Collector uses the File Disk Quota parameter to ensure that the disk
Error Files  does not fill up with error files. If you set this parameter to true, you can specify one of
these:

o Maximum space allotted to error files in the Error Files Size parameter.

o Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Select the check box to manage error files. The check box is not selected by default.
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Error Files
Size

Error Files
Count

Error Files
Reduction
%

Manage
Saved Files

Saved Files
Size

Saved Files
Count

Saved File
Reduction
%

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Specifies to what extent NetWitness Platform saves error files. The value that you
specify is the maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. Y ou specify these values in
either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default. If you
change this parameter, the change does not take effect until you restart collection or
restart the Log Collector service.

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Maximum number of error files allowed in the error directory. Valid value is a number
in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Percent amount by size or count of the error files that the Log Collector service removes
when the maximum size or count has been reached. The service removes the oldest files
first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Select the check box to manage saved files. The check box is not selected by default.
By default, the Log Collector uses the File Disk Quota parameter to ensure that the disk
does not fill up with saved files. If check this check box, you can specify one of these:

« Maximum space allotted to saved files in the Saved Files Size parameter.

o Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Only valid if the Manage Saved Files and Save On Success parameters are set to true.
Maximum total size of all the files in the save directory. Valid value is a number in the
0 to 281474976710655 range. Y ou specify these values in either Kilobytes, Megabytes,
or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Only valid if the Manage Saved Files and Save On Success parameters are set to true.
Maximum number of saved files in the save directory. Valid value is a number in 0 to
65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart collection
or restart the Log Collector service.

Percent amount by size or count of the saved files that the Log Collector service
removes when the maximum size or count has been reached. The service removes the
oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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Debug

Caution: Only enable debugging (set this parameter to On or Verbeose) if you have a
problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source.
Valid values are:

o Off = (default) disabled
e On = enabled
o Verbose = enabled in verbose mode - adds thread information and source context

information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).
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Log Collection Service System View

A Log Collector is a service that runs on a Log Decoder host (referred to as a Local Collector) or sends
events from a Remote Collector to a Local Collector, and is configured and managed in a similar way to
a Log Decoder.

To access the Log Collection Service System view, go to ADMIN > Services and select a Log Collector
service, then select View > System.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
: Configure Verify that
| Collection Log Collection
Implementation Lockbox Collection Protocols and is Working
Services | Event Sources

|
|
|
Perform Basic Setupa | Start
|
|
|
|

What do you want to do?
m_
Administrator Perform basic Log Collection Basic Implementation
implementation
Administrator Set up a lockbox to maintain lockbox Set Up a Lockbox
settings
Administrator *Start Log Collection Services. Start Collection Services
Administrator Configure Log Collection protocols and Configure Collection Protocols and
event sources. Event Sources
Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics

Basic Implementation

Quick Look

From the Log Collector Service Information Toolbar, you can manage event data using the Collection
icon to start event data from a stopped protocol or stop collecting data from a started protocol. From the
Host Tasks icon, you can select tasks that you want to run. You can also shutdown your service and
reboot your service from the Service Information Toolbar.
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ODBC Event Source Configuration Parameters

This topic tells you how to configure ODBC collection protocol which collects events from event
sources that store audit data in a database using the Open Database Connectivity (ODBC) software
interface.

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:
1. Go to Administration > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
The Service Config view is displayed with the Log Collector General tab open.

4. Click the Event Sources tab, and select ODBC/Config from the drop-down menu.
Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
Implementation Lockbox Collection Protocols and |
Services Event Sources :
|

is Working

What do you want to do?

Administrator ~ Perform basic Log Collection implementation. Basic Implementation

Administrator -~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator ~ Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics
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o Configure ODBC Event Sources in NetWitness Platform

o Configure Data Source Names (DSN5s)
o Troubleshoot ODBC Collection

o Create Custom Typespec for ODBC Collection

Data Source Name (DSN) Parameters

Use the Sources panel to review, add, modify, and delete Data Source Name (DSN) parameters.

Sources Panel

An ODBC DSN tells the Log Collector how to reach an ODBC endpoint. You refer to an ODBC DSN
when you configure a data source name with information such as which ODBC driver to use or the host
name and port of the ODBC endpoint.

An ODBC DSN is a sequence of name-value pairs. For information about the valid names for a given
ODBC data source type, such as Sybase, Microsoft SQL Server, or Oracle, please download the
DataDirect Connect Series for ODBC User's Guide and DataDirect Connect Series for ODBC User's
Guide in the Progress DataDirect Document Library.

Toolbar

The following table provides descriptions of the toolbar options.

opten _ [pescrpor

+ Opens the Add DSN dialog in which you add an event source for the event source type you selected in
the Event Categories panel.

Deletes the selected event sources.

Z Opens the Edit DSN dialog in which you modify the configuration parameters for the selected event
source.

When you select multiple event sources, this option opens the Bulk Edit Source dialog in which you
can edit the parameters values for the selected file directories.

> ) Opens the Bulk Add Option dialog in which you can import DSN parameters in bulk from a comma-
Import5eurce geparated values (CSV) file. The Bulk Add Option dialog has the following two options:

e Import CSV File

e Paste CSV Content

Creates a .csv file that contains the parameters for the selected DSNs.

™ Export Source

¥, Test Connection Validates the configuration parameters for the selected ODBC database.

Add or Edit DSN Dialog

In this dialog, you add or modify an event source for the selected event source.
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Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e o

DSN* The data source name (DSN) that defines the database from which to collect events.

Select an existing DSN from the drop-down list. For details, see ODBC DSNs Event Source
Configuration Parameters.

Username*  User name that the data source name uses to connect to the database. You must specify a user name when you
create the event source.

Password  Password that the data source name uses to connect to the database.

Caution: The password is encrypted internally and is displayed in its encrypted form.

Enabled Select the checkbox to enable the event source configuration to start collection. The checkbox is selected by default.

Address* For ODBC, this field is not used. The Log Collector uses the address in the ODBC.ini file.

Advanced Parameters

e o

Max Cell Maximum size in bytes of the data that the Log Collector can pull from one cell in the database. The default value is
Size 2048.

733

Nil Value  Character string that the Log Collector displays when NIL is returned for a cell in the database. Default value:
(null).

Polling Interval (amount of time in seconds) between each poll. The default value is 180.

Interval For example, if you specify 180, the collector schedules a polling of the event source every 180 seconds. If the

previous polling cycle is still underway, the collector waits for that cycle to finish. If you have a large number of
event sources that you are polling, it may take longer than 180 seconds for the polling to start because the threads
are busy.

Max The maximum number of events per polling cycle (how many events collected per polling cycle).
Events Poll

Debug Caution: Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an

event source and you need to investigate this problem. Enabling debugging will adversely affect the performance
of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:
o Off = (default) disabled

e On = enabled

e Verbose = enabled in verbose mode - adds thread information and source context information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues. If you change this value,
the change takes effect immediately (no restart required). The debug logging is verbose, so limit the number of
event sources to minimize performance impact.
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o

Initial Initial identification code that the Log Collector assigns to this event source if collection is not started. If there is no
Tracking value for this parameter, the Log Collector starts at the end of the table and only pulls rows after the end of the table
Id as they are added. The default value is ** (null).

Filename For Microsoft SQL Server Event Sources only, the location of the trace files directory (for example,
C:\MyTraceFiles).

Refer to the RSA Microsoft SQL Server Event Source Configuration Guide, located on RSA Link here:
https://community.rsa.com/docs/DOC-40241.

Test Checks the configuration parameters specified in this dialog to make sure they are correct.
Connection

Cancel Closes the dialog without adding or modifying DSN parameters.

OK Adds or modifies the parameters for the DSN.
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ODBC DSNs Event Source Configuration Parameters

Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you need to
define DSNs with their associate value pairs for ODBC event source configuration.

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:
1. Access the Services view by selecting Admin > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ View > Config to display the Log Collection configuration parameter
tabs.

The Service Config view is displayed with the Log Collector General tab open.
4. Click the Event Sources tab, and select ODBC/DSNs from the drop-down menu.
Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
Implementation Lockbox Collection Protocols and |
Services Event Sources :
|

is Working

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator -~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator  Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics
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o Configure ODBC Event Sources in NetWitness Platform

o Configure Data Source Names (DSN5s)

ODBC DSN Configuration Parameters

This topic describes the Data Source Names DSNs configuration parameters.

DSN Panel

In the DSNs panel, you can add, delete, or edit DSNs and the DSN name-value pairs for ODBC Event
sources.

o [oeen

+ Displays the Add DSN dialog in which you define a DSN and its parameters.
- Deletes the selected DSNSs.
z Displays the Edit DSN dialog in which you edit the name-value pairs for the selected
DSN.

4 Manage Ter Displays the Manage DSN Templates dialog in which you can add or delete DSN name-
value pair templates.

Selects DSNs.

DSN Name of the DSN that you added.

Parameters <name-value for="""'p="" pairs="" the="""> </name-value>

Add or Edit DSN Dialog

In this dialog, you add or modify a file directory for the selected event source.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e [oreen

DSN Select a predefined DSN value name-value pairs template for the DSN.

Template

DSN Add the name of the DSN. You cannot edit a DSN name after you add it.

Name* This value must correspond with a DSN entry in the ODBC.ini file. Valid value is a

character string that is restricted to the following characters:
[ a-zA-Z][ a-zA-720-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores (for example, oracle_executive_compensation).
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o [omewn

Parameters +

Adds a row in which you can define a parameter name-value pair.

™ Deletes the selected parameter name-value pair.

Name - Enter or modify the parameter name.

Selects parameter name-value pairs.

Value - Enter or modify the value associated with the parameter name.

Cancel Closes the dialog without adding the DSN and its name-value pairs or saving
modifications to the name-value pairs.

Save Adds the DSN and its name-value pairs or saves modifications to the name-value pairs.

Manage DSN Templates Dialog

In this dialog, you can add or delete DSN name-value pair templates.

e o

Template Selection Panel

+ Opens the Add Template panel in which you can add a DSN name-value pair template.
— Deletes the selected template.
Selects a template for deletion or modification.
Add Template Panel
+ Adds a value pair row.
— Deletes a value pair row.
Selects a value pair row.
Name Enter the parameter name.
Value Enter the value associated with the parameter name.
Cancel Cancels any changes you made in the dialog.
Save Adds the DSN and its name-value pairs or saves modifications to the name-value pairs.
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o o

Close Closes the dialog without adding the DSN and its name-value pairs or saving modifications
to the name-value pairs.
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Remote/Local Collectors Configuration Parameters

When you deploy Log Collection, you must configure the Log Collectors to collect the log events from
various event sources, and to deliver these events reliably and securely to the Log Decoder host, where
the events are parsed and stored for subsequent analysis.

This topic introduces features of the Services Config view > Remote Collectors/Local Collectors tab.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.
You are here I

Configure Verify that
Perform Basic Start Collection Log Collection

Implementation Collection Protocols and is Working
Services Event Sources

What do you want to do?

Administrator  Perform basic Log Collection implementation Basic Implementation

Administrator ~ Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator ~ Start Log Collection services. Start Collection Services

Administrator  *Configure Log Collection protocols and Configure Collection Protocols and Event
event sources. Sources

Administrator  Verify that Log Collection is working. Verify That Log Collection Is Working

*Y ou can perform this task here.

Related Topics

o Provision Local Collectors and Remote Collectors

o Configure Local and Remote Collectors

Services Config View

The Services Config view is the view on which you maintain all the Log Collection parameters. The tab

in which you maintain the deployment parameters referred to in this guide is the Remote/Local

Collectors tab:

o Ifyou are configuring a Local Collector , NetWitness Platform displays the Remote Collectors tab
so that you can configure the Local Collector to pull events from Remote Collectors.

139 Reference



Log Collection Configuration Guide

o If you are configuring a Remote Collector , NetWitness Platform displays the Local Collectors tab so
that you can configure the Remote Collector to push events to a Local Collector .

Remote Collectors Tab

On a Local Collector, the Remote Collectors panel provides a way to add or delete Remote Collectors
from which the Local Collector pulls events.

=+ Displays the Add Source dialog in which you select the Remote Collectors from which
you want the Local Collector to pull events.

Deletes the Remote Collector from the Local Collector Remote Collectors panel.

z Displays the Edit Source dialog for the selected Remote Collector .
Selects Remote Collectors.
Name Names of the Remote Collectors from which the Local Collector currently pulls events.

Address IP Addresses of the Remote Collectors from which the Local Collector currently pulls
events.

Collections Choose which collection protocols that the Remote Collector pushes to a Local Collector.

You can select any combination of protocols. If you do not select a protocol, NetWitness
Platform selects all protocols.

Local Collector Tab

On a Remote Collector , the Local Collector panel provides a way to add or delete the Local Collectors
to which you want to the Remote Collector to push events.

Select the Destination or Source in the Select Configuration drop-down menu.
o Destination displays the Add Remote Destination dialog.
o Source displays the Add Source dialog.

The following table describes the Add Source dialog.

=+ Displays the Add Source dialog in which you select the Remote Collectors from which
you want the Local Collector to pull events.

Deletes the Remote Collector from theLocal Collector Remote Collectors panel.
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z Displays the Edit Source dialog for the selected Remote Collector .
Selects Remote Collectors.
Name Names of the Remote Collectors from which the Local Collector currently pulls events.

Address [P Addresses of the Remote Collectors from which the Local Collector currently pulls
events.

The following table describes the Local Collectors Panel.

+ Displays the Add Remote Destination dialog for the Group that you selected. You add
destination Local Collectors for this group to which you want the Remote Collector to
push events.

Deletes the destination Log Collector from the group.

z Displays the Edit Remote Destination dialog for the selected destination Local
Collector .
Selects a destination Local Collector .

Destination Displays the name of the destination Local Collector .
Name

Address Displays the IP address of the destination Local Collector .

Collections Choose which collection protocols that the Local Collector pulls from a Remote
Collector.

You can select any combination of protocols. If you do not select a protocol, NetWitness
Platform selects all protocols.

Log Collection Tabs
This topic describes the tabs available in the Log Collection view.
Access Log Collection View

To access the log collection view:
1. Goto ADMIN > Services from the NetWitness Platform menu.

2. Select a Log Collection service.
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3.

Under Actions, select View > Config to display the Log Collection configuration parameter tabs.
The Service Config view is displayed with the Log Collector General tab open.

4. Select any of the available tabs to view or update the corresponding parameters.

Available Tabs

Use the Admin > Services view to maintain Log Collection parameters. It has the following tabs:

General: contains high-level parameters that govern the operation of the Log Collector service and
each collection protocol. See Log Collection General Tab for details.

Remote Collectors: use this tab to set up remote collectors. See Configure Local and Remote
Collectors for details.

Files: provides an interface for editing Log Collector configuration files.

Event Sources: use this tab to configure collection for your event sources. See Log Collection Event
Sources Tab for details.

Event Destinations: Use the Event Destinations tab of the Log Collection service Config view to
configure the destination of event data collected by the Log Collector. See Log Collection Event
Destinations Tab for details.

Settings: contains parameters for Lockbox security setup, and certificate management.

Appliance Service Configuration: contains configuration parameters for the RSA NetWitness
Platform Core Appliance service.

Please refer to the Files tab and the Appliance Service Configuration tab in the Host and Services
Configuration Guide for information on the configuration parameters on these tabs.
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This topic introduces features of the service Config view > General tab that relate specifically to Log
Collector .

To access the Log Collection General tab:
1. Goto ADMIN > Services from the NetWitness Platform menu.

2. Select a Log Collection service.

3. Click % 7 > View > Config.
The Service Config view is displayed with the Log Collector General tab open.
Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Lockbox Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator Configure Log Collection protocols and event sources. Configure
Collection

Protocols and
Event Sources

Administrator *Verity that Log Collection is working. Verify That Log
Collection Is

Working

*Y ou can perform this task here.

Related Topics
o Configure AWS (CloudTrail) Event Sources in NetWitness Platform

o Configure Check Point Event Sources in NetWitness Platform

o Configure File Event Sources in NetWitness Platform
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o Configure Netflow Event Sources in NetWitness Platform

o Configure ODBC Event Sources in NetWitness Platform

o Configure SDEE Event Sources in NetWitness Platform

o Configure SNMP Event Sources in NetWitness Platform

o Configure Syslog Event Sources

o Configure VMware Event Sources in NetWitness Platform

o Configure Windows Event Sources in NetWitness Platform

o Windows Legacy and NetApp Collection Configuration

Quick Look

The RSA NetWitness Platform administrator must configure event sources to send logs to the
collectors. When event sources are configured they poll event sources, retrieve logs, and send the event
data to NetWitness Platform ).

System Configuration Panel

The System Configuration panel manages service configuration for a NetWitness Platform service.
When a service is first added, default values are in effect. You can edit these values to tune
performance. Refer to the General tab for a description of these parameters.

System Configuration =&l

Name

Compression —— —E
Part 1—“
SSLFIPS Mode «+— —n
55L Fort ‘—B

Stat Update Interval ¢— ﬂ

Threads «——— —n

System Configuration Panel manages service configuration for a NetWitness Platform service.

WA Compression: The minimum number of bytes that must be transmitted per response before
compression. A setting of 0 disables compression. The default value is 0.
A change in value is effective immediately for all subsequent connections.

RI Port: The port on which the service listens. The ports are:
o 50001 for Log Collectors

o 50002 for Log Decoders
o 50003 for Brokers

o 50004 for Decoders

« 50005 for Concentrators

¢ 50007 for other services
SSL FIPS Mode: When enabled (on), the security of data transmission is managed by encrypting
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information and providing authentication with SSL certificates. The default value is off.

RIl SSL Port: The NetWitness Platform Core SSL port on which the service listens. The ports are:
e 56001 for Log Collectors
e 56002 for Log Decoders

e 56003 for Brokers
e 56004 for Decoders
e 56005 for Concentrators

e 56007 for other services

Stat Update Interval: The number of milliseconds between statistic updates on the system. Lower
numbers cause more frequent updates and can slow down other processes. The default value
is 1000,
A change in value is effective immediately.

A Threads: The number of threads in the thread pool to handle incoming requests. A setting of 0 lets
the system decide. The default value is 15.
A change takes effect on service restart.

Collector Configuration Panel

The Collector Configuration panel provides a way to enable automatic start of log collection by event
source type.

Collector Configuration «——

Name

Check Point Collection

File Collection

Start Collection on Service Startup &«
Metflow Collection

Start Collection on Service Startup
ODEBC Collection

Start Collection on Service Startup

Collector Configuration Panel provides a way to enable automatic start of log collection by event
source type.
Enable All enables the automatic collection for all event types.

Enable All = start receiving events and collecting logs for all event types when the Log Collector
service starts.

Disable all disables the automatic collection for all event types.

Disable All = (default) do not receive event data for all event types until you explicitly start
collection.

Start Collection on Service Startup enables automatic start, per event source type, of log
collection when the Log Collector service starts. Valid values are:
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o Selected = start collecting logs when the Log Collector service starts.
o Not selected = (default) do not collect event data until you explicitly start collection.

Apply: Click Apply to save the changes to the parameter values.
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Log Collection Event Destinations Tab

Use the Event Destinations tab of the Log Collection service Config view to configure the destination of
event data collected by the Log Collector :

o Log Decoders
« Identity Feed

Prerequisites
Y ou must implement the following configuration to create an identity feed.
o A Log Collector service with an Identity Feed Event Processor

o A Log Collector service with Windows Collection configured and enabled

Note: See the "Create an Identity Feed" topic in the Live Resource Management Guide for more
information on how to create and investigate on an identity feed.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.
You are here

I
Configure : Verify that
Perform Basic Start Collection [l Log Collection
[
I
|
|

is Working

Implementation Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation
Administrator Set up a to maintain lockbox settings. Set Up a Lockbox
Administrator Start Log Collection services. Start Collection
Services
Administrator *Configure Log Collection protocols and event Configure
sources. Collection

Protocols and
Event Sources

Administrator Verify that Log Collection is working. Verify That Log
Collection Is
Working

*Y ou can perform this task here.
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Related Topics

o See the Create an Identity Feed topic in the Live Resource Management Guide.

Quick Look

The Event Destinations tab of the Log Collection service Config view allows you to configure the
destination of event data collected by the Log Collector.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN '@;ladnwin Z

Hosts Services Event Sources Health & Wellness System  Security

= Change Service LD - Log Cellector | Config

General Remote Collectors Files SV YTl Fvent Destinations Settings Appliance Service Configuration

Select Event Log Decoder v
Destinations —

imatinn (Sre - N
Destination Groups LOg Lecoaders
+ - +
4| Name ~ Name ~ Host Port S5L Fallover Log Decoders Status
¥ logdecoder logdecoder 127.0.01 514 false started

| Page 1 | of1 | I | Page 1 |of1 | I c tems 1 -1 of 1

The required permission to access this view is Manage Services.

To access the Event Destinations tab:
1. Goto ADMIN > Services .

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Destinations tab.
5. Inthe Select Event Destinations drop-down menu:

o Select Log Decoder to configure Log Decoder destinations for event data collected by the Log
Collector.

Note: You must select a Log Decoder service from the Add Log Decoder Destination dialog,
but the remainder of the configuration is done automatically.

o Select Identity Feed to configure an identity feed destination for event data collected by the Log
Collector.
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& Change Service | - Log Collector Config &

General Remote Collectors Files. ALl Event Destinations Appliance Service Configuration

Select Event - -

Destinations Log Decoce
Destination Groups Log Decoders

+ - +
4 Name ~ [ name ~ Host Port SSL Failover Log Decoders Status
¥ logdecader [ logdecoder 127.0.0.1 514 false started
| Page 1 of1 | | Page 1 of1 | | Iterns 1-1 of 1

+ Change Service -Log Collector | Config &

Appliance Service Configuration

Remote Collectors Files [ v=4l Event Destinations Settings

General

Select Event § -
Destinations Identity Feed

Identity Feed

-z
M| Name ~ Rollover Interval Update Interval Event Source Filter | Status Start Processor on Service Startup
¥ IDFEED 3 1 true
| Page 1 | of1 | Items 1 -1 of 1
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Use the Event Sources tab to configure the AWS (CloudTrail), Check Point, File, ODBC, SDEE,
SNMP, Syslog, SNMP, VMware, Windows, and Windows Legacy event sources.

To access the Event Sources tab, go to ADMIN > Services > select Log Collection service > View
> Config > Event Sources) .

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator *Configure Log Collection protocols and event Configure

sources. Collection

Protocols and
Event Sources

Administrator Verify that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.

Related Topics

o Configure AWS (CloudTrail) Event Sources in NetWitness Platform

o Configure Check Point Event Sources in NetWitness Platform

o Configure File Event Sources in NetWitness Platform

o Configure ODBC Event Sources in NetWitness Platform

o Configure SDEE Event Sources in NetWitness Platform

o Configure SNMP Event Sources in NetWitness Platform

o Configure Syslog Event Sources
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o Configure VMware Event Sources in NetWitness Platform

o Configure Windows Event Sources in NetWitness Platform

o Windows Legacy and NetApp Collection Configuration

Quick Look

The Config view has two drop-down menus:

o The left-most menu lists all of the available collection protocols.

General Remote Collectors Files Event Sources I

Check Point | ~ [§Config v

L L '.
S Sources

File
Netflow = & Import Source
1 0DBC
Plugins
SDEE
SHMP
Viiware

Name Address Ser

SA_OPSEC 10.1.. «cp

Windows

o The right-most menu has two choices: Config and Filter.

General Remote Collectors Files Event Sources I

Check Point

Event Categorig

Homm om ol B s sammim

[

The Config view in the Event sources tab has two panels: Event Categories and Sources.

Note: For details on the Filter menu item, see Configure Event Filters for a Collector.

Event Source Types Menu

The Log Collector Event Sources tab has a two-box, drop-down menu in which you select the collection
protocol and any supporting parameters for that protocol.

In the left box, you select one of the following protocols: Check Point, File, ODBC, Plugins, SDEE,
SNMP, SNMP, VMware, Windows, and Windows Legacy.

In the right box, you select:
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« Config to configure the generic event source parameters for the type you selected in the left drop-
down. All generic Config panels have a toolbar with these options:

o Add, Edit, and Delete

o Import (also Import Source, Import DSN)

« Export (also Export Source, Export DSN)
o For ODBC, SNMP, and Windows only:

o For ODBC, DSNs to configure

e For SNMP, SNMP v3 User Manager

o For Windows, Kerberos Realm Configuration

Selecting an option displays a configuration panel where you configure the collection parameters for the
event source. The configuration panels are slightly different for different event sources and are described
separately.

Event Categories Panel

Once you select a collection protocol, the Event Categories panel is populated with all of the event
sources that you have configured for that collection protocol. For example, the following image shows
ODBC event sources that have been configured:

General Remote Collectors

oDBC v Config

[1 ciscolmsaudit a
r’f"

¥ emcionixuim

[ itim

[1 meafeenac

[T netflowanalyzer_security
[ oracle_12c_auditing

[1  oracledw

The Event Categories panel provides a way to add or delete event source types.

Displays the Available Event Source Types dialog from which you select the event source type
for which you want to define parameters.

Deletes the selected event source types from the Event Categories panel.
Selects event source types.

Displays the name of the event source types that you have added.
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Sources Panel

The Sources panel lists the values of the parameters for the selected event source type. For details, see
the individual collection protocol topics.
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Log Collection Settings Tab

Use the Settings tab to:
o Setup a lockbox
o Reset Stable System value

o Manage certificates

Caution: If the host name on which the Log Collector is installed is changed after installation, the Log
Collector will fail to collect events from event sources. You must reset stable system values if the
hostname changes.

To access the Log Collection Settings Tab, go to ADMIN > Services. In the Services grid, select a Log
Collector Service. Click Actions menu cropped under Actions and select View > Config.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

I You are here
Configure Verify that
Start Collection Log Collection
Collection Protocols and is Working
| Services Event Sources

|
I |
[ [
| Setupa |
Lockbox

Perform Basic
Implementation

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic

Implementation

Administrator *Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator Configure Log Collection protocols and event sources. Configure
Collection

Protocols and
Event Sources

Administrator Verity that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.

Related Topics

o See the "Create an Identity Feed topic" in the Live Resource Management Guide.

Quick Look
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This is an example of the Settings tab.

RSA| RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN @jadmin

H ices H
& Change Service | - Log Collector | Config

General Remote Collectors Files Event Sources  Event Destinations Settings Appliance Service Configuration

Lockbox
Certificates

Lockbox Security Settings

Set or change the lockbox passwerd. You will be required to enter this password to perform any lockbox management.

Mew Lockbox
Password

Reset Stable System Value

This operation sets the system fingerprint in the lockbox. This is typically only required after changing the host hardware.

0
D
>
]

rate New Encryption Key

a new internal encryption key and re-encrypts the log collector's encrypted configuration values with it,

Apply
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Troubleshoot Log Collection

This topic describes the format and content of Log Collection Troubleshooting. NetWitness Platform
informs you of Log Collector problems or potential problems in the following two ways.

o Log files.

o Health and Wellness Monitoring views.

Junk Syslog Messages

The remote log collector has been made looser in regards to how it handles syslog messages. This was
done to reduce the number of dropped messages due to missing parts of the header, or for other minor
formatting errors. However, this might also allow syslog event messages that contain junk to get through
the parser. If you see such messages in the system, you can add a syslog collection filter to remove
events that are sending these messages.

Log Files

If you have an issue with a particular event source collection protocol, you can review debug logs to
investigate this issue. Each event source has a Debug parameter that you can enable (set parameter to
On or Verbose) to capture these logs.

Caution: Only enable debugging if you have a problem with this event source and you need to
investigate this problem. If you have Debug enabled all the time it will adversely affect the
performance of the Log Collector.

Health and Wellness Monitoring

Health and Wellness monitoring makes you aware of potential hardware and software problems in a
timely manner so that you can avoid to outages. RSA recommends that you monitor the Log Collector
statistical fields to make sure that the service is operating efficiently and is not at or near the maximum
values you have configured. Y ou can monitor the following statistics (Stats) described in the Admin >
Health & Wellness view.

Sample Troubleshooting Format

RSA NetWitness Platform returns the following types of error messages in the log files for.

timestamp failure (LogCollection) Message-Broker Statistics:...

timestamp failure (AMQPClientBaselLogCollection):...
timestamp failure (MessageBrokerLogReceiver):...

The Log Collector cannot reach the Message Broker because the Message Broker:

e has stopped running
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e has erroneous connection settings

1. <use the="the" systemctl="systemctl" command="command" on="on"

console="console" to="to" check="check"

status="status" of="of"

message="message" broker="broker" shell="shell"
console.="console.">returns the following if the message broker

not running:</use>

prompt$ systemctl status rabbitmg-server

rabbitmg start/running, process 10916

2. Start the RabbitMQ Message Broker on event-broker node in the Explore view:

% Change Senvice | LogCollector | Explore

is

fEvent-Broker

security.roles: logeollection.manage
[storedproc
Msy=

Cusers
Response Output
[ deviceappliance

« I ¢

Log Collector {Log Collector)

= Log C... <
config -
=25 Log Collector (LOG_COLLE destination I
&[] connections -
destinations
[devent-broker . . T
I —
[ event-processars - s
B logeollection Properties for Log Collector (Log Collector) /event-broker. X
Miogs start ~
ol
B sak Message Help
[ e rvices Start the event broker

Log Collector DNS

Make sure that the log collector is configured as a DNS client for the corporate DNS server. Otherwise,

the Log Collector will not know how to find the Kerberos Realm.
Check if DNS is configured, if not perform the following steps:

1. Add the DNS server addresses (‘“nameserver X.x.x.X” entries) in

/etc/netwitness/platform/resolv.dnsmasq.
2. Restart the dnsmasq service using the following command:
systemctl restart dnsmasg

3. Verify the capability to reach external systems via a hostname.
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