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Introduction
NetWitness Investigate provides  data analysis capabilities in RSA NetWitness® Platform, so that 
analysts can analyze packet, log, endpoint, and UEBA data, and identify possible internal or external 
threats to security and the IP infrastructure. This guide helps analysts perform investigations of endpoint 
data using NetWitness Investigate.

Note: In Version 11.1 and later, the Hosts and Files views provide a view into endpoint data. Earlier 
versions offer access to endpoint data using a standalone NetWitness Endpoint server.

For more information, see the NetWitness Endpoint Quick Start Guide, the NetWitness Investigate Quick 
Start Guide, and the NetWitness Investigate User Guide.

Endpoint Metadata
Endpoint metadata is generated when hosts are scanned and when there are real-time activities on the 
hosts. You can view the following categories of sessions when metadata forwarding is enabled:

7 Introduction



NetWitness Endpoint User Guide

Operating 
System

Scan Categories Tracking Categories 

Windows file, service, dll, process, 
task, autorun, machine, 
kernel hook, image hook, 
registry discrepancies, 
and suspicious threads

 l Process event - Reports any process related activities, 
such as openprocess, openosprocess, 
createprocess, createremotethread, 
openbrowserprocess.

 l File event - Reports any file related activities by an 
executable, such as readdocument, 
writetoexecutable, renameexecutable,  
selfdeleteexecutable,   openphysicaldrive.

 l Registry event - Reports activities that result in registry 
creation or modification, such as 
modifyservicesimagepath, 
modifyfirewallpolicy, 
createservicesimagepath, 
createsecuritycenterconfiguration, 
modifybadcertificatewarningsetting.

 l System event - Reports IP change and boot events.

 l Network event - TCP/UDP and incoming/outgoing. 
 l Reports outbound and inbound network connections on 

all supported Windows platforms.

Note: Reports events only on Windows operating 
systems that support Windows Filtering Platform 
(WFP), such as Windows Vista, Windows Server 
2008 and later.

 l Reports IPv4 and IPv6 connections.
 l Console event (for Windows 8 and later) - User input that 

is entered into a console application, such as cmd.exe, 
powershell.exe, is captured and reported with the 
context console.local.

For example, Get-Item -Path Registry::HKEY_
LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion.

Linux file, autrorun, loaded 
library, systemd, process, 
cron, initd, and machine

-
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Operating 
System

Scan Categories Tracking Categories 

Mac file, daemon, process, 
task, dylib, autorun, and 
machine

 l Process event - Reports any process related activities, 
such as openprocess, createprocess, 
openosprocess, openbrowserprocess, 
allocateremotememory, createremotethread.

 l File event - Reports any file related activities by an 
executable, such as writetoexecutable, 
renameexecutable, createautorun, 
deleteexecutable, selfdeleteexecutable, 
writetoplist, writetosudoers, 
createbrowserextension.

 l Network event - TCP/UDP and incoming/outgoing.

 l Reports outbound and inbound network connections on 
all supported Mac operating system.

 l Reports IPv4 and IPv6 connections.

For more information on metadata, meta keys, meta values, and meta entities, see the NetWitness 
Investigate User Guide.

Risk Score 
Analysts can use the risk score to begin an investigation on hosts and files.  RSA uses a proprietary 
algorithm to calculate the risk scores ranging from 0 to 100. A subset of alerts associated with hosts and 
files contribute to the risk score calculation. Analysts can review critical and high alerts associated with 
a risk score to identify strong evidence of malicious activity and take required action. 

Note: If you have an Insights agent, you can view the risk score for files but not for hosts. To view the 
risk score for hosts, upgrade to the Advanced agent. For more information, see the NetWitness 
Endpoint Configuration Guide. 

The following  factors contribute to the risk score: 
 l Distinct Alerts.  Any host or file  activities that are suspicious or malicious generate alerts. Only the 

distinct alerts are used for risk score calculation.

 l Severity of Alerts. Severity of alerts, such as critical, high, and medium. 
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This figure is an example of a host  with 2 Critical, 10 High and 12 Medium distinct alerts.

All the distinct alert shown in the above example can be for the same file or different files. For 
example, Configures Image Hijacking alert is triggered for files, such as malware4.exe and 
malware7.exe.

This figure is an example of files with distinct alerts. Each file can have a multiple distinct alerts. The 
files can have a same alert name being triggered by two different hosts as shown below.
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Besides the above factors, the risk score is reset when you perform any of the following actions:

 l Whitelist or blacklist a file after investigation. The risk score of a file is set to 0 on whitelisting and 
set to 100 on blacklisting.

 l If the alerts or events triggered by the host or files on the host are false positive, you make changes to 
the Endpoint Application rules or ESA rules and reset the risk score.

Note: When you whitelist a file or reset the risk score, the alerts  that contributed to the risk score are 
not shown in the Host Details tab.

The host risk score depends on the risk score of all the files on the host. When you change the file status 
or reset the file risk score, the host risk score is recalculated. For example, the score for all the hosts on 
which a blacklisted file is present is recalculated and becomes 100. If the host is not found to be 
infected,  you can reset the host risk score. This deletes the alerts  contributed to the risk score and does 
not impact the global file score. For more information on changing the file status, see Changing File 
Status or Remediate.

Note: For the risk score calculation, the ESA Correlation server must be configured  with an Endpoint 
Concentrator. The application rules are automatically deployed on installation. For an upgrade, you 
must deploy the application rules from RSA Live. For more information, see the NetWitness Endpoint 
Configuration Guide.

Severity of Alerts
The following table depicts the risk score range based on the associated alert severity: 

Severity Color
Risk Score 
Range

Critical Red 100
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Severity Color
Risk Score 
Range

High Orange 70-99

Medium Yellow 31-69

Low Green 0-30

The following is an example of alerts contributing to the risk score:

In the above example, there are three distinct critical alerts. For each alert type, associated events are 
displayed. You can see that the "Enables Cleartext Credential Storage" alert was triggered twice. The 
details of the two events are displayed with the metadata information. For more information on severity 
alerts and metadata information, see Analyze Hosts Using the Risk Score and Analyze Files Using the 
Risk Score. 

Global and Local Risk Score
Analysts can get better context on file activities on hosts using the global risk score and the local risk 
score of a file.
Global Risk Score -  The global risk score is an aggregate of all suspicious and malicious activities 
performed by the file across all hosts. This score indicates the potential threat posed by the file across 
the NetWitness Platform. 
Local Risk Score - The local risk score is calculated on suspicious or malicious activities performed by 
the file on a specific host. The local risk score is used for the host risk score calculation.  
For more information on the global and local risk score, see Investigating Files and Investigating Hosts. 
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Automated Incident Creation Based on Risk Score
By default, a threshold is set for the risk score to control the generation of incidents and alerts in 
NetWitness Respond.  For more information on configuring the threshold limit, see the NetWitness 
Respond Configuration Guide. 

File Reputation
The File Reputation service available on RSA Live checks the reputation of every file hash against an 
extensive database of known file hashes updated in real-time. The file reputation is displayed on the 
Investigate and Respond views. 
The reputations for a file hash are:

Reputation Description

Malicious File hash is labeled as malicious.

Suspicious File hash is suspected to be malicious.

Unknown File hash is not known.

Known File hash information is known to the file reputation service and does not have any 
previous bad record. 

Known Good File hash information is known good, such as files signed by Microsoft or RSA. 

Invalid File hash format is invalid. 

The suspicious or malicious files are available for further analysis in the Investigate > Navigate view 
and Investigate > Event Analysis view. For more information on the file reputation service, see the Live 
Services Management Guide. 

Note: The File Reputation service supports maximum of 10 million files for a reputation of file hash.

File Status 
To help analysts triage and focus on their investigation, NetWitness Platform provides capabilities to 
manage suspect and legitimate files. For example, you can whitelist files that are legitimate  (such as 
security products), or blacklist files based on known threats and investigation. 
A file can be classified as follows: 
 l Blacklist: File that is marked suspicious, such as when  ransomware is found by scan.

 l Graylist: File that is marked for a later review.

 l Whitelist: File that is legitimate and is not to be considered for risk scoring.

 l Neutral: Default status.
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Remediation
If a file is malicious or infected, you can block the file to prevent future execution on any host. 
Remediation helps to: 

 l Stop or reduce the spread of identified malware, such as viruses, trojans, rootkits, worms, spyware, 
and adware.

 l Identify attempted breach points to aid in deeper analysis; all events are time-stamped allowing 
analysts to trace backward to identify the entry point.

 l Remove unwanted software, such as adware, which can potentially mask real malware.

 l Stop all actions possible by the loader.

You can block files with the following file extension: EXE, COM, SYS, DLL, SCR, OCX, BAT, PS1, 
VBS, VBE, and VB. 
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Focusing on Endpoint Analysis
This guide provides the information needed to conduct an investigation that is focused on endpoint data 
from configured hosts. Analysts who conduct analysis using Investigate need to have the appropriate 
system roles and permissions set up for their user accounts. An administrator must configure roles and 
permissions as described in Roles and Permissions for Endpoint Analysts. For more information on roles 
and permissions, see the System Security and User Management Guide.
To hunt for information on hosts that have the agent running, begin the investigation in the Hosts view 
(INVESTIGATE > Hosts). For every host, you can see processes, drivers, DLLs, files (executables), 
services, anomalies, and autoruns that are running, and information related to logged-in users. (See 
Investigating Hosts.)
You can begin the investigation on files in your deployment in the Files view (INVESTIGATE > Files). 
(See Investigating Files.)

Note: To access the Hosts and Files views, you must have the endpoint-server.filter.manage 
permission. 

Analysts use the Hosts and Files views to investigate or perform analysis on hosts  or files using 
attributes such as IP address, host name, Mac address, risk score, and so on. This figure shows the high-
level capabilities of an endpoint investigation. The top box are all the possible starting points, and the 
lower box shows the tasks that you can accomplish from different starting points.
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Investigating Files

Note: The information in this topic applies to RSA NetWitness® Platform Version 11.3 and later.

The Files view provides a holistic view of all files in your deployment. You can apply various filters, 
sort, and categorize files into different status to reduce the number of files for analysis and identify 
suspicious or malicious files.

Best Practices
The following are some best practices and tips that may help you investigate  efficiently to identify and 
isolate threats or attacks:

 l Whitelist all files signed by RSA, Microsoft, and any other known good vendors. Use the filters to list 
the files and change the status of all these files to whitelist. For more information, see Filter Files and 
Changing File Status or Remediate.

Note: Some Microsoft signed files are restricted from whitelisting as there is a potential risk of 
them being used for malicious purposes. To view the list, see Files Restricted from Whitelisting.

 l Change the status of certificate and the associated files automatically. For more information, see 
Analyze Certificates.

 l Filter to exclude whitelisted, files with valid signature, known good files based on reputation status. 
For more information, see Filter Files.

 l Lookup Google or VirusTotal with the filename or hash to get more information about a suspected 
file. For more information, see Launch an External Lookup for a File.

 l Analyze the files using one or more of these indicators:

 a. Risk score - Displays the risk score for a file. Analysts can view the associated alerts and events 
for further investigation. For more information, see Analyze Files Using the Risk Score.

 b. Active on - Indicates the number of hosts on which this file is active in the past seven days. This 
helps an analyst to determine whether the file is of interest or not. If a file is present on fewer 
hosts with a high risk score, it may require further investigation. For more information, see 
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Analyze Hosts with File Activity.

 c. File status - To manage suspected and legitimate files, analysts can use the file status to manage. 
For more information on the various file status, see Changing File Status or Remediate.

 d. Reputation status - Indicates the reputation of a file hash for analyst to narrow-down the files to 
investigate. For more information, see File Reputation.

 e. Signature - A valid signature on a file signed by a trusted vendor, such as Microsoft and Apple 
indicates that the file is not a risk. If a file is unsigned, it may be malicious, and needs 
investigation.

 f. File name - Many trojans write random file names when dropping their payloads to prevent an 
easy search across the hosts in the network based on the filename. For example, if a file is named 
svch0st.exe, scvhost.exe, or svchosts.exe, it indicates that the legitimate Windows file 
named svchost.exe is being mimicked. 

 l Investigate a particular file name or hash by pivoting to Navigate or Event Analysis view to view 
context, file activity on different hosts, and any file transfers across the network through packet data. 
For more information, see Analyzing Events.

 l Download suspicious files to the server  for deeper analysis. For more information, see Analyzing 
Downloaded Files.

 l Change the status of the file (blacklist or graylist), and block an infected or malicious file. For more 
information, see Changing File Status or Remediate.

View Files
You can view all files present on a specific Endpoint server or consolidated list of all files on multiple 
Endpoint servers using the Endpoint Broker for analysis. To view files:
 1. Go to INVESTIGATE > Files.

 2. Select one of the following:
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 l Endpoint Broker Server to view all files across all Endpoint servers.
 l Endpoint Server to view files on a specific Endpoint server. 

 3. Select the file that you want to analyze.
 4. Click a row to view the following details:

 l File Details displays the file information. For more information, see Launch an External Lookup 
for a File.

 l Risk Details displays the distinct alerts associated with the risk score. For more information, see 
Analyze Files Using the Risk Score.

 l  Hosts displays the number of hosts on which file activities are present. For more information, see 
Analyze Hosts with File Activity.
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Filter Files
You can narrow down the search by filtering files on file name, file status, risk score, remediation, 
reputation status, operating system, size, entropy, format, signature, company name, checksum (MD5 
and SHA256), and downloaded status. 

Note: While filtering on a large data set, use at least one indexed field with the Equals operator for 
better performance. The following fields are indexed in the database - Filename, MD5, SHA256, 
Operating System, First Seen Time, Format, Risk Score, File Status, and Reputation Status.

Select the parameters in the Filters tab. Click Save to save the search and provide a name (up to 250 
alphanumeric characters). The filter is added to the Saved Filters list. To delete a filter, hover over the 

name and click .

Note: Special characters are not allowed in the filter name except underscore ( _ ) and hyphen (-) 
while saving the filter.

For example, to filter the files based on file reputation, select the reputation status in the Filter panel.

Note: For the file size, 1 KB is calculated as 1024 bytes. For example, if the actual size of the file is 
8421 bytes, the UI will display it as 8.2 KB instead of 8.22 KB. It is recommended to search using the 
bytes format when using the Equals operator.

Add and Sort Columns in the Table
By default, the Files view displays a few columns, and files are sorted based on the risk score. To add or 
remove columns:
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 1. Go to INVESTIGATE > Files.

 2. Select the columns by clicking  in the right-hand corner. 

 3. Scroll down or enter the keyword to search and select the required columns.

 4. To sort the column in ascending or descending order, click the arrow on the column header. 

Analyze Files Using the Risk Score
To analyze files using the risk score: 
 1. Go to INVESTIGATE > Files.

The Files view is displayed.

 2. In the Server drop-down list, select the Endpoint server or Endpoint Broker server to view the files.

 3. Select the file and do any of the following.
 l Click a row to view the risk associated with the file in the Risk Details panel.

 l Click the hostname to investigate the host.

The Details tab is displayed.

 4. In the Alert Severity panel, click the alert severity, such as Critical, High, Medium, or All. 
The list of distinct alerts is displayed along with the total number of events associated with the alert.

 5. Click an alert to view the associated events. 

Note: Only the latest 1000 events are displayed. 
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 6. To view all the metadata associated with a specific event, click the event header. The information 
such as source path, target path, filename, and others is displayed.

 7. Hover over one of the meta values for IP, Hostname, Mac, File name, File hash, User, and Domain 
to view additional information about the specific metadata. A hover box displays a list of the data 
sources that have context data available for meta value. These are the possible data sources: 
NetWitness Endpoint, Incidents, Alerts, Hosts, Files, Feeds, and Live Connect.

 8. To investigate the original event and destination domain of the event, do any of the following:
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 l To reconstruct an event in a readable form that matches the original, click the Investigate 
Original Event link highlighted in blue. For more information on event reconstruction, see the 
NetWitness Investigate User Guide.  

 l For details about the elements associated with an event, click the Investigate Destination 
Domain link highlighted in blue. For more information on Contextual Information for an Event, see 
the NetWitness Investigate User Guide. 

Note: Investigate Destination Domain link is not displayed if there is no domain.dst event.

 l To view a list of processes captured on the hosts and investigate a particular process, click the 
Analyze Process link highlighted in blue. For more information on process analysis, see 
Investigating a Process.

Note: Analyze Process link is not displayed if there is no createprocess event.

Analyze Hosts with File Activity
To view the list of hosts on which the file activities are present, do the following:  

Note: By default, the system detects the best data source for the active on aggregation. To change the 
data source, modify the investigate service ID under endpoint/investigate in the Explore view. 

 1. Click the number in the Active on column for the file you want to analyze.

 2. In the right panel, click the Hosts tab. The list of hosts is displayed.
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 3. Click the host name to open the host details. 

 4. Click  to analyze events on the host in the Event Analysis view. For more information, see 
Analyzing Events.

Launch an External Lookup for a File
While analyzing a file, you can search Google or VirusTotal with the filename or hash to get more 
information about the file. To launch the search:
 1. Go to INVESTIGATE > Files.

 2. View the details of the file name and hash from the table MD5, SHA1, and SHA256 columns, or 
view the details in the File Details tab on the right panel.

 3. Select one or more files, and right-click or in the More drop-down list in the toolbar, do the 
following:

 a. Select Google Lookup and perform a search on the filename, MD5, SHA1, or SHA256.

 b. Select VirusTotal Lookup and perform a search on MD5, SHA1, or SHA256.

Note: To open files in multiple tabs, make sure you enable the pops-up in the browser.
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Set Files Preference
By default, the Files view displays a few columns and the files are sorted based on the risk score. If you 
want to view specific columns and sort data on a specific field:

 1. Go to INVESTIGATE > Files.

 2. Select the columns by clicking  in the right-hand corner. The following example shows the drop-
down list displayed while adding columns: 

 3. Sort the data on the required column.

Note: The selections you make here become your default view every time you log in to the  Files view. 

Export Global Files
To extract the list of global files to a comma-separated values (csv) file:

Note: While filtering on a large data set, use at least one indexed field with the Equals operator for 
better performance. You can export up to 100k files at a time. 

 1. Go to INVESTIGATE > Files.

 2. Filter the files by selecting the required filter option. 

 3. Add columns by clicking  in the right-hand corner.
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 4. Click  to export the files to a csv file.

You can either save or open the CSV file.

Note: This exports all columns in the table except Active on. 

Analyze Certificates
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.3 and later.

The Certificates view provides a list of code-signing certificates reported by hosts found in your 
deployment and their associated properties. You can select the certificates under a specific Endpoint 
server. 
To view the certificates in an Endpoint server:
 1. Go to INVESTIGATE > Files. 

 2. From the drop-down menu, select the Endpoint server to view certificates present on that server. To 
view a consolidated list of certificates, select the Endpoint Broker server. 

 3. Select a file and do one of the following:
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 l Right-click and select View Certificates from the context menu.

 l Click View Certificates in the toolbar.

Change the Certificate Status
You can assign a Whitelist status to the certificate signed by certain trusted vendors and this status can 
be automatically applied to all files that is signed by this certificate. If you consider abc a trusted vendor, 
you can set the status for the certificates signed by abc as Whitelist. 
Similarly, you can also set the certificate status as Blacklist or Neutral. If a company's certificate is 
stolen or compromised, you can blacklist this certificate and remediate.
To change the certificate status:
 1. Select a certificate, and click Change Certificate Status. 

 2. In the Change Certificate Status dialog, select a status - Blacklist, Whitelist, or Neutral.

Note: If you have manually updated a file status in the Files or Hosts view, changing the status in 
the Certificate view does not impact the file status as the manual update takes precedence. For 
example, if you have whitelisted the file vmci.sys that is signed by VMware, Inc. in the Files or 
Hosts view, and you have blacklisted  VMware, Inc. in the Certificate view, the file vmci.sys 
remains Whitelisted though the certificate is blacklisted.

 3. Add a comment and click Save.

 4. Click < Files to go to the Files view.
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Note: In a multi-server environment, changing the status of a certificate in one endpoint server updates 
the respective files in other endpoint servers. For example, if a certificate status is set to Blacklist on 
one endpoint server, all files signed by this certificate are set to Blacklisted on all endpoint servers. 

Filter Certificates
You can filter certificates on status, signature, friendly name, and thumb print. 

Click Save to save the filter and provide a name (up to 250 alphanumeric characters). The filter is added 

to the Saved Filters list. To delete a filter, hover over the name, and click .

Note: Special characters are not allowed except underscore (_) and hyphen (-) while saving the filter.

Resetting Risk Score of Files
You can reset the risk score for a file in these situations:

 l If the alerts or events triggered by the host or a file are considered to be false positive, you can make 
required changes to the Endpoint Application rules or ESA rules.

 l After you take required action on a malicious file.

When you reset the risk score, the risk calculation for the file is deleted and score is set to 0. The risk 
score on all the hosts on which this file exists is recalculated. You can reset the risk score for a single 
file or multiple files.

To reset the risk score of a file:
 1. Go to INVESTIGATE > Files.

 2. Select the Endpoint Server or Endpoint Broker.
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 3. Select one or more files and do one of the following:

 l Right-click and select Reset Risk Score from the context menu.

 l Click More Actions > Reset Risk Score in the toolbar. 
All the alerts associated with the score are deleted. 

Note: You can select a maximum of 100 files to reset the score.

 4. Refresh the page to view and confirm if the file's score is reset. This may take sometime for changes 
to take effect.
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Investigating Hosts

Note: The information in this topic applies to RSA NetWitness® Platform Version 11.3 and later.

The Hosts view allows you to investigate on a host, which includes scan details, tracking events related 
to alerts, anomalies, and process details. 

Best Practices
The following are some best practices and tips that may help you investigate  efficiently to identify and 
isolate threats or attacks:

 l Review hosts with highest risk score and analyze the alerts contributing to the risk. Review the 
entities, such as file name, processes involved in the alerts. For more information, see Analyze Hosts 
Using the Risk Score.

 l Review files or processes that created this suspected file, and check if any other files are accessed or 
created in the Event Analysis view. For more information, see Analyzing Events.

 l Review hosts for rare files in the Active On column.  If a file is present on 100 hosts, it might be 
legitimate.  If a file is present on fewer hosts with a high risk score, it could be malicious and needs 
further investigation.

 l Search Google or VirusTotal with the file hash and review any reported activities. For more 
information, see Launch an External Lookup for a File.

 l Review the processes, autoruns, files, libraries, drivers, and system information. For example, 

 l Search for files in known malware locations. For example, 

 l C:\Windows\.

 l C:\Users\<name>\AppData\<uncommon folder>.
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 l C:\Users\<name>\AppData\Local\Temp.

 l C:\Windows\Temp\.
 l Search for a particular file name or hash and review the snapshot to check when the file was first 

seen.

 l Review any network connections established by the process, such as:

 l Domain or IP address.

 l Ports used (common (80 and 443) versus uncommon ports (8080 , 8888, and 3465)) and check if 
the ports are listening actively.

 l Check the file compile time. If the date is recent, it could be malicious.

 l Check the file creation time on the host. 

 l Review reported anomalies, such as suspicious threads, kernel hooks, image hooks, and registry 
discrepancies. For more information, see Analyze Anomalies.

 l Launch Process Analysis  to view the sequence of activities performed on the host by the file or 
process. For more information, see Analyze Processes.

 l Download suspicious files to the server  for deeper analysis. For more information, see Analyzing 
Downloaded Files.

 l After investigation if a file is found to be malicious you change the status of the file (blacklist or 
graylist) and block infected or malicious file. For more information, see Changing File Status or 
Remediate.

View Hosts
You can view all hosts present on a specific Endpoint server or consolidated list of all hosts on multiple 
Endpoint servers using the Endpoint Broker for analysis. By default, hosts are sorted based on the risk 
score. To view the hosts: 

 1. Go to INVESTIGATE > Hosts.
 2. Select from the following:

 l Endpoint Broker Server to view all  hosts across all Endpoint servers. When querying, the 
Endpoint Broker ignores Endpoint servers that are offline. If the Endpoint server is online but is 
not responding, the Endpoint Broker waits for 10 seconds, and ignores if it does not respond.
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 l  Endpoint Server to view  hosts on a specific Endpoint server. 

 3. Select a host that you want to analyze.

 4. Click a row to view the following details:

 l Host Details displays the host information such as Network Interfaces, operating system, 
hardware and others.

 l Risk Details displays the distinct alerts associated to the risk score and the alerts severity. Click 
Critical, High, Medium, or All to display all the alerts. For more information, see Analyzing 
Risky Users.

 5. Click Show next 100 hosts to view other hosts.  
 6. Click the host name to investigate the scan results. For more information, see Analyze Host Details.

Filter Hosts
You can filter hosts on agent version, agent ID, agent mode, agent last seen, last scan time, operating 
system, hostname, username, managed agents, Mac address, risk score, IPV4, driver error code, security 
configurations, and agent groups. 

Note: While filtering on a large amount of data, use at least one indexed field with the Equals 
operator for better performance. The following fields are indexed in the database - Hostname, IPv4, 
Operating System, Last Scan Time, and Risk Score.
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To search multiple values within a field, set the filter option to Equals, and use || as a separator. 
For example, using Equals operator for multiple IPV4 values with a separator ||.

To filter on the agent last seen or last scan time, select the option from the drop-down list. If you select 3 
Hours ago for the Last Scan Time, the result displays hosts that were last scanned 3 hours ago or earlier.
To filter on the risk score, use the slider to increase or decrease the values between 0 to 100. 
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Click Save to save the search and provide a name (up to 250 alphanumeric characters). The filter is 

added to the Saved Filters panel on the left. To delete a filter, hover over the filter name and click .

Note: Special characters are not allowed except underscore (_) and hyphen (-) while saving the filter.

Adding and Sorting Columns in the Table
By default, the Hosts view displays a few columns and the hosts are sorted based on the risk score. To 
add or remove columns:
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 1. Go to INVESTIGATE > Hosts.

 2. Select the columns by clicking  in the right-hand corner.

 3. Scroll down or enter the keyword to search for the column. 

 4. Click the arrow on the column header to sort the column in ascending or descending order. 

Scan Hosts
You may want to perform an on-demand scan if you want to get the latest snapshot of the host. 
When the hosts are scanned, the Endpoint Agent retrieves the following data that can be used for 
investigation:

 l Drivers, processes, DLLs, files (executables), services, autoruns, anomalies, host file entries, and 
scheduled tasks running on the host.

 l System information such as network share, installed Windows patches, Windows tasks, logged-in 
users, bash history, and security products installed.

To start a scan:
 1. Go to INVESTIGATE > Hosts.

 2. Select one or more hosts (up to 100) at a time for an on-demand scan, and do one of the following:
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 l Right-click and select Start Scan from the context menu.

 l Click Start Scan in the toolbar. 
 3. Click Start Scan in the dialog. This performs a quick scan of all executable modules loaded in 

memory.

The following are the scan statuses: 

Status Description

Idle No scan is in progress. 

Scanning Scan is in progress.

Pending Scan request is sent to the server and the agent will receive the request the next time it 
communicates with the server.

Cancel Stop request is sent to the server and the agent will receive the request the next time it 
communicates with the server. 

Analyze Hosts Using the Risk Score
You can investigate a host by analyzing the risk contributors such as alerts and events to look for 
suspicious or malicious activity.
To analyze the hosts using the risk score: 
 1. Go to INVESTIGATE > Hosts.

The Hosts view is displayed.

 2. In the Server drop-down list, select the Endpoint server or Endpoint Broker server to view the hosts.

 3. Select the host and do any of the following.

 l Click a row to view the risk associated with the host in the Risk Details panel.

 l Click the hostname to investigate the host.
 4. In the Alert Severity panel, click the alert severity such as Critical, High, Medium, or All. 

The list of distinct alerts is displayed along with the total number of events associated with the alert.

 5. Click  an alert to view the associated events.
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Note: Only the latest 1000 events are displayed. 

 6. To view all the metadata associated with a specific event, click the event header. The information 
such as source path, target path, filename, and others is displayed.

 7. Hover over one of the meta values for IP, Hostname, Mac, File name, File hash, User, and Domain 
to view additional information about the specific metadata.  A hover box displays a list of the data 
sources that have context data available for meta value. These are the possible data sources: 
NetWitness Endpoint, Incidents, Alerts, Hosts, Files, Feeds, and Live Connect.
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 8. To investigate the original event and destination domain of the event, do any of the following:

 l To reconstruct an event in a readable form that matches the original, click the Investigate 
Original Event link highlighted in blue. For more information on event reconstruction, see the 
NetWitness Investigate User Guide.  

 l For details about the elements associated with an event, click the Investigate Destination 
Domain link highlighted in blue. For more information on Contextual Information for an Event, see 
the NetWitness Investigate User Guide. 

Investigating Hosts 38



NetWitness Endpoint User Guide

Note: Investigate Destination Domain link is not displayed if there is no domain.dst event. 

 l To view a list of processes captured on the hosts and investigate a particular process, click the 
Analyze Process link highlighted in blue. For more information on process analysis, see 
Investigating a Process.

Note: Analyze Process link is not displayed if there is no createprocess event.

Analyze Host Details
To look for suspicious files on a host, click the host name and view the details of the host, or start an on-
demand scan to get the most recent information. On the right-hand panel, you can view the following:

 l Host Details displays the host information,such as Network interface, operating system, hardware 
and others.

 l Policy Details displays the complete resolved policy settings.

For more details, see Hosts View - Details Tab.

Search on Snapshots
To investigate a host or to check if it is infected with a known malware, you can search for occurrences 
of the file name, file path, or SHA-256 checksum. 

Note: To search for a SHA-256 checksum, provide the entire hash string in the search box. 

The result displays details, such as file name, signature information, along with its interaction with the 
system (ran as process, library, autorun, service, task, or driver). To view more details for these results, 
click the category.
For example, a user has clicked and executed a malicious attachment through a phishing email, and 
downloaded it to C:\Users. To investigate this file: 
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 1. Go to INVESTIGATE > Hosts.

 2. Select the host that you want to investigate or select the Endpoint Broker server to investigate all the 
hosts. 

 3. In the Details tab, enter the file path C:\Users in the search box. 

The search displays a maximum of 100 results of the executables in this folder. In this example, the 
file Malware.exe, is an unsigned file that might be malicious. If the search is executed on an 
Endpoint Broker server, it queries all the Endpoint servers. 

This file is run as a Process.

 4. To view details  of this file, click Process in the result. 

This opens the Process tab where you can view the process details. 
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Analyze Processes
To analyze the  process:
 1. In the Hosts Details view, select the Processes tab. 

The following is an example of the tree view:
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 2. In the Processes Tab, do one of the following:
 l Click a row to view the properties of a process in the right panel.

 l Click the process name to view the process details of a specific process.

When reviewing processes, it is important to see the launch arguments. Even legitimate files can be used 
for malicious purposes, so it is important to view all of them to determine if there is any malicious 
activity.
For example,

 l rundll32.exe is a legitimate Windows executable that is categorized as a good file. However, an 
adversary may use this executable to load a malicious DLL. Therefore, when viewing processes, you 
must view the arguments of the rundll32.exe file. 

 l LSASS.EXE is a child to WININIT.EXE. It should not have child processes. Often malware use this 
executable to dump passwords or  mimic to hide on a system (lass.exe, lssass.exe, 
lsasss.exe, and so on). 
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 l Most legitimate user applications like Adobe and Web browsers do not spawn child processes like 
cmd.exe. If you encounter this, investigate the processes.

You can view the sequence of activities performed on the host by the file or process using the process 
analysis. For more information, see Investigating a Process.

Analyze Autoruns
In the Hosts view, select the Autoruns tab. You can view the autoruns, services, tasks, and cron jobs 
that are running for the selected host. 
For example, in the Services tab, you can look for the file creation time. The compile time is found 
within each portable executable (PE) file in the PE header. The time stamp is rarely tampered with, even 
though an adversary can easily change it before deploying to a victim's endpoint. This time stamp can 
indicate if a new file is introduced. You can compare the time stamp of the file against the created time 
on the system to find the difference. If a file was compiled a few days ago, but the time stamp of this file 
on the system shows that it was created a few years ago, it indicates that the file is tampered.

Analyze Files
In the Hosts view, select the Files tab. You can view the list of files scanned on the host at the time of 
scan. By default, the table displays 100 files. To display more files, click Load More at the bottom of 
the page.
For example, many trojans write random filenames when dropping their payloads to prevent an easy 
search across the endpoints in the network based on the filename. If a file is named svch0st.exe, 
scvhost.exe, or svchosts.exe, it indicates that the legitimate Windows file named svchost.exe is 
being mimicked. 

Analyze Libraries
In the Hosts view, select the Libraries tab. You can view the list of libraries loaded at the time of scan. 
For example, a file with high entropy gets flagged as packed. A packed file means that it is compressed 
to reduce its size (or to obfuscate malicious strings and configuration information).

Analyze Drivers
In the Hosts view, select the Drivers tab. You can view the list of drivers running on the host at the time 
of scan. 
For example, using this panel, you can check if the file is signed or unsigned. A file that is signed by a 
trusted vendor such as Microsoft and Apple, with the term valid, indicates that it is a good file.

Analyze Anomalies

Note: This tab is available only for advanced agent.

In the Hosts view, select the Anomalies tab. You can view the following details for the selected host:
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 l Image hooks - Hooks found in executable images (user-mode or kernel-mode) - IAT, EAT, Inline, 
exceptionHandler.

 l Kernel hooks - Hooks found on kernel objects (such as Driver Object [Pointers, IRP_MJ, SSDT, IDT, 
and so on]). This also includes filter devices.

 l Suspicious threads - Threads whose starting address points to memory DLLs or floating code. The 
threads could be running with either user-mode or kernel-mode privileges. These threads could run 
malicious code inside a trusted application to execute their own code. 

 l Registry discrepancies - The Windows registry is a hierarchical database that stores configuration 
settings and options on Microsoft Windows operating systems. It contains settings for low-level 
operating system components and for applications running on the platform: the kernel, device drivers, 
services, SAM, user interface, and third party applications all use the registry. The discrepancies 
between low-level parsing with Win32 registry API are reported.

Note: Anomalies is applicable only for Windows hosts.

For example, hooking is used to intercept calls in a running application and to capture information related 
to the API invocations. Malicious programs can implant hooks in various system applications for 
different purposes, such as hiding files, directories, registry entries, intercepting users keystrokes to 
establish a stealthy communication channel with the attacker.

Analyze System Information
In the Hosts view, select the System Information tab. This panel lists the agent system information. For 
Windows operating system, the panel displays the host file entries and network shares of that host. 
For example, malware might use host file entries to block antivirus updates.

Export Host Details to JSON File
To export host details about a particular snapshot time:

 1. Go to INVESTIGATE > Hosts.

 2. Click the hostname to view the details.

 3. In any of the tabs, select the snapshot time, and click Export to JSON.

Launch an External Lookup for a File
While analyzing a file, you can search Google or VirusTotal with the filename or hash to get more 
information about the file. To launch the search:
 1. Go to INVESTIGATE > Host Details (Autorun, Files, Drivers, Libraries, or Anomalies tab).

 2. Right-click one or more files, or in the More drop-down list in the toolbar, do the following:
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 l Select Google Lookup to perform a search on the filename, MD5, SHA1, or SHA256.

 l Select VirusTotal Lookup to perform a search on MD5, SHA1, or SHA256.

Note: To open files in multiple tabs, make sure you enable the pops-up in the browser.

Delete a Host 
If the agent is uninstalled on a host or if you no longer require the host scan data, you can manually 
delete this host from the Hosts view. Deleting a host deletes all scan data associated with the host. To 
delete hosts:
 1. Go to INVESTIGATE > Hosts.

 2. Select the hosts that you want to delete from the Hosts view and do one of the following: 
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 l Right-click and select Delete from the context menu.

 l Click More drop-down list in the toolbar and select Delete. 

Note: If you accidentally delete a host from the Hosts view,  the Endpoint Server forbids all requests 
from this agent. The agent must be uninstalled manually from the host and reinstalled for it to appear 
on the Hosts view.

Deleting Hosts with Older Agent Versions
After upgrading the 11.1.x and 11.2.x agents to 11.3, if you want to delete the hosts with older versions:
 1. Go to Investigate > Hosts view.

 2. Filter the hosts based on the Agent version, and delete these hosts. 

If you do not delete, the hosts are deleted based on the Data Retention Policy settings.

Set Hosts Preference
By default, the Hosts view displays a few columns and the hosts are sorted based on the risk score. If 
you want to view specific columns and sort data on a specific field:
 1. Go to INVESTIGATE > Hosts.

 2. Select the columns by clicking  in the right-hand corner. The following example shows the drop-
down list displayed while adding columns:
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 3. Scroll down or enter the keyword to search for the column in the displayed list. 

 4. Sort the data on the required column.

Note: The selections you make here become your default view every time you log in to the  Hosts 
view. 

Export Host Attributes
You can export up to 100,000 host attributes at a time. To extract the host attributes to a csv file:
 1. Go to INVESTIGATE > Hosts.

 2. Filter the hosts by selecting the required filter options.

 3. Add columns by clicking  in the right-hand corner.

 4. Click  to export the host attributes to a csv file.

You can either save or open the csv file.

Migrate Hosts 
Hosts can be migrated from one Endpoint server to another using groups and policy associated with the 
host. If a host is migrated, the Server column shows as Migrated.  The risk score of a migrated host is 
displayed on all Endpoint servers where it is present. 

Note: Some of the actions are disabled for the migrated host on the selected server, such as start scan, 
start  stop, analyze events, and others. If you want to perform the required action, select the Endpoint 
server to which the host is migrated.

Note: To view only managed hosts, select the Show Only Managed Agents option in the Filters 
panel. 

Analyzing Risky Users
If you have NetWitness UEBA installed, you can view the alerts associated with users logged in on the 
host. To analyze risky users:
 1. Go to INVESTIGATE > Hosts.

 2. Click the host name you want to analyze.
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 3. In the Host Details panel, under the Users category, click the name. 

This opens the Users tab for investigation in a new tab.

Resetting Risk Score of Hosts
You can reset the risk score for a host in these situations:

 l If the alerts or events triggered by the host or files on the host are false positive, you can make 
changes to the Endpoint Application rules or ESA rules.

 l After you take required action on the host for malicious file activities contributing to the risk score. 
When you reset the risk score, all the risk calculation for the host is deleted. When you reset the 
host's risk score, it does not change the file's risk score. You can reset the score for a single host or 
multiple hosts.

To reset the risk score of a host:
 1. Go to INVESTIGATE > Hosts.

 2. Select the Endpoint Server or Endpoint Broker.

 3. Select one or more hosts and do one of the following:
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 l Right-click and select Reset Risk Score from the context menu.

 l Click More Actions > Reset Risk Score in the toolbar. 
All the alerts associated with the score are deleted. 

Note: You can select a maximum of 100 hosts to reset the score.

 4. Refresh the page to view and confirm if the host's score is reset. This may take sometime for 
changes to take effect.
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Investigating a Process

Note: The information in this topic applies to RSA NetWitness® Platform Version 11.3 and later.

Analysts can perform process analysis to investigate a particular process behavior to:

 l Understand the entire process event chain, process parent-child relationships, and all associated 
events in a timeline view.

 l Analyze important process attributes, such as username, launch arguments, reputation, file status, 
signer, signature, and file path.

The Analyze Process view provides a list of processes captured on hosts in a parent-child hierarchical 
format over a time range. The process tree is created from the tracking event type "Process event" 
where the action meta key is createProcess. The agent reports new events for the same 
createProcess if the following parameters change:

 l Parent process filename

 l Child process filename

 l Launch arguments

 l User name

If the above parameters do not change, the event is reported only once every eight hours. 

Best Practices
When reviewing a host for malicious activity, there are a few key things to review while looking for 
malicious processes. 
 l Process Name - When reviewing running processes on a host, check for the name of the program that 

looks suspicious.  Sometimes malware uses random names, such as wzuduje.exe.  In some cases, the 
names might be misleading such as adob3.exe, scvhost.exe, or Microsoft.exe.  Being familiar 
with Windows processes and any type of internal tool that might be used throughout the environment, 
also helps you to identify potentially malicious or suspicious files.

 l File Path - Similar to knowing normal and key Windows processes, knowing what path the processes 
originate from is a key to detect certain processes that imitate the legitimate process.  For instance, if 
you see svchost.exe running on a system from 
C:\Users\<username>\AppData\Roaming\adobe\ (which is a valid file path), and knowing that 
the legitimate Windows process originates from C:\Windows\System32\,  you can determine that 
the svchost.exe file starting from the C:\Users\<username>\AppData\Roaming\adobe\  
directory is the suspicious one.  To help determine further identification of a suspicious process, 
review the Autoruns tab to see if this process is running as an autorun, service, or task.

 l File Signature - When a software package is created, it has a valid digital signature. The following 
are a few exceptions:
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 l If a process that is running is not digitally signed, it does not automatically confirm that the file is 
malicious.

 l While files may have a valid signature, it does not mean that they are legitimate.  There are 
instances of software identified as a Potentially Unwanted Program (PUP) or Adware, which can 
have a valid signing certificate.  

 l Active On  - Determines on how many hosts a file is currently active.   You can look for suspicious 
files based on the rarity of a file.  

 l Reputation -  Leveraging the reputation service is a way to find malicious processes.  

 l Analyze events - For further insight to a process, you can analyze console events, network events, file 
events, process events, and registry events.

 l Network events - Look for any suspicious domains to which the process is connecting.  Sometimes 
malware creates legitimate connections to a known site, such as google.com, bing.com to hide its 
activity on the network.  Look for connections to Dynamic DNS domains where a lot of known 
malicious activity resides. During analysis, consider uncommon processes making direct 
connections to an IP address or to a uncommon port number.

 l File and process events - Review process interactions that have occurred on the system with the 
suspected file. You can look for key events such as writeToExecutable, renameExecutable, 
and createRemoteThread, which indicate suspicious behavior.

 l Leverage other methods

 l Look up with Google - You can search the file name or hash value against Google to determine if 
the file is malicious.

 l Look up with VirusTotal – You can search the hash value against the VirusTotal to determine if 
the file is malicious between multiple AV vendors.

 l Download file – Download and analyze a file to find indicators such as compile time, imported 
DLLs, section names, and performing string searches.  Look for TLD values (.com, .net, .biz) or 
debug information of a compiled binary (.pdb), which can be easily changed or forged.

 l Time stamp values – Review modified, accessed, and created dates associated with the binary. 
Review how long a file has been residing on a host.  While this value is correct most of the time, 
attackers can change the time stamp values of a file.

Analyze a Process
Note: Linux is not supported for analyzing a process.

To analyze the process:
 1. Go to INVESTIGATE > Hosts.

 2. Click the hostname. 

 3. To analyze process activities of a file, do one of the following:
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 l In the Host Details tab:

a. Click the alert severity.

The list of distinct alerts is displayed along with the total number of events associated with the 
alert.

b. Click the event header and click the Analyze Process link at the bottom. 

 l Select the Processes tab and do one of the following:

- Right-click a process and select Analyze Process from the context menu.

- Click Analyze Process in the toolbar.

In the following example, there is one critical alert, where the file powershell has invoked 
mimikatz, which is a tool  to extract plain text passwords, hashes, and kerberos tickets from 
memory. 

Clicking Analyze Process displays the process visualization along with the associated events. 
Optionally, you can change the time range to view data. Also you can filter the events based on the 
events category. For more information on filtering, see Analyze Events for a Process.
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Note: The result is not displayed in the process visualization view, if there is no data for last seven 
days or if there is no createprocess event. 

 4. Hover over the process name to analyze important process attributes, such as username, launch 
arguments, reputation, file status, signer, signature, and file path. 

 5. Click  to load the child processes. The associated events and properties are displayed in the right 
panel. 
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Analyze Events for a Process
To analyze events for the selected process:
 1. Perform steps 1 to 5 in Analyze a Process.

 2. In the process visualization, click the Events tab. You can sort the result based on the event time. 

 3. To narrow down the search to find any suspicious indicators, behaviors, or specific type of event, 
filter on a set of matched events based on a category - Process, File, Registry, Network Event, or 
Console Event (for Windows).

For example, while viewing events, to view only network connections made by the process, or view 
the registry modifications done by the process, filter events on these categories. 

 4. When you select a category, you have an option filter on action (openProcess, createProcess, 
and so on). The result displays the sequence of activities involving this process for the selected 
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filters.
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Changing File Status or Remediate

Note: By default, the blocking option is disabled. To enable blocking, in the policy configuration, 
change the Blocking option to Enabled under Response Action Settings. For more information, see the 
NetWitness Endpoint Configuration Guide. 

To change the status of a file:
 1. Do one of the following:

 l Go to INVESTIGATE > Host Details (Processes, Autoruns, Files, Drivers, Libraries, or 
Anomalies tab).

 l Go to INVESTIGATE > Files.
 2. Select one or more files and do one of the following:

 l Right-click and select Change File Status from the context menu.

 l Click Change File Status in the toolbar. 
 3. In the Change File Status dialog, select a status - Blacklist, Whitelist, Graylist, or Neutral.
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Note: You cannot whitelist certain Microsoft files, such as cscript.exe, wscript.exe, 
cmd.exe, bash.exe, as there is a potential risk of them being used for malicious purposes. For 
more information, see Files Restricted from Whitelisting. 

If you select Blacklist or Graylist, the following options are displayed:

 a. Category:  Select the appropriate category type: Generic Malware, APT: Advanced 
Persistent Threats, Attacker Tool, Unidentified, Ransomware.

Caution: Before blocking, make sure that you review the file because this may cause the 
system or software to be unusable.

 b. Remediate: Select Block to block the file.

Note: Blocking is supported only for Windows hosts. 
You cannot block the following:
- Memory DLL and floating code
- Files that are signed by Microsoft or RSA.

 4. Add a comment and click Save. 
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You can change the status of only 100 files at a time. When the status is changed, it impacts the file 
status on all hosts on which the file is present. The status is sent as a session under the File category, 
and available for investigation. If the file is seen in subsequent scan or tracking, the corresponding 
sessions contain a meta value with the file status (except Neutral).

Files Restricted from Whitelisting
To view or update the files that are restricted from whitelisting, do the following:

 1. On the NW server, run the nw-shell command from the command line.

 2. Run the login command and enter your credentials.
 3. Connect to the Endpoint Server using the following command:

connect endpoint-server

 4. Run the following commands to view the list of files:

 l cd endpoint/file/status/restricted/get

 l invoke Whitelist

 5. Run the following commands to add files to the list:

 l cd endpoint/file/status/restricted/get

 l invoke '{"id":"<filename>","restrictedStatus":["Whitelist"], 
"enable":true}

 6. Run the following commands to delete files from the list:

 l cd endpoint/file/status/restricted/update

 l invoke '{"id":"<filename>","restrictedStatus":["Whitelist"], 
"enable":false}
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Analyzing Downloaded Files
To perform a deep analysis of suspicious files, you can manually download the file to the server. 

Note: Make sure that the location for file download is configured and metadata forwarding is enabled 
in the Endpoint Log Hybrid. For more information, see the NetWitness Endpoint Configuration Guide.

For the downloaded file, you can:  

 l Search for strings in the executable

 l View text content for scripts

 l View imported libraries and functions

 l Save a local copy for further analysis 

Download Files to Server
The Download to Server option is disabled for memory DLL and floating code. To download file to the 
server from the Hosts view:
 1. Go to INVESTIGATE > Hosts.

 2. Select the hostname  to open the Host Details view.

 3. In any of the Processes, Autoruns, Files, Drivers, Libraries, or Anomalies tabs, select the file, and 
do one of the following:

 l Right-click and select Download File to Server from the context menu.

 l Select Download File to Server from the More drop-down list in the toolbar. 
To download files to the server from the Files view:
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 1. Go to INVESTIGATE > Files.

 2. Select the file and do one of the following:

 l Right-click and select Download File to Server from the context menu.

 l Select Download File to Server from the More drop-down list in the toolbar.
The status of the download is displayed in the Downloaded column. The download statuses are 
Downloaded, Not downloaded, and Error.

Save Downloaded Files
You can retrieve a downloaded file and save it to your local file system for further analysis. Downloaded 
files are stored in the server in the configured location. This option is enabled only if the file is 
downloaded to the server.
To save a file:

 1. Go to INVESTIGATE > Hosts Details or Files .

 2. Right-click the file you want to save and select Save a Local Copy.

 3. Browse  the location and click Save.

Analyze Downloaded Files
You can use the Analyze File option to view detailed information about a downloaded file. This option is 
enabled only if the file is downloaded to the server. To analyze a file:
 1. Go to INVESTIGATE > Hosts or Files.

 2. Right-click the downloaded file and select Analyze File. The File Analysis view opens and 
properties of the are is displayed in the right panel.
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 3. View strings in the file in the Strings view while analyzing an executable (such as macho, pe, elf). 
This view contains the string, offset in the binary, unicode, and the length of the string. You can 
search for or filter on a specific string value in the Filter String field. 

 4. View the text content of the file and look for any suspicious behavior in the script file. 

For example, if the file contains C2 information in the form of domain names or IP addresses, it is 
highly suspicious.
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If you see unprintable keyboard keys listed within the file, such as: [F1], [F2]…[Page Up], [Enter], 
[ESC], and so on, that may be indicative of a keystroke logger.
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Analyzing Events
If you need to investigate a particular host, IP address, username, filename, or hash to look for related 
activity across a time range, you can pivot to Navigate view to get the entire context of the activity. By 
default, the time range is set to 7 days. You can change the time range.

Note: By default, the system detects the best data source to pivot to Navigate view. To change the 
data source, modify the investigate service ID under endpoint or investigate in the Explore view. 

Analyze Events from Files View
To  investigate a particular filename or hash (SHA256 and MD5):

 1. Go to INVESTIGATE > Files.
 2. Select the file you want to analyze and do one of the following:

 l Right-click and select Analyze Events from the context menu.

 l Click Analyze Events in the toolbar.

This opens the Navigate view with data related to the file. For more information on analyzing events 
in the Navigate and Event Analysis views, see the NetWitness Investigate User Guide.

Note: If the values are not indexed, the results take time to load. For more information, see 
Troubleshooting NetWitness Endpoint.

Analyze Events from Hosts View
To investigate a particular host, IP address (IPV4), or username:
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 1. Go to INVESTIGATE > Hosts.

 2. Do one of the following.
 l Select a file and click Analyze Events from the toolbar.

 l Right-click a file, select Analyze Events, and select a specific event type (such as network 
events, file events) that you want to view. 
The following figure is an example of the Autoruns tab.

This opens the Navigate view with data related to the file. 

For more information on analyzing events in the Navigate and Event Analysis views, see the NetWitness 
Investigate User Guide.

Text Analysis for an Endpoint Event 
You can view all Endpoint events in their original text format in the Event Analysis view Event List 
panel. When you click an event in the Event list panel, the adjacent panel shows the Text Analysis. 
Pagination controls add flexibility when paging through the reconstructed text of an event. The Text 
Analysis displays the following:

 l Event Header, which provides summary information about the event. 

 l Options for exporting - log, csv, xml, and json formats.

 l Option to pivot to the Endpoint Thick Client to analyze the meta value. 

 l Option to analyze process details associated with the event.

 l Option to view the host details for further analysis.

Below is an example of the Process event for Endpoint. The text in the Text Analysis panel explains that 
a source process WmiPrvSE.exe opened a browser process named chrome.exe. In the events, if there 
is a meta value that exceeds 255 characters, the value is displayed in the Large Meta Values panel.
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Below is an example of the Network event:

For more information on Event Analysis, see the NetWitness Investigate User Guide.

65 Analyzing Events



NetWitness Endpoint User Guide

Troubleshooting NetWitness Endpoint
This section provides information about possible issues when using NetWitness Endpoint.

General Issues

Issue Some of the hosts or files data are not displayed when  Endpoint 
Broker is selected for querying.

Solution

While querying, the Endpoint Broker ignores the Endpoint 
servers that are offline, and shows the result of Endpoint server 
that is online, only if the Endpoint server responds with in 10 
seconds. The Endpoint Broker ignores the query if Endpoint 
server does not respond with in 10 seconds.
You must increase the query timeout value to see the result of 
Endpoint server that is online. Perform the following:

 1. Go to ADMIN > Endpoint Broker service.

 2. Click  > View > Explore.

 3. Click endpoint/broker node.

 4. In the query-timeout field increase the value, for example, 
30 seconds.

 

Issue

The Endpoint Agent is unable to communicate with the Endpoint 
Server. The connection may not be established due to any of the 
following issues:

 l UDP

 l HTTP

 l Firewall

Solution

 l To verify the UDP or HTTP connection, you must verify the 
connection between Windows Endpoint Agent and Endpoint 
Server:

 1. Go to System32 folder using the following command:
cd  C:\Windows\System32

 2. Execute the following command:
<Agent Service name>.exe /testnet

For example, NWEAgent.exe /testnet

 l If the issue is with the firewall, check the incoming and 
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outgoing firewall rules.

 

Issue

The Endpoint Agent is unable to communicate with the Log 
Decoder. The connection may not be established due to any of 
the following issues:

 l UDP

 l HTTP

 l Firewall

Solution

 l To verify the UDP or HTTP connection, you must verify the 
connection between Windows Endpoint Agent and the Log 
Decoder:

 1. Go to System32 folder using the following command:
cd  C:\Windows\System32

 2. Execute the following command:
<Agent Service name>.exe /testlognet

For example, NWEAgent.exe /testlognet

 l If the issue is with the firewall, check the incoming and 
outgoing firewall rules.

 

Issue

After you update to 11.3 and try to delete the meta forwarding configuration of the 
Log Decoder that you have configured in 11.1.x.x or 11.2.x.x, the Log Decoder 
configuration is not deleted and automatically starts the meta forwarding. 
Therefore, you will not be able to configure a new Log Decoder for meta 
forwarding.  

Solution 

You must stop the meta forwarding for the existing Log Decoder, add the new Log 
Decoder service using nw-shell and start the meta forwarding. Perform the 
following steps: 
 1. Go to ADMIN > Services, select the Endpoint Server service.

 2. Click    and select > View > Config.

 3. In the General tab, Endpoint Meta view, select the Log Decoder service.

 4. Click   

 5. On the NW server, run the nw-shell command from the command line. 

 6. Run the login command and enter the credentials. 

 7. Connect to the Endpoint Server using the following command: 
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connect --service endpoint-server.<service-id> 

 8. Run the following commands: 
cd endpoint/meta/logdecoder-host 
set <log-decoder-ip> 

 9. Go to ADMIN > Services, select the Endpoint Server service.

 10. Click    and select > View > Config. 

 11. In the General tab, Endpoint Meta view, select the new Log Decoder service.

 12. Click  . 

Hosts View Issues

Message An error has occurred. The Endpoint Server may be offline or 
inaccessible.

Issue When attempting to access the Hosts or Files view, the view opens with the message.

Explanation

Endpoint Server or Nginx Server is not running. Check the status of the Endpoint Server 
under ADMIN > Service or check if the Endpoint Server host IP address is registered 
with the Admin Server. For more information, see the  Physical Host Installation Guide 
or Virtual Host Installation Guide. If the service is not running, start the Endpoint 
Server. 

 

Issue The Hosts and Files views do not load in the Safari browser.

Explanation

When you open the Ember pages in the Safari  browser with a non-trusted SSL 
certificate, the Hosts and Files views do not load. To load the views.

 1. Click the Show Certificate pop-up menu.

 2. Enable the Always trust NetWitness when connecting to <IP Address> 
checkbox.

 3. Click Continue.

 4. Enter your username and password.

 5. Click Update Settings.

 

Message No process information was found.

Issue When attempting to access the Process or Libraries tab in the Host Details view, the 
detailed host information is not available, and the view opens with the message.

Explanation Scan data is not available due to any of the following reasons:
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 l First time scan is not complete.

 l Data retention policy has deleted all scan snapshots.

Files View Issues

Behavior Meta values take time to load.

Issue Meta values are not set to index by values.

Explanation

During investigation, while pivoting to the Navigate or Event Analysis view from the 
Files view, if the filename or hash (SHA256 and MD5) are not set to index by values, 
the matching results take time to load because the Concentrator must generate the index 
by accessing the meta database and retrieving value of the meta for each event. You 
have to manually index the values before pivoting.

 

Issue Filtering files takes a longer time to load results.

Explanation
In the Files view, while filtering files with the Contains operator, the results takes a 
few seconds to load on the UI. You must use at least one indexed field with the Equals 
operator while filtering the files.

 

Issue Unable to analyze events from Investigate > Hosts and Files view.

Explanation

Other than Broker or Concentrator, if any aggregation service, such as Archiver, is 
aggregating data from the Log Decoder that is configured for metadata forwarding from 
any Endpoint server, clicking Analyze Events from Hosts and Files view for this 
Endpoint server may not work. To resolve this issue:

Note: To get the investigate-service-id:
 1) Go to ADMIN > Concentrator service.

 2) Click  > View > Explore tab.
 3) Expand the sys/stats node list.
 4) In the UUID filed, copy the value.

 1. Go to ADMIN > Endpoint Server service.

 2. Click  > View > Explore tab.

 3. In the endpoint/investigate field, specify the investigate-service-id.

Policy Issue

Issue Policy status in the Policy Details panel is not updated or shows Policy 
Unavailable/Permission Required.
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Explanation

Policy Unavailable - Hosts belong to previous versions, such as NetWitness Platform 
11.1 or 11.2, where a policy is not applied.  
Permission Required - If you do not have permissions, see the "Role Permissions" 
topic in the System Security and User Management Guide. 

 

Issue Policy Status shows error.

Explanation
Policy may have wrong configurations. Check the error description, logs in Endpoint 
server, and audit logs for details. Contact your system administrator with the error 
details.

Driver Issue

Issue While loading the driver on the host, an error is encountered.

Explanation Check the driver error code. Contact your system administrator with the error code.

File Reputation Service Issue

Issue When you configure RSA Live for the first time and the File 
Reputation service is not connected.

Solution

You must manually enable the File Reputation service. To 
enable the File Reputation service:

 1. Go to ADMIN > System > Live Services.

 2. In the Additional Live Services section, select the enable 
File Reputation check box.

 3. Click Apply.

Risk Scoring for Hosts or Files Issue

Issue NetWitness Endpoint takes a long time to process risk scoring 
for Hosts or Files.

Solution

Check the backlog of  alerts for risk scoring.
 1. SSH to the ESA Primary appliance.

 2. Execute the following command:
mongo respond-server --authenticationDatabase 
admin -u deploy_admin -p <deploy_admin_
password> --eval 'db.staging.find({"$or":
[{state:"STAGED"},{state :"WORKING"}]}).count
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()' --quiet

The backlog count is displayed. If the backlog count is 1 
million or greater, you must disable the risk scoring and 
Endpoint ESA alerts.

 3. To disable risk scoring:

 a. Go to ADMIN > Respond service.

 b. Click  > View > Explore.

 c. Expand the respond/scheduled/jobs node list.

 d. In the risk-scoring-enabled field, set the value to false.
 4. To disable Endpoint ESA alerts:

 a. To disable NetWitness Endpoint ESA alerts generation 
for severity; Critical, High and Medium.

 i. Go to CONFIGURE > ESA Rules.

The Configure view is displayed with the Rules tab 
open.

 ii. In the Options panel, under Deployments, select the 
Endpoint deployment to delete.
A confirmation dialog is displayed.

 iii. Click Yes.

 b. To disable only Medium severity NetWitness Endpoint 
ESA alerts:

 i. Go to ADMIN >  ESA Correlation service (on 
which Endpoint deployment is added).

 ii. Click  > View > Explore.

 iii. Expand the correction/alert  node list.
 iv. In the  transient-enabled field, set the value to false.
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NetWitness Endpoint Reference Materials
This section provides is intended to help you understand the purpose and application of NetWitness 
Investigate > Hosts view and Files view. For each view,  there is a brief introduction and a What Do You 
Want To Do table with links to related procedures. In addition some of the reference materials include 
workflows and Quick Looks to highlight important features in the user interface. 

 l Files View

 l Hosts View

 l Hosts View - Details Tab

 l Hosts View - Process Tab

 l Hosts View - Autoruns Tab

 l Hosts View - Files Tab

 l Hosts View - Drivers Tab

 l Hosts View - Libraries Tab

 l Hosts View - Anomalies Tab

 l Hosts View - System Information Tab
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Files View
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Files view provides a holistic view of all files in your deployment. To access this view, go to 
INVESTIGATE > Files. By default, the Files view displays 100 files. To display more files, click 
Load More at the bottom of the page.
You can either view files specific to an Endpoint server or view all files from multiple Endpoint servers 
by selecting the Endpoint Broker.

Workflow

What do you want to do?

User 
Role

I want to ... Show me how

Threat 
Hunter

whitelist files and certificates signed by known good 
vendors*

Analyze Certificates

Threat 
Hunter

create filter to identify files for investigation* Filter Files

Threat 
Hunter

analyze files* Investigating Files

Threat 
Hunter

analyze events* Analyzing Events

Threat 
Hunter

download files for deeper analysis* Analyzing Downloaded Files

Threat 
Hunter

perform external lookups* Launch an External Lookup for 
a File

Threat 
Hunter

change file status or remediate* Changing File Status or 
Remediate
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*You can perform this task in the current view

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Downloaded Files

 l Analyzing Events

 l Analyze Certificates

 l Changing File Status or Remediate

Quick Look
Below is an example of the Files view:

1 Filter Files. You can filter the files by selecting the options in the Filters panel and create 
filters. For more information, see Filter Files.
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2 Actions in the toolbar:
Server drop-down list - You can select the Endpoint server or Endpoint Broker server to view 
the hosts.
View Certificates - Provides a list of code-signing certificates reported by hosts found in your 
deployment and their associated properties. For more information, see Analyze Certificates.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected files to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More - Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

 l Reset risk score.

Note: You can perform the above actions from the right-click context menu. 

 

3 Sort Columns. Lets you sort on column titles. 

4 Settings Menu. You can set Files view preferences by selecting columns from the Settings 
menu. For more information, see  Set Files Preference.

5 Show/Hide File Properties Panel. Click a row to show or hide the File Properties panel. It 
displays the following tabs:
File details - Displays the file information.
Risk details - Displays the distinct alerts associated with the risk score. 
Hosts - Displays the hosts on which file activities are present. For more information, see 
Analyze Hosts with File Activity.

6 Export to CSV - Extracts global files to a CSV file. For more information, see  Export Global 
Files.
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Hosts View
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Hosts view provides a list of all hosts with an Endpoint agent installed. To access this view, go to 
INVESTIGATE > Hosts. By default, hosts are sorted based on the risk score. 

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details* Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes* Investigating a Process

Threat Hunter review reported anomalies* Analyze Anomalies

Threat Hunter analyze risky users* Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Downloaded Files

 l Changing File Status or Remediate

 l Investigating a Process

 l Analyzing Events

Quick Look
Below is an example of the Hosts view:

1 Filter Hosts.You can filter the hosts by selecting the options in the Filters panel and create 
filters. For more information, see Filter Hosts.
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2 Actions in the toolbar:
Server drop-down list - You can select the Endpoint server or Endpoint Broker server to view 
the hosts.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
Start Scan - Starts a scan for the selected hosts.
Stop Scan - Stops a scan for the selected hosts. 
More - Provides options to:

 l Reset risk score.

 l Delete - Lets you delete hosts manually from the user interface. After deletion, the Endpoint 
server does not process any request from this host. For more information, see Delete a Host .

Note: You can perform the above actions from the right-click context menu. 

3 Sort Columns. Lets you sort on column titles. 

4 Export to CSV - Extracts host attributes  to a CSV file. For more information, see  Export Host 
Attributes.

5 Settings Menu. You can set Hosts view preferences by selecting columns from the Settings 
menu. For more information, see  Set Hosts Preference.

6 Show/Hide Host Properties Panel. Click a row to show or hide the Host Properties panel. It 
displays the following tabs:
Host details - Displays the host information such as Network Interfaces, operating system, 
hardware and others.
Risk details - Displays the distinct alerts associated with the risk score. 
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Hosts View - Details Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Details tab provides details of the selected host.  To access this view, go to INVESTIGATE > 
Hosts, and select a host from the Hosts view. 

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details* Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes* Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users* Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis Analyzing Downloaded Files

Threat Hunter perform external lookups Launch an External Lookup for a File

Threat Hunter change file status or remediate Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

Quick Look
Below is an example of  the Details tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping Scan. 
For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.

2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
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3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Show/Hide Right Panel - Displays host and policy details panel. 

5 Host Details Panel - Displays all properties of the selected host. It is grouped as follows: 
Groups - Groups on which the host is added on. 
User - Information related to the user.
Network Interfaces - Network adapter information, such as Mac Address, Gateway.
Operating System - Operating system version and build information.
Agent - Agent-related information, such as agent ID, driver error code, install time, and agent 
mode.
Hardware - Information related to the architecture.
Locale - Time zone and language that is local to the host.

6 Policy Details Panel - Displays the following:

 l EDR Policy Name that is associated with the highest ranked group.

 l Windows Log Policy Name.

 l Policy Status - 

 l Updated - Host has the latest policy.

 l Pending - Policy is resolved but the latest policy is not updated on the host. When the host 
communicates with the Endpoint server next time, the latest policy is applied if there are 
no errors.

 l Unavailable - Hosts that belong to previous versions, such as NetWitness Platform 11.1 or 
11.2, or the source server is not installed. 

 l Error - Problem applying the latest policy along with the error description.

 l Evaluated Time - Time when the Endpoint server evaluated the policy.

 l Relay Server. Displays the Relay Server details.

 o Server - Host name or IP address of the Relay Server.

 o Port - Port number.

 o HTTP Beacon Interval - HTTP beacon interval value in minutes.

 l Complete resolved policy settings. For more information, see the NetWitness Endpoint 
Configuration Guide.

7 Alerts Severity - Displays list of distinct alerts, such as Critical, High, Medium and All, along 
with the total number of events associated with the alert. 

8 Displays events for an alert and metadata associated with a specific event.
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Hosts View - Process Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Process panel provides a list of processes running on the host. To access this tab, select a host from 
the Hosts view and click the Process tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes* Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Investigating a Process

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Process tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.
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2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you select the snapshot 
time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Investigating Hosts.
Analyze Process - Lets you perform process analysis to investigate a particular process 
behavior, and understand the entire process event chain, process parent-child relationships, and 
all associated events. For more information, see Investigating a Process.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Toggle. Lets you toggle between List view and Tree view.

5 Process panel - Displays process information, such as process name, local risk score, global 
risk score, active on, reputation status, file status, and others.

6 Show/Hide Right Panel - Displays the following properties of a process in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

Process - Details of the process, such as image size and PID.

Image - Image details loaded by the process.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.
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Process Details
Clicking the process name displays the process details of a specific process as shown in the following 
figure:

Field Description

Process 
Name

Name of the process. For example, server.exe.

PID ID of the process. For example, 492.

Path Path of the file associated with the process on the disk. For example, 
C:\Windows\System32.

Launch 
Arguments 

Command line arguments passed to the process when it is launched. For example, -k 
LocalServiceNoNetwork.

 l List of  loaded libraries for the selected process, such as DLLs (for Windows), Dylibs (for Mac), or 
.SO (for Linux).

 l List of autoruns (if configured).

 l List of image hooks and suspicious threads (for Windows).
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Hosts View - Autoruns Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Autoruns panel provides a list of autoruns, services, tasks, and cron jobs running on the host. To 
access this tab, select a host from the Hosts view and click the Autoruns tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Autoruns tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.
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2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Details Panel - Displays the following tabs:

 l Autoruns - Files that are executed at start-up.

 l Services - Files that are running as a service for the selected host.

 l Tasks/Cron jobs - Files that are configured to run as scheduled tasks along with the trigger.

5 Show/Hide Right Panel - Displays the following properties in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

Autoruns/Services/Tasks - Details related to autrouns, services, or tasks.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.

6 Clicking a filename lets you navigate to the Files view for further analysis. 
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Hosts View - Files Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Files tab displays all files scanned on the host. To access this tab, select a host from the Hosts view 
and click the Files tab. By default, it displays 100 files. To display more files, click Load More at the 
bottom of the page.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Files tab:
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1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.

2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Details Panel - Displays information, such as filename, local risk score, global risk score, 
active on, reputation status, file status, and others.
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5 Show/Hide Right Panel - Displays the following properties in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.

6 Clicking a filename lets you navigate to the Files view for further analysis. 
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Hosts View - Drivers Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Drivers tab lists the drivers running on the hosts at the time of scan. To access this tab, select a host 
from the Hosts view and click the Drivers tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Drivers tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.
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2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Details Panel - Displays information, such as filename, local risk score, global risk score, 
active on, reputation status, file status, and others.

5 Show/Hide Right Panel - Displays the following properties in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

Image - Loaded image.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.

6 Clicking a filename lets you navigate to the Files view for further analysis. 
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Hosts View - Libraries Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The Libraries tab lists the libraries loaded at the time of scan. To access this tab, select a host from the 
Hosts view and click the Libraries tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Libraries tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.
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2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Details Panel - Displays information, such as process context, filename, local risk score, global 
risk score, active on, reputation status, file status, and others.

5 Show/Hide Right Panel - Displays the following properties in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

Process - Details of the process, such as image size and PID.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.

6 Clicking a filename lets you navigate to the Files view for further analysis. 
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Hosts View - Anomalies Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.3 and later.

The Anomalies panel provides a list of image hooks, suspicious threads, kernel hooks, and registry 
discrepancies running on the host. To access this tab, select a host from the Hosts view and click the 
Anomalies tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score* Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies* Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events* Analyzing Events

Threat Hunter download files for deeper analysis* Analyzing Downloaded Files

Threat Hunter perform external lookups* Launch an External Lookup for a File

Threat Hunter change file status or remediate* Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

 l Analyzing Events

 l Changing File Status or Remediate

 l Analyzing Downloaded Files

Quick Look
Below is an example of the Anomalies tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.
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2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.
Change File Status - Provides capabilities to manage suspect and legitimate files and  block 
malicious or infected file to prevent future execution of the file on any host. For more 
information, see Changing File Status or Remediate.
Analyze Events - Lets you investigate a particular host, IP address, username, filename, or 
hash to get the entire context of the activity. For more information, see Analyzing Events.
More -  Provides options to:

 l Perform external lookups.

 l Download files to server, save a local copy, and analyze files for deeper analysis.

Note: You can perform some of the above actions from the right-click context menu. 

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 Details Panel - Displays the following tabs:

 l Image Hooks

 l Kernel Hooks 

 l Suspicious Threads 

 l Registry Discrepancies

5 Show/Hide Right Panel - Displays the following properties in the right panel:
 l File Details - Displays all properties of the selected process. It is grouped as follows: 

General - General information about the file, such as file name, entropy, size, and format.

Signature - Provides signatory information.

Hash - Hash type of the file (MD5, SHA1, and SHA256).

Time - Time when the file was created, modified, or accessed.

Location - Location of the file.

Image Hooks/Kernel Hooks/Suspicious Threads/Registry Discrepancies - Details related 
to image hooks, kernel hooks, suspicious threads, or registry discrepancies.

 l Local Risk Details - Displays the alerts associated with the local risk score, such as Critical, 
High, Medium and All.

6 Clicking a filename lets you navigate to the Files view for further analysis. 
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Image Hooks
Image hooks found in executable image are displayed in the following columns.

Columns Description

Type Type of the hook . Possible values are - inline, iat, eat, or exception Handler.

Local Risk 
Score

Risk score of suspicious or malicious activities performed by the file on a specific 
host.

Global Risk 
Score

Aggregated score of all suspicious and malicious activities performed by the file 
across all hosts.

Reputation Reputation of a file hash. The statuses are - Malicious, Suspicious, Unknown, Known, 
Known Good, and Invalid.

Signature Provides signatory information.

Downloaded Indicates the status of the downloaded file - Downloaded, Not Downloaded, and Error.

Hooked 
Process

Process in which hooks are placed.

Hooked 
Filename

Name of the file that was modified by the hook.

Hooked 
Symbol

Symbol in which the hook is performed.

Kernel Hooks
Hooks found on kernel objects are displayed in the following columns.

Category Description

Type Type of kernel object which was modified. Possible values are:  
objectInitializer,basicObjectPointer, majorFunction, invalidObject, fastIO, 
notifyRoutine, attachedDevice, device, miniPort, sdt, sysEnter, or type.idt.

Driver name Name of the driver which placed the hooks.

Local Risk 
Score

Risk score of suspicious or malicious activities performed by the file on a specific host.

Global Risk 
Score

Aggregated score of all suspicious and malicious activities performed by the file across 
all hosts.

Reputation Reputation of a file hash. The statuses are - Malicious, Suspicious, Unknown, Known, 
Known Good, and Invalid.

Signature Provides signatory information.
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Category Description

Downloaded Indicates the status of the downloaded file - Downloaded, Not Downloaded, and Error.

Object 
Function

Name of the object function hooked into.

Hooked File 
Name

Name of the file that was modified by the hook.

Suspicious Threads
Threads whose service table was hooked are displayed in the following columns.

Category Description

Start Address Start Address - Start address of the thread.

DLL Name Name of the DLL.

Local Risk Score Risk score of suspicious or malicious activities performed by the file on a 
specific host.

Global Risk Score Aggregated score of all suspicious and malicious activities performed by the file 
across all hosts.

Reputation Reputation of a file hash. The statuses are - Malicious, Suspicious, Unknown, 
Known, Known Good, and Invalid.

Process File name and PID of the process in which thread is running.

Downloaded Indicates the status of the downloaded file - Downloaded, Not Downloaded, and 
Error.

Signature Provides signatory information.

Thread ID ID of the running thread.

Thread 
Environment 
Block

Address of the thread environment block.

Registry Discrepancies
Configuration settings and options on Microsoft Windows operating systems that are stored are displayed 
in the following columns.

Category Description

Hive Name of the registry hive when possible, otherwise it displays the hive ID. Possible 
values are: hkeyClassesRoot, hkeyCurrentUser, hkeyLocalMachine, 
hkeyUsers, or hkeyPerformanceData.
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Category Description

Reason Type of registry discrepancy. Possible values are: notFound, embeddedNull, 
accessDenied, parentIsHidden, or dataMismatch.

Registry 
Path

Registry path that is affected. The value is separated by a @ character.

Raw Type Value type found in the low-level parsing.

Raw Data Value data extracted from the low-level parsing.

API Type Value type from the Win32 registry API.

API Data Value data from the Win32 registry API.
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Hosts View - System Information Tab
Note: The information in this topic applies to RSA NetWitness® Platform Version 11.1 and later.

The System Information tab lists the agent system information. To access this tab, select a host from the 
Hosts view and click the System Information tab.

Workflow

What do you want to do?

User Role I want to ... Show me how

Threat Hunter review hosts with highest risk score Analyze Hosts Using the Risk Score

Threat Hunter analyze hosts* Investigating Hosts

Threat Hunter perform adhoc scan* Scan Hosts

Threat Hunter review host details Analyze Host Details

Threat Hunter search on snapshot* Search on Snapshots

Threat Hunter analyze processes Investigating a Process

Threat Hunter review reported anomalies Analyze Anomalies

Threat Hunter analyze risky users Analyzing Risky Users

Threat Hunter analyze events Analyzing Events

Threat Hunter download files for deeper analysis Analyzing Downloaded Files

Threat Hunter perform external lookups Launch an External Lookup for a File

Threat Hunter change file status or remediate Changing File Status or Remediate
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*You can perform this task in the current view.

Related Topics
 l Focusing on Endpoint Analysis

 l Investigating Hosts

Quick Look
Below is an example of the System Information tab:

1 Agent and Scan Details. You can view the following agent and scan details of the selected 
host:
Host name - Name of the host. For example, WIN-ABC.
Risk score - Risk score of the host.
Operating System - Operating system on which the agent is running (Linux, Windows, or 
Mac).
Agent Scan Status - Current status of the scan - Idle, Scanning, Starting Scan, or Stopping 
Scan. For more information, see Scan Hosts.

Agent Last Seen - Time when the agent last communicated with the Endpoint server.  
indicates time when the roaming agent last communicated with the Endpoint server.
Agent Version - Version of the agent. For example, 11.3.0.0.

2 Actions in the toolbar:
Snapshot Time - Lists scanned time stamps. To view the scan history, you can select the 
snapshot time from the drop-down menu.  
Start Scan - Starts a scan for the selected hosts. For more information, see Scan Hosts.
Export to JSON - Extracts host attributes and endpoint data to a JSON file of the selected 
snapshot. For more information, see Export Host Attributes.

3 Search on Snapshots. Lets you search on all snapshots (file name, file path, and SHA-256 
checksum). For more information, see Search on Snapshots.

4 System Information Panel - See System Information Panel.

System Information Panel
The System Information panel displays the following tabs:
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Tabs Description

Host File 
Entries

All network redirections written in the host file. For example, IP Address - 
10.10.10.3 and DNS Name - 
localhost,localhost.localdomain,localhost4,localhost4.localdomain
4

Network 
Shares

Network name of the shared resource (for Windows only). For example, Name - 
Admin$, Description - Remote Admin, Path - C:\, Permissions - None, Type - disk, 
special, Max Users - 4294967295, Current Users - 0.

Security 
Products

Installed security products (for Windows only). For example, Display Name - 
Windows Defender, Instance - D68DDC3A-831F-4FAE-9E44-DA132C1ACF46, 
Features - Enabled, Type - antiVirus.

Windows 
Patches

List of patches applied by Windows update (for Windows only). For example, 
KB2959936.

Security 
Configuratio
n

Security configuration details on the host. For example,  firewall disabled or enabled, 
smart screen filter disabled or enabled. This field is only applicable for Windows and 
Mac.
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