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About Log Collection

This guide describes the high-level steps and subtasks for setting up and configuring log collection for
event sources that include:

What Log Collection does, how it works from a high level, and provides high-level deployment
diagrams.

How to start collecting events.

Where to find instructions to set up more complex deployments.

How to start any collection protocol.

Which tools to use to troubleshoot Log Collection issues and lists global troubleshooting instructions.

How to fine tune and customize Log Collection in your environment.

How to configure individual collection protocols. Instructions are in the individual Log Collection
sections.

Workflow

This workflow depicts the basic tasks needed to start collecting events through Log Collectors.

Configure Collection Verify that Log
Set Up Lock Box . Protocols and Event Collection is
Services .
Sources Working

Perform Basic Start Collection

Implementation

Configure the following Colletion
Protocols and Event Sources

AWS (Cloud Trail)

Azure

Check Point

File

Log Stash

Netflow

ODBC

SDEE

SNMP

Syslog

Vmware

Windows

Windows Legacy and NetApp

High-Level Procedures

At a high level, these are the procedures you must follow for log collection:

About Log Collection
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II.

III.

Iv.

VL

Add local and remote collectors to NetWitness.

Set up a Log Collector locally on a Log Decoder (that is a Local Collector). You can also set up Log
Collectors in as many remote locations (that is Remote Collectors) as you need for your enterprise.
For details, see Basic Implementation.

Download the latest content from NetWitness Live. You must perform this task periodically, as the
content provided on NetWitness Live is updated regularly.

Log Collection content is marked as one of the following resource types:

¢ NetWitness Log Collector - content enabling the collection of event source types.

¢ NetWitness Log Device - the latest supported event source parsers.

You can also subscribe to content on Live. For details, see the Live Services Management Guide.
Configure Settings: set up the lockbox and Certificates.

For details, see Set Up a Lockbox and Configure Certificates.

Configure Event Sources.

You configure all the event sources on your network to send their log information to NetWitness.
Whenever you add new event sources, you need to perform this procedure as well. All event source
configuration guides are found in the NetWitness Supported Event Sources space in

NetWitness Link.

Start and stop services for configured protocols. Occasionally, you may be required to stop and
restart services, based on new event sources that you add to NetWitness.
Verify that Log Collection is working.

Whenever you set up a new event source or add a new collection protocol, you should verify that the
correct logs are being sent to NetWitness.

About Log Collection 10
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Log Collection Architecture

This topic describes how NetWitness performs log collection.

How to Deploy Log Collection
You can deploy Log Collection according to needs and preferences of your enterprise. This includes

deploying Log Collection across multiple locations and collecting data from varying sets of event
sources. You do this by setting up a Local Collector with one or many Remote Collectors.

Components of Log Collection

The following figure shows all the components involved in event collection through the NetWitness Log
Collector.
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logstash \ per p: / — Audit, etc.)
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event source \
VMware
event sources T OPSEC LEA
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Syslog

/ http or https
/ Check Point
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ftp (TCP22
ESX Server SNMP SDEE b ETCPZZ; (TcsPll :IDP
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SNMP File -
event sources event sources
SDEE log file

i
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log file log file
- E
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sources

—
=

*In Log Collection, Remote Collectors send events to the Local Collector and the Local Collector sends events to the Log Decoder.
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Local and Remote Collectors

In this scenario, log collection from various protocols like Windows, ODBC, and so on, is performed
through both the Remote Collector and Log Collector service. If the log collection is done by the Local
Collector, it is forwarded to the Log Decoder service, just like the local deployment scenario. If the log
collection is done by a Remote Collector, there are two methods in which these are transferred to the
Local Collector:

e Pull Configuration - From a Local Collector, you select the Remote Collectors from which you want

to pull events.

¢ Push Configuration - From a Remote Collector, you select the Local Collector to which you want to
push events.

Note: Typically, the Push configuration is used. Pull is available if you have a DMZ in your
environment. Less secure network segments are not allowed to make connections to more secure
network segments. With Pull, the Log Collector (or Virtual Log Collector) in the secure network
initiates the connection to the VLC in the less secure network, and the logs are then transferred without
breaking the connection rules.

You can configure one or more Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from one or more Remote Collectors.

Additionally, you can set up a chain of Remote Collectors for which you can configure:
¢ One or more Remote Collectors to push event data to a Remote Collector.

e A Remote Collector to pull event data from one or more Remote Collectors.

The following figure illustrates how the Local and Remote Collectors interact to collect events from all
of your locations.

Log Collection Architecture 12
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Pull Configuration:
LC Pulls Event Data frem RC |~ 7

I Push C ion:
! 'RC Pushes Event Datato LC

[Pull Configuration: :
Parent RC Pulls Event
Data from RC :

EPush Configuration:
{RC Pushes Event
to Parent RC

/" Remote Collector (RC})
Log Collector
Service on
Virtual Machine

Remote Collector (RC)
Log Collector
Service on
Virtual Machine

* The Lecal Collectar (LC) is the Log Collector service on the Log Decoder appliance.

Windows Legacy Remote Collector

The NetWitness Windows Legacy Collector is a Microsoft Windows based remote log collector (RC)
which can be installed on a Windows domain.

It supports collection from:

® Windows 2003 and earlier event sources

B NetApp ONTAP host evt files

The following figure illustrates the deployment required to collect events from Windows Legacy event
sources.

13 Log Collection Architecture



Log Collection Architecture

Domain 1
Event Sources

Event Source Domains

Log Collection Configuration Guide

=]

Windows 2003

Domain2

Event Sources
F
NetApp Cntap i

or earfer Windows 2003 "NetApp Ontap
or earler
— ".\‘ ~ -
R - — r’
)Y Domain n

Event Sources ‘
@ \\ |

Windews 2003 AN
ar earler ¥

Log Collectar

on Log Decoder

]

p
£

MNetApp Ontap

Remote Legacy
Windows Collector
on 64-Bit
Windows Server

».k\\
\
\\
\\.
b
A\

14



Basic Implementation

This topic tells how to perform the initial setup of Local Collectors and Remote Collectors.

Prerequisites

Verify that the Log Decoder is set up and:
* is capturing data.
* has the current content loaded.

* is properly licensed.

Roles of Local and Remote Collectors

A Local Collector (LC) is a Log Collector service running on a Log Decoder host. In a local deployment
scenario, the Log Collector service is deployed on a Log Decoder host, with the Log Decoder service.
Log collection from various protocols like Windows, ODBC, and so on, is performed through the Log
Collector service, and events are forwarded to the Log Decoder service. The Local Collector sends all
collected event data to the Log Decoder service.

You must have at least one Local Collector to collect non-Syslog events.

A Remote Collector (RC), also referred to as a Virtual Log Collector (VLC), is a Log Collector service
running on a stand-alone Virtual Machine. Remote Collectors are optional and they must send the events
they collect to a Local Collector. Remote Collector deployment is ideal when you have to collect logs
from remote locations. Remote Collectors compress and encrypt the logs before sending them to a Local
Collector.

Deploying and Configuring Log Collection

The following diagram illustrates the basic tasks you must complete to deploy and configure Log
Collection. To deploy Log Collection, you need to set up a Local Collector. You can also deploy one or
more Remote Collectors. After you deploy Log Collection, you need to configure the events sources in
NetWitness and on the events sources themselves. The following diagram shows the Local Collector
with one Remote Collector that pushes events to the Local Collector.

15 Basic Implementation
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_.-A
6y Local Collector (LC)*

]

Local Deployment

Remote Locations

—_____ Push Configuration: RC
Pushes Event Data to LC

Remote Collector (RC)
Log Collector
Service on
Virtual Machine

*The Local Collector (LC) is the Log Collector service on the Log Decoder appliance.

Set up Local and Remote Collectors.

The Local Collector is the Log Collector service running on the Log Decoder host.

A Remote Collector is the Log Collector service running on a virtual machine or Windows server in a

remote location.

Collection Protocols

Event Sources

Configure event sources:

e Configure collection protocols

» Configure each event source to communicate with the NetWitness Log Collector.

For details on these procedures, see Configure Collection Protocols and Event Sources.

Basic Implementation
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Adding Local Collector and Remote Collector to NetWitness

To add a Local Collector and Remote Collector to NetWitness:
D
1. Goto (Admin) > Services.

2. Click + and select Log Collector from the menu.
The Add Service dialog box is displayed.
3. Define the details of the Log Collection service.

4. Select Test Connection to ensure that your Local or Remote Collector is added.

Configuring Log Collection

You choose the Log Collector—that is a Local Collector (LC) or Remote Collector (RC)—for which you
want to define parameters in the Services view. The following figure shows how to navigate to the
Services view, select a Log Collector service, and display the configuration parameter interface for that
service.

To configure log collection:

A
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Click ¥ ~ View > Config to display the Log Collection configuration parameter tabs.
4. Define global Log Collection parameters in the General tab.

5. The UI presents tabs, depending on whether the current service is Local or Remote.

¢ For a Local Collector, NetWitness displays the Remote Collectors tab. Select the Remote
Collectors from which the Local Collector pulls events in this tab.

¢ For a Remote Collector, NetWitness displays the Local Collectors. Select the Local Collectors to
which the Remote Collector pushes events in this tab.

Edit configuration files as text files in the Files tab.
Define collection protocol parameters in the Event Sources tab.

Define the lockbox, encryption keys, and certificates in the Settings tab.

A e )

Define Appliance Service parameters in the Appliance Service Configuration tab.

17 Basic Implementation
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Data Flow Diagram

You use the log data collected by the Log Collector service to monitor the health of your enterprise and

to conduct investigations. The following figure shows you how data flows through NetWitness Log
Collection to Investigation.
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Provision Local Collectors and Remote Collectors

The NetWitness server verifies if an appliance has a Log Decoder service. If there is a Log Decoder
service, it becomes a Local Collector. If a Log Decoder service is missing, it becomes a Remote
Collector. A local Log Collector has an Event Destination and by default goes to the Local Log Decoder
service. A Remote Collector does not have an Event Destination. The NetWitness Server identifies

a Legacy Windows Collector as a Remote Collector.

To edit a Local Collector or Remote Collector:

QA
1. Goto (Admin) > Services.

2. Select a Log Collector service.

3. In the Services view, select lﬁ in the toolbar.

The Edit Service dialog is displayed.

Edit Service

Service Log Decoder

Host NWAPPLIANCEZ7T
Name NWAPPLIANCE277 - Log

Connection Details

Port 56002

551 [+

Username

Password

Test Connection

Cancel

4. In the Edit Service dialog, provide the following information.

o Jomemn

Service Select Log Collector as the service type.
Host Select a Log Decoder host.
Name Type name you want to assign to the service.

19 Basic Implementation



Log Collection Configuration Guide

e e

Port Default port is 50001 for clear text and 56001 for SSL encrypted.

SSL Select SSL if you want NetWitness to communicate with the host using
SSL. The security of data transmission is managed by encrypting
information and providing authentication with SSL certificates.

(Optional) Username  Type the username of the Local Collector.
(Optional) Password ~ Type the password of the Local Collector.

5. Click Test Connection to determine if NetWitness connects to the service.
6. When the result is successful, click Save.

If the test is unsuccessful, edit the service information and retry.

Configure Local and Remote Collectors

This topic describes how to configure Local and Remote Collectors.

When you deploy Log Collection, you must configure the Log Collectors to collect the log events from
various event sources, and to deliver these events reliably and securely to the Log Decoder service,
where the events are parsed and stored for subsequent analysis.

You can configure one or more Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from one or more Remote Collectors.

This topic describes how to:
o Configure Local Collector to Pull Events from Remote Collector

If you want a Local Collector to pull events from Remote Collector, you set this up in the Remote
Collectors tab of the Local Collector's Configuration view.

o Configure Remote Collector to Push Events to Local Collectors

If you want a Remote Collector to push events to a Local Collector, you set this up in the Local
Collector tab of the Remote Collector's Configuration view. In the Push configuration, you can also:

o Configure Failover Local Collector for Remote Collector

You set up a destination made up of local collectors. When the primary Local Collector is
unreachable, the Remote Collector attempts to connect to each Local Collector in this destination
until it makes a successful connection.

o Configure Replication

You set up multiple destination groups so that NetWitness replicates the event data in each group.
If the connection to one of the destination groups fails, you can recover the required data because it
is replicated in the other destination group.

o Configure Log Routing for Specific Protocols

You set up multiple destinations in a destination group to direct event data to specific locations
according to protocol type.

o Configure Chain of Remote Collectors

Basic Implementation 20
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You can set up a chain of Remote Collectors to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from a chain of Remote Collectors.

* You can configure one or more Remote Collectors to push event data to a Remote Collector.

* You can configure a Remote Collector to pull event data from one or more Remote Collectors.

Failover, Replication and Load Balancing

This section describes failover, replication, and load balancing work in how NetWitness.

The following figure illustrates a Remote Collector configured for load balancing, failover
and replication.

Destination 1 Destination 2

{RC-TD.101.214.8H RC-10.101.214.9 J RC-10.101.214.105

Primary Failover

Failover Scenario

Load Balancing Scenario

RC-10.101.214.7 | Replication Scenario

Destination 3

RC-10.101.214.106

Primary

Group 2

Failover is achieved by setting up multiple collectors in the same Destination. Destination 1 has a

primary Collector, and second, failover Collector. This is done in NetWitness by adding multiple Log
Collectors to the same Destination.

21
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Destination Name *  Destination1

Group Name Group'

Collections Windows Legacy v
Log Collectors Addresses

SR =y

L Name*

0 10.101.2148

O 10.101.2149

Cancel OK

Since 10.101.214.8 is listed first, that becomes the primary collector, and 10.101.214.9 becomes the
failover. To make 10.101.214.9 the primary, use the up arrow to change the order.

Below, you can see the two collectors both listed for Destination 1. The primary (10.101.214.8) is in
bold.

General Local Collectors Files Event Sources Settings
Select . G
Configuration: B uktions
Destination Groups Destination Collectors
+ - +
™ Name ~ [ Destination Name ~ Address Collections
¥ Group1 O Destination1 10.101.214.8, 10.101.214.9 windowslegacy

o Replication is accomplished by having multiple Destination Groups: each group receive the entire set
of message data.

RC-10.101.214.7

Group 2

In the following screen, you can see that message data is sent to the collectors in Group 1 and Group
2.

Basic Implementation 22
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Local Collectors Files Event Sources Settings

Select : Destinations bl
Configuration:

Destination Groups Destination Collectors

+ - -
Name ~ ] Destination Name ~ Address Collections

[0 Group1 O Destination3 10.101.214.106 windowslegacy

™  Group2

o Load balancing is achieved by setting up multiple Destinations within a Group.

Destination 1 Destination 2

RC-10.101.214.8 RC-10.101.214.9 RC-10.101.214.105

Primary Failover

Failover Scenario

Load Balancing Scenario

Group 1

In the following screen, you can see that Group 1 has two destinations, Destination 1 and Destination
2. The message data is divided up equally among the Destinations in the group.

Local Collectors Files Event Sources Settings

Select : Destinations b
Configuration:

Destination Groups Destination Collectors

+ - +

4 Name ~ Destination Name ~ Address Collections

¥ Group1 O Destination 10.101.214.8, 10.101.214.9 windowslegacy
O Destination2 10.101.214.105 windowslegacy

With two Destinations, each destination receives half the message data. With three Destinations, each
would receive 1/3 of the total message data. Keep adding Destinations to further reduce the load on

the collectors in each destination.
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Note: You can also set up log routing so that event data for specific protocols is sent to specific
destinations.

Configure a Local Collector or Remote Collector

You choose the Log Collector, that is a Local Collector (LC) or Remote Collector (RC), for which you
want to define deployment parameters in the Services view. The following procedure shows you how to
navigate to the Services view, select a Local or Remote Collector, and display the deployment
parameter interface for that service.

To configure a Local Collector or Remote Collector:

QA
1. Goto (Admin) > Services.
2. Select a Local or Remote Log Collection service.

3. Under Actions, select ﬁ' © > View > Config to display the Log Collection configuration
parameter tabs.

4. Depending on your selection in step 2:

e Ifyou selected a Local Collector, the Remote Collectors tab is displayed. Select the Remote
Collectors from which the Local Collector pulls events in this tab.

¢ If you selected a Remote Collector, the Local Collectors are displayed. Select the Local
Collectors to which the Remote Collector pushes events in this tab.

Remote Collectors Tab

The following figure depicts the Remote Collectors tab for a Local Collector that is configured to pull
events from a Remote Collector. NetWitness displays this tab when you have selected a Local Collector

QA
in (Admin) > Services.

- Change Service [l - Log Collector | Config &

General Remote Collectors Files Event Sources  Event Destinations ~ Settings  Appliance Service Configuration

Remote Collector
+

O Name ~ Group Mame Address

| Page of 0 | |

Local Collectors Tab for a Remote Collector

The following figure depicts a Local Collectors tab for a Remote Collector that is configured to push
events to a Local Collector or another Remote Collector.
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%, Change Service | D Log Collector | Config

General Local Collectors Files Event Sources Settings Appliance Service Configuration

Select
Configuration:

Destinations v
Destination EFOLDS
+

' Name =~

The following figure depicts the Local Collectors tab for a Remote Collector that is configured to pull
events from a Remote Collector. NetWitness displays this tab when you have selected a Remote

Q
Collector in (Admin) > Services.

%, Change Service | -LogCollector | Config ©

General Local Collectors Files Event Sources Settings  Appliance Service Configuration

Select

Sources ~
Configuration: |

- Sources

Remote Collector
+

O Name ~ Group Name Address

| Page of 0 | | C

Parameters

Remote/Local Collectors Configuration Parameters

Configure Failover Local Collector

This topic tells you how to set up a Failover Local or Remote Collector.

Set up a Failover Local Collector

You can set up a Failover Local Collector that NetWitness will fail over to if your primary Local
Collector stops operating for any reason.
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Q
. Goto (Admin) > Services.

In Services, select a Remote Collector service.

Click ¥ * View > Config.

The Service Config view is displayed with the Log Collector General tab open.
Select the Local Collectors tab.

In the Destination Groups panel section, select + .

The Add Remote Destination dialog displays.

Set up a Destination Group and select a primary Local Collector (for example, LC-PRIMARY).

Select the Group (for example, Primary_Standby_LCs) in the Destination Groups panel and click
L4

| Ml
The Group you selected is displayed in the Local Collectors panel.
Add the Failover Local Collector (for example, LC-STANDBY).

The following examples show the newly added primary and failover Local Collectors showing the
primary Local Collector as Active and the Failover Local Collector as Standby. The active Local
Collector is highlighted (for example, LC-PRIMARY).

(Optional) Add, delete, and change the order of Local Collectors to each Remote Destination.

a. Click + to add a Log Collector as a failover Remote Destination.

b. When connecting to a Remote Destination, the Remote Collector will attempt to connect to each
Local Collector in this list in order, until it makes a successful connection.

c. Select a Local Collector and use the up ( L) ) and down ("’ ) arrow buttons to change the order
of connection.

d. Select one or more Local Collectors and click - to remove them from the list.

The selected Local Collectors are added to the Log Collector section. When the Remote Collector
starts collecting data, it pushes data to these Log Collectors.

Set up a Failover Remote Collector

You can set up a Failover Remote Collector that NetWitness will fail over to if your primary Remote
Collector stops operating for any reason.

To set up a failover remote collector:

1.
2.

QA
Go to (Admin) > Services.
In Services, select a Remote Collector service.

Click ¥ * View > Config.
The Service Config view is displayed with the Log Collector General tab open.
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Select the Local Collectors tab.

Select Sources in Select Configuration drop-down menu.

Click + to display in Add Source dialog.
Define the failover Remote Collector and click OK.

Parameters

Remote/Local Collectors Configuration Parameters

Configure Replication

This topic tells you how to replicate event data sent by a Remote Collector.

You can specify multiple Destination Groups so that the event data is replicated to each group.

To replicate event data to multiple Local Collectors:

1.

Q4
Go to (Admin) > Services.

2. Select a Remote Log Collection service.
3. Under Actions, select ﬁ “ > View > Conlfig.
The Service Config view is displayed with the Log Collector General tab open.
4. Select the Local Collectors tab.
5. In the Destination Groups panel section, click +
The Add Remote Destination dialog is displayed.
Add Remote Destination
Destination Mame * Destination
Group Name DestinationGroup
Collections Check Point, File, Metflow, ODBC, SDEE, SNMF ~
Log Collectors Addresses
+ - 1+ 4
Mame *
M LCi
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6. Set up a separate Destination for each Local Collector and designate the protocols for which you
want to push event messages to that Local Collector. The following examples shows the addition of
two Destination Local Collectors (Destinationl and Destination2) for the Check Point, File,
Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection protocols:

Add Remote Destination Add Remote Destination

Destination Name * Destination1

Group Name DestinationGroup1

Collections Check Point, File, Netflow, ODBC, 5DEE, SNMF v

Log Collectors Addresses
+ -1 4
Name *

™ LC1

LY

Destination Name * Destination2

Group Name |Destinati0nGroup2|

Cuollections Check Point, File, Netflow, ODBC, SDEE, SNMF v

Log Collectors Addresses
+ -1
[ mame =

M Lc2

+ Change Service | 199 | Config =

General Local Collectors Files Event Sources Settings
Sel <

elect . Destinations ¥ s
Configuration: o

Destination Groups ,D'esfination Collectors

+ - A *
- o : :
! Name ~ - < Destination Name = Address
ra
[ DestlnatlonGrour_ﬂ)/ ' Destination
DestinationGroup2 )
| Page 1 oft | | Page 1 | of1 |

4 sdmin | €9 English (United States) GMT=00:00

Appliance Service Configuration

Collections

checkpoint file netflow odbc sdee snmptrap syslog vmware windows

Items 1-10f1

Send Us Feedback | 10.5.0.0.15688-1

a. Type the Destination Name.
b.
Group Name.
c. Select the collection protocols in the drop-down list.
d. Select a Local Collector (for example, LC1).
e. Click OK.
f.

Select the new group (for example, DestinationGroup2) group in the Destination Groups

panel and click + in the Local Collector panel.

Type the Group Name. If you do not type a Group Name, the Destination Name is taken as the

Basic Implementation
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g. In the Local Collector panel, click + and complete the Add Remote Destination dialog as
illustrated in the following figure.

Add Remote Destination

Desztination Mame * Destination2

Group Mame |DE5tinatiDnGrDup2| |

Collections Check Point, File, Metflow, ODBC, SDEE, SMMF ~

Log Collectors Addresses

+ -+ 4
Name *
M LCz

The Check Point, File, Netflow, ODBC, SDEE, SNMP, Syslog, and Windows collection protocols are
sent to two Local Collectors (LC1 and L.C2). Both Local Collectors are active and collecting event data.

g Change Service | riC199 | anfig

Local Collectors Files EventSources  Settings  Appliance Service Configuration

Select

= . Destinations v
Configuration:

Destination Groups Destination Collectors
+ - +
Name ~ Destination Name ~ Address Collections

¥ DestinatlonGroup1 Destination? 1 checkpoint file netflow odbc sdee snmptrap syslog vmware windows

DestinationGroupl

| Page 1 | of1 | | Page 1 | of1 | | C Items 1-1of 1
____________________________________________________________________________________________________________|

Configure Chain of Remote Collectors

This topic describes how to chain Remote Collectors (also referred to as VLCs).

You can set up a chain of Remote Collectors to push event data to a Remote Collector, or you can
configure a Remote Collector to pull event data from a chain of Remote Collectors.

* Remote Collectors to push data. Push data from a Remote Collector to other Remote Collectors or
Local Collectors.

e Remote Collector to pull data. Use a Remote Collector to pull data from one or more Remote
Collectors.
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Configure Remote Collector to Push Event Data to Remote Collector

Q
1. Goto (Admin) > Services.

2. In Services, select a Remote Collector.

3. Under Actions, select ﬁ' “ > View > Config to display the Log Collection configuration
parameter tabs.

The Log Collector Service Config view is displayed with the Log Collector General tab open.
4. Select the Local Collectors tab.

5. Select Destinations in the Select Configurations drop-down menu.

6. In the Destination Groups panel section, select + .
The Add Remote Destination dialog is displayed.

7. Set up a Destination Group:
a. Enter a Destination Name.

b. (Optional) Enter a Group Name. If you leave Group Name blank, NetWitness sets it to the
value that you specified in Destination Name.

c. Select one or more collection protocols in the Collections drop-down list.

d. Under Log Collectors Addresses, click + to select a Remote Collector.

Add Remote Destination

Destination Name * Branch1
Group Name BranchOffices
Collections Windows b

Log Collectors Addresses

+ -1y
™| Name*
| - Log Collector v

Cancel OK

Note: If you do not select a collection protocol, the Remote Collector pushes all collection
protocols to the Remote Collectors.

Configure Remote Collector to Pull Event Data from a Remote

Collector

QA
1. Goto (Admin) > Services.

2. In Services, select a Remote Collector.
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3. Under Actions, select ﬁ ~ > View > Conlfig to display the Log Collection configuration
parameter tabs.

The Service Config view is displayed with the Log Collector General tab open.
4. Select the Local Collectors tab.

5. Select Sources in the Select Configurations drop-down menu.

& Change Service | -LogCollector | Config &
Local Collectors Files Event Sources Settings Appliance Service Configuration

Select -
Configuration: |Sources

Sources
Remote Collector
+
O Name ~ Group Name Address

| Page of 0 | | C

_______________________________________________________________________________________________________________________________|
6. In the Remote Collectors panel, select .

The Add Source dialog is displayed.
7. In the Add Source dialog:

a. Select one or more collection protocols.

If you do not select a collection protocol, the Remote Collector pulls all collection protocols from
the Remote Collector.

b. Click OK.

The Remote Collector is added to the Remote Collector section. When the Log Collector starts
collecting data, it pulls event data from this Remote Collector.

Throttle Remote Collector to Local Collector Bandwidth

To improve performance, you can throttle the bandwidth to control the rate that the Remote Collector
sends event data to Local Collector or between Message Brokers. To do this, you configure the Linux
kernel's filtering and IPTable functionality.

This works for both push and pull Remote Collector configurations. The set-shovel-transfer-limit.sh
shell script located on the /opt/netwitness/bin automates the configuration of the kernel filter and
iptables related to this port.

This topic describes how to throttle Remote Collector to Local Collector bandwidth using the set-shovel-
transfer-limit.sh shell script. It contains the following sections:

31 Basic Implementation



Log Collection Configuration Guide

o The set-shovel-transfer-limit.sh shell script command line help.

Note: The filter value that you need to set depends on the rate at which remote log collector is
sending events to the Local Collector.

* An example that sets the Filter to 4096 kilobits per second.

Command Line Help for Set Shovel Transfer Limit Script

Issue the -h command to display help for set-shovel-transfer-limit.sh shell script.

cd /opt/netwitness/bin
./set-shovel-transfer-limit.sh

Usage:

set-shovel-transfer-limit.sh -s|-c|-d|[-1 interface] [-r rate]
where:

* -c = clear existing

e -d = display filter

e -s = set new values

e -i=interface is the name of the network interface. Default value is eth0

e -r =rate is the bandwidth rate. Default value is 256kbps

Bandwidths and rates can be specified in:
e nolimit: disables throttling

e Kkbit: Kilobits per second

* mbit: Megabits per second

¢ kbps: Kilobytes per second

e mbps: Megabytes per second

* bps: Bytes per second

Set the Filter to 4096 Kilobits per Second

This example sets the Filter to 4096 kilobits per second.
[root@<hostname> bin]#./set-shovel-transfer-limit.sh -s -r 4096kbit

RATE=4096kbit
PORTNUMBER=5671
DEVICE INTERACE=ethO

iptables: No chain/target/match by that name.
iptables: No chain/target/match by that name.
iptables: Saving firewall rules to /etc/sysconfig/iptables:[ OK ]

Current/new values...

iptables -t mangle -n -v -L
Chain PREROUTING (policy ACCEPT 2 packets, 161 bytes)
pkts bytes target prot opt in out source destination
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Chain INPUT (policy ACCEPT 2 packets, 161 bytes)

pkts bytes target prot opt in out source destination
Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
Chain OUTPUT (policy ACCEPT 2 packets, 248 bytes)
pkts bytes target prot opt in out source destination
0 0 MARK tcp -- * eth0 0.0.0.0/0 0.0.0.0/0 multiport
dports 5671 MARK set Oxa
0 0 MARK tcp -- * ethO 0.0.0.0/0 0.0.0.0/0 multiport

sports 5671 MARK set 0Oxa

Chain POSTROUTING (policy ACCEPT 2 packets, 248 bytes)
pkts bytes target prot opt in out source destination

tc -s -d class show dev ethO

class htb 1:1 root rate 10000Kbit ceil 10000Kbit burst 1600b/8 mpu Ob
overhead 0b cburst 1600b/8 mpu 0b overhead 0b level 7

Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)

rate Obit Opps backlog Ob Op requeues 0

lended: 0 borrowed: 0 giants: O

tokens: 20000 ctokens: 20000

class htb 1:2 parent 1:1 prio 0 guantum 51200 rate 4096Kbit ceil 4096Kbit
burst 1599b/8 mpu 0b overhead 0b cburst 1599b/8 mpu Ob overhead Ob level O
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
rate Obit Opps backlog 0b Op requeues 0
lended: 0 borrowed: 0 giants: O
tokens: 48828 ctokens: 48828

Set Up a Lockbox

What Is a Lockbox

A lockbox is an encrypted file that you use to store confidential information about an application. The
NetWitness Lockbox stores an encryption key for the Log Collector.

The encryption key is used to encrypt all event source passwords and the event broker password.
When you create the Lockbox, you need to define a password for the Lockbox.

The Log Collector operates the Lockbox in a mode during data collection that does not require you to
specify the password (the Log Collector uses the host system fingerprint instead).

These are the lockbox security settings.

e Towmn

Old When you set up a Lockbox for the first time, this field is blank. NetWitness populates
Lockbox this field after you enter a New Lockbox Password and click Apply.
Password

New Initial or new lockbox password. To maximize lockbox security, specify a password that
Lockbox is eight or more characters in length with at least one numeric character, uppercase
Password character, and non-alphanumeric character such as # or !

Apply Click Apply to save the changes to the lockbox password.
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Set Up a Lockbox

To set up a lockbox you need to set a password, as follows:

Q
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ ~ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Settings tab.

NETWITNESS

HC 5 SERVICES EMT SOURCES EMDPOIMNT SOURCES HEALTH & WELLMNESS

¢ Change Service | Log Collector |  Config =

General  Remote Collectors Files EventSources  Event Destinations [ECSSLETEN Appliance Service Configuration

Lockbax
Certificates

Lockbox Security Settings

Set or change the lockbox password. You will be required to enter this password to perform any lockbox managerment.

Qld Leckbox ——
Password
Mew Lockbaox skl e e
Password

Apply

Reset Stable System Value

This operation sets the system fingerprint in the lockboex. This is typically only required after changing the host hardware.
Lockbox "
Password

Apply

Generate New Encryption Key

Generates a new interral encryption key and re-encrypts the log collector's encrypted configuration values with it.

Apply

5. In the options panel, select Lockbox to configure Lockbox settings.

6. Under Lockbox Security Settings, enter a password in the New Lockbox Password field and click
Apply.

Start Collection Services

If a collection service stops, you may need to start it again. You can also enable the automatic start of
collection services.
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Start a Collection Service

4
1. Goto (Admin) > Services.

2. Select a Log Collector service and click ﬁ " under Actions.
3. Click View > System.

4. Click Collection > service (for example File) and click Start.

Enable Automatic Start of Collection Services

A
1. Goto (Admin) > Services.

2. Select a Log Collector service and click ﬁ " under Actions.
3. Click View > Config.
The General tab is displayed.

4. In the Collector Configuration panel, select Start Collection on Service Startup for the individual
collection services that you want to start automatically. Alternatively, select Enable All to
automatically start all collection services.

NETWITNESS

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS

& Change Service | endpointloghybrid - Log Collector |  Config &

General Remote Collectors Files. Event Sources  Event Destinations Settings Appliance Service Configuration

System Configuration

Name Config Value

Compression 1]

Fart 50001

S5L FIFS Mode

S5L Port 56001

Stat Update Interval 1000

Collector Configuration DI;aDIeAII
MName Config Value

= Check Point Collection

I Start Collection on Service Starup I

= Flle Collection

I Start Collectlon on Service Startup I

= Metflow Collection

5. Click Apply for your changes to take effect.

Verify That Log Collection Is Working

This topic tells you how to verify that you have set up Log Collection correctly.
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The following methods verify that Log Collection is working.

e Verify that there is event activity the Event Source Monitoring tab of the Administration > Health
& Wellness view.

* Verify that there are parsers in the device.type field in the Details column in the
Investigation > Events view for the collection protocol you configured.

Please refer to the topics for each Collection Protocol for steps on how to verify that the protocol is set
up correctly.

Configure Certificates

You manage certificates by creating trust stores on the Log Collector. The Log Collector refers to these
trust stores to determine whether or not the event sources are trusted.

Note: You can configure custom certificates for one or more event sources: for details, see (Optional)
Configure Custom Certificates on Log Collectors.

Add a Certificate

To add a certificate:

Q
1. Goto (Admin) > Services.

2. In the Services grid, select a Log Collector service.

3. Click ﬁ'  under Actions and select View > Config.
4. Click the Settings tab.
5. In the options panel, select Certificates.
6. Click + in the Certificates tool bar.
The Add Cert dialog is displayed.
7. Click Browse and select a certificate (*.PEM) from your network.
8. Specify a password (if required).
9. Click Save.

Certificates Panel

The following table describe the buttons and columns available in the Certificates panel.

Fad o

+ Opens the Add Cert dialog in which you can add a certificate and
password.
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oo

Deletes the selected certificates.

Selects certificates.
Trust Store Name Displays the name of the trust store.

Certificate Distinguished  For Check Point event source only, displays the distinguished name for
Name the certificate.

Certificate Password For Check Point event source only, displays the password name for the
Name certificate.

Add Cert Dialog

The following table describes the parameters available in the Add Cert dialog.

T

Trust Store Name Enter a trust store name.

File Click Browse to select a certificate (*.PEM file) file from your network
Password Specify the password for this certificate.

Close Closes the dialog without adding a certificate.

Save Adds the certificate.
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(Optional) Configure Custom Certificates on Log Collectors

You can configure custom certificates for the syslog listener on Log Collectors. This enables you to put
your own trusted certificate in place on the syslog listener for specific event sources, while all other
functionality uses the pre-installed certificates.

To configure custom certificates for an event source:

1. Upload the custom certificate and key files onto the Log Collector or Virtual Log Collector, and save
them into a folder. You need to add this path information in step 4 below.

2 =
Go to (Admin) > Services, select a Log Collector service and ‘ﬂ' > View > Config.
Select the Event Sources tab, then choose Syslog from the drop-down menu.

Add (or select) a syslog-tcp event source type.

A

In the Sources pane, add (or edit) a source.

The Add Source dialog box is displayed.

6. In the Add Source dialog box, click the Advanced section toggle.
The Advanced parameters are displayed.

7. For the Certificate Directory Path, enter the pathname for the folder that contains the certificate
files.

Add Source

Basic

Port * <
Enabled ™

SSL Receiver O

InFlight Publish Log

Threshold

Maximum Receivers 2 o
Event Filter v
Debug Off ~

Encoding UTF-8

S5L Verify Mode verify-none v

Certificate Directory
Path

Cancel 0K

The Log Collector SSL syslog connections will use the logcollector cert.pem and
logcollector key.pem files in the folder specified.

8. Press OK to save all parameters that you added or changed.

9. Restart syslog collection for the changes to take effect.

Note: More than one event source can use the same certificates: for each event source that shares the

certificate, specify the same Certificate Directory Path. However, the specified path cannot contain

more than one certificate (that is, one cert and one key file). To use a different custom certificate, you
must specify a different Certificate Directory Path.
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How Log Collection Works

The Log Collector service collects logs from event sources throughout the IT environment in an
organization and forwards the logs to other NetWitness components. The logs and the descriptive
content are stored as meta data for use in investigations and reports.

Event sources are the assets on the network, such as servers, switches, routers, storage arrays, operating
systems, and firewalls. In most cases, your Information Technology (IT) team configures event sources
to send their logs to the Log Collector service and the NetWitness administrator configures the Log
Collector service to poll event sources and retrieve their logs. As a result, the Log Collector receives all
logs in their original form.

Collection Protocols
NetWitness can collect logs from a wide variety of event sources. When you are configuring log

collection for a specific event source, you need to know, first and foremost, the protocol that is used to
collect the logs.

Collection

Description

Protocol

Check Point Collects events from Check Point event sources using OPSEC LEA. OPSEC LEA is
the Check Point Operations Security Log Export API that facilitates the extraction of
logs. For details, see Configure Check Point Event Sources in NetWitness.

File Collects events from log files. Event sources generate log files that are transferred
using a secure file transfer method to the Log Collector service.

For details, see Configure File Event Sources in NetWitness.

Note: In NetWitness 11.4 and later, you can perform File Log collection for many
event sources using Endpoint Agents, thus simplifying the collection process. For
details, see the NetWitness Endpoint Configuration Guide. For a list of which event
sources are supported, see the section "Currently Supported File Log Event Source
Types."

Netflow Accepts events from Netflow v5 and Netflow v9. For details, see Configure Netflow
Event Sources in NetWitness.

ODBC Collects events from event sources that store audit data in a database using the Open
Database Connectivity (ODBC) software interface. For details, see Configure ODBC
Event Sources in NetWitness.
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Collection

Protocol

Description

Plugins

SDEE

SNMP Trap

Syslog

VMware

Windows

Logstash

The Plugins collection is a generic collection framework for collecting events using
external scripts written in other languages. NetWitness currently provides collection
for Amazon Web Services (AWS) CloudTrail and Microsoft Azure.

¢ AWS: Collects events from Amazon Web Services (AWS) CloudTrail.
Specifically CloudTrail records AWS API calls for an account. For details, see
Configure AWS (CloudTrail) Event Sources in NetWitness

e Azure: Collects events from Microsoft Azure. For details, see Configure Azure
Event Sources in NetWitness.

Customers can use this framework to develop their own collection protocols.

Collects Intrusion Detection System (IDS) and Intrusion Prevention Service (IPS)
messages.
For details, see Configure SDEE Event Sources in NetWitness.

Accepts SNMP traps. For details, see Configure SNMP Event Sources in NetWitness.

Accepts messages from event sources that issue syslog messages. For details, see
Configure Syslog Event Sources.

Note: You do not configure Syslog Collection for Local Log Collectors. You only
need to configure Syslog Collection for Remote Collectors.

Collects events from a VMware virtual infrastructure. For details, see Configure
VMware Event Sources in NetWitness.

Collects events from Windows machines that support the Microsoft Windows model.
Windows 6.0 is an event logging and tracing framework included in the operating
system beginning with Microsoft Windows Vista and Windows Server 2008. For
details, see Configure Windows Event Sources in NetWitness.

Utilize Logstash as a collection method, leveraging the various number of plugins
supported by Logstash, such as:

¢ Custom - This send the events from Logstash to NetWitness Platform.
« Filebeat- This collects events from file.

¢ Auditbeat - This collects audit events from an operating system (for example
CentOS).

e Export connector - This exports events from Decoder or Log Decoder to third
party system.
By default, Logstash version 7.10.0 is installed with all standard Logstash plugins

(Beats, Export connector and so on) when Log collector is installed.
For more information see, Configure Logstash Event Sources in NetWitness.
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Collection -
Description

Protocol

Windows Collects events from:

Legacy

¢ Older Windows versions such as Windows 2000 and Window 2003 and collects
from Windows event sources that are already configured for enVision collection
without having to reconfigure them.

e NetApp ONTAP appliance event source so that you can now collect and parse
NetApp evt files.

¢ For more information, see. Windows Legacy and NetApp Collection
Configuration.

Note: You install the NetWitness Windows Legacy Collector on a physical or
virtual Windows 2008 R2 SP1 64-Bit server using the
SALegacyWindowsCollector-version-number.exe.

Log Collection Basic Procedure for all Protocols

The basic procedure is the same for all of the supported Collection Protocols.

To configure collection for an event source:

1. Set up your Event Source for collection. Each supported event source has a configuration
document available in the NetWitness Supported Event Sources space on NetWitness Link

a. Navigate to the NetWitness Supported Event Sources space on NetWitness Link.
b. Find the Instructions for your Event Source.

The Overview page lists all of the currently supported Event Sources, as well as information
about the collection method, device class, and supported versions.

c. Download the configuration instructions for your event source, and follow them.

2. Configure collection onNetWitness. The event source configuration guide contains these
instructions. However, this guide also provides these instructions, based on the collection method
used by your event source. See Collection Protocols for details.

3. Start the Service for your Collection Method. Normally, you only need to do this for the first
event source that uses this collection method. For example, the first time you configure an event
source that uses File Collection, you may need to start the File Service in NetWitness.

4. Verify that Collection is working for your Event Source.

The remainder of this topic discusses steps 2, 3, and 4 in more detail.
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Configure Collection in NetWitnhess

The process to configure event sources is dependent upon the collection method they use. Note, however,
that they are very similar. The following procedure is generic: more details for individual collection
methods are available in topics that cover the details for each specific collection method.

Basic procedure to configure an event source in NetWitness:

Q
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Conlfig to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

NETWITNESS

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLMESS

& Change Service | EE} Log Collector |  Config &
General Remote Collectors Files Event Sources QS E{ Settings  Appliance Service

|| V| Config v

Check Point

File 3

Netflow
' ODBC
| Plugins

SDEE

SNMP

Viware

Windows

5. In the Log Collector Event Sources tab, select your collection method from the drop-down menu.

6. In the Event Categories panel toolbar, click + .
The Available Event Source Types dialog box is displayed.
7. Select an event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click + in the Sources toolbar.
The Add Source dialog is displayed.

9. Enter values for the available parameters.
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Refer to the Parameters section of the specific collection method that you are configuring.

10. Click OK.

Start the Service for your Collection Method

To start the service for your collection method:
Q
1. Goto (Admin) > Services.

2. Select a Log Collector and select ﬂ ~ > View > System.
3. Click Collection > protocol > Start

where protocol is the protocol that you wish to start, for example Netflow.

Verify that Collection is working for your Event Source

Q4
You can verify that a collection method is working from the (Admin) > Health & Wellness >
Event Source Monitoring tab.

To verify that collection is working for an event source:

A
1. Goto (Admin) > Health & Wellness
2. Click the Event Source Monitoring tab.
3. In the grid, find the Log Decoder, Event Source, and Event Source Type.
4

. Look for activity in the Count column for an event source to verify that collection is accepting
events.

Search for Specific Event Sources

In some cases, your Log Collector may contain a lot of pre-configured event sources for a specific
collection protocol (for example File). If so, you can quickly search for one or more event sources based
on address (IP/hostname) or name.

To search for one or more specific event sources:

QA
1. Goto (Admin) > Services from the NetWitness menu.
2. Select a Log Collection service.
3. Under Actions, select ﬂ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

5. In the Event Sources tab, select any collection protocol/Config from the drop-down menu.
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NETWITNESS
HOSTS  SERVICES NT SOURCES  ENDPOIN

-+ Chan 0} tor Config

General Remote Collectors Files Event Sources [SUERINMEATENE Settings Appliance Servicg

|| V| Config hd

Check Point

File S
Metflow
1 ODBC
‘| Plugins

SDEE

SNMP

WVMware

Windows

6. From the Filter by Name / Address text field, enter an IP address or hostname and click Enter.

Event sources that match the information entered into the search box are returned. For example, the
image below shows a list of Check Point event sources whose names match the string checkpoint11.

+ Change Service | logdecoder1 - Log Collector | Config &
General Remote Collectors Files Event Sources [SVELIRENTRENTLE Settings Appliance Service Configuration
Check Point ~ | Config v S Event Source Configuration Guides
Event Categories sources
+ - + - Import Source |checkpomtﬂ\ X
™
R Name Address Server Nam¢ Certificate N Event Filter Client Distin Client Entity Server Distir Enabled Port CollectLog T Collect Logs Pollir
4 i —
checkpoint checkpaint11 gw- gwl gel true 18184 Security Now 30
[0 checkpaint110 gwi gel true 18184 Security Now 30
[ checkpaint111 gel true 18184 Security Now 30
[0 checkpoint112 gwi gel true 18184 Security Now 30
[ checkpoint113 gwi zel true 18184 Security Mow 30
O checkpaint114 gwi gel true 18184 Security Now 30
[0 checkpaint115 gwi gel true 18184 Security Now 30
[0 checkpaint116 gw gwi gel true 18184 Security Now 30
O checkpaint117 gw gwi gel true 18184 Security Now 30
[0 checkpoint118 gwi gel true 18184 Security Now 30
[ checkpoint119 n2016 gwi zel true 18184 Security Mow 30

Configure Event Filters for a Collector

This topics tells you how to create and maintain Event filters across all collection protocols.

Configure an Event Filter

To configure an event filter for an event source:
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4
. Goto (Admin) > Services.

1
2. Select a Log Collection service.
3. Under Actions, select ﬁ "~ View > Config to display the Log Collection configuration parameter
tabs.
4. Click the Event Sources tab.
5. In the Event Sources tab, select any collection method / Filter from the drop-down menus.
The following screen shows Syslog selected.
METWITNESS
HOS5TS SERVICES EVEMT SOURCES ENDPOI
General Local Collectors Files Event Source
Syslog ~ | Filters ™
The Filters view displays the filters that are configured for the selected collection method, if any.
6. In the Filters panel toolbar, click + .
The Add Filter dialog displays.
Add Filter
Name * Filter100
Description * Syslog Leve
Cancel
7. Enter a name and description for the new filter and click Add.
The new filter displays in the Filter panel.
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10.

& Change Service | -Log Collector | Config &

General Local Collectors Files Event Sources Settings  Appliance Service Configuration
Syslog ~ | Filters i
Filters

+
] Name
[ Filter100

| Page 1 of1 |

Select the new filter in the Filters panel and click + in the Filter Rules panel toolbar.
The Add Filter Rule dialog is displayed.

Click + under Rule Conditions.
Add the parameters for this rule and click Update > OK.

Add Filter Rule

Filter Name * Filter100

Rule Description * SysloglLevel100

Rule Conditions

™ Key * Operator * Use Regex | Value Ignore Case Action
Match * Mo Match *
Syslog Level (syslog.level) ~ Equals v £ 1-2 O Accept « ||Drop

NetWitness updates the filter with the rule that you defined.

Note: Rules are processed in order from top down until an Action type aborts the processing, or the
final rule is checked. Default behavior is to accept the rule if no matches are found.

The following tables describe the parameters for adding a filter rule.

Event Filter Rule "Key" Parameter

The values for the Key field depend on the Collection method to which the filter applies.
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Collection Method Values for the Key Field

Checkpoint, File, Netflow, Plugin,
SDEE SNMP and VMware

ODBC

Syslog

Windows

All Data Fields
Event Source Type
Event Source Name
Source IP

Raw Event

All Data Fields
Event Source Type
Event Source Name
Source IP

Message ID

Message Level

All Data Fields
Event Source Type
Event Source Name
Source IP

Syslog level

Raw Event

All Data Fields
Event Source Type
Event Source Name
Source IP

Event ID

Provider

Channel

Computer
UserName

DomainName

77
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Collection Method Values for the Key Field

Windows Legacy e All Data Fields
¢ Event Source Type
¢ Event Source Name
e Source [P

e Event ID

Other Event Filter Rule Parameters

The following table describes all the other available fields for creating an event filter rule.

o i 0

Operator  Valid values are:
¢ Contains
¢ Equal
Use Regex Optional. You can select this if you want to use Regex.

Value Value depends on the key value you selected.

For example if you choose Syslog level for Key, the value will be a number that denotes
the syslog level.

Ignore Optional. Select this to ignore the case sensitivity.
case
Action Choose actions for message data that matches a condition, or that does not match a

condition. See below for more details.

Actions

You can choose a ‘match’ and ‘no-match’ action for each rule condition. This screenshot shows a
condition that uses the Accept action on matches, and Drop action on events that do not match the
condition.

Action

Match * Mo Match *

Accept ~ ||Drop

The available actions are as follows:

o Accept: the filtered event is included in event logs, and no further rule processing is done for the
event: the event will display in the NetWitness user interface during Investigation.
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o Drop: the filtered event will not be included in event logs, and no further rule processing is done for
the event: the event will not display during Investigation.

¢ Next condition: the filtered event moves on to the next rule condition in the rule. If there are no more
rule conditions in the current rule, it moves on to the next rule.

o Next rule: the filtered event moves on to the next rule. If there are no more rules in the filter, the filter
event is included in event logs, and no further rule processing is done for the event (same as Accept).

For example, consider the following condition:

Add Filter Rule

Filter Name * Filver100

Rule Description * Filter out Internal events

Rule Conditions

™ Key * Operator * Use Regex | Value * Ignore Case Action
Match * Mo Match *
All Data Fields (all) v Contains O internal ™ Drop ~ | Accept v

Cancel OK

In this condition, if the event log contains the string "internal," the event is not included in the event
meta, nor is it displayed during Investigation. If the string is not found, the event is included and is
displayed during Investigation.

Modify Filter Rules

To modify existing filter rules:

4
1. Goto (Admin) > Services.
Select a Log Collection service.

Under Actions, select View > Config to display the Log Collection configuration parameter tabs.

Click the Event Sources tab.

A I T

In the Event Sources tab, select any collection method / Filter from the drop-down menus.

The screen shows Check Point selected.
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Investigate

SERVICES EVENMT SOURCES ENDPOI

Local Collectors Files Event Source

Syslog ~ | Filters ~

The Filters view displays the filters that are configured for the selected collection method, if any.
6. In the Filter Rules list, select a rule and click lilg

The Edit Filter Rule dialog is displayed.

Edit Filter Rule

Filter Name * Filter100

Rule Description * SyslogLevel100

Rule Conditions

+
O Key * Operator * Use Regex = Value * Ignore Case Action
Match * No Match *
[ sysloglevel Equals true 1-2 true Accept Drop
Cancel OK

7. Select the rule condition that you want to modify.
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Edit Filter Rule

Filter Name * Filter100

Rule Description * SyslogLevel100

Rule Conditions

+
O Key * Operator * Use Regex  Value* Ignore Case Action
Match * No Match *
[ sysloglevel Equals true 1-2 true Accept Drop
Cancel OK

8. Modify the condition parameters that require changes and click Update > OK.

NetWitness applies the condition parameter changes to the selected filter rule.

Import, Export, Edit, and Test Event Sources in Bulk

This topic describes how to import, export, edit, and test event sources in bulk.

You can use the bulk export option to export the event source details of your current set up and store
it. This data can be imported in bulk when you face a problem with your current set up and require the
event source data you had.

You can use the bulk edit feature when you have multiple event sources that need a specific
modification. You can select all the sources and apply the edit option across them at a time and avoid
applying the change one by one.

Import Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some data
fields like numbers and dates can be re-formatted into the spreadsheet program’s native field types.
This can cause issues when re-importing this information, as some data fields may be garbled or
formatted incorrectly. This can be avoided by importing the CSV file into the spreadsheet program,
and specifying all data fields as text values.

To import multiple event sources at once:

A
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.
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5. Select Check Point, File, Netflow, Logstash, ODBC, Plugins, SDEE, (Syslog for Remote
Collectors) only, VMware, Windows, or Windows Legacy (SNMP does not have an Import
function.).

6. In the Sources panel toolbar, click Import Source.
The Bulk Add Option dialog is displayed.

Bulk Add Cption

Import C5Y File

Paste C5V Content

Close

7. Select either Import CSV File or Paste CSV Content. If you select:
o Import CSV File:
a. Click Next.
The Import dialog is displayed.
b. Click Add and select a .csv file from your network.

Import
4 -

File Name =

newFileEventSources. cav

Close Import

c. Click Import.
The event sources are added to the Event Source list.

o Paste CSV Content
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a. Copy the contents of the .csv file and paste them into the dialog.

Bulk Add Cption

Import CEV File
() Paste C5V Content

FileDir1,W5E.*%24 FALSE TRUE TRUE,UTF-
8,10,FALSE FALSE1.10E+121.10E+12,65536,10,10, TRUE,D,
TRUE

b. Click Import.

The event sources are added to Event Source List.

Export Event Sources in Bulk

Warning: When using a spreadsheet program to edit an exported event source CSV file, some data
fields like numbers and dates can be re-formatted into the spreadsheet program’s native field types.
This can cause issues when re-importing this information, as some data fields may be garbled or
formatted incorrectly. This can be avoided by importing the CSV file into the spreadsheet program,
and specifying all data fields as text values.

To export event source information:

Q
. Goto (Admin) > Services.

. Select a Log Collection service.

. Select ﬁ “ > View > Conlfig to display the Log Collection configuration parameter tabs.

. Click the Event Sources tab.

. Select Check Point, File, Netflow, Logstash, ODBC, Plugins, SDEE, (Syslog for Remote Collectors)
only, VMware, Windows, or Windows Legacy (SNMP does not have an Export function.).

. In the Sources panel, select one or multiple event sources and click Export Source.

The Bulk Export dialog is displayed.

Bulk Export

Export all rows or selected rows?

Selected Cancel

. Based on your selection:
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e All: NetWitness exports all event sources to a time-stamped CSV file.
* Selected: NetWitness exports the event source or sources you selected to a time-stamped CSV file.

e Cancel: NetWitness cancels the export.

The following is an example of a time-stamped CSV file that gets created with the event sources that you
selected from the list.

CH RS - Exportedfile-config-Feb-28-2013-13-3.cU® Microsoft Excel L=
o —
Home Insert Page Layout Formulas Drata Review View Acrobat @ - =7 X
o -1l iti — = = =
j & Calibri n -AaLE= General FﬂCondltlonal Formatting o= Insert x % [?a
B 53 | - % 9| @Format as Table ~ & Delete ~ IE'
Past - - = = £ - o Sort & Find &
ase 7 U d- A ES = = Ca (5] cell Styles ~ B Format - || (2~ FiTte,. SéTm.
Clipboard ™= Font E} Alignment {F] Number = Styles Cells Editing
Al - (> f« | fileDirectory
A B C D E F G H | J K L M N
1 file[lirect!eventSowfiIeSpec fileSaveO fileSaveO fileSeque fileEncodi fileDiskQu manageEr manageSe errorFiles savedFile: errorFiles savedFile: [£]
2 |Eur_Londc¢127.0.0.1 %S5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 1.1E+12 1.1E+12 65536 65536
3 |US_Chicag127.0.0.1 %5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 1.1E+12 1.1E+12 65536 65536
4 US_Mew '127.0.0.1 %5E.*%24 FALSE TRUE TRUE UTF-8 10 FALSE FALSE 1.1E+12 1.1E+12 65536 65536
H 4 » M| exported-file-config-Feb-28-201 %] L m 1]
Ready 0% s CE

Edit Event Sources in Bulk

To edit multiple event sources at once:

1. On the Log Collector Event Sources tab, select Check Point, File, Netflow, Logstash,
ODBC, Plugins, SDEE, Syslog, VMware, Windows, or Windows Legacy (SNMP does not have
an Edit function.).
]

2. In the Sources panel, select multiple event sources and click .

The appropriate Bulk Edit dialog for the selected event source is displayed. The following figure is
an example of Bulk Edit Source dialog for File event source parameters.
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Bulk Edit Source

Basic

Select fields for bulk edit operation. Only selected fields will be updated.

# Enabled [+

Advanced

O

Cancel 0K

3. Select the checkbox to the left of the fields that you want to modify (for example, Debug).

4. Modify the selected parameters (for example, change Debug from Off to On).
5. Click OK.

NetWitness applies the same parameter value change to all of the selected event sources

Test Event Source Connections in Bulk

To test multiple event source connections at once:

4
1. Goto (Admin) > Services.

2. In the Services grid, select a Log Collector service.

3. Select ﬁ ~ > View > Config to display the Log Collection configuration parameter tabs.

4. Select the Event Sources tab, select Plugins, ODBC, Logstash or Windows (the other protocols do
not have a bulk test connection function).

5. Select one or more:
¢ sources from the Sources panel for Plugins or ODBC
¢ hosts from Hosts panel for Windows

The Test Connection button is enabled.
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+ Change Service | -log Collector | Config ©

General Remote Collectors Files AT ISGIGEEE  Event Destinations  Settings  Appliance Service Configuration

Windows ~ | Config v
Event Categories Hosts
+ = @ & importSource [ Export Source + = @ & importSource ™ ExportSourcel]  Test Connection
[ Alias Authoriza: Channel Max Durar Max Even! User Name Read All E Polling Int ™ Event Source Addres Port Event Filt Transpor Debug Enabled Validate £ Render Lt Windo
Windows1 basic Securi.. 120 150000 scott false 180 T4 5985 http Off true false en-uUs Non-.
Windows2 basic Systemn 120 150000 templarKnig... false 180 4 5085 http Off true false en-Us Non-.
| Page 1 of 1 | | ¢ Items 1-20f 2 | Page 1 of1 | | ¢ Items 1-2 of :

W e =i
6. Click M Test Connecticn

The Bulk Test Connections dialog is displayed showing the current status of the test for each
source. The status can be waiting, testing, passed or failed.

If you choose to close the testing before it is completed, the testing stops and the Bulk Test
Connections dialog closes.

After the testing is complete, the results are displayed in the Bulk Test Connections dialog.
See Also

A
You can use the Event Sources module ( (Admin) > Event Sources) to create groups of event
sources, typically imported from a CMDB, and to monitor event sources based on those groups. For
details, see the following topics in the Event Source Management Guide:

e Import Event Sources
* Export Event Sources

¢ Bulk Edit Event Source Attributes
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Configure Collection Protocols and Event Sources

This topic tells you how to configure collection protocols and the event sources using those protocols.

You configure the Log Collector to collect event data from your event sources in the Event Sources tab
of the Log Collection parameter view.

To configure a collection protocol:

4
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Under Actions, select ﬂ “ > View > Conlfig to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES . WELLNESS
& Change Service | B Log Collector | Config ®
General Remote Collectors Files Event Sources QU idslSiliE{ Settings  Appliance Servics

|| V| Config ~

Check Point

File S

Netflow
1 ODBC
* Plugins

SDEE

SNMP

VMware

Windows

5. Select a collection protocol (for example, File) and select Config.
6. Click + and select an event source.

7. Select the newly added category and click +

8. Specify the parameters for the event source. For details, see the individual collection protocol topics.

The following guides provide detailed instructions on how to configure the collection protocols and their
associated event sources in NetWitness. Each guide includes an index to configuration instructions for
the event sources supported for that collection protocol.

To configure individual collection protocols, see the following topics:
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Configure AWS (CloudTrail) Event Sources in NetWitness

Configure Azure Event Sources in NetWitness

Configure Check Point Event Sources in NetWitness

Configure File Event Sources in NetWitness

Configure Netflow Event Sources in NetWitness

Configure ODBC Event Sources in NetWitness

e Configure Data Source Names (DSNs)

¢ Create Custom Typespec for ODBC Collection

e ODBC Event Source Configuration Parameters

e ODBC DSNs Event Source Configuration Parameters

Configure SDEE Event Sources in NetWitness

Configure SNMP Event Sources in NetWitness

Configure Syslog Event Sources

Configure VMware Event Sources in NetWitness

Configure Windows Event Sources in NetWitness

Windows Legacy and NetApp Collection Configuration

e Set Up the Windows Legacy Collector

e Configure Windows Legacy and NetApp Event Sources

e Troubleshoot Windows Legacy and NetApp Collection

Configure Logstash Event Sources in NetWitness

Configure Collection Protocols and Event Sources
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This topic tells you how to configure the AWS collection protocol, which collects events from Amazon
Web Services (AWS) CloudTrail.

Note: The AWS plugin is meant only for collecting from AWS CloudTrail logs, and not for collecting
from arbitrary logs in S3 buckets (under arbitrary directories). The AWS CloudTrail logs are sent in
JSON format, as detailed in the AWS documentation here:
http://docs.aws.amazon.com/awscloudtrail/latest/userguide/cloudtrail-event-reference.html.

How AWS Collection Works

The Log Collector service collects events from Amazon Web Services (AWS) CloudTrail. CloudTrail
records AWS API calls for an account. The events contain the identity of the API caller, the time of the
API call, the source IP address of the API caller, the request parameters, and the response elements
returned by the AWS service. The AWS API call history provided by CloudTrail events enables security
analysis, resource change tracking, and compliance auditing. CloudTrail uses Amazon S3 for log file
storage and delivery. NetWitness copies the log files from the cloud (S3 bucket), and sends the events
contained in the files to the Log Collector.

Deployment Scenario

The following figure illustrates how you deploy the AWS Collection Protocol in NetWitness.
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AWS
(CloudTrail)

AWS
http or https

Log Collection

(Local and
Remote
Collectors)

*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configuration

To configure an AWS (CloudTrail) Event Source:

QA
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Select ﬁ © > View > Conlfig to display the Log Collection configuration parameter tabs.
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4. Click the Event Sources tab.

NETWITNESS

HOSTS SERVICES EVENT SOURCES EMDPOINT 50 5 HEALTH & WELLNESS

& Change Service | EE} Log Collector | Config &
General Remote Collectors Files Event Sources JESUEgidslSuaEl{o T Settings

|| v | Config v

Check Point

File S

Metflow
1 ODBEC
| Plugins

SDEE

SNMP

VMware

Windows

5. In the Event Sources tab, select Plugins/Config from the drop-down menu.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select cloudtrail) and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.

The Add Source dialog is displayed.

9. Define parameter values. For details, see AWS Parameters below.
10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness displays an error message.

11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

AWS Parameters

The following table describes the Basic configuration parameter for AWS collection.
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Note: Required parameters are marked with an asterisk. All other parameters are optional.

Name * Name of the event source.

Select the check box to enable the event source configuration to start collection. The check box is

Enabled selected by default.

Account Id * Account Identification code of the S3 Bucket

S3 Bucket Name Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS (CloudTrail) region in
which you create the bucket. You specify the name at the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for DNS-compliant bucket
names are:

o Bucket names must be at least three and no more than 63 characters long.

e Bucket names must be a series of one or more labels. Adjacent labels are separated by a
single period “.”. Bucket names can contain lowercase letters, numbers, and hyphens. Each
label must start and end with a lowercase letter or a number.

¢ Bucket names must not be formatted as an IP address (for example, 192.168.5.4).

The following examples are valid bucket names:

e myawsbucket
e my.aws.bucket

* myawsbucket.l

The following examples are invalid bucket names:
e .myawsbucket - Do not start a Bucket Name with a period

e myawsbucket. - Do not end a Bucket Name with a period

e my..examplebucket - Only use one period between labels.

Access Key * Key used to access the S3 bucket. Access Keys are used to make secure REST or Query
protocol requests to any AWS service API. Please refer to Manage User Credentials on the
Amazon Web Services support site for more information on Access Keys.

Secret Key * Secret key used to access the S3 bucket.
Region * Region of the S3 bucket. us-east-1 is the default value.

Region Endpoint  Specifies the AWS CloudTrail hostname. For example, for an AWS public cloud for us-east
region, the Region Endpoint would be s3.amazonaws.com. More information can be found at
http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region. This parameter is
necessary to collect CloudTrail logs from AWS Government or Private clouds.

Use Proxy Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Proxy Server Enter the proxy name you want to connect to access the AWS server.

Proxy Port Enter the port number that connects to the proxy server to access the AWS server.
Proxy User Enter the user name to authenticate with the proxy server.
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Proxy Password

Start Date *

Log File Prefix

Cancel

OK

Enter the password to authenticate with proxy port.

Starts AWS (CloudTrail) collection from the specified number of days in the past, measured from
the current timestamp. The default value is 0, which starts from today. The range is 0-89 days.

Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure to enter the same prefix
in this parameter.

Closes the dialog without adding the AWS (CloudTrail).

Adds the current parameter values as a new AWS (CloudTrail).

The following table describes the Advanced configuration parameter for AWS collection.

Debug

Command Args

Polling Interval

SSL Enabled

I

Test Connection

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an
event source and you need to investigate this problem. Enabling debugging will adversely affect the
performance of the Log Collector.

Enables or disables debug logging for the event source.

Valid values are:

o Off = (default) disabled

On = enabled

o Verbose = enabled in verbose mode - adds thread information and source context information
to the messages.

This parameter is designed to debug and monitor isolated event source collection issues. The
debug logging is verbose, so limit the number of event sources to minimize performance impact.
If you change this value, the change takes effectimmediately (no restart required).

Arguments added to the script.

Interval (amount of time in seconds) between each poll. The default value is 60.

For example, if you specify 60, the collector schedules a polling of the event source every 60
seconds. If the previous polling cycle is still underway, it will wait for it to finish that cycle. If you
have a large number of event sources that you are polling, it may take longer than 60 seconds for
the polling to start because the threads are busy.

Select the check box to communicate using SSL. The security of data transmission is managed
by encrypting information and providing authentication with SSL certificates.

The check box is selected by default.

Validates the configuration parameters specified in this dialog are correct. For example, this test
validates that:

¢ NetWitness can connect with the S3 Bucket in AWS using the credentials specified in this
dialog.

¢ NetWitness can download a log file from the bucket (test connection would fail if there were no
log files for the entire bucket, but this would be extremely unlikely).
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Configure Azure Event Sources in NetWitness

This topic tells you how to configure the Azure collection protocol. Microsoft Azure is a cloud
computing platform and infrastructure for building, deploying, and managing applications and services
through a global network of Microsoft-managed data centers.

Configuration in NetWitness

For complete details about configuring Azure as an event source, see the Azure Event Source
Configuration Guide, available on NetWitness Link.

To configure an Azure Event Source:

QA
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Select ﬂ ~ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVEMT SOURCES ENDPOINT SOURCES HEALTH & WELLMNESS
& Change Service | J Log Collector | Config ©
General Remote Collectors Files Event Sources QS dBliliEI( Settings
|| ~ | Config ~
Check Point
File S
Metflow
1 ODBC
! Plugins
SDEE
SMMP
ViMware
Windows

5. In the Event Sources tab, select Plugins/Config from the drop-down menu.

=+

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select azureaudit) and click OK.

The newly added event source type is displayed in the Event Categories panel.
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8. Select the new type in the Event Categories panel and click in the Sources toolbar.

The Add Source dialog is displayed.

9. Define parameter values. For details, see Azure Parameters below.
10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness displays an error message.

11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Azure Parameters

This section describes the Azure event source configuration parameters.

Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Nems__ [oescrpton

Name *
Enabled
Client ID *

Client Secret *

API Resource
Base URL *

Federation
Metadata
Endpoint *

Subscription ID
*

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

The Client ID is found the Azure Application Configure tab. Scroll down until you
see it.

When you are configuring the event source, the client secret is displayed when you
are creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it cannot be
retrieved later.

Enter https://management.azure.com/. Be sure to include the trailing
slash (/).

In your Azure application, click the View Endpoints button (near the bottom of the
pane).

There are a lot of links that all begin with the same string. Compare the URLs and
find the common string that begins most of them. This common string is the
endpoint that you need to enter here.

You can find this in the Microsoft Azure dashboard: click on Subscriptions at the
bottom of the list on the left.
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e o

Tenant Domain  Go to the active directory and click on the directory. In the URL, the tenant domain
& is the string directly following manage.windowsazure.com/. The tenant domain is
the string up to and including the .com.

Resource In Azure, select Resource groups from the left navigation pane, then select your
Group Names * group.

Start Date * Choose the date from which to start collecting. Default's to the current date.
Test Checks the configuration parameters specified in this dialog to make sure they are
Connection correct.

Advanced Parameters

Click = next to Advanced to view and edit the advanced parameters, if necessary.

e

Polling Interval (amount of time in seconds) between each poll. The default value is 180.

Interval For example, if you specify 180, the collector schedules a polling of the event source
every 180 seconds. If the previous polling cycle is still underway, the collector waits for
that cycle to finish. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are busy.

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Duration

Poll

Max The maximum number of events per polling cycle (how many events collected per

Events Poll polling cycle).

Max Idle =~ Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Time Poll

gommand Optional arguments to be added to the script invocation.
rgs
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Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a
problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:
e Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
If you change this value, the change takes effect immediately (no restart required). The
debug logging is verbose, so limit the number of event sources to minimize performance
impact.

Configure Check Point Event Sources in NetWitness

This topic tells you how to configure the Check Point collection protocol, which collects events from
Check Point event sources.

This protocol collects events from Check Point event sources using OPSEC LEA. OPSEC LEA is the
Check Point Operations Security Log Export API that facilitates the extraction of logs.

How Check Point Collection Works

The Log Collector service collects events from Check Point event sources using OPSEC LEA. OPSEC
LEA is the Check Point Operations Security Log Export API that facilitates the extraction of logs.

Note: OPSEC LEA (Log Export API) supports extraction of logs from Check Point event sources
configured with a SHA-256 or SHA-1 certificate.

Deployment Scenario

The following figure illustrates how you deploy the Check Point Collection Protocol in NetWitness.
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Intranet

" Check Paint

event sources

OPSEC LEA
(port: 18184)

Log Collection
(Local and

Remote
Collectors)

*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configuration in NetWitness

To configure a Check Point Event Source:

QA
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Select ﬂ ~ > View > Config to display the Log Collection configuration parameter tabs.
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4. Click the Event Sources tab.

NETWITNESS

HOSTS SERVICES EVENT SOURCES EMDPOINT 50 5 HEALTH & WELLNESS

& Change Service | EE} Log Collector | Config &
General Remote Collectors Files Event Sources JESUEgidslSuaEl{o T Settings

|| v | Config v

Check Point

File S

Metflow
1 ODBEC
| Plugins

SDEE

SNMP

VMware

Windows

5. In the Event Sources tab, select Check Point/Config from the drop-down menu.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select a check point event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.

The Add Source dialog is displayed.

9. Define parameter values. For details, see Check Point Parameters below.
10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information and retry.

Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time limit,
the test times out and the NetWitness displays an error message.

11. If the test is successful, click OK.

The new event source is displayed in the Sources panel.

Check Point Parameters

This section describes the Check Point event source configuration parameters.
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Basic Parameters

Name*
Address*
Server Name*

Certificate
Name

Client
Distinguished

Client Entity
Name

Server
Distinguished

Enabled
Pull Certificate
Certificate

Server Address

Password

Name of the event source.
IP Address of the Check Point server.
Name of the Check Point server.

Certificate name for secure connections to use when the transport mode is https. If
set, the certificate must exist in the certificate trust store that you created using the
Settings tab.

Select a certificate from the drop-down list. The file naming convention for Check
Point event source certificates is checkpoint_name-of-event-source.

Enter the Client Distinguished Name from the Check Point server.

Enter the Client Entity Name from the Check Point server.

Enter the Server Distinguished Name from the Check Point server.

Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

Select the checkbox to pull a certificate for first time. Pulling a certificate makes it
available from the trust store.

IP Address of the server on which the certificate resides. Defaults to the event source
address.

Only active when you select the Pull Certificate checkbox for first time. Password
required to pull the certificate. The password is the activation key created when
adding an OPSEC application to Check Point on the Check Point server.

Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to stay open
for a specific time and specific event volume (transient connection). NetWitness defaults to the following
connection parameters that establish a transient connection:

* Polling Interval = 180 (3 minutes)

e Max Duration Poll = 120 (2 minutes)

e Max Events Poll = 5000 (5000 events per polling interval)
e Max Idle Time Poll = 0
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For very active Check Point event sources, it is a good practice to set up a connection that stays open
until you stop collection (persistent connection). This ensures that Check Point collection maintains the
pace of the events generated by these active event sources. The persistent connection avoids restart and
connection delays and prevents Check Point collection from lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters to the

following values:

e Polling Interval = -1

¢ Max Duration Poll = 0
e Max Events Poll = 0
e Max Idle Time Poll =0

Port

Collect Log
Type

Collect Logs
From

Polling
Interval

Max Duration
Poll

Port on the Check Point server that Log Collector connects to. Default value is
18184.

Type of logs that you want to collect: Valid values are:
e Audit - collects audit events.

e Security - collects security events.

If you want to collect both audit and security events, you must create a duplicate
event source. For example, first you would create an event source with Audit selected
pulling a certificate into the trust store for this event source. Next you would create
another event source with the same values except that you would select Security for
the Collect Log Type and you would select the same certificate in Certificate Name
that you pulled when you set up the first set of parameters for this event source and
you would make sure that Pull Certificate was not selected.

When you set up a Check Point event source, NetWitness collects events from the
current log file. Valid values are:

¢ Now - Start collecting logs now (at this point in time in the current log file).

¢ Start of Log - Collect logs from the beginning of the current log file.

If you choose "Start of Log" for this parameter value, you may collect a very large
amount of data depending on how long the current log file has been collecting events.
Note that this option is effective only for the first collection session.

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event source
every 180 seconds. If the previous polling cycle is still underway, it will wait for it to
finish that cycle. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are
busy.

The maximum duration of polling cycle (how long the cycle lasts) in seconds.

71



Log Collection Configuration Guide

Max Events
Poll

Max Idle Time
Poll

Forwarder
Log Type
(Name Value
Pair)

Debug

The maximum number of events per polling cycle (how many events collected per
polling cycle).

Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is the
default value.

Enables or disables the Check Point server as a forwarder. By default it is disabled.

Logs from the event source in Name Value format. By default it is disabled.

Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you

have a problem with an event source and you need to investigate this problem.

Enabling debugging will adversely affect the performance of the Log Collector.
Enables and disables debug logging for the event source.

Valid values are:
e Off = (default) disabled

¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to
minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).

Verify Check Point Collection is Working

The following procedure illustrates how you can verify that Check Point collection is working from the
Administration > Health & Wellness > Event Source Monitoring tab.

To verify Check Point collection from the Event Source Monitoring tab:

- -
1. Access the Manage tab from the K48 (Admin) > Event Sources view.

2. Find a checkpoint event source in the Event Sources column.

3. Look for activity in the Total Count column to verify that Check Point collection is accepting

events.

To verify Check Point collection from the Investigation > Events view:

The following procedure illustrates how you can verify that Check Point collection is working from the
Investigation > Events view.
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1. Access the Investigation > Events view.

2. Select the Log Decoder (for example, LD1) collecting Check Point events in the Investigate a
Device dialog.

3. Look for a Check Point event source parser (for example, checkpointfw1) in the device.type field in
the Details column to verify that Check Point collection is accepting events.

Note: If the logs from the VSX Checkpoint firewall server are collected by the Log Collector
checkpoint service, to translate the VSX IP in the logs to ip.orig meta, you must add the VSX
hostname and the VSX IP address to the /etc/hosts file in the Log Collector.

Configure File Event Sources in NetWitness

This topic tells you how to configure the File collection protocol:

Note: In NetWitness 11.4 and later, you can perform File Log collection for many event sources using
Endpoint Agents, thus simplifying the collection process. For details, see the NetWitness Endpoint
Configuration Guide. For a list of which event sources are supported, see the section "Currently
Supported File Log Event Source Types."

Configure a File Event Source

To configure a File Event Source:

4
Go to (Admin) > Services from the NetWitness menu.

—_—

2. Select a Log Collection service.

3. Under Actions, select ﬂ "~ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.
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5. In the Event Sources tab, select File/Config from the drop-down menu.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select a file event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.

The Add Source dialog is displayed.

9. Add a File Directory name and modify any other parameters that require changes. For details, see
File Collection Parameters below.

10. To get the public key and enter it into the dialog box, do the following:
a. Select and copy the public key from the Event Source by running: cat ~/.ssh/id rsa.pub
b. Paste the public key in the Eventsource SSH Key field.

11. Click OK.

You need to restart file collection for your changes to take effect.

Stop and Restart File Collection

After you add a new event source that uses file collection, you must stop and restart the NetWitness File
Collection service. This is necessary to add the key to the new event source.
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File Collection Parameters

The following table provides descriptions of the File Collection source parameters.

The following table describes the Basic configuration parameter for File collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e o

File Collection directory (for example, Eur_London100) into which the File event source
Directory*  places its files. Valid value is a character string that is conforms to the following regular

expression:
[ a-zA-Z][ a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores. Do not modify this parameter after you start collecting event data.

After you create the collection, the Log Collector creates the work, save, and error sub-

directories under the collection directory.

Address* IP address of the event source. Valid value is an IPv4 address, IPv6 address, or a

hostname including a fully-qualified domain name.

File Spec Regular expression. For example, *.*$ = process everything.
File Character encoding used by the syslog senders to this port. Defaults to UTF-8.
Encoding

and most senders have their encoding set to UTF-8.

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as well,

NetWitness has tested the following values:
* EUC-KR
» SIIS
* GB3212/GBK
e [ISO_8859-1 (German)
e [SO_8859-7 (Greek)
Cancel Closes the dialog without making adding an event source type.

OK Adds the parameters for the event source.

The following table describes the Advanced configuration parameter for File collection.

e o

Ignore Select the check box to ignore encoding conversion errors and ignore invalid data. The
Encoding check box is selected by default.
Conversion

Errors Caution: This may cause parsing and transformation errors.
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e Jowen P

File Disk Determines when to stop saving files regardless of the Save On Error and Save On

Quota Success parameter settings. For example, a value of 10 indicates that when there is
less than 10% available disk left, the Log Collector stops saving files to reserve
enough space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection directory is
mounted. If the Log Decoder server has a 10TB disk size and 2TB is allocated to
base collection directory, then setting this value to 10 causes log collection to stop
when less than 0.2TB (10% of 2TB) of space is left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential Sequential processing flag:

Pl ¢ Select the check box (default) to process event source files in collection order.

e Do not select the checkbox to process event source files in parallel.

Save On Save on error flag. Check the checkbox to retain the eventsource collection file when
Error the Log Collector it encounters an error. The check box is selected by default.

Save On Save eventsource collection file after processing flag. Check the checkbox to save the
Success eventsource collection file after processing it. The check box is not selected by default.

Eventsource  SSH public key used to upload files for this event source. Please refer to the Generate
SSH Key Key Pair on Event Source and Import Public Key to Log Collector section in the
Install and Update the SFTP Agent Guide for instructions on generating keys.

Note: If File collection is stopped, NetWitness does not update the authorized keys
file with the SSH public key that you add or modify in this parameter. You must
restart File collection to update the public key.

You can add or modify the value of the public key in this parameter in multiple File
event sources without File collection running, but NetWitness will not update the
authorized_keys file until File collection is restarted.

Manage Error By default, the Log Collector uses the File Disk Quota parameter to ensure that the
Files disk does not fill up with error files. If you set this parameter to true, you can specify
one of these:

e Maximum space allotted to error files in the Error Files Size parameter.

e Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Select the check box to manage error files. The check box is not selected by default.
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Error Files
Size

Error Files
Count

Error Files
Reduction %

Manage
Saved Files

Saved Files
Size

Saved Files
Count

Saved File
Reduction %

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Specifies to what extent NetWitness saves error files. The value that you specify is the
maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. You specify these values in
either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default. If you
change this parameter, the change does not take effect until you restart collection or
restart the Log Collector service.

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Maximum number of error files allowed in the error directory. Valid value is a number
in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Percent amount by size or count of the error files that the Log Collector service
removes when the maximum size or count has been reached. The service removes the
oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Select the check box to manage saved files. The check box is not selected by default.
By default, the Log Collector uses the File Disk Quota parameter to ensure that the
disk does not fill up with saved files. If check this check box, you can specify one of
these:

e Maximum space allotted to saved files in the Saved Files Size parameter.

e Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Only valid if the Manage Saved Files and Save On Success parameters are set to
true.

Maximum total size of all the files in the save directory. Valid value is a number in
the 0 to 281474976710655 range. You specify these values in either Kilobytes,
Megabytes, or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Only valid if the Manage Saved Files and Save On Success parameters are set to
true. Maximum number of saved files in the save directory. Valid value is a number in
0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Percent amount by size or count of the saved files that the Log Collector service
removes when the maximum size or count has been reached. The service removes the
oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have
a problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source.
Valid values are:

e Off = (default) disabled
¢ On = enabled
¢ Verbose = enabled in verbose mode - adds thread information and source context

information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to
minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).

Configure Logstash Event Sources in NetWitness

You can configure the Logstash collection protocol.

IMPORTANT:

- Do not change logstash.yml file as it breaks the functionality.

- Do not change sincedb_path input configuration. If you change the sincedb_path, the back up and
restore functionality breaks.

- Do not modify any pipeline configuration yml files.

To configure a Logstash Event Source:

QA
1. Goto (Admin) > Services from the NetWitness menu.
2. Select a Log Collection service.

3. Under Actions, select ﬁ © > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

5. In the Event Sources tab, select Logstash/Config from the drop-down menu.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select the event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
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8. Select the new type in the Event Categories panel and click in the Sources toolbar.
The Add Source dialog is displayed.

9. Fill in the fields, based on the Logstash event source you are adding. General details about the
available parameters are described below in Logstash Collection Parameters.

10. Click OK.

Logstash Collection Parameters

The following tables provides descriptions of the Logstash Collection source parameters.

Note: Items that are followed by an asterisk (*) are required.

Basic Parameters

Custom Event Source Parameters

The following table lists the custom event source parameters.

e o

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Enabled Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Description Enter a text description for the event source.

Input An input plugin enables a specific source of events to be read by Logstash.
Configuration *

Filter A filter plugin performs intermediary processing on an event. Paste in any filter
Configuration * details for your Logstash event source.

Device Type *  Enter the device parser type used to parse the data.

Note:

- While saving an existing instance with no specified device type, enter the device
type to enable Ok. Else, click Cancel.

- The device type can have 3 to 30 characters of a-z, 1-9, or underscore and must
start with a-z.

Source Address Enter the IP address, host name or other identifier of the event source.
Message 1D Enter the message group ID used to bypass header parsing.

Message Prefix  Enter the prefix added to each message to assist parsing.
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N

Event Select the NetWitness Log Collector or Log Decoder to which event needs to be
Destination * send from the drop-down list.

Test Checks the configuration parameters specified in this dialog to make sure they are
Configuration  correct.

Beats Event Source Parameters

The following table lists the beats event source parameters.

e o

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

Description Enter a text description for the event source.

Port Number*  Enter the port number (for example, 5044) that you configured for your event
sources.

Linux-Audit Select the checkbox to enable processing for Linux audit.

Linux-System  Select the checkbox to enable processing for Linux system.

Ngnix Select the checkbox to enable processing for Nginx.

Event Select the NetWitness Log Collector or Log Decoder to which event needs to be
Destination* send from the drop-down list.

Test Checks the configuration parameters specified in this dialog to make sure they are

Configuration  correct.

Export Connector Event Source Parameters

The following table lists the custom export connector event source parameters.

Mo Jowserptn

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Enabled Select the check box to enable the event source configuration to start collection.
The check box is selected by default.

Description Enter a text description for the event source.
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Host* Select the hostname of the Decoder or Log Decoder for data aggregation from the
drop-down list.

Username* Username used to access the Decoder or Log Decoder for data aggregation.

Authentication Note: If you upgrade from NetWitness Platform 11.6.0.0 to 11.6.1.0, automatic
key is generated and stored in the key store management for the password set in
Logstash pipeline configuration. You can view the key instead of password in the
Authentication field.

Select the authentication type used for data aggregation. By default, SSL field is
enabled, if you select trusted authentication.

Note: For trusted authentication, make sure you add the PEM file at
/etc/pki/nw/node/node-cert.pem to the source Decoders REST APIs
(/sys/trustpeer and /sys/caupload).

SSL Select the check box to communicate using SSL. The security of data transmission
is managed by encrypting information and providing authentication with SSL
certificates. By default, SSL option is enabled, if you select trusted authentication
type in the Authentication field.

Decoder Type*  Decoder Type is a read only field and it is auto populated when you select the Host.

Output Logstash pipeline output configuration to forward events received from input

Configuration*  stream to a defined destination/s. The output plugin sends the processed event data
to the data warehouse destinations. You can use the standard Logstash output
plugins to send the data. To understand more, see Work Flow of NetWitness Export
Connector.

A basic sample Logstash output TCP plugin would look like below.
output {
tep |
id => "nw-output-tcp"
host => "10.10.1.2"
port => 514

}

You can use any of the listed output plugins on Output plugins. We recommend
you check with your respective vendor to know the input receiver type (such as
TCP, HTTP) they support.

Test Checks the configuration parameters specified in this dialog to make sure they are
Configuration correct.
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HTTP Receiver Event Source Parameters

The following table lists the HTTP receiver event source parameters.

N

Name *

Enabled

Description

Port Number*

Device Type*

Message ID

Message
Prefix

Event
Destination*

HTTP
Receiver SSL

Certificate

Key

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.

Enter the port number that you configured for your event sources. The default value
of port number is 8080.

Enter the device parser type used to parse the data.
Enter the message group ID used to bypass header parsing.

Enter the prefix added to each message to assist parsing.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Select the checkbox to communicate using HTTP receiver SSL. The security of data
transmission is managed by encrypting information and providing authentication with
HTTP receiver SSL certificates. This checkbox is not selected by default.

Note: If you select the checkbox, the event source accepts SSL connections only.
Also, if you change this setting, you must stop and restart Syslog collection for the
change to become effective.

Select the name of the HTTP receiver server’s SSL certificate.

Select the name of the HTTP receiver server’s SSL key.

IPFIX Event Source Parameters

The following table lists the IPFIX event source parameters.

e

Name *

Enabled

Description

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.
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Port Number

Event
Destination *

Test
Configuration

Enter the port number that you configured for your event source. The default value
of port number is 4739.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

Kubernetes Event Source Parameters

The following table lists the Kubernetes receiver event source parameters.

Nome Jpeserpien

Name *

Enabled

Description

Port Number*

Event
Destination*

Test
Configuration

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.

Enter the port number that you configured for your event sources. The default value
of port number is 5044.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

JDBC Oracle 11g Auditing Event Source Parameters

The following table lists the JDBC Oracle 11g auditing event source parameters.

N

Name *

Enabled

Description

Host ID*
Port Number*

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.
Enter the IP address of the machine where the oracle 11g database server is installed.

Enter the port number that you configured for your event sources. The default value
of port number is 1521.
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Database
Name*

User ID*

Password*

Polling
Interval*

Event
Destination*

Test
Configuration

Enter the name of the database where the audit tables exists.

Enter the username of oracle 11g database.

Enter the password to log into the oracle 11g database.

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to
60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

JDBC Oracle 12c Auditing Event Source Parameters

The following table lists the JDBC Oracle 12¢ auditing event source parameters.

e

Name *

Enabled

Description

Host ID*
Port Number*

Database
Name*

User ID*

Password*

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.
Enter the IP address of the machine where the oracle 12¢ database server is installed.

Enter the port number that you configured for your event sources. The default value
of port number is 1521.

Enter the name of the database where the audit tables exists.

Enter the username of oracle 12¢ database.

Enter the password to log into the oracle 12¢ database.

&4



Log Collection Configuration Guide

e o

Polling
Interval*

Event
Destination*

Test
Configuration

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to
60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

JDBC Oracle 18c Auditing Event Source Parameters

The following table lists the JDBC Oracle 18c auditing event source parameters.

T EE

Name *

Enabled

Description

Host ID*
Port Number*

Database
Name*

User ID*

Password*

Polling
Interval*

Event
Destination*

Test
Configuration

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.
Enter the IP address of the machine where the oracle 18c database server is installed.

Enter the port number that you configured for your event sources. The default value
of port number is 1521.

Enter the name of the database where the audit tables exists.

Enter the username of oracle 18c database.

Enter the password to log into the oracle 18c database.

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to
60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.
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JDBC Oracle 19c Auditing Event Source Parameters

The following table lists the JDBC Oracle 19¢ auditing event source parameters.

e o

Name *

Enabled

Description

Host ID*
Port Number*

Database
Name*

User ID*

Password*

Polling
Interval*

Event
Destination*

Test
Configuration

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

Enter a text description for the event source.
Enter the IP address of the machine where the oracle 19¢ database server is installed.

Enter the port number that you configured for your event sources. The default value
of port number is 1521.

Enter the name of the database where the audit tables exists.

Enter the username of oracle 19c¢ database.

Enter the password to log into the oracle 19¢ database.

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to
60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

JDBC IBMDB2 Event Source Parameters
The following table lists the JDBC IBMDB2 event source parameters.

N

Name *

Enabled

Description

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the check-box to enable the event source configuration to start collection. The
check-box is selected by default.

Enter a text description for the event source.
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Host ID*
Port Number*

Database
Name*

User ID*

Password*

Polling
Interval*

Event
Destination*

Test
Configuration

Enter the IP address of the machine where the jdbc_ibmdb2 server is installed.

Enter the port number that you configured for your event source. The default value
of port number is 50000.

Enter the name of the database where the audit table exists.

Enter the username of jdbc_ibmdb2 database.

Enter the password to log into the jdbc_ibmdb2 database.

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to
60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

JDBC Custom Event Source Parameters

The following table lists the JDBC Custom event source parameters.

e

Name *

Enabled

Description

JDBC Driver
Library*

JDBC Driver
Class*

Host ID*
Port Number*

Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.

Select the check-box to enable the event source configuration to start collection. The
check-box is selected by default.

Enter a text description for the event source.

Enter the JDBC driver library path to interact with a database.

Enter the JDBC Driver class to interact with a database.

Enter the IP address of the machine where the Oracle server is installed.

Enter the port number that you configured for your event source. The default value
of port number is 1521.
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Database Enter the name of the database where the audit table exists.

Name*

User ID* Enter the username of Oracle database.

Password* Enter the password to log into the Oracle database.

Polling Polling interval takes the input in minutes. Based on the minutes entered, the
Interval* pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from the
database for every 1 minute. If the polling interval is 2, then the pipeline will pull the
data from the database for every 2 minute. This filed takes the values between 1 to

60.
SQL Enter the SQL statements based on the requirement. Here, the text area field will
Statement* also supports the new custom query.

Device Type*  Enter the device type of the event source used for parsing.

Message ID Enter the message group ID to bypass header parsing.

Message Prefix  Enter the prefix added to each message to assist parsing.

Event Select the NetWitness Log Collector or Log Decoder to which event needs to be sent
Destination*® from the drop-down list.
Test Checks the configuration parameters specified in this dialog to ensure they are

Configuration  correct.

Advanced Parameters

Click ~ next to Advanced to view and edit the advanced parameters, if necessary.
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T S

Debug

Beats SSL
(This option is applicable only for beats typespec)

Caution: Only enable debugging (set this
parameter to On or Verbeose) if you have a
problem with an event source and you need to
investigate this problem. Enabling debugging
will adversely affect the performance of the Log
Collector.

Caution: Enables or disables debug logging for
the event source. Valid values are:

e Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds
thread information and source context
information to the messages.

This parameter is designed to debug and monitor
isolated event source collection issues. If you
change this value, the change takes effect
immediately (no restart required). The debug
logging is verbose, so limit the number of event
sources to minimize performance impact.

Select this checkbox to communicate using beats
SSL. The security of data transmission is
managed by encrypting information and providing
authentication with SSL certificates. This
checkbox is not selected by default.

Note: Ensure that you copy the server SSL
certificate and the key (generated in your
system) to /etc/logstash/pki on Log
Collector, which is used during SSL connection.
/etc/logstash/pki is a path in the Log
Collector node.
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Kubernetes SSL

(This option is applicable only for Kubernetes
typespec)

Certificate

(This option is applicable only for beats and
Kubernetes typespec)

Key

(This option is applicable only for beats and
Kubernetes typespec)

SSL Enabled

Export Logs

(This option is applicable only for export
connector typespec)

Starting Session

(This option is not applicable for export _connector
typespec)

Select this checkbox to communicate using
Kubernetes SSL. The security of data
transmission is managed by encrypting
information and providing authentication with
SSL certificates. This checkbox is not selected by
default.

Note: Ensure that you copy the server SSL
certificate and the key (generated in your
system) to /etc/logstash/pki on Log
Collector, which is used during SSL connection.
/etc/logstash/pki is a path in the Log
Collector node.

Select the name of a server SSL certificate located
at /etc/logstash/pki.

Select the name of a server SSL key located at
/etc/logstash/pki,

o For custom typespec - Select the checkbox to
communicate using SSL. The security of data
transmission is managed by encrypting
information and providing authentication with
SSL certificates. This checkbox is selected by
default.

o For beats typespec - Select the checkbox to
communicate using SSL. The security of data
transmission is managed by encrypting
information and providing authentication with
SSL certificates. This checkbox is selected by
default.

o For export connector typespec - Select the
checkbox for Logstash to communicate with
Packet Decoder and Log Decoder in SSL and
Non-SSL mode. This checkbox is not selected
by default.

Select the checkbox to export logs from Log
Decoders.

Specify the session ID from which you want to
start the aggregation from instead of the default.

90



Log Collection Configuration Guide
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Include Metas

(This option is not applicable for export connector
typespec)

Exclude Metas

(This option is not applicable for export connector
typespec)

Query

(This option is not applicable for export connector
typespec)

Enable Metrics Collection

(This option is applicable only for export
connector typespec)

Elastic Host (This option is applicable only for
export_connector typespec)

Elastic Port

(This option is applicable only for export
connector typespec)

Elastic Username

(This option is applicable only for export
connector typespec)

Elastic Password

(This option is applicable only for export
connector typespec)

Minutes Back

(This option is applicable only for export
connector typespec)

Persistent Queue
(This option is applicable only for export
connector typespec

Specify the list of metas separated by comma that
you want to aggregate. The default metas such as

time, did and sessionid are collected in addition to
the metas you added for aggregation.

Specify the list of metas separated by comma that
you want to exclude from aggregration.

Specify the query so the data matching the query
is only aggregated. For example, select * where
user.dst = 'john'.

Enables metrics collection in Elastic.

IMPORTANT: If you enable the metrics
collection, you must provide the Elastic host,
username, and password.

Specify the Elastic host to forward metrics.

Port number through which metrics are
forwarded.

Specify the name of the Elastic search.

Note: If you upgrade from NetWitness Platform
11.6.0.0 to 11.6.1.0, automatic key is generated
and stored in the key store management for the
password set in Logstash pipeline configuration.
You can view the key instead of password in
the Elastic Password field.

Specify the Elastic search password.

Starts collecting data from last xx minutes.

For example, if the value is set to 30 minutes, Log
Collector starts collecting the logs and metas
starting from last 30 minutes.

Persistent queue stores the message queue on disk
to avoid data loss. By default, this option is not
enabled.
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Additional Custom Configuration

Required Plugins

Pipeline Workers

Ports

(This option is only applicable for custom
typespec and beats typespec)

Required Ports

(This option is not applicable for custom typespec
and beats typespec)

Exclude Metas

(This option is not applicable for export connector
typespec)

Query

(This option is not applicable for export _connector
typespec)

Use this text box for any additional configuration,
in case you have multiple inputs or another set of
outputs to send somewhere in addition to a
NetWitness Log Collector or Log Decoder.

For example, you can configure the data to be
sent to Elasticsearch. In this case each event that
is sent to Netwitness Platform will also be send to
Elasticsearch.

Specify the required plugins in a comma
separated list.

Note:

- Backup and restore is not supported for
custom plugins.

- If the test connection failed due to required
plugin is not installed, you must install the
required plugin, for more information, see
Install or Manage Logstash Plugin.

Number of pipeline worker threads allocated for
logstash pipeline.

Enter a port number (for example, 5000 or
UDP:5000, TCP:5000), and ensure the checkbox
is checked. This allows the plugins to collect logs
over the network (For example, UDP, TCP).

IMPORTANT: If you are configuring beats
event source, ensure you provide beats event
source port (For example, 5044) in the advance
configuration even if you have updated the port
in the basic parameters.

Enter the list of ports required for external access.

Specify the list of metas separated by comma that
you want to exclude from aggregration.

Specify the query so the data matching the query
is only aggregated. For example, select * where
user.dst = 'john'.
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Destination SSL (This option is only applicable
for cutom typespec, http_receiver typespec, ipfix
typespec, kubernetes typespec, jdbc_oracle 11g
auditing_typespec, jdbc_oracle 18c_auditing,
jdbc_oracle 19c_auditing typespec, ibmdb2
typespec and jdbc_custom typespec)

Custom SQL Statement (This field is applicable

only for jdbc_oracle 18¢ auditing typespec, jdbc

oracle 19¢ auditing typespec, jdbc oracle 11g
auditing_typespec and jdbc oracle 12c¢ auditing

typespec)

Legacy Codec
(This option is only
applicable for
custom typespec
and beats typespec)

Select the checkbox to communicate using
destination SSL.

By default, this is an empty text area field. This
field also supports the new custom query.

Select the check box to send events to Log
Decoder using legacy format. When selected, Log
Collector will send events to Log Decoder
embedded in JSON encoded Logstash events.
When not selected, Log Collector will send events
in the collected format.

System Maintenance Guide.

Note: You can monitor the health and throughput for Logstash pipeline using Logstash Input Plugin
Overview dashboard. For more information, see "New Health and Wellness Dashboards" topic in the

Note: The JDBC pipelines are supported only from 12.3 version onwards.

View logstash collection in the Investigation > Events view

To view logstash collection in the Events view
1. Gotothe Investigation > Events view.

2. Select a Log Decoder service

(for example, LD1) which collects logstash events, from the drop-down list.

3. Select the time range.

4. Click BN

5. Look for events with a device.type value that matches the one defined in the Logstash pipeline.

for full parsing.

Note: Though some meta are parsed by default, a custom parser or Log Parser Rules are required

Install or Manage Logstash Plugin

By default, Logstash related plugins are installed when Logstash is installed. In addition, you can add or

customize the plugins based on your requirement.
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List All Lostash Plugins

You can list all the Logstash plugins available on your environment using the following command:
/usr/share/logstash/bin/logstash-plugin list --verbose

Install New Logstash Plugin

You can install new plugin using the following command:
/usr/share/logstash/bin/logstash-plugin install <plugin-name>

For example, see the following command:
/usr/share/logstash/bin/logstash-plugin install logstash-input-github

Manage Logstash Plugin

You can manage the existing plugins using the following commands:
o To update all Logstash plugins:
/usr/share/logstash/bin/logstash-plugin update

o To update specific Logstash plugin:

/usr/share/logstash/bin/logstash-plugin update <plugin-name>

Configure Keystore Management

Keystore management allows you to securely store secret values (key and password). These keys are
used as a placeholder for authentication credentials within a Logstash pipeline configuration.

To configure keystore management:

A
1. Goto (ADMIN) > Services from the NetWitness Platform menu.
2. Select a Log Collection service.
5 -

3. Under Actions, select > View > Config to display the Log Collection configuration parameter

tabs.
4. Click the Event Sources tab.

b

In the Event Sources tab, select Logstash > Keystore management from the drop-down menu.

Click + .
In the key field, enter the name of the key.

In the password field, enter the password.

o ©° =N A

Click Save.
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Configure Netflow Event Sources in NetWitness

This topic tells you how to configure the Netflow collection protocol.

Configure a Netflow Event Source

To configure a Netflow Event Source:

A
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Select ;} “ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVENT SOURCES EMDPOINT SOURCES HEALTH & WELLMNESS
& Change Service | i Log Collector |  Config &
General Remote Collectors Files Event Sources JESYEdbRlEIlo]gks settings Appliance Servicd
|| hd | Config v
Check Point
File =)
MNetflow
1 ODBC
* Plugins
SDEE
SNMP
VMware
Windows

5. In the Event Sources tab, select Netflow/Config from the drop-down menu.

.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select the netflow event source type and click OK.
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Available Event Source Types

Cancel

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click in the Sources toolbar.
The Add Source dialog is displayed.

9. Enter a port number in the Port field, and ensure the Enabled box is checked.

Note: NetWitness opens the 2055, 4739, 6343, and 9995 ports on the firewall by default. You can
open other ports for Netflow if required.

For details of other parameters, see Netflow Collection Parameters below.

10. Click OK.

The new event source is displayed in the list.

Netflow Collection Parameters

The following table provide descriptions of the basic Netflow Collection parameters.

oo i

Port Specify the port number configured for the Netflow event source.
NetWitness opens the 2055, 4739, 6343, and 9995 ports for Netflow by default. You can
open other ports for Netflow if required.

Enabled  Select the check box to enable the event source configuration to start collection. The check
box is selected by default.

Cancel Closes the dialog without making adding an event source type.
OK Adds the parameters for the event source.

The following table provide descriptions of the advanced Netflow Collection parameters.
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InFlight Establishes a threshold that, when reached, NetWitness generates a log message to help
Publish Log you resolve event flow issues. The Threshold is the size of the netflow event messages
Threshold  currently flowing from the event source to NetWitness .

Valid values are:
¢ (0 (default) - disables the log message.

¢ 100-100000000 - generates a log message when this Log Collector has
processed the specified number of netflow events. For example, if you set this
value to 100, NetWitness generates a log message when 100 netflow events of
the specific netflow version (v5 or v9) have been processed.

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you have a
problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector .

Enables or disables debug logging for the event source.

Valid values are:
e Off = (default) disabled

¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).

ODBC

Configure ODBC Event Sources in NetWitness
This topic tells you how to configure ODBC collection protocol which collects events from event

sources that store audit data in a database using the Open Database Connectivity (ODBC) software
interface.

Deployment Scenario

The following figure illustrates how you deploy the ODBC Collection Protocol in NetWitness.
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Intranet

Open Database
Connectivity (ODBC)

event sources

= e
Qracle
Other DBs

(Local and
Remote |
Collectors)

*In Log Collection, Remote Collectors send
events to the Local Collector and the Local
Collector sends events to the Log Decoder.

Configure an ODBC Event Source

To configure an ODBC event source, you need to configure an event source type, and also choose a
DSN template.

Configure a DSN

The following procedure describes how to add a DSN from an existing DSN template. For other
procedures related to DSNs, see Configure Data Source Names (DSNs).

Configure a DSN (Data Source Name):

L.
2.

Q
Go to (Admin) > Services.

In the Services grid, select a Log Collector service.

Click = JC under Actions and select View > Config.
In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
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5. The DSNs panel is displayed with the existing DSNs, if any.

6. Click + to open the Add DSN dialog.

7. Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use the
name when you set up the ODBC event source type.) If required, click (4 Manage Templates ¢, o4 or

delete DSN templates.

8. Fill in the parameters and click Save.

Add an Event Source Type

For details on parameters used in the following procedure, see ODBC Event Source Configuration
Parameters.

To configure an ODBC Event Source Type:

QA
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬂ “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVENT SOURCES EMDPOINT SOURCES HEALTH & WELLMNESS
~+ Change Service | 3 Log Collector | Config
General Remote Collectors Files Event Sources JESYEdbRlEIlo]gks settings Appliance Servicd
|| hd | Config v
Check Point
File =)
MNetflow
1 ODBC
* Plugins
SDEE
SNMP
VMware
Windows
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5. In the Event Sources tab, select ODBC/Config from the drop-down menu.

6. In the Event Categories panel toolbar, click
The Available Event Source Types dialog is displayed.

Available Event Source Types

L] mame ~
IBMDB2
actiance
actividentity
asels

bigfix

bitg

bitgw72
bmcremedyitsm
ciscolmsaudit

ciscolmsfault

O ooogooogodgaoo

cisconcm

Cancel

0K

=+

7. Select an event source category (for example mssql and click OK.

The newly added event source type is displayed in the Event Categories panel.

8. Select the new type in the Event Categories panel and click

The Add Source dialog is displayed.

in the Sources toolbar.
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Add Source

Basic
DSN * v
Username *
Password
Enabled £4
Address *

Advanced
Max Cell Size 2048 o]
Nil Value (null)
Polling Interval 180 ]
Max Events Poll 5000 ]
Debug Off v
Initial Tracking Id
Test Connection

Cancel 0K

9. Select a DSN from the drop down list, specify or modify the other parameters as required, and click
OK.

10. Click Test Connection.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the
DSN information and retry.

Note: Log Collector takes approximately 60 seconds to return the test results. If it exceeds the time
limit, the test times out and the NetWitness server displays an error message.

11. If the test is successful, click OK.
The newly defined DSN is displayed in the Sources panel.

Configure Data Source Names (DSNs)

This topic tells you how to create and maintain DSNs for ODBC Collection.

Context

Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you need to
define DSNs with their associate value pairs for ODBC event source configuration.

Navigate to the DSN Panel

To add or edit DSNs or DSN templates, first navigate to the appropriate screen.
To navigate to the DSN templates panel:

A
1. Goto (Admin) > Services.

2. In the Services grid, select a Log Collector service.

3. Click ﬁ " under Actions and select View > Config.
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4. In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
The DSNs panel is displayed with the DSNs that are added, if any.

# Change Service | - Log Collector | Config
General Remote Collectors Files Event Sources [MSVEHIRMESGEelg Settings  Appliance Service Co
ODBC v || DSNs v
o ] Manage Templates
DSN ~ Parameters
DSNSample Database=MSSQLHost, Driver=/opt/netwitness/odbc/lib/R3sqls27.s0, PortNumber=1433, HostName=localhost

From this screen, you can perform the following actions:
¢ Add a new DSN template

e Add a DSN from an existing template

* Add a DSN by editing an existing DSN template

e Remove a DSN or DSN template

Add a New DSN Template

If none of the predefined DSN templates fit your needs, use this procedure to add a DSN template.

1. From the DSNs panel, click 2 Manage Templates

The Manage DSN Templates dialog is displayed.
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+ =

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DB2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Tempil...
MySQL_Server_Unix_Template
Oracle_Server_Windows_Template
Oracle_Server_Unix_Template
Oracle_Native_Windows_Template
Oracle_Mative_Unix_Template

PostgresSQL_Windows_Template

OO0O0oOoDo0OooOoooooogoo O

PostgresSQL_Unix_Template

Close

Note: NetWitness provides default templates on the left side panel that you can use while adding a
new DSN.

.

2. Click .
The right panel is activated.

3. Specify a template name and click on the right panel to add parameters.

4. Specify the parameters. Click Save.
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Manage DSN Templates

Template Name : MS5QL_Server_Windows_Template + =
[ Name Value
¥ HostName ’ http://testServer/home
[0 PortNumber 1433
[ Database MS5QLHost
[ Driver Jopt/netwitness/odbc/lib/R3sqls27.50
Cancel Save Close

The new DSN template is added in the Manage DSN Templates list.

Add a DSN from an existing template

You can select an existing template, and fill in the parameters for your needs.

1. From the DSNs panel, click + to open the Add DSN dialog box.
The Add DSN dialog is displayed with existing DSNGs, if any

2. Choose a DSN Template from the drop down menu and enter a name for the DSN. (You use the
name when you set up the ODBC event source type.)

3. Fill in the parameters and click Save.
Your DSN is added to the list of DSNs.

Add a New DSN by editing an existing DSN template

You can add a DSN by updating an existing DSN template to fit your needs.

1. From the DSNs panel, click (4 Manage Templates

The Manage DSN Templates dialog is displayed.
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+ =

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DB2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Tempil...
MySQL_Server_Unix_Template
Oracle_Server_Windows_Template
Oracle_Server_Unix_Template
Oracle_Native_Windows_Template
Oracle_Mative_Unix_Template

PostgresSQL_Windows_Template

OO0O0oOoDo0OooOoooooogoo O

PostgresSQL_Unix_Template

Close

2. Select the existing template that you want to modify.

The right panel is activated, and the default parameters for the selected template are displayed.
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Add DSN

OsM Mame*

Parameters
= -
Mame
PortNumber
HostMame
Database

Driver

D5SM Temnplate | EMC_Greenplurn_Unix_Template

= |

Value
5432
GreenplumServer

Gplumdb

ODBCHOME/ibfoxgplmnn.zz

Cancel Save

A

Specify a name in the DSN Name field.
Add, delete or edit the default parameters.

Once you have the set of required parameters, click Save, then Close.

Choose the DSN Template that you updated from the drop down menu and enter a name for the

DSN. (You use the name when you set up the ODBC event source type.)

7. Fill in the parameters and click Save.

Your DSN is added to the list of DSNSs.

Remove a DSN or DSN template

If you no longer use a DSN or a DSN template, you can remove it from the system.

To remove an existing DSN:

1. From the DSNs panel, select an existing DSN.

2. Click =.

A Warning message appears, asking whether you are sure you want to delete the DSN.

3. To delete the DSN, click Yes. Alternatively, to cancel the deletion, click No.

If you confirmed the deletion, the selected DSN is removed from the system.
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To remove an existing DSN Template:

1. From the DSNs panel, click (4 Manage Templates

The Manage DSN Templates dialog is displayed.

Manage DSN Templates

+ -

|

Template Name
EMC_Greenplum_Unix_Template
EMC_Greenplum_Windows_Tem...
IBM_DB2_Unix_Template
IBM_DBE2_Windows_Template
IBM_DB2_Zos_Template
MSSQL_Server_Windows_Templ...
MSSQL_Server_Unix_Template
MySQL_Server_Windows_Templ...
MySQL_Server_Unix_Template
Oracle_Server_Windows_Template
Oracle_Server_Unix_Template
Oracle_Native_Windows_Template
Oracle_Mative_Unix_Template

PostgresSQL_Windows_Template

Oo0Oo0ooooooooooood

PostgresSQL_Unix_Template

2. From the DSNs panel, select an existing DSN Template.
Click =—.
A Confirmation message appears, asking whether you are sure you want to delete the DSN Template.

4. To delete the DSN Template, click Yes. Alternatively, to cancel the deletion, click No.

If you confirmed the deletion, the selected DSN Template is removed from the system.

Configure device.ip meta for ODBC Data Source

For any ODBC event source, you can choose to have the ODBC collector populate the device.ip meta
value with either the event source IP address or the actual source IP on which logs are being collected.

To view or set this parameter:
1. Go to ADMIN > Services.

2. In the Services grid, select a Log Collector service.

3. Click ﬁ ~ under Actions and select View > Explore.

4. Navigate to logcollection > odbc > eventsources.
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There are entries for each ODBC event source that you have configured in NetWitness. For example,
for this installation, the only ODBC event source currently configured is MS SQL.:

| I Log- Collector |

+ Change Service

Explore &

= Log - Collector (Log C...

L) =l =gl e )

rﬂErlcg:oIIec:'or‘ A

B checkpoint

B[] crndscript

| file

B[] netflow

B edbe
B[] destinations 14
B eventsources

-

! Log - Collector {Log Caollector)

connections
event-broker
EVENT-processors
logeallection

logs

rest

sdk

services
storedproc

sys

users

£ Change Service | Log - Collector

Click + next to an event source to expand it and see its DSN entry.

|  Explore &

= Log - Collector (Log C...

Ll I =4 IL'|.|' ULCESUNS
B legeollection
B[] checkpoint
B[] cmdscript
@Al
B[] netflow
B cdbe
B[] destinations I
B eventsources
B mssql

[ Test DsN

flogcollection/odbc/eventsources/mssql Log - Collector (Log Collector)

Test_DSN
20180205T125526

Createc_at

created_by User admin (session 255620, 10,10

EVENTSOUrce_type ITIEEC||

6. Click the DSN entry (in this example Test DSN) to show the parameters.

7. The use_eventsource_address parameter is listed.
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£, Change Service | Log - Collector

Explore &

= log - Collector (Log C...

flogcollectionfodbc/eventsources/mssql/ Test_DSN

Log - Collector {Log Collector)

o everCprocessors created_at 20180205T123832
-
B & logcollection created_by User admin (session 255774, 10.101.32.172:52140)
- 0
B[] checkpaint debug v
B[] cmdscript osn Test_DSN
a[dle enabled true
event_filter
B[] netflow -
event_filter_debu, 0
B odbe - - s
eventsource_address 1.1.1
B[ destinations -
file_name file_template
B {5 eventsources
initial_tracking_id
B mssql
max_cell_size 2048
[ Test_DsN
max_events_per_cycle 150000
B[ stats
name Test_DSN
[Jwerkmanager
nil_value {(null)
B[ sdee
node_type workgroup
B[] snmptrap o
pass-.u\,crc *hhkHAA IR
B[ syslog o Y on
polling_interval 180
B[ vmware X o
typespec_version 1.0
windows
i use_eventsource_address false
logs
[logs » [ username test-user

¢ False: actual source IP address is used. This is the default value.
¢ True: event source IP address is used.

8. Click on the value (in this case False), and type in the new value.

Note: If you type anything other than true or false (case does not matter), you receive an error
saying that the value you entered cannot be set.

Any changes you make take effect immediately.

Create Custom Typespec for ODBC Collection

NetWitness uses type specification (typespec) files for ODBC and file collection. These files act on raw
log files, and are used for two main purposes:

» Define where in the log file data resides. For instance, some log files contain header information that
is not considered data to be parsed.

e Replace certain types of characters that the log parser cannot parse correctly. For instance, the tab
character can sometimes cause problems.

This topic tells you how to create a custom typespec for the Log Collector. The topic includes:

e Create Custom typespec procedure

e ODBC Collection typespec syntax
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e Sample ODBC Collection typespec files

Create Custom Typespec

To create a custom typespec file:

1. Open an SFTP client (for example, WinSCP) and connect to a Log Collector or remote Log

Collector.

2. Navigate to /etc/netwitness/ng/logcollection/content/collection/odbc, and copy an
existing file, for example bit9.xml.

3. Modify the file according to your requirements. See ODBC Collection Typespec Syntax for details.

4. Rename and save the file to the same directory.

5. Restart the Log Collector.

Collector.

Note: You will not be able to see new Event Source type in NetWitness until you restart the Log

ODBC Collection Typespec Syntax

The following table describes the typespec parameters.

name

type
prettyName

version
author

description

parser

name
maxVersion

description

The display name of your ODBC event source (for example, activeidentity). NetWitness
displays this name in the Sources panel of the View > Config > Events Sources tab.

Valid value is an alphanumeric string. You cannot use - (dashes), _(underscores), or spaces.
The name must be unique across all typespec files in the folder.

Event source type: odbc. Do not modify this line.

User-defined name for the event source. You can use the same value as name (for example,
apache) or use a more descriptive name.

Version of this typespec file. Default value is 1.0.
Person who created the typespec file. Replace author-name with your name.

Formal description of the event source. Replace formal-description with your description of
the event source.

<device> Section

This optional parameter contains the name of the log parser. This value forces the Log
Decoder to use the specified log parser when parsing logs from this event source.

Note: Please leave the field blank when unsure of the log parser to be used.

Name your ODBC event source (for example, Actividentity ActivCard AAA Server).
The version number of the event source (for example, 6.4.1).
Description of the event source.

<collection> Section
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odbc The syntax under <odbc> is used for event collection and processing. You can provide multiple
queries for the same event source type by adding <query> tags.

query This section contains the details of the query used to collect information from the event
source.
tag The prefix tag you want to add to events during transformation (for example Actividentity).
outputDelimiter Specify the delimiter to use to separate fields. Specify any of the following values:
* |l (piping)
e " (caret)

e , (comma)
e : (colon)

¢ (0x20 (to represent a space)

interval Specify the number of seconds between events. Default value is 60.
dataQuery Specify the query to fetch data from the ODBC eventsource database for SQL-syntax. For
example:

SELECT acceptedrejected, servername, serveripa, sdate,
millisecond, suid, groupname, ipa, reason, infol, info2,
threadid FROM A AHLOG WHERE sdate > 'STRACKING%' ORDER BY
sdate

maxTrackingQuery The query used on the initial pull of events to identify the starting point within the data set to
begin pulling logs from. After the initial pull, this query is no longer used, unless the
maxTracking value has been reset or altered. For example:

SELECT MAX (Event Id) from ExEvents

trackingColumn The tracking column value used when the ODBC collector pulls a new set of events.

Sample ODBC Collection Typespec Files

The following sample is the typespec file for the IBM ISS SiteProtector event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

<name>siteprotector4 x</name>
<type>odbc</type>
<prettyName>SITEPROTECTOR4 X</prettyName>
<version>1.0</version>
<author>Administrator</author>

<description>Collects events from SiteProtector</description>

<device>
<name>Internet Security Systems, Inc. RealSecure SiteProtector v 2.0</name>

<maxVersion>2.0</maxVersion>
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<description></description>
<parser>iss</parser>

</device>

<configuration>

</configuration>

<collection>
<odbc>
<query>
<tag></tag>
<outputDelimiter></outputDelimiter>
<interval></interval>
<dataQuery></dataQuery>
<maxTrackingQuery></maxTrackingQuery>
<trackingColumn></trackingColumn>
<levelColumn></levelColumn>
<eventIdColumn></eventIdColumn>
<addressColumn></addressColumn>
</query>
</odbc>
</collection>

</typespec>
The following sample is the typespec file for the Bit9 Security Platform event source.

<?xml version="1.0" encoding="UTF-8"?>

<typespec>

<name>bit9</name>
<type>odbc</type>
<prettyName>BIT9</prettyName>
<version>1.0</version>
<author>Administrator</author>

<description>Bit9 Events</description>

<device>
<name>Bit9</name>
<parser>bit9</parser>

</device>

<configuration>

</configuration>
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<collection>
<odbc>

<query>
<tag>BIT9</tag>
<outputDelimiter>| |</outputDelimiter>
<interval>10</interval>
<dataQuery>
SELECT
Timestamp,
Event Id,
Computer Id,
File Catalog Id,
Root File Catalog Id,
Priority,
Type,
Subtype,
IP Address,
User Name,
Process,
Description
FROM
ExEvents
WHERE
Event Id > '$TRACKING%'
</dataQuery>
<trackingColumn>Event Id</trackingColumn>
<maxTrackingQuery>SELECT MAX (Event Id) from ExEvents</maxTrackingQuery>
<eventIdColumn></eventIdColumn>

</query>

</odbc>
</collection>

</typespec>

Troubleshoot ODBC Collection

You can troubleshoot problems and monitor ODBC collection by reviewing the ODBC collector log
informational, warning, and error messages to during execution of collection.

Each ODBC log messages includes the:
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e Timestamp
* (ategory: debug, info, warning, or failure
e collection method = 0dbcCollection

¢ ODBC event source type (GOTS-name) = Generic ODBC Type Specification name that you
configured for the event source.

* collection function completed or attempted (for example, [processing])

¢ ODBC event source name (DSN-name) = Data Source Name that you configured for the event source.
¢ description (for example, how many events the Log Collector collected)

e tracking ID = the Log Collector position in the target database table.

The following example illustrates the message you would receive upon successful collection of an
ODBC event:

2014-July-25 17:21:25 info (OdbcCollection) : [event-source] [processing]
[event-source] Published 100 ODBC events: last tracking id: 2014-July-25
13:22:00.280

The following example illustrates a message you may receive upon unsuccessful collection of an ODBC
event:

timestamp failure (OdbcCollection: [event-source] [processing]
Log [event-source-type] Failed during doWork: Unable to prepare
Message statement: state: S0002; error-code:208; description: [RSA] [ODBC-
driver] [event-source-type]Invalid object name 'object-name'.
Possible ODBC collection failed while accessing the ODBC Driver or the target database.
Cause
Solutions Validate the DSN value pairs for the events source.

Configure SDEE Event Sources in NetWitness
This topic tells you how to configure the SDEE collection protocol.
To add an SDEE Event Source:

Q
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select 'I} “ > View > Conlfig to display the Log Collection configuration
parameter tabs.
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4. Click the Event Sources tab.

NETWITNESS

HOSTS SERVICES EVENT SOURCES EMDPOINT 5¢ CES & WELLNESS

& Change Service | D) Log Collector | Canfig
General Remote Collectors Files Event Sources JESUEgidslSuaEl{o T Settings
|| v | Config v
Check Point
File S
Metflow
1 ODBEC
| Plugins
SDEE
SNMP
VMware
Windows

5. In the Event Sources tab, select SDEE/Config from the drop-down menu.
The Event Categories panel displays the SDEE event sources that are configured, if any.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select an event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
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8. Select the new type in the Event Categories panel and click

The Add Source dialog

is displayed.

in the Sources panel toolbar.

Basic

Mame *
Username *
Password *
Addrass *
Enabled

Certificate Name

Port

S5L Version

Include Raw Event Data |
Save Raw XML Files
Saved File Quota

Subscription Event
Types
Force Subscription

Subscription Severity

Filter

Subscription Time
Offsat

Polling Interval
Max Events Poll
Query Timagut
URL Parameters
URL Path

URL Protocol

Debug

ApacheSimulatorHost
AT

ERsREEEEEEERES

simw

]

(¥

'
4.

tlswi

100 Megabyte

fcgi-binfsdee-server
hittps

On

L4

L3

£ £}

9. Add a Name, Username, Address, and Password, and modify any other parameters that require

changes, and click OK.
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Configure SNMP Event Sources in NetWitness

This topic tells you how to configure the SNMP collection protocol.

Configure the SNMP Trap Event Source

To add the SNMP Event Source:

Note: If you have previously added the snmptrap type, you cannot add it again. You can edit it, or
manage users.

. Go to K& (Admin) > Services from the NetWitness menu.

—_—

2. Select a Log Collection service.

3. Under Actions, select ﬂ © > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

NETWITNESS

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS

& Change Service | D) Log Collector | Config ©
General Remote Collectors Files Event Sources JESUEidlSailaENo Settings

|| v | Config v

Check Point

File S

Metflow
1 ODBC
| Plugins

S5DEE

SNMP

VMware

Windows

5. In the Event Sources tab, select SNMP/Config from the drop-down menu.

.

6. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
7. Select the snmptrap event source type and click OK.

The newly added event source type is displayed in the Event Categories panel.
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8.

9.
10.

Select snmptrap in the Event Categories panel.

Select snmptrap in the Sources panel and then click the Edit icon, lj, to edit the parameters.
Update any of the parameters that you need to change and click OK.

(Optional) Configure SNMP Users

If you are using SNMPv3, follow this procedure to update and maintain the SNMP v3 users.

To configure SNMPv3 Users:

1.
2.

Q
Go to (Admin) > Services.

In the Services grid, select a Log Collector service.

3. Click ﬁ ~ under Actions and select View > Config.

In the Log Collector Event Sources tab, select SNMP/SNMP v3 User Manager from the drop-
down menu.

The SNMPv3 User panel is displayed with the existing users, if any.

Click + to open the Add SNMP User dialog.

Fill in the dialog with the necessary parameters. The available parameters are described below.

SNMP User Parameters

The following table describes the parameters that you need to enter when you create an SNMPv3 user.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Username * User name (or more accurately in SNMP terminology, security name). NetWitness

uses this parameter and the Engine ID parameter to create a user entry in the SNMP
engine of the collection service.

The Username and Engine ID combination must be unique (for example,
logcollector).

Engine ID (Optional) Engine ID of the event source. For all event sources sending SNMP v3

traps to this collection service, you must add the username and engine id of the
sending event source.

For all event sources sending SNMPv3 informs, you must add just the username
with a blank engine id.
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Authentication  (Optional) Authentication protocol. Valid values are as follows:

Type o None (default) - only security level of noAuthNoPriv can be used for traps sent
to this service

e SHA - Secure Hash Algorithm
o MDS - Message Digest Algorithm

IMPORTANT: DO NOT USE: do not select MDS5, as it conflicts with the
Log Collector running in FIPS mode.

Authentication  Optional if you do not have the Authentication Type set. Authentication
Passphrase passphrase.

Privacy Type (Optional) Privacy protocol. You can only set this parameter if Authentication Type
parameter is set. Valid values are as follows:

o None (default)
e AES - Advanced Encryption Standard
o DES - Data Encryption Standard

IMPORTANT: DO NOT USE: do not select DES, as it conflicts with the Log
Collector running in FIPS mode.

Privacy Optional if you do not have the Privacy Type set. Privacy passphrase.

Passphrase

Close Closes the dialog without adding the SNMPv3 user or saving modifications to the
parameters.

Save Adds the SNMPv3 user parameters or saves modifications to the parameters.

Configure Syslog Event Sources

This topic tells you how to configure Syslog event sources for the Log Collector.

Note: Prior to NetWitness 11.3, you did not configure Syslog Collection for Local Log Collectors:
syslog collection was only configurable for Remote Collectors. You can configure Syslog for local
Log Collectors that are on version 11.3 or later.

Configure a Syslog Event Source

For Remote or Virtual Log Collectors, syslog listeners for UDP on port 514, TCP on port 514 and SSL
on port 6514 are created by default. You should not change the SSL settings on the TCP and SSL
listeners. If you need SSL certificate verification, create a new event source type to listen on a different
port.
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Note: For local Log Collectors, you cannot create syslog listeners on ports 514 and 6514: these ports
are used by the Log Decoder service.

To configure the Log Collector for Syslog collection:
QA
1. Goto (Admin) > Services.
2. In the Services grid, select a Log Collector, and from the Actions menu, choose ﬂ " > View >

Config.

3. Select the Event Sources tab.
4. Select Syslog/Config from the drop-down menu.

The Event Categories panel displays the Syslog event sources that are configured, if any.

Note: For NetWitness, some Syslog event sources are available by default. In this case, you can
proceed to step 6.

5. In the Event Categories panel toolbar, click .
The Available Event Source Types dialog is displayed.
6. Select either syslog-tep, syslog-udp or syslog-lengthprefix-tcp. You can set up either or all,

depending on the needs of your organization. You can select syslog-lengthprefix-tcp when the logs
have Length prefix field in the log.

7. Select the new type in the Event Categories panel and click in the Sources panel toolbar.
The Add Source dialog is displayed.

8. Enter the port number, and select Enabled. Optionally, configure any of the Advanced parameters as
necessary.

Click OK to accept your changes and close the dialog box.

Once you configure one or both syslog types, the Log Decoder or Log Collector collects those types of
messages from all available event sources. So, you can continue to add Syslog event sources to your
system without needing to do any further configuration in NetWitness.

Character Encodings
For each protocol (TCP, UDP), you need to instantiate a separate syslog listener for each character
encoding.

For example, assume that you have legacy event sources sending syslog in UDP and TCP with EUC-KR
and EUC-JP encodings. You would need to configure four listeners for the Log Collector, and configure
the syslog event sources to send to separate ports as follows:

e UDP <port1> for EUC-KR
e UDP <port2> for EUC-JP
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e TCP <port3> for EUC-KR
e TCP <port4> for EUC-JP

Alternatively, you could use separate Remote/Virtual Log Collectors, each using the default port 514.

Syslog Parameters

The following tables describe the available basic and advanced parameters for Syslog configuration.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Basic Parameters

N

Port* Enter the port number that you configured for your event sources.

Enabled Select the check box to enable the event source configuration to start collection. The
check box is selected by default.

SSL Receiver Note: This parameter applies to NetWitness version 11.1 and later. This option is
only available for the syslog-tcp and syslog-lengthprefix-tcp event categories.

If you select the check box, the event source accepts SSL/TLS connections only.
Also, if you change this setting, you must stop and restart Syslog collection for the
change to become effective.

Advanced Parameters

e o

Inflight Establishes a threshold that, when reached, NetWitness generates a log message to help
Publish Log you resolve event flow issues. The Threshold is the size of the syslog event messages
Threshold currently flowing from the event source to NetWitness.

Valid values are:
¢ 0 (default) - disables the log message

¢ 100-100000000 - generates log message when the syslog event messages currently
flowing from the event source to NetWitness are within the 100 to 100000000 byte
range.

Maximum  Maximum number of receiver resources used to process collected syslog events. The
Receivers default value is 2.

Event Filter Select a filter.
Refer to Configure Event Filters for a Collector for instructions on how to define filters.
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e o

Debug

Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you

have a problem with an event source and you need to investigate this problem.

Enabling debugging will adversely affect the performance of the Log Collector.
Enables or disables debug logging for the event source.

Valid values are:
e Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
The debug logging is verbose, so limit the number of event sources to minimize
performance impact.

If you change this value, the change takes effect immediately (no restart required).

Encoding Character encoding used by the syslog senders to this port. Defaults to UTF-8.

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as well,
and most senders have their encoding set to UTF-8.

NetWitness has tested the following values:
* EUC-KR

SJIS

GB3212/GBK

ISO _8859-1 (German)

ISO_8859-7 (Greek)
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e o

SSL Verify
Mode

Certificate
Directory
Path

Note: This parameter applies to NetWitness version 11.1 and later. This option is only
available for the syslog-tcp and syslog-lengthprefix-tcp event categories.

This setting is relevant only if the SSL. Receiver setting is selected. If you change the
SSL Verify Mode, you must stop and restart Syslog collection for the change to become
effective.

Available options:

 verify-none: (default) The server does not verify the client's certificate, if any. A
client can connect without presenting a certificate.

o verify-peer: The server verifies the client's certificate, if any. A client can connect
without presenting a certificate.

Note: If verification fails, a warning is logged but the messages will still be
accepted.

o verify-peer-fail-if-no-cert: The client must present a certificate and the server will
verify it.

Note: If you use this mode, the client's CA certificate must be uploaded to the Log

Collector's truststore using the REST APl at http://LC-ip-
address:50101/sys/caupload

You can configure custom certificates for the syslog listener on Log Collectors. For
details, see (Optional) Configure Custom Certificates on Log Collectors.

Note: This option is only available for the syslog-tcp and syslog-lengthprefix-tcp
event categories.

Configure VMware Event Sources in NetWitness

This topic tells you how to configure the VMware collection protocol.

To add a VMware Event Source:

A
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ © > View > Config to display the Log Collection configuration
parameter tabs.
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4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVEMT SOURCES ENDPOINT 5OURCES HEALTH & WELLNESS
% Change Service | D) Log Collector |  Config
General Remote Collectors Files Event Sources QS E{ Settings  Appliance Service
|| v | Config v
Check Point
File 3
Netflow
{ ODBC
| Plugins
SDEE
SNMP
Viware
Windows

5. In the Log Collector Event Sources tab, seclect VMware/Config from the drop-down menu.

The Event Categories panel displays the VMware event sources that are configured, if any.

6. Click + to open the Available Event Source Types dialog.

Available Event Source Types

L] MName ~
[ wvmware-events

[l wmware-tasks

Cancel OK
7. Select vmware-events or vmware-tasks from the Available Event Source Types dialog and click

OK.

The VMware available event source types are as follows:

e vmware-events: Setup vmware-events to collect events from vCenter Servers and ESX/ESXi
servers.

* vmware-tasks: (Optional) Setup vmware-tasks to collect tasks from vCenter Servers.

8. Select the new type in the Event Categories panel, and click + in the Sources toolbar.
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9. Add a Name, Username and Password, and modify any other parameters that require changes.
Caution: If you need to enter the domain name as part of the Username, you must use a double-
backslash as a separator. For example, if the domainjusername is corp\smithj, you must specify
corp\\smithj.

10. Click OK to save your changes.

Configure Windows Event Sources in NetWitness

This topic tells you how to configure the Windows collection protocol.

In NetWitness, you need to configure the Kerberos Realm, and then add the Windows Event Source
type.

To configure the Kerberos Realm for Windows collection:

4
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬂ ~ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

NETWITNESS
HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS
& Change Service | EE} Log Collector | Config &
General Remote Collectors Files Event Sources JESUEgidslSuaEl{o T Settings
|| v | Config v
Check Point
File S
Meatflow
1 ODBEC
| Plugins
SDEE
SNMP
ViMware
Windows

5. Select Windows/Kerberos Realm from the drop-down menu.

6. In the Kerberos Realm Configuration panel toolbar, click to add a new realm.
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The Add Kerberos Domain dialog is displayed.

7. Fill in the parameters, using the guidelines below.

Kerberos Enter the realm name, in all caps. For example, DSNETWORKING.COM. Note that the
Realm Name Mappings parameter is automatically filled with variations on the realm name.

KDC Host Enter the name of the Domain Controller. Do not use a fully qualified name here: just the host
Name name for the DC.

Note: Make sure that the log collector is configured as a DNS client for the corporate
DNS server. Otherwise, the Log Collector will not know how to find the Kerberos
Realm.

Admin Server (Optional) The name of the Kerberos Administration Server in FQDN format.

Mappings This parameter is automatically filled after you enter the realm name.

8. Click Save to add the Kerberos domain.

To add a Windows Event Source:

Q
1. Goto (Admin) > Services.

2. Select a Log Collection service.

3. Under Actions, select ﬁ' “ > View > Config to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.
5. In the Log Collector Event Sources tab, select Windows/Config from the drop-down menu.
The Event Categories panel displays the VMware event sources that are configured, if any.

Next, continue from the current screen to add a Windows Event Category and type.

To configure the Windows Event Type:

1. Select Windows/Config from the drop-down menu.

2. In the Event Categories panel toolbar, click to add a source.
The Add Source dialog is displayed.

3. Fill in the parameters, using the guidelines below.

Alias The windows domain, referred to as Alias, is the configuration parameter that the Log Collector
uses to group event sources. These event source type groups (for example, domain2,
domain3, and domain4) categorize the event sources you have configured.
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Authorization The authentication method. Valid values are:
Method

o Basic (default)

o Negotiate - Negotiates authentication between Kerberos and NTLM (Microsoft Windows
NT LAN Manager). For security reasons, NetWitness supports Kerberos exclusively. Select
this method.

Channel For most event sources that use Windows collection, you want to collect from the Security,
System, and Application channels.

This is a comma-separated list of channels from which NetWitness collects events. The default
value for this parameter is:

System, Application, Security

You can use parentheses to include and exclude event IDs. The exclude filter must have a *
between the channel name and the event ID. You must separate event IDs with a |.

For example, Application*(211|300), System(1010|1012) excludes the 211 and 300
Application events and includes the 1010 and 1012 System events.

A channel is a named stream of events that transports them from an event publisher to an
event log file. There are many predefined Windows channels. The following are examples of
some of these channels:

e System - applications that run under system service accounts (installed system services),
drivers, or a component or application that has events that relate to the health of the
system.

e Application - all user-level applications. This channel is unsecured and it is open to any
application. If an application has extensive information, you should define an application-
specific channel for it.

o Security - the Windows Audit Log (event log) used exclusively for the Windows Local
Security Authority.

User Name Enter the account name for the Windows user account that you set up earlier for
communicating with NetWitness. Note that you need to enter the full account name, which
includes the domain. For example, rsalog@DSNETWORKING . COM.

Note: For negotiate authentication, this must be the Kerberos principal name in the
name@kerberos_domain format. For example, logcollector@ LAB30.LOCAL.

Password Enter the correct password for the user account for the event source. The password is
encrypted internally and is displayed in its encrypted form.

Read All Events Select this box to read all historical event data from a channel.

¢ Unchecked (default) - Log Collector does not collect from all historical event data for a
specified channel.

e Checked - Log Collector collects from all historical event data from a specified channel.

Max Events Per (Optional). NetWitness recommends that you set this value to 0, which collects everything.
Cycle

Polling Interval  (Optional). For most users, a value of 60 should work well.
Render Events  Select this box to request rendered events from the event source.

e Checked (default) - Log Collector requests rendered events from the event source.

¢ Unchecked - Log Collector does not request rendered events from the event source.
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4. Click OK to add the source.
The newly added Windows event source is displayed in the Event Categories panel.
5. Select the new event source in the Event Categories panel.

The Hosts panel is activated.

6. Click + in the Hosts panel toolbar.

7. Fill in the parameters, using the guidelines below.

Event Source Enter the IP address or host name for the Windows host.

Address
Note: From 12.4 Onwards, NetWitness is depreciating the use of IP address for
basic authentication. If you are configuring basic authentication, you should use
a FQDN or host name and add the same entry in the '/etc/hosts'.

Port Accept the default value, 5985.

Transport Mode Enter http.

Enabled Ensure the box is checked.

8. Click Test Connection.

Note: You should be able to successfully test the connection, even if the Windows service is not
running.

For more information on any of the previous steps, see the following Help topics in the NetWitness User
Guide:

e Configure Windows Collection
* Microsoft WinRM Configuration Guide
e Test and Troubleshoot Microsoft WinRM Guide

Configure RFC5424 Format

The RFC5424 format is supported for all event types. This format is enabled through the ‘Enable
RFC5424° flag. The default value of this flag is ‘False’. It can be set to either ‘True’ or ‘False’ to enable
or disable RFC5424 respectively.

True Log is sent to Log Decoder in RFC5424 format

False Log is sent to Log Decoder in Z Connector format

Note: When the log is sent to Log Decoder in RFC 5424 format, the disk utilization for Netwitness
database is slightly higher and this may impact the data retention

To enable RFC5424 flag:
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1.

2.

3.

4.

Go to K&l (Admin) > Services from the NetWitness menu.

The Services panel displays the list of services.

NETWITNESS

Mama Name Licensed  Host Type Version Actions

I
&

Lo 2O - JONE - JNE - TS - JNE - AR - RN -

NETWITNESS  PLATFORM
Select a Log Collection service.

Click 'I} ~ > View > Explore.

NETWITNESS
HOSTS  SERV

%, Change Service | [ endpointioghybrid1 - Lt Explore =

NETWITNESS PLATFORM

On the left panel, go to (event-processors) > logdecoder > destinations > logdecoder > > >
processors > tecpconnector > config > connector > event
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NETWITNESS

9 loghybeid! - Log Collector

NETWITNESS PLATFORM

5. Click TCP connector RFC-5424 event payload (enable RFC2454).
6. Change the value to true to enable the flag.

7. Restart the Log Collector service.

Windows Legacy and NetApp Collection Configuration

This Windows Legacy protocol collects events from Windows Legacy (Windows 2003 or earlier event
sources) and CIFS Auditing events from NetApp ONTAP event sources.

You must deploy Log Collection, that is set up a Local Collector and Windows Legacy Remote
Collector, before you can configure the Windows Legacy collection protocol.

How Legacy Windows and NetApp Collection Works
You use the Windows Legacy collection protocol to configure NetWitnessto collection events from:
* Legacy Microsoft Windows event sources (Window 2003 and earlier event sources)

* NetApp event sources

Window 2003 and Earlier Event Sources

Legacy Windows event sources are older Windows versions (such as Windows 2000 and Window 2003).
The Windows Legacy collection protocol collects from Windows event sources that are already
configured for enVision collection without having to reconfigure them. You set up these event sources
under the windows event source type.
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NetApp Event Sources

NetApp appliances running Data ONTAP support a native auditing framework that is similar to
Windows Servers. When configured, this auditing framework generates and saves audit events in
Windows.evt file format. The Windows Legacy collection protocol supports collection of events from
such NetApp.evt files. You set up these event sources under the netapp_evt event source type.

The NetApp Data ONTAP appliance is configured to generate CIFS Auditing events and save them
periodically as.evt files in a format that includes the timestamp in the filename. Refer to the Network
Appliance Data ONTAP Event Source Configuration Guide on NetWitness Link for details. The
collection protocol saves the timestamp of the last processed.evt filename to keep track of collection
status.

Net App Specific Parameters

Most of the parameters that you maintain in Add/Edit Source dialog apply to both Windows Legacy and
Net App events sources.

The following two parameters are unique to NetApp event sources.

* Event Directory Path - The NetApp appliance generates event data and saves it in.evt files in a
shareable directory on the NetApp appliance. NetWitness requires you to specify this directory path in
the Event Directory Path parameter

* Event File Prefix - Similar to the Event Directory Path, NetWitness requires you to specify the prefix

(for example, adtlog.) of the event data.evt files so that NetWitness can process this data.

In each polling cycle, NetWitness browses the configured NetApp shared path for the .evt files that you
identified with the Event Directory Path and Event File Prefix parameters. NetWitness:

e Sorts Files matching the event-file-prefix.Y YMMDDhhmmss.evt format in ascending order.

* Uses the timestamp of the last file processed to determine the files that still need processing. If
NetWitness finds a partially processed file, it skips the events already processed.

Deployment Scenario
The Windows Legacy collection protocol collects event data from Windows 2003 or earlier, and NetApp

ONTAP appliance, event sources. The Windows Legacy Remote Collector is the SA Legacy Windows
Collector installed on physical or virtual Windows 2008 64-bit server in your event source domain.
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Set Up the Windows Legacy Collector

This topic tells you where to find the executable and instructions required to install or upgrade the
Windows Legacy collector in your Windows Legacy domain or domains.

You install the NetWitness Windows Legacy collector on a physical or virtual Windows 2008 R2 SP1
64-Bit server using the NW Legacy Windows Collector build number. You download the build number
from NetWitness Link. Please refer to the NetWitness Windows Legacy Collection Upgrade &
Installation Instructions for the details on how to install or upgrade Windows Legacy collection.

Note: The Microsoft Management Console (MMC) should be closed during the installation process.

Configure Windows Legacy and NetApp Event Sources

This topic tells you how to configure Windows Legacy event sources in NetWitness.

The Windows Legacy collection protocol collects event data from Windows 2003 or earlier event
sources, and from NetApp event sources.

Prerequisites

Before you configure a Windows Legacy event source, make sure that you have:
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1. Installed the NetWitness Windows Legacy Remote Collector on a physical or virtual Windows 2008
64-bit server.

2. Added this Windows Legacy Remote Collector to NetWitness.

Add a Windows Legacy Event Source

4
1. Access the Services view by selecting (Admin) > Services from the NetWitness menu.
2. In the Services grid, select a Windows Legacy Log Decoder service.
3. Under Actions, select ﬁ "~ > View > Conlfig to display the Log Collection configuration
parameter tabs.

4. Click the Event Sources tab.

5. In the Event Sources tab, select one of the following options from the drop-down menu.
¢ Windows Legacy/Windows.

e Windows Legacy/NetApp.
6. Configure the alias:

a. Click in the Event Categories panel toolbar.
The Add Source dialog is displayed.
b. Specify values for the parameters and click OK.

Basic
Alias * Domain-Alias
User Name * userl@domain.com

Password *

Advanced

Use Remote Registry 4
Initialization

Cancel

Note: By default, Remote Registry Initialization is selected. For details, see Remote Registry
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Access below.

The newly added windows event source type is displayed in the Event Categories panel.

7. Add the event source:

a. Select the new alias in the Event Categories panel and click in the Source panel toolbar.

The Add Source dialog is displayed.

b. Specify values for the event source parameters and click OK.

Basic

Mame * Domainsource

Event Source Address *

Event Log Mame * Security

Enabled ¥
Adwvanced

Event Buffer Size 100

Event Too Large Result  fail
Maximum Event Data |16
Max Events Per Cycle 0
Palling Interval 180

Debug Off

Kilobyte w
Kilobyte w
Ll
W
Ll
W

Cancel OK

For details, see Windows Legacy Configuration Parameters below.

The newly added Windows event source is displayed in the Event Categories panel.

Sources

+| — 4 & importSource

™~

v

* Export Source

Name Event Source Addr Event Log Name Event Ewent BufferS Maximum Ewve

Domainsource

Security fail 100 KB 16 KB
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Remote Registry Access

Windows Legacy Collector performs an initial verification of the event source before collecting data. By
default, Windows Legacy Collector uses Windows Management Instrumentation (WMI) method to
perform this initial verification. If you enable Remote registry access method, Windows Legacy
Collector performs a remote registry query to verify the event source.

Configure Push or Pull between Log Collector and Windows Legacy Collector

You can configure the Windows Legacy Collector to push event data to a Local Collector, or you can
configure a Local Collector to pull event data from the Windows Legacy Collector.

To configure a Local Collector or the Windows Legacy Collector:

a
1. Goto (Admin) > Services.
2. Select a Local Collector or the Windows Legacy Collection service.

3. Under Actions, select 'ﬁ "~ > View > Conlfig to display the Log Collection configuration
parameter tabs.

4. Depending on your selection in step 2:

¢ Ifyou selected a Local Collector, the Remote Collectors tab is displayed. Select the Windows
Legacy Collector from which the Local Collector pulls events in this tab.

¢ Ifyou selected a Windows Legacy Collector, the Local Collectors are displayed. Select the Local
Collectors to which the Windows Legacy Collector pushes events in this tab.

Windows Legacy Configuration Parameters

The following table describes the basic parameters for a Windows Legacy event source.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e e

Name* The name of the event source. Valid value is a name in the [_a-zZA-Z] [_a-zA-Z0-9]* range. You can use a
dash "-" as part of the name.

Event Source P address of the event source. Valid value is an IPv4 address, [Pv6 address, or a hostname including a fully
Address* qualified domain name. NetWitness defaults to 127.0.0.1,
Log Collector converts the hostname to lower-case letters to prevent duplicate entries.

Event Log The name of the event log from which to collect event data (for example, System, Application, or

Name Security).
The following are examples of some of these channels:

e System - applications that run under system service accounts (installed system services), drivers,
or a component or application that has events that relate to the health of the system.

e Application - all user-level applications. This channel is unsecured and it is open to any
application. If an application has extensive information, you should define an application-specific
channel for it.

¢ Security - the Windows Audit Log (event log) used exclusively for the Windows Local Security
Authority.
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o Jowemn

Enabled

Event
Directory
Path

Event File
Prefix

Cancel

OK

Select this checkbox to collect from this event source. If you do not check this checkbox, the Log Collector
does not collect events from this event source.

NetApp .evt or.evtx files directory path. This must be the UNC path.

The NetApp generates event data and saves it in.evt or.evtx files in a shareable directory on the
NetApp appliance.

e In each polling cycle, Log Collector browses the configured NetApp shared path for the.evt files that you
identified with the Event Directory Path and Event File Prefix parameters. Log Collector :

o sorts files that match the event-file-prefix.YYMMDDhhmmss.evt format in ascending order.

o uses the timestamp of the last file processed to determine the files that still need processing. If
Log Collector finds a partially processed file, it skips the events already processed.

o In each polling cycle, Log Collector browses the configured NetApp shared path for the .evtx files that
you identified with the Event Directory Path and Event File Prefix parameters. Log Collector :

o sorts files that match the event-file-prefix.YYMMDDhhmmssms.evtx format in ascending order.

© uses the timestamp of the last file processed to determine the files that still need processing. If Log
Collector finds a partially processed file, it skips the events already processed.

Prefix of the -evt files (for example, adtlog.) saved in the Event Directory Path,

Closes the dialog without adding the Windows Legacy event source.

Adds the current parameter values as a new event source

The following table describes the advanced parameters for a Windows Legacy event source.

o Towemn

Event Buffer
Size

Event Too

Large Result

Maximum
Event Data

Max Events
Per Cycle

Polling
Interval

Maximum size of the data the Log Collector pulls from the event source for each request.
Valid value is a number in 0 to 511 Kilobytes range. You specify this value in Kilobytes.

Tells Log Collector what to do if an event is too large for the event buffer.

Maximum size of event data to include in the output. Valid value is a number in 0 to 511Kilobytes
range. You specify this value in Kilobytes or Megabytes.

¢ 1 Kilobyte - 100 Megabytes

e 0=donotinclude event data in the output.

The maximum number of events per polling cycle (how many events collected per polling cycle).

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event source every 180
seconds. If the previous polling cycle is still underway, it will wait for it to finish that cycle. If you have a
large number of event sources that you are polling, it may take longer than 180 seconds for the polling
to start because the threads are busy.
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e Jowmn

Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an
event source and you need to investigate this problem. Enabling debugging will adversely affect the
performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:
o Off = (default) disabled

e On =enabled

e Verbose =enabled in verbose mode - adds thread information and source context information to
the messages.

This parameter is designed to debug and monitor isolated event source collection issues. If you
change this value, the change takes effect immediately (no restart required). Limit the number of
event sources for which you use Verbose debugging to minimize performance impact.

Troubleshoot Windows Legacy and NetApp Collection

This topic highlights possible problems that you may encounter with Windows Legacy Collection
(LWC) and suggested solutions to these problems.

Note: In general, you receive more robust log messages by disabling SSL.

Protocol Restart Problems

Possible
Problem
Causes
You restart the The Restart the logcollector service.
Legacy Windows collection protocol, logcollector .
but NetWitness is not receiving events.  service is 1. Log on to the Windows
stopped. Legacy Remote Collector.

2. Go to Start > Administrative Tools
> Task Scheduler and click on Task
Scheduler Library.

3. In the right panel, look for
the restartnwlogcollector task and
make sure that it is running.

4. If this is not the case, right-click
restartnwlogcollector
and select Run.

Installation Problems

If you see any of the following messages in the MessageBroker.log, you may have issues.
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Any message that contains "rabbitmq"

RabbitMQ service may not be running.
Port 5671 may not be opened.

Make sure that the RabbitMQ service is running.
Make sure that port 5671 is open.

Error: Adding logcollector user account.

Error: Adding administrator tag to logcollector account.
Error: Adding logcollection vhost.
Error: Setting permissions to logcollector account in all vhosts.

rabbitmq-server was not running when installer tried to create users and vhosts.

Make sure that the RabbitMQ service is running and run below commands manually.

rabbitmgctl -q add user logcollector netwitness

rabbitmgctl -q set user tags logcollector administrator
rabbitmgctl -g add vhost logcollection

rabbitmgctl -g set permissions -p / logcollector ". *" " #&" w v
rabbitmgctl -q set permissions -p logcollection logcollector ".*"

LU LI | RS ]}

Windows Legacy Federation Script Issues

If you see any of the following messages in the federation script log, you may have issues.

Federation NetWitness log shows connection failure This issue is fixed automatically after restarting the
script started, but exceptions with Windows Windows Legacy service.

the LWC service Legacy Collector.

went down.
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LWC is running, but
RabbitMQ

service is down or
restarting.

RabbitMQ service
is down on the
NetWitness side.

Customer receives
a Health and
Wellness
notification, or the
following Health
and Wellness
Alarm is displayed:
"Communication
failure between
Master NetWitness
Host and a Remote
Host" with

LWC Host as the
Remote IP.

Federation log file at Windows
Legacy side displays an error message
about RabbitMQ service being down.

The log file to look at is:
C:\NetWitness\ng\logcollector

The following error message is logged
in case RabbitMQ is not running:

"Unable to connect to
node
logcollector@localhost:
nodedown"

The following diagnostics messages are
displayed:

attempted to contact:
[logcollector@localhost]

logcollector@localhost:

* connected to epmd
(port 4369) on localhost

* epmd reports: node
'logcollector' not running
at all other nodes on

localhost: ['rabbitmgctl-
4084 "]

* suggestion: start the
node

NetWitness User Interface pages do not
work.

Federate.bat script failed to run
successfully.

Run the federation.bat script manually at LWC.
To run the federate.bat script manually, perform
the following steps:

1. Goto folder C:\Program
Files\NwLogCollector where the Windows
Legacy instance is installed.

2. Locate the file federate.bat in this
folder. Select the file and right click.

3. Select Run as Administrator.
4. To monitor the log file, navigate to

C:\NetWitness\ng\logcollector\federate.log
while the federate.bat script is being executed.

Note: Make sure the log file does not show any
errors while the script is being executed.

Restart RabbitMQ service.

If the Federate.bat script did not run correctly, run it
manually as described previously.
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AWS Parameters

This topic provides an overview of the AWS collection configuration parameters for deploying a remote
log collection service (VLC) in an Amazon Web Services (AWS) environment.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
I
I
I
|

is Working

Implementation Lockbox Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics
e Configure AWS (CloudTrail) Event Sources in NetWitness

The following table describes the Basic configuration parameter for AWS collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Name * Name of the event source.

Select the check box to enable the event source configuration to start collection. The check box is

Enabled selected by default.

Account Id * Account Identification code of the S3 Bucket
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S3 Bucket Name

Access Key *

Secret Key *
Region *

Region Endpoint

Use Proxy
Proxy Server
Proxy Port
Proxy User
Proxy Password

Start Date *

Log File Prefix

Name of the AWS (CloudTrail) S3 bucket.

Amazon S3 bucket names are globally unique, regardless of the AWS (CloudTrail) region in
which you create the bucket. You specify the name at the time you create the bucket.

Bucket names should comply with DNS naming conventions. The rules for DNS-compliant bucket
names are:

e Bucket names must be at least three and no more than 63 characters long.

e Bucket names must be a series of one or more labels. Adjacent labels are separated by a

single period “.”. Bucket names can contain lowercase letters, numbers, and hyphens. Each
label must start and end with a lowercase letter or a number.

e Bucket names must not be formatted as an IP address (for example, 192.168.5.4).

The following examples are valid bucket names:

e myawsbucket

e my.aws.bucket
* myawsbucket.1l

The following examples are invalid bucket names:
e .myawsbucket - Do not start a Bucket Name with a period

e myawsbucket. - Do notend a Bucket Name with a period

e my..examplebucket - Only use one period between labels.

Key used to access the S3 bucket. Access Keys are used to make secure REST or Query
protocol requests to any AWS service API. Please refer to Manage User Credentials on the
Amazon Web Services support site for more information on Access Keys.

Secret key used to access the S3 bucket.

Region of the S3 bucket. us-east-1 is the default value.

Specifies the AWS CloudTrail hostname. For example, for an AWS public cloud for us-east
region, the Region Endpoint would be s3.amazonaws.com. More information can be found at

http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region. This parameter is
necessary to collect CloudTrail logs from AWS Government or Private clouds.

Enable Use Proxy to set proxy for AWS server. By default, it is disabled.

Enter the proxy name you want to connect to access the AWS server.

Enter the port number that connects to the proxy server to access the AWS server.
Enter the user name to authenticate with the proxy server.

Enter the password to authenticate with proxy port.

Starts AWS (CloudTrail) collection from the specified number of days in the past, measured from
the current timestamp. The default value is 0, which starts from today. The range is 0—89 days.

Prefix of the files to be processed.

Note: If you set a prefix when you set up your CloudTrail service, make sure to enter the same prefix
in this parameter.

141

Reference


http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region

Log Collection Configuration Guide

Cancel

OK

Closes the dialog without adding the AWS (CloudTrail).

Adds the current parameter values as a new AWS (CloudTrail).

The following table describes the Advanced configuration parameter for AWS collection.

Debug

Command Args

Polling Interval

SSL Enabled

O

Test Connection

Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem with an
event source and you need to investigate this problem. Enabling debugging will adversely affect the
performance of the Log Collector.

Enables or disables debug logging for the event source.

Valid values are:

o Off = (default) disabled

On =enabled
¢ Verbose = enabled in verbose mode - adds thread information and source context information
to the messages.
This parameter is designed to debug and monitor isolated event source collection issues. The
debug logging is verbose, so limit the number of event sources to minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).
Arguments added to the script.

Interval (amount of time in seconds) between each poll. The default value is 60.

For example, if you specify 60, the collector schedules a polling of the event source every 60
seconds. If the previous polling cycle is still underway, it will wait for it to finish that cycle. If you
have a large number of event sources that you are polling, it may take longer than 60 seconds for
the polling to start because the threads are busy.

Select the check box to communicate using SSL. The security of data transmission is managed
by encrypting information and providing authentication with SSL certificates.

The check box is selected by default.

Validates the configuration parameters specified in this dialog are correct. For example, this test
validates that:

¢ NetWitness can connect with the S3 Bucket in AWS using the credentials specified in this
dialog.

¢ NetWitness can download a log file from the bucket (test connection would fail if there were no
log files for the entire bucket, but this would be extremely unlikely).

Reference
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Azure Parameters

Microsoft Azure is a cloud computing platform and infrastructure for building, deploying, and managing
applications and services through a global network of Microsoft-managed data centers.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Lockbox Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics

¢ Configure Azure Event Sources in NetWitness

Azure Event Source Configuration Parameters

This topic describes the Azure event source configuration parameters.

Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used for
displaying the name on this screen.
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e o

Enabled
Client ID *

Client Secret *

API Resource
Base URL *

Federation
Metadata
Endpoint *

Subscription ID
%

Tenant Domain
*

Resource
Group Names *

Start Date *

Test
Connection

Select the checkbox to enable the event source configuration to start collection. The
checkbox is selected by default.

The Client ID is found the Azure Application Configure tab. Scroll down until you
see it.

When you are configuring the event source, the client secret is displayed when you
are creating a key, and you select a duration of validation.

Make sure to save this, because you will only be able to see it once, and it cannot be
retrieved later.

Enter https://management.azure.com/. Be sure to include the trailing
slash (/).

In your Azure application, click the View Endpoints button (near the bottom of the
pane).

There are a lot of links that all begin with the same string. Compare the URLs and
find the common string that begins most of them. This common string is the
endpoint that you need to enter here.

You can find this in the Microsoft Azure dashboard: click on Subscriptions at the
bottom of the list on the left.

Go to the active directory and click on the directory. In the URL, the tenant domain
is the string directly following manage.windowsazure.com/. The tenant domain is
the string up to and including the .com.

In Azure, select Resource groups from the left navigation pane, then select your
group.

Choose the date from which to start collecting. Default's to the current date.

Checks the configuration parameters specified in this dialog to make sure they are
correct.

Advanced Parameters

Click ' next to Advanced to view and edit the advanced parameters, if necessary.

Nemo_Doscroton

Polling Interval (amount of time in seconds) between each poll. The default value is 180.

Interval For example, if you specify 180, the collector schedules a polling of the event source
every 180 seconds. If the previous polling cycle is still underway, the collector waits for
that cycle to finish. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are busy.

Max Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.

Duration
Poll
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e

Max The maximum number of events per polling cycle (how many events collected per
Events Poll polling cycle).

Max Idle Maximum duration, in seconds, of a polling cycle. A zero value indicates no limit.
Time Poll

gommand Optional arguments to be added to the script invocation.
rgs

Debug Caution: Only enable debugging (set this parameter to On or Verbose) if you have a

problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:
e Off = (default) disabled
e On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection issues.
If you change this value, the change takes effect immediately (no restart required). The
debug logging is verbose, so limit the number of event sources to minimize performance
impact.
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Check Point Parameters

The Check Point Collection protocol collects events from Check Point event sources using OPSEC LEA.
OPSEC LEA is the Check Point Operations Security Log Export API that facilitates the extraction of
logs.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics
¢ Configure Check Point Event Sources in NetWitness

Check Point Collection Configuration Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

Basic Parameters

Name* Name of the event source.

Address* IP Address of the Check Point server.
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Server Name*  Name of the Check Point server.

Certificate Certificate name for secure connections to use when the transport mode is https. If
Name set, the certificate must exist in the certificate trust store that you created using the
Settings tab.

Select a certificate from the drop-down list. The file naming convention for Check
Point event source certificates is checkpoint name-of-event-source.

Client Enter the Client Distinguished Name from the Check Point server.

Distinguished

Client Entity Enter the Client Entity Name from the Check Point server.

Name

Server Enter the Server Distinguished Name from the Check Point server.

Distinguished

Enabled Select the check box to enable the event source configuration to start collection. The

check box is selected by default.

Pull Certificate  Select the checkbox to pull a certificate for first time. Pulling a certificate makes it
available from the trust store.

Certificate IP Address of the server on which the certificate resides. Defaults to the event source
Server Address address.

Password Only active when you select the Pull Certificate checkbox for first time. Password
required to pull the certificate. The password is the activation key created when
adding an OPSEC application to Check Point on the Check Point server.

Determine Advanced Parameter Values for Check Point Collection

You use less system resources when you configure a Check Point event source connection to stay open
for a specific time and specific event volume (transient connection). NetWitness defaults to the following
connection parameters that establish a transient connection:

* Polling Interval = 180 (3 minutes)

e Max Duration Poll = 120 (2 minutes)

e Max Events Poll = 5000 (5000 events per polling interval)

* Max Idle Time Poll =0

For very active Check Point event sources, it is a good practice to set up a connection that stays open
until you stop collection (persistent connection). This ensures that Check Point collection maintains the

pace of the events generated by these active event sources. The persistent connection avoids restart and
connection delays and prevents Check Point collection from lagging behind event generation.

To establish a persistent connection for a Check Point event source, set the following parameters to the
following values:
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e Polling Interval = -1

e Max Duration Poll = 0
e Max Events Poll =0
e Max Idle Time Poll =0

Port Port on the Check Point server that Log Collector connects to. Default value is
18184.

Collect Log Type of logs that you want to collect: Valid values are:
Wpe ¢ Audit - collects audit events.

* Security - collects security events.

If you want to collect both audit and security events, you must create a duplicate
event source. For example, first you would create an event source with Audit selected
pulling a certificate into the trust store for this event source. Next you would create
another event source with the same values except that you would select Security for
the Collect Log Type and you would select the same certificate in Certificate Name
that you pulled when you set up the first set of parameters for this event source and
you would make sure that Pull Certificate was not selected.

Collect Logs When you set up a Check Point event source, NetWitness collects events from the
From current log file. Valid values are:

¢ Now - Start collecting logs now (at this point in time in the current log file).

» Start of Log - Collect logs from the beginning of the current log file.

If you choose "Start of Log" for this parameter value, you may collect a very large
amount of data depending on how long the current log file has been collecting events.
Note that this option is effective only for the first collection session.

Polling Interval (amount of time in seconds) between each poll. The default value is 180.

Interval For example, if you specify 180, the collector schedules a polling of the event source

every 180 seconds. If the previous polling cycle is still underway, it will wait for it to
finish that cycle. If you have a large number of event sources that you are polling, it
may take longer than 180 seconds for the polling to start because the threads are
busy.

Max Duration  The maximum duration of polling cycle (how long the cycle lasts) in seconds.
Poll

Max Events The maximum number of events per polling cycle (how many events collected per
Poll polling cycle).

Max Idle Time Maximum idle time, in seconds, of a polling cycle. 0 indicates no limit.> 300 is the
Poll default value.

Forwarder Enables or disables the Check Point server as a forwarder. By default it is disabled.
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Log Type Logs from the event source in Name Value format. By default it is disabled.
(Name Value

Pair)

Debug Caution: Only enable debugging (set this parameter to "On" or "Verbose") if you

have a problem with an event source and you need to investigate this problem.
Enabling debugging will adversely affect the performance of the Log Collector.
Enables and disables debug logging for the event source.

Valid values are:
e Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to
minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).
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File Parameters
This topic describes the File Collection configuration parameters.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.
You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Lockbox Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event  Configure Collection Protocols and Event
sources Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics

e Configure File Event Sources in NetWitness

File Collection Event Source Parameters
The following table provides descriptions of the File Collection source parameters.

The following table describes the Basic configuration parameter for File collection.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e Do
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e o

File
Directory*

Address*

File Spec

File
Encoding

Cancel

OK

Collection directory (for example, Eur_London100) into which the File event source
places its files. Valid value is a character string that is conforms to the following regular
expression:

[ a-zA-Z][_a-zA-Z0-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores. Do not modify this parameter after you start collecting event data.

After you create the collection, the Log Collector creates the work, save, and error sub-
directories under the collection directory.

IP address of the event source. Valid value is an IPv4 address, IPv6 address, or a
hostname including a fully-qualified domain name.

Regular expression. For example, *.*$ = process everything.

Character encoding used by the syslog senders to this port. Defaults to UTF-8.

Note: It is safe to leave this as UTF-8, since UTF-8 handles ASCII characters as well,
and most senders have their encoding set to UTF-8.

NetWitness has tested the following values:
* EUC-KR

» SIIS

* GB3212/GBK

e [SO 8859-1 (German)

e ISO_8859-7 (Greek)

Closes the dialog without making adding an event source type.

Adds the parameters for the event source.

The following table describes the Advanced configuration parameter for File collection.

e o

Ignore
Encoding

Conversion

Errors

Select the check box to ignore encoding conversion errors and ignore invalid data. The
check box is selected by default.

Caution: This may cause parsing and transformation errors.

151



Log Collection Configuration Guide

e Jowan P

File Disk Determines when to stop saving files regardless of the Save On Error and Save On

Quota Success parameter settings. For example, a value of 10 indicates that when there is
less than 10% available disk left, the Log Collector stops saving files to reserve
enough space for your estimated normal collection processing.

Caution: Available disk refers to a partition where the base collection directory is
mounted. If the Log Decoder server has a 10TB disk size and 2TB is allocated to
base collection directory, then setting this value to 10 causes log collection to stop
when less than 0.2TB (10% of 2TB) of space is left. It does not mean 10% of 10TB.

Valid value is a number in the 0 to 100 range. 10 is the default.

Sequential Sequential processing flag:

gl i e Select the check box (default) to process event source files in collection order.

e Do not select the checkbox to process event source files in parallel.

Save On Save on error flag. Check the checkbox to retain the eventsource collection file when
Error the Log Collector it encounters an error. The check box is selected by default.

Save On Save eventsource collection file after processing flag. Check the checkbox to save the
Success eventsource collection file after processing it. The check box is not selected by default.

Eventsource SSH public key used to upload files for this event source. Please refer to the Generate
SSH Key Key Pair on Event Source and Import Public Key to Log Collector section in the
Install and Update the SFTP Agent Guide for instructions on generating keys.

Note: If File collection is stopped, NetWitness does not update the authorized keys
file with the SSH public key that you add or modify in this parameter. You must
restart File collection to update the public key.

You can add or modify the value of the public key in this parameter in multiple File
event sources without File collection running, but NetWitness will not update the
authorized_keys file until File collection is restarted.

Manage Error By default, the Log Collector uses the File Disk Quota parameter to ensure that the
Files disk does not fill up with error files. If you set this parameter to true, you can specify
one of these:

e Maximum space allotted to error files in the Error Files Size parameter.

e Maximum number of error files allowed in Error Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Select the check box to manage error files. The check box is not selected by default.

152


https://community.rsa.com/docs/DOC-53125

Log Collection Configuration Guide

e o

Error Files
Size

Error Files
Count

Error Files
Reduction %

Manage
Saved Files

Saved Files
Size

Saved Files
Count

Saved File
Reduction %

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Specifies to what extent NetWitness saves error files. The value that you specify is the
maximum total size of all the files in the error directory.

Valid value is a number in 0 to 281474976710655 range. You specify these values in
either Kilobytes, Megabytes, or Gigabytes. 100 Megabytes is the default. If you
change this parameter, the change does not take effect until you restart collection or
restart the Log Collector service.

Only valid if the Manage Error Files and Save On Error parameters are set to true.
Maximum number of error files allowed in the error directory. Valid value is a number
in 0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Percent amount by size or count of the error files that the Log Collector service
removes when the maximum size or count has been reached. The service removes the
oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.

Select the check box to manage saved files. The check box is not selected by default.
By default, the Log Collector uses the File Disk Quota parameter to ensure that the
disk does not fill up with saved files. If check this check box, you can specify one of
these:

e Maximum space allotted to saved files in the Saved Files Size parameter.

e Maximum number of saved files allowed in Saved Files Count parameter.

A reduction percent is also specified, which tells the system how much to reduce when
the maximum is reached.

Only valid if the Manage Saved Files and Save On Success parameters are set to
true.

Maximum total size of all the files in the save directory. Valid value is a number in
the 0 to 281474976710655 range. You specify these values in either Kilobytes,
Megabytes, or Gigabytes. 100 Megabytes is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Only valid if the Manage Saved Files and Save On Success parameters are set to
true. Maximum number of saved files in the save directory. Valid value is a number in
0 to 65536 range. 65536 is the default.

If you change this parameter, the change does not take effect until you restart
collection or restart the Log Collector service.

Percent amount by size or count of the saved files that the Log Collector service
removes when the maximum size or count has been reached. The service removes the
oldest files first.

Valid value is a number in the 0 to 100 range. 10 is the default.
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e oo

Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you have
a problem with an event source and you need to investigate this problem. Enabling
debugging will adversely affect the performance of the Log Collector.

Enables or disables debug logging for the event source.
Valid values are:

e Off = (default) disabled
e On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source context
information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. The debug logging is verbose, so limit the number of event sources to
minimize performance impact.

If you change this value, the change takes effect immediately (no restart required).
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Log Collection Service System View

A Log Collector is a service that runs on a Log Decoder host (referred to as a Local Collector) or sends
events from a Remote Collector to a Local Collector, and is configured and managed in a similar way to
a Log Decoder.

4
To access the Log Collection Service System view, go to (Admin) > Services and select a Log
Collector service, then select View > System.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
: Configure Verify that
Perform Basic Setupa Start | Collection Log Collection
Protocols and is Working
Services | Event Sources

|
|
|
|
Implementation Lockbox ] Collection
|
|
|

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation
Administrator Set up a lockbox to maintain lockbox settings Set Up a Lockbox
Administrator *Start Log Collection Services. Start Collection Services

Administrator Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics

Basic Implementation

Quick Look

From the Log Collector Service Information Toolbar, you can manage event data using the Collection
icon to start event data from a stopped protocol or stop collecting data from a started protocol. From the
Host Tasks icon, you can select tasks that you want to run. You can also shutdown your service and
reboot your service from the Service Information Toolbar.
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ODBC Event Source Configuration Parameters

This topic tells you how to configure ODBC collection protocol which collects events from event
sources that store audit data in a database using the Open Database Connectivity (ODBC) software
interface.

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:

A
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Select ﬁ "~ > View > Config to display the Log Collection configuration parameter tabs.
The Service Config view is displayed with the Log Collector General tab open.

4. Click the Event Sources tab, and select ODBC/Config from the drop-down menu.
Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
Implementation Lockbox Collection Protocols and |
Services Event Sources :
|

is Working

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic Implementation
Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox
Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.
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Related Topics
e Configure ODBC Event Sources in NetWitness

e Configure Data Source Names (DSN5s)
e Troubleshoot ODBC Collection

e Create Custom Typespec for ODBC Collection

Data Source Name (DSN) Parameters

Use the Sources panel to review, add, modify, and delete Data Source Name (DSN) parameters.

Sources Panel

An ODBC DSN tells the Log Collector how to reach an ODBC endpoint. You refer to an ODBC DSN
when you configure a data source name with information such as which ODBC driver to use or the host
name and port of the ODBC endpoint.

An ODBC DSN is a sequence of name-value pairs. For information about the valid names for a given
ODBC data source type, such as Sybase, Microsoft SQL Server, or Oracle, please download the
DataDirect Connect Series for ODBC User's Guide and DataDirect Connect Series for ODBC User's
Guide in the Progress DataDirect Document Library.

Toolbar

The following table provides descriptions of the toolbar options.

oren _Jowsetpten

+ Opens the Add DSN dialog in which you add an event source for the event source type you
selected in the Event Categories panel.

Deletes the selected event sources.

z Opens the Edit DSN dialog in which you modify the configuration parameters for the selected
event source.

When you select multiple event sources, this option opens the Bulk Edit Source dialog in
which you can edit the parameters values for the selected file directories.

» N Opens the Bulk Add Option dialog in which you can import DSN parameters in bulk from a
= Importsource comma-separated values (CSV)file. The Bulk Add Option dialog has the following two
options:

e Import CSV File

o Paste CSV Content

" Export Creates a .csv file that contains the parameters for the selected DSNs.
¥ Export Source

) Validates the configuration parameters for the selected ODBC database.
™ Test Connection
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Add or Edit DSN Dialog

In this dialog, you add or modify an event source for the selected event source.

Basic Parameters

Note: Required parameters are marked with an asterisk. All other parameters are optional.

e o

DSN*

Username*

Password

Enabled

Address*

The data source name (DSN) that defines the database from which to collect events.

Select an existing DSN from the drop-down list. For details, see ODBC DSNs Event Source
Configuration Parameters.

User name that the data source name uses to connect to the database. You must specify a user
name when you create the event source.

Password that the data source name uses to connect to the database.

Caution: The password is encrypted internally and is displayed in its encrypted form.

Select the checkbox to enable the event source configuration to start collection. The checkbox is
selected by default.

For ODBG, this field is not used. The Log Collector uses the address in the ODBC.ini file.

Advanced Parameters

Nemo Jpsectpten

Max Cell Size

Nil Value

Polling
Interval

Max Events
Poll

Maximum size in bytes of the data that the Log Collector can pull from one cell in the database. The
default value is 2048.

Character string that the Log Collector displays when NIL is returned for a cell in the database.
Default value: “ (null).

Interval (amount of time in seconds) between each poll. The default value is 180.

For example, if you specify 180, the collector schedules a polling of the event source every 180
seconds. If the previous polling cycle is still underway, the collector waits for that cycle to finish. If you
have a large number of event sources that you are polling, it may take longer than 180 seconds for
the polling to start because the threads are busy.

The maximum number of events per polling cycle (how many events collected per polling cycle).
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e Jomn

Debug Caution: Caution: Only enable debugging (set this parameter to On or Verbose) if you have a problem
with an event source and you need to investigate this problem. Enabling debugging will adversely affect
the performance of the Log Collector.

Enables or disables debug logging for the event source. Valid values are:

o Off = (default) disabled

e On =enabled

e Verbose = enabled in verbose mode - adds thread information and source context information to
the messages.

This parameter is designed to debug and monitor isolated event source collection issues. If you

change this value, the change takes effect immediately (no restart required). The debug logging is

verbose, so limit the number of event sources to minimize performance impact.

Initial Initial identification code that the Log Collector assigns to this event source if collection is not started.

Tracking Id If there is no value for this parameter, the Log Collector starts at the end of the table and only pulls

rows after the end of the table as they are added. The default value is “” (null).

For Example: 2020-11-11 05:05:11
Note: The Initial Tracking ID format varies based on the format of the tracking
column used in the data query in the typespec.
For Example: If the tracking column value is in epoch, the Initial Tracking ID must be
in the epoch format.

Filename For Microsoft SQL Server Event Sources only, the location of the trace files directory (for example,

C:\MyTraceFiles).
Refer to the NetWitness Microsoft SQL Server Event Source Configuration Guide, located on
NetWitness Link.

Test Checks the configuration parameters specified in this dialog to make sure they are correct.

Connection

Cancel Closes the dialog without adding or modifying DSN parameters.

OK Adds or modifies the parameters for the DSN.

160


https://community.netwitness.com/t5/netwitness-platform-integrations/event-source-log-configuration-guide-for-microsoft-sql-server/ta-p/573427

Log Collection Configuration Guide

ODBC DSNs Event Source Configuration Parameters

Open Database Connectivity (ODBC) event sources require Data Source Names (DSNs) so you need to
define DSNs with their associate value pairs for ODBC event source configuration.

Access ODBC Configuration Parameters

To access the ODBC Event Source Configuration Parameters:

4
1. Access the Services view by selecting (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.
3. Under Actions, select 'ﬁ "~ View > Config to display the Log Collection configuration parameter
tabs.

The Service Config view is displayed with the Log Collector General tab open.
4. Click the Event Sources tab, and select ODBC/DSNs from the drop-down menu.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Setupa Start Collection [l Log Collection
Implementation Lockbox Collection Protocols and |
Services Event Sources :
|

is Working

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.
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Related Topics
¢ Configure ODBC Event Sources in NetWitness

e Configure Data Source Names (DSNs)

ODBC DSN Configuration Parameters

This topic describes the Data Source Names DSNs configuration parameters.

DSN Panel

In the DSNs panel, you can add, delete, or edit DSNs and the DSN name-value pairs for ODBC Event
sources.

P pescrion

+ Displays the Add DSN dialog in which you define a DSN and its parameters.
- Deletes the selected DSNS.
z Displays the Edit DSN dialog in which you edit the name-value pairs for the selected
DSN.

[ Manage Tem; Displays the Manage DSN Templates dialog in which you can add or delete DSN
name-value pair templates.

Selects DSNs.

DSN Name of the DSN that you added.

Parameters  <name-value for="""" p="" pairs="" the=""> </name-value>

Add or Edit DSN Dialog

In this dialog, you add or modify a file directory for the selected event source.

Note: Required parameters are marked with an asterisk. All other parameters are optional.

P oescrpior

DSN Select a predefined DSN value name-value pairs template for the DSN.
Template
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e Jowan

DSN Name*

Parameters

Cancel

Save

Add the name of the DSN. You cannot edit a DSN name after you add it.

This value must correspond with a DSN entry in the ODBC.ini file. Valid value is a
character string that is restricted to the following characters:

[ a-zA-Z][ a-zA-7Z0-9]*

This means that the file directory must start with a letter followed by numbers, letters,
and underscores (for example, oracle_executive compensation).

=+

Adds a row in which you can define a parameter name-value pair.

™ Deletes the selected parameter name-value pair.

O

Name - Enter or modify the parameter name.

Selects parameter name-value pairs.

Value - Enter or modify the value associated with the parameter name.

Closes the dialog without adding the DSN and its name-value pairs or saving
modifications to the name-value pairs.

Adds the DSN and its name-value pairs or saves modifications to the name-value pairs.

Manage DSN Templates Dialog

In this dialog, you can add or delete DSN name-value pair templates.

Fewrs Jossepten

o

Template Selection Panel

Opens the Add Template panel in which you can add a DSN name-value pair template.

Deletes the selected template.

Selects a template for deletion or modification.

Add Template Panel

Adds a value pair row.

Deletes a value pair row.

Selects a value pair row.
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e Jowemn

Name
Value
Cancel
Save

Close

Enter the parameter name.

Enter the value associated with the parameter name.

Cancels any changes you made in the dialog.

Adds the DSN and its name-value pairs or saves modifications to the name-value pairs.

Closes the dialog without adding the DSN and its name-value pairs or saving
modifications to the name-value pairs.
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Remote/Local Collectors Configuration Parameters

When you deploy Log Collection, you must configure the Log Collectors to collect the log events from
various event sources, and to deliver these events reliably and securely to the Log Decoder host, where
the events are parsed and stored for subsequent analysis.

This topic introduces features of the Services Config view > Remote Collectors/Local Collectors tab.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here

I
Configure : Verify that
Perform Basic Start Collection [l Log Collection
[
I
I
|

is Working

Implementation Collection Protocols and
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation Basic Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection Services

Administrator *Configure Log Collection protocols and event Configure Collection Protocols and Event
sources. Sources

Administrator Verify that Log Collection is working. Verify That Log Collection Is Working

*You can perform this task here.

Related Topics

¢ Provision Local Collectors and Remote Collectors

e Configure Local and Remote Collectors

Services Config View

The Services Config view is the view on which you maintain all the Log Collection parameters. The tab
in which you maintain the deployment parameters referred to in this guide is the Remote/Local
Collectors tab:

e If you are configuring a Local Collector , NetWitness displays the Remote Collectors tab so that you
can configure the Local Collector to pull events from Remote Collectors.
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e If you are configuring a Remote Collector , NetWitness displays the Local Collectors tab so that you
can configure the Remote Collector to push events to a Local Collector .

Remote Collectors Tab

On a Local Collector, the Remote Collectors panel provides a way to add or delete Remote Collectors
from which the Local Collector pulls events.

—- Displays the Add Source dialog in which you select the Remote Collectors from which
you want the Local Collector to pull events.

Deletes the Remote Collector from the Local Collector Remote Collectors panel.

E Displays the Edit Source dialog for the selected Remote Collector

D Selects Remote Collectors.
Name Names of the Remote Collectors from which the Local Collector currently pulls events.
Address IP Addresses of the Remote Collectors from which the Local Collector currently pulls

events.

Collections  Choose which collection protocols that the Remote Collector pushes to a Local
Collector.

You can select any combination of protocols. If you do not select a protocol,
NetWitness selects all protocols.

Local Collector Tab

On a Remote Collector , the Local Collector panel provides a way to add or delete the Local Collectors
to which you want to the Remote Collector to push events.

Select the Destination or Source in the Select Configuration drop-down menu.
* Destination displays the Add Remote Destination dialog.
e Source displays the Add Source dialog.

The following table describes the Add Source dialog.

+ Displays the Add Source dialog in which you select the Remote Collectors from which
you want the Local Collector to pull events.

Deletes the Remote Collector from theLocal Collector Remote Collectors panel.
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4

Name

Address

Displays the Edit Source dialog for the selected Remote Collector
Selects Remote Collectors.
Names of the Remote Collectors from which the Local Collector currently pulls events.

IP Addresses of the Remote Collectors from which the Local Collector currently pulls
events.

The following table describes the Local Collectors Panel.

=+

4

Destination
Name
Address

Collections

Displays the Add Remote Destination dialog for the Group that you selected. You add
destination Local Collectors for this group to which you want the Remote Collector to
push events.

Deletes the destination Log Collector from the group.

Displays the Edit Remote Destination dialog for the selected destination Local
Collector .

Selects a destination Local Collector .
Displays the name of the destination Local Collector .

Displays the IP address of the destination Local Collector ,

Choose which collection protocols that the Local Collector pulls from a Remote
Collector.

You can select any combination of protocols. If you do not select a protocol,
NetWitness selects all protocols.

Log Collection Tabs

This topic describes the tabs available in the Log Collection view.

Access Log Collection View

To access the log collection view:

A
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.
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3.

Under Actions, select View > Config to display the Log Collection configuration parameter tabs.

The Service Config view is displayed with the Log Collector General tab open.

4. Select any of the available tabs to view or update the corresponding parameters.

Available Tabs

Q
Use the (Admin) > Services view to maintain Log Collection parameters. It has the following tabs:

General: contains high-level parameters that govern the operation of the Log Collector service and
each collection protocol. See Log Collection General Tab for details.

Remote Collectors: use this tab to set up remote collectors. See Configure Local and Remote
Collectors for details.

Files: provides an interface for editing Log Collector configuration files.

Event Sources: use this tab to configure collection for your event sources. See Log Collection Event
Sources Tab for details.

Event Destinations: Use the Event Destinations tab of the Log Collection service Config view to
configure the destination of event data collected by the Log Collector. See Log Collection Event
Destinations Tab for details.

Settings: contains parameters for Lockbox security setup, and certificate management.

Appliance Service Configuration: contains configuration parameters for the NetWitness Core
Appliance service.

Please refer to the Files tab and the Appliance Service Configuration tab in the Host and Services
Configuration Guide for information on the configuration parameters on these tabs.
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This topic introduces features of the service Config view > General tab that relate specifically to Log
Collector .

To access the Log Collection General tab:

QA
1. Goto (Admin) > Services from the NetWitness menu.

2. Select a Log Collection service.

3. Click % > View > Config.
The Service Config view is displayed with the Log Collector General tab open.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here I

Configure Verify that
Perform Basic Setupa Start Collection Log Collection

Implementation Lockbox Collection Protocols and is Working
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator Configure Log Collection protocols and event Configure Collection

sources. Protocols and Event

Sources

Administrator *Verify that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.

Related Topics

e Configure AWS (CloudTrail) Event Sources in NetWitness

¢ Configure Check Point Event Sources in NetWitness
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e Configure File Event Sources in NetWitness

e Configure Netflow Event Sources in NetWitness

e Configure ODBC Event Sources in NetWitness

e Configure SDEE Event Sources in NetWitness

e Configure SNMP Event Sources in NetWitness

e Configure Syslog Event Sources

¢ Configure VMware Event Sources in NetWitness

e Configure Windows Event Sources in NetWitness

¢ Windows Legacy and NetApp Collection Configuration

Quick Look

The NetWitness administrator must configure event sources to send logs to the collectors. When event
sources are configured they poll event sources, retrieve logs, and send the event data to NetWitness ).

System Configuration Panel

The System Configuration panel manages service configuration for a NetWitness service. When a service
is first added, default values are in effect. You can edit these values to tune performance. Refer to the
General tab for a description of these parameters.

System Configuration +

MName

Compression #—
Port <—E
W

Stat Update Interval = ﬂ
Threads =—

System Configuration Panel manages service configuration for a NetWitness service.

P Compression: The minimum number of bytes that must be transmitted per response before
compression. A setting of 0 disables compression. The default value is 0.
A change in value is effective immediately for all subsequent connections.

RN Port: The port on which the service listens. The ports are:
¢ 50001 for Log Collectors

¢ 50002 for Log Decoders

e 50003 for Brokers
¢ 50004 for Decoders

¢ 50005 for Concentrators
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¢ 50007 for other services

SSL FIPS Mode: When enabled (on), the security of data transmission is managed by encrypting
information and providing authentication with SSL certificates. The default value is off.

SN SSL Port: The NetWitness Core SSL port on which the service listens. The ports are:
e 56001 for Log Collectors

¢ 56002 for Log Decoders
e 56003 for Brokers

¢ 56004 for Decoders

¢ 56005 for Concentrators

¢ 56007 for other services

Stat Update Interval: The number of milliseconds between statistic updates on the system. Lower
numbers cause more frequent updates and can slow down other processes. The default value
is 1000,
A change in value is effective immediately.

g Threads: The number of threads in the thread pool to handle incoming requests. A setting of 0
lets the system decide. The default value is 15.
A change takes effect on service restart.

Collector Configuration Panel

The Collector Configuration panel provides a way to enable automatic start of log collection by event
source type.

Collector Configuration «—
Name

Check Point Collection

Start Collection on Service Startup +—— 7
o 4
File Collection Py
- 7 i
Start Collection on Service Startup & ./ ;,«‘
Netflow Collection s Vi
/ ra
Start Collection on Service Startup ¥ ‘/'
ODBC Collection Vi

Start Collection on Service Startup

Collector Configuration Panel provides a way to enable automatic start of log collection by event
source type.
2 Enable All enables the automatic collection for all event types.

Enable All = start receiving events and collecting logs for all event types when the Log Collector
service starts.
R Disable all disables the automatic collection for all event types.

Disable All = (default) do not receive event data for all event types until you explicitly start
collection.
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88 Start Collection on Service Startup enables automatic start, per event source type, of log
collection when the Log Collector service starts. Valid values are:

» Selected = start collecting logs when the Log Collector service starts.

¢ Not selected = (default) do not collect event data until you explicitly start collection.
Apply: Click Apply to save the changes to the parameter values.

172



Log Collection Event Destinations Tab

Use the Event Destinations tab of the Log Collection service Config view to configure the destination of
event data collected by the Log Collector :

* Log Decoders
¢ Identity Feed

Prerequisites
You must implement the following configuration to create an identity feed.
* A Log Collector service with an Identity Feed Event Processor

* A Log Collector service with Windows Collection configured and enabled

Note: See the "Create an Identity Feed" topic in the Live Resource Management Guide for more
information on how to create and investigate on an identity feed.

Workflow

This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here I

Configure Verify that
Perform Basic Setupa Start Collection Log Collection

Implementation Lockbox Collection Protocols and is Working
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator Set up a to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator *Configure Log Collection protocols and event sources. Configure Collection
Protocols and Event
Sources

Administrator Verify that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.
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Related Topics

* See the Create an Identity Feed topic in the Live Resource Management Guide.

Quick Look

The Event Destinations tab of the Log Collection service Config view allows you to configure the
destination of event data collected by the Log Collector.

NETWITNESS

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEALTH & WELLNESS
= Change Service LD - Log Collector | Config

General Remate Collectors Files S L=l Event Destinations Appliance Service Configuration
Select Event Log Decoder v
Destinations -

imatinn (Cro = )
Destination Groups LOg Uecoders
+ - +
o Name =~ Name ~ Host Port SSL Fallover LDg Decoders Status
¥ logdecoder logdecoder 127001 514 false started
| Page |1 | of1 | | | Page |1 | of1 | [ tems 1-10f1

NETWITNESS

The required permission to access this view is Manage Services.

To access the Event Destinations tab:

Q
1. Goto (Admin) > Services .

2. Select a Log Collection service.

3. Select ﬁ “ > View > Config to display the Log Collection configuration parameter tabs.
4. Click the Event Destinations tab.
In the Select Event Destinations drop-down menu:

e Select Log Decoder to configure Log Decoder destinations for event data collected by the Log
Collector.

Note: You must select a Log Decoder service from the Add Log Decoder Destination dialog,
but the remainder of the configuration is done automatically.

¢ Seclect Identity Feed to configure an identity feed destination for event data collected by the Log
Collector.
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& Change Service | -Log Collector | Config &
General Remote Collectors Files 2Ll Event Destinations Settings Appliance Service Configuration
Select Event . -
Destinations Log Decoce
Destination Groups Log Decoders
+ - +
4 Name ~ ] Name ~ Host Port SsL Failover Log Decoders Status
¥ logdecoder [ logdecoder 127.0.0.1 514 false started
page 1 of1 | page 1 of1 | C Items 1-10f 1

&% Change Service | -Log Collector | Config &

Appliance Service Configuration

Files A% (=3l Event Destinations Settings

General Remote Collectors

Select Event Y
Destinations Identity Feed

Identity Feed

-=
¥ Name ~ Rollover Interval Update Interval Event Source Filter | Status Start Processor on Service Startup
¥ IDFEED 3 1 true
Page 1 | of1 | Items 1 -1 of 1
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Use the Event Sources tab to configure the AWS (CloudTrail), Check Point, File, ODBC, SDEE,
Logstash, SNMP, Syslog, SNMP, VMware, Windows, and Windows Legacy event sources.

Q
To access the Event Sources tab, go to (Admin) > Services > select Log Collection service > View
> Config > Event Sources) .

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

You are here I

Configure Verify that
Perform Basic Setupa Start Collection Log Collection

Implementation Lockbox Collection Protocols and is Working
Services Event Sources

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator *Configure Log Collection protocols and event sources. Configure Collection

Protocols and Event
Sources

Administrator Verify that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.

Related Topics

e Configure AWS (CloudTrail) Event Sources in NetWitness

e Configure Check Point Event Sources in NetWitness

e Configure File Event Sources in NetWitness

e Configure ODBC Event Sources in NetWitness

e Configure SDEE Event Sources in NetWitness

e Configure SNMP Event Sources in NetWitness
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e Configure Syslog Event Sources

e Configure VMware Event Sources in NetWitness

e Configure Windows Event Sources in NetWitness

e Configure Logstash Event Sources in NetWitness

¢ Windows Legacy and NetApp Collection Configuration

Quick Look

The Config view has two drop-down menus:

o The left-most menu lists all of the available collection protocols.

General Remote Collectors Files Event Sources I

Check Paoint | ~ [WConfig bl

NECH PO

e S Sources

Netflow - & Import Source
ODBC

Plugins
SDEE
SMMP

Wilware

Mame Address Ser

SA_OPSEC 101.. «p

Windows

o The right-most menu has two choices: Config and Filter.

General Remote Collectors Files Event Sources I

Check Point

Event Categorig

[ E— [

The Config view in the Event sources tab has two panels: Event Categories and Sources.

Note: For details on the Filter menu item, see Configure Event Filters for a Collector.

Event Source Types Menu

The Log Collector Event Sources tab has a two-box, drop-down menu in which you select the collection
protocol and any supporting parameters for that protocol.
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In the left box, you select one of the following protocols: Check Point, File, ODBC, Plugins, SDEE,
SNMP, SNMP, VMware, Windows, and Windows Legacy.

In the right box, you select:

» Conlfig to configure the generic event source parameters for the type you selected in the left drop-
down. All generic Config panels have a toolbar with these options:

¢ Add, Edit, and Delete

e Import (also Import Source, Import DSN)

» Export (also Export Source, Export DSN)
e For ODBC, SNMP, and Windows only:

e For ODBC, DSNs to configure

e For SNMP, SNMP v3 User Manager

* For Windows, Kerberos Realm Configuration

Selecting an option displays a configuration panel where you configure the collection parameters for the
event source. The configuration panels are slightly different for different event sources and are described
separately.

Event Categories Panel

Once you select a collection protocol, the Event Categories panel is populated with all of the event
sources that you have configured for that collection protocol. For example, the following image shows
ODBC event sources that have been configured:

General Remote Collectors

oDBC v Config

Event Categories n

ciscolmsaudit

¥ emcionixuim *
itim
mcafeenac
netflowanalyzer_security
oracle_12c_auditing

oracledv

The Event Categories panel provides a way to add or delete event source types.

Displays the Available Event Source Types dialog from which you select the event source type
for which you want to define parameters.

Deletes the selected event source types from the Event Categories panel.
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Selects event source types.
Displays the name of the event source types that you have added.

Sources Panel

The Sources panel lists the values of the parameters for the selected event source type. For details, see
the individual collection protocol topics.

Below is an example of a list of Check Point event sources. Note that the result set has been limited to
sources whose names contain the string checkpoint11.

+ Change Service | logdecoder1 - Log Collector |  Config &
General Remote Collectors Files Event Sources JEEVdNWLENGLH Settings Appliance Service Configuration
Check Point ~ Config v {2 Event Source Configuration Guides
Event Categories Sources
+ - + & Import Source |:heckpoint11‘ X
o
¥ Name 0| name Address Server Nam¢ Certificate N Event Flilter  Cllent Distin Cllent Entity Server Distir Enabled Port Collect Log T Collect Logs Follir
¥ checkpoint [0 checkpoint11 Win2010  gw-11 w1 2wl gel true 18184 Security  Now 20
[0 checkpointi1o Win2007  gw-8 w1 wl zel true 18184 Security Now 30
[] checkpoint111 ‘Win2008 gw-9 gw-1 gwil gel true 18184 Security Now 30
[] checkpoint112 ‘Win2009 gw-10 gw-1 gwl gel true 18184 Security Now 30
[0 checkpoint113 Win2010  gw-11 w1 wl gel true 18184 Security Now 30
[0 checkpoint114 Win2011 Ew-12 Ew-1 gwl gel true 18184 Security Now 30
[] checkpoint115 Win2012 gw-13 gw-1 gwil gel true 18184 Security Now 30
[ checkpoint116 Win2013  gw-14 w1 gwl get true 18184 Security Now 30
[0 checkpoint117 Win2014 Ew-15 Ew-1 Ewl gel true 18184 Security Now 30
[] checkpoint118 Win2015 gw-16 gw-1 gwil gel true 18184 Security Now 30
[] checkpoint119 Win2016 gw-17 gw-1 gwl gel true 18184 Security Now 30
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Use the Settings tab to:
e Set up a lockbox
e Reset Stable System value

* Manage certificates

Caution: If the host name on which the Log Collector is installed is changed after installation, the Log
Collector will fail to collect events from event sources. You must reset stable system values if the
hostname changes.

Q
To access the Log Collection Settings Tab, go to (Admin) > Services. In the Services grid, select a
Log Collector Service. Click Actions menu cropped under Actions and select View > Config.

Workflow
This workflow illustrates the basic tasks needed to start collecting events through Log Collection.

I You are here
Configure Verify that
Start Collection Log Collection
Collection Protocols and is Working
| Services Event Sources

|

I |

I I
Perform Basic | |
Implementation

What do you want to do?

Administrator Perform basic Log Collection implementation. Basic
Implementation

Administrator *Set up a lockbox to maintain lockbox settings. Set Up a Lockbox

Administrator Start Log Collection services. Start Collection
Services

Administrator Configure Log Collection protocols and event sources. Configure Collection

Protocols and Event
Sources

Administrator Verify that Log Collection is working. Verify That Log
Collection Is
Working

*You can perform this task here.

Related Topics

e See the "Create an Identity Feed topic" in the Live Resource Management Guide.
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Quick Look

This is an example of the Settings tab.

NETWITNESS

SERVICES . ENDPOINT

& Change Service | -Log Collector |  Config

General Remote Collectors Files Event Sources  Event Destinations Settings Appliance Service Configuration

Lockbox
Certificates

Lockbox Security Settings

Set or change the lockbox password. You will be required to enter this password to perform any lockbox management.

Mew Lockbox *AA
Password

Reset Stable System Value

This operation sets the system fingerprint in the lockbox. This is typically only required after changing the host hardware.

Lockbox PN

Password

ply

Generate New Encryption Key

Generates a new internal encryption key and re-encrypts the log collector's encrypted configuration values with it

Apply
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Troubleshoot Log Collection

This topic describes the format and content of Log Collection Troubleshooting. NetWitness informs you
of Log Collector problems or potential problems in the following two ways.

* Log files.

e Health and Wellness Monitoring views.

Junk Syslog Messages

The remote log collector has been made looser in regards to how it handles syslog messages. This was
done to reduce the number of dropped messages due to missing parts of the header, or for other minor
formatting errors. However, this might also allow syslog event messages that contain junk to get through
the parser. If you see such messages in the system, you can add a syslog collection filter to remove
events that are sending these messages.

Log Files

If you have an issue with a particular event source collection protocol, you can review debug logs to
investigate this issue. Each event source has a Debug parameter that you can enable (set parameter to On
or Verbose) to capture these logs.

Caution: Only enable debugging if you have a problem with this event source and you need to
investigate this problem. If you have Debug enabled all the time it will adversely affect the
performance of the Log Collector.

Health and Wellness Monitoring

Health and Wellness monitoring makes you aware of potential hardware and software problems in a
timely manner so that you can avoid to outages. NetWitness recommends that you monitor the Log
Collector statistical fields to make sure that the service is operating efficiently and is not at or near the
maximum values you have configured. You can monitor the following statistics (Stats) described in the

Q
(Admin) > Health & Wellness view.

Sample Troubleshooting Format

NetWitness returns the following types of error messages in the log files for.

timestamp failure (LogCollection) Message-Broker Statistics:...
Lo
M(—f’ssages timestamp failure (AMQPClientBaseLogCollection):...

timestamp failure (MessageBrokerLogReceiver):...

Possible The Log Collector cannot reach the Message Broker because the Message Broker:
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e has stopped running

e has erroneous connection settings

2. Start the RabbitMQ Message Broker on event-broker node in the Explore view:

1. <use the="the" systemctl="systemctl" command="command" on="on"
console="console" to="to" check="check" status="status" of="of"
message="message" broker="broker" shell="shell"
console.="console.">returns the following if the message broker
is not running:</use>

prompt$ systemctl status rabbitmg-server

rabbitmg start/running, process 10916

*. Change Service LC] Log Collector | Explore

Log Callecter (Log Collectar)

E LOg C <l {Event-Broker
. config .
=5 Log Collector (LOG_COLLE destination I
& connections :
destinations
[ event-broker . X -
I —
[devent-pracessars —_—
8 logeollection Properties for Log Collector (Log Collector) /event-broker. X
Ciogs start -
s
B[ sak Message Help
o R Start the event broker
seness security.roles: logrollection.manage
[Mstoredproc Il
My

Musers
Response Output
[ deviceappliance

« I ¥

Troubleshooting Logstash

Unable to re-configure or edit the custom configuration in Logstash.

While re-configuring the events source configuration, if you update the Event source
host's IP and save it, Logstash still connects to the old IP.

For example, suppose the Elasticsearch IP is not reachable due to some reason, and you
updated the correct IP, but Logstash connects to the old IP (which is not reachable).

You must restart the Logstash service:
systemctl restart logstash

NetWitness Export connector UI does not validate user aggregation permissions.

Users without aggregation permission are also allowed to configure NetWitness Export
Connector in the Ul

Make sure you configure the NetWitness Export Connector Event source with the right
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aggregation permissions.

NetWitness Export Connector UI does not validate user credentials.

NetWitness Export Connector Ul displays test configuration successful even if you have
configured Export Connector without appropriate aggregation permissions.

Make sure you configure the NetWitness Export Connector Event source using the correct
credentials.

Logstash event source test configuration fails with memory allocation an error "There is
insufficient memory for JVM".

Sometimes test configuration fails due to insufficient memory available for JVM.

You must change the JVM -xms to a lower value at /etc/logstash/jvm.options.
Perform the following:

1. Goto /etc/logstash/jvm.options and change -xms8g to a lower value as per
the memory configuration of the appliance.

2. Restart the Logstash service using the following command:
service logstash restart

Issue with Logstash Performance.

If EPS is more than 25K, you must increase JVM to get better performance.

You must change the JVM -xmx to a higher value at /etc/logstash/jvm.options.
Perform the following:

1. Goto /etc/logstash/jvm.options and update JVM to -xmx32g

2. Restart the Logstash service using the following command:
service logstash restart
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