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How Warehouse Connector Works

Warehouse Connector collects meta and events from Decoder and Log Decoder and writes them
in AVRO format into a Hadoop-based distributed computing system. You can set up Warehouse
Connector as a service on existing Log Decoders or Decoders.

The Warehouse Connector contains the following components:
o Data Source
o Destination

o Data Stream

Data Source

A data source is the service from which the Warehouse Connector collects data to store in the
destination. The supported data sources are Log Decoder and Decoder services.

Destination

Destination is the Hadoop-based distributed computing system that collects, manages, and
enables reporting on security data. The following are the supported destinations:

o RSA NetWitness Warehouse (MapR) deployments
o HortonWorks Data Platform

o Any Hadoop-based distributed computing system that supports WebHDFS or NFS mounting
of HDFS file systems.

o Example: Commercial MapR M5 Enterprise Edition for Apache Hadoop

Data Streams

A data stream is a logical connection between the data source and destination. You can have
multiple streams for different subsets of data collected. You can setup streams to segregate data
from multiple Decoder and Log Decoder services. You can create a stream with multiple data
sources and a single destination or with a single data source and destination.

The Warehouse Connector does the following:

o Aggregates session and raw log data from Decoders and Log Decoders.
o Transfers the aggregated data into supported destinations like Hadoop based deployments.

o Serializes the aggregated data that includes both schema and data into AVRO format.

In addition the Warehouse Connector also supports the following:

5 How Warehouse Connector Works
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Meta Filters

Meta filters enables you to filter the meta keys that should be written into the Warehouse. For
more information, see Specify Meta Filters for a Stream.

Support for Multi-Valued Meta Keys

RSA NetWitness Warehouse supports multi-valued meta keys. The multi-valued meta keys is
the meta field with the array type. You can use the meta keys library to determine the meta
fields of type array and write HIVE queries with the correct syntax for arrays. By default, the
following meta keys are treated as multi-valued and are defined in the file, multivalue-
bootstrap.xml located at /etc/netwitness/ng in the Warehouse Connector:

o alias.host
e action

o username
« alias.ip
o alias.ipv6
o email

» device.group

o cvent.class

Checksum Validation

Warehouse Connector enables you to validate the file integrity of the AVRO files that are
transferred from the Warehouse Connector to the data destinations. You need to enable
checksum validation while you configure the Warehouse Connector.

Lockbox Support

Lockbox provides an encrypted file that Warehouse Connector uses to store and protect sensitive
data. You need to create the lockbox by providing a lockbox password while configuring the
Warehouse Connector for the first time.

You can orchestrate Warehouse Connector on a Log Decoder or a Decoder appliance.

The following is an overview of the entire process of installing and configuring the Warehouse
Connector service on Log Decoder or Decoder, configuring the Warehouse Connector service
on NetWitness, configuring data sources, destinations, streams for Warehouse Connector, and
configuring alert notifications on NetWitness.

How Warehouse Connector Works 6
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Install Warehouse Connector ‘ Configure a Warehouse
Service on a Log Decoder or
Decoder

Configure a Destination Add Warehouse as a Data
Connector Service Source to Reporting

Engine
Create a Lockbox

Configure Destination
using NFS, SFTP, and
WebHDFS

Analyze a Warehouse

Cenfigure the Data Source Configurs a Stream Report

for Warehouse Connector
Create a Stream

Update the Port Number
and SS5L Settings of the
Data Source

Finalize the Stream

Start the Stream

Connector

Manage a Stream and

|
|
|
: Menitor a Warehouse
|
|
| Lockbox

Edit a Stream

Reload the Stream

Specify Meta Filters for
a Stream

Define Multi-valued
Metas

Change or Refresh
Lockbox ‘

To install and configure the Warehouse Connector service, perform the following:

1. Install Warehouse Connector service on a Log Decoder or Decoder
2. Configure a Warehouse Connector service

3. Configure the Data Source for Warehouse Connector

4. Configure a Destination

5. Configure a Streams

6. Monitor a Warehouse Connector

7. Add Warehouse as a Data Source to Reporting Engine

8. Analyze a Warehouse Report

9. Manage a Stream and Lockbox

7 How Warehouse Connector Works
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Install Warehouse Connector Service on a Log

Decoder or Decoder or Hybrid

To install (fresh install) the Warehouse Connector service on a Log Decoder or Decoder or
Hybrid:

1. Log on to the Log Decoder or Decoder host.

2. Enter the following command on NetWitness Server:
warehouse-installer --help

The command line interface (CLI) usage descriptions are displayed.

4. Install Warehouse Connector service by executing either of the following commands:
warehouse-installer --host-addr 10.0.0.0
warehouse-installer --host-id 5928b9d8-83be-4143-9602-fa9%936debc4dle
warehouse-installer --host-name NWllAdminServer
Where,
10.0.0.0 - IP address of the Host
5928b9d8-83be-4143-9602-fa936deS5c41e - Host ID
NWI11AdminServer - Host name

The Warehouse Connector service is successfully installed on the Log Decoder or Decoder or
Hybrid.

Install Warechouse Connector Service on a Log Decoder or Decoder or Hybrid 8
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Configure a Warehouse Connector Service

You can configure the Warehouse Connector service using the following procedure.

To set the Lockbox password:

1. Log on to NetWitness.
2. Go to ADMIN > Services.
3. Inthe Services view, select the added Warehouse Connector service, and select o
> View > Config.
4. In the Services Config view of Warehouse Connector, click the Lockbox Settings tab.
RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN
4 Change Service | Warehouse Connector | Config
Sources and Destinations ~ Streams ([EISNUISEIZANESE General  Appliance Service Configuration
Create New Lockbox
Lockbox Password FEEEAE
[Change Lockbox Password
[Current Lockbox Password =~ | **Fsssss
[New Lockbox Password *RETEXRL
[Confirm New Lockbox Password | ### ikt
Refresh Lockbox
[Lockbox Password ~ FEEEERRE
‘ NETWITNESS SUITE
5. Inthe Create New Lockbox section, perform the following:
a. Inthe Lockbox Password field, enter the new lockbox password.
Note: The lockbox password must be at least eight characters in length and it must
contain at least three of the following groups: one uppercase character [A-Z], one
lowercase character [a-z], one numeral [0-9], and one special character.
b. In the Confirm Lockbox Password field, enter the added lockbox password to confirm.
c. Click Apply.
The Lockbox password is set.
9 Configure a Warechouse Connector Service
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Configure the Data Source for Warehouse

Connector

To configure the data source:
1. Log on to NetWitness.
2. Go to ADMIN > Services.

3. Inthe Services view, select the added Warehouse Connector service, and select -
> View > Config.

The Services Config view of Warehouse Connector is displayed.

4. On the Sources and Destinations tab, in the Source Configuration section, click +.

Available Services

;9’ Name -~ Address Type
;ﬁ' Decoder Decoder
’9’ Log Decoder Log Decoder

Cancel oK

5. Inthe Available Services dialog, select the Log Decoder or Decoder services that you want
to add as a source to the Warechouse Connector service and click OK.

The selected Log Decoder and Decoder services are listed in the Source Configuration
section.

Configure the Data Source for Warehouse Connector 10



Warehouse Connector Configuration Guide

Update the Port Number and SSL Settings of the Data Source

If there is change in the port number or SSL settings of the data sources used in the Warehouse
Connector, you can directly update these details in Warehouse Connector, using the
Explore view of the Warehouse Connector.

Make sure that:
o You have the updated port number or SSL settings of the data source.
o You stop the streams related to the data source that you want to update the port number or

SSL settings.

To update the port number or SSL settings:

1. Log on to NetWitness.

2. Goto ADMIN > Services.

ﬁv

3. Inthe Services view, select the added Warehouse Connector service and select
> View > Explore.
The Service Explore view of Warehouse Connector is displayed.

Warehouse Connectar (Warehouse Connector)

| NETWITNESS SUITE

4. Navigate to warehouseconnector/sources, right-click the source, and click Properties.
The Properties section of the source is displayed.

11 Configure the Data Source for Warehouse Connector
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RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN

Services

# Change Service | Warehouse Connector | Explore

v Warehouse Connector (Warehouse Connector)

= Warehouse Connect...

|5 & Warehouse Connector (WAREHOUSE._CO..
BT conne ctions

8 logs

B rest

BT services

[Ostoredproc

connections
logs
rest
storedproc
s
B0 warehouseconnector
B Jusers deviceappliance
[warehouseconnectar
Cconfig
B[ destinations I
[sources
O
]
Cstats

8 deviceappliance

Properties

5. Inthe drop-down menu, select update. In the Parameters field, perform the following:

o To update the port number of the source, enter port=<new source portnumber> and
click Send.

Parameters port=443 Send ‘

« To update the SSL settings of the source, enter ssl=<new ssl settings>and click
Send.

Parameters |ssl=on Send ‘

Note: You can also update the port number and ssl settings simultaneous by adding
space between the parameters.

Parameters port=442 ssl=on

6. Restart the Warehouse Connector service.

7. Start the streams.

Configure the Data Source for Warehouse Connector 12
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Configure the Destination

You can configure the destination using NFS, SFTP, and WebHDFS. Change the destination to
which the Warehouse Connector service needs to write the collected data using NFS:

o RSA NetWitness Warehouse (MapR) deployments

o Commercial MapR M5 Enterprise Edition for Apache Hadoop deployments

You can configure the Warehouse Connector to write to a remote destination using Secure File
Transfer Protocol (SFTP). The remote destination can be a remote server that is NFS mounted to
the MapR cluster or it can be a remote staging server.

By default, in the remote destination the Warehouse Connector writes data in the following
directory structure:

e /<staging
folder>/rsasoc/vl/sessions/data/<year>/<month>/<day>/<hour>/

e /<staging
folder>/rsasoc/vl/logs/data/<year>/<month>/<day>/<hour>/
Where <staging_folder> is the folder on the remote server where the Warehouse Connector

writes the data.

If you are using a remote staging server as the remote destination, you need to manually copy or
move the directory structure to any of the following deployments:

o RSA NetWitness Warehouse (MapR)
o Commercial MapR M5 Enterprise Edition for Apache Hadoop

¢ HortonWorks HD

To generate reports from the data written by Warehouse Connector, make sure that in your
Hadoop deployment you maintain a similar directory structure that is created by Warehouse
Connector in the remote destinations.

13 Configure the Destination
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The following illustration describes how you can use SFTP to write data from Warehouse
Connector to a remote destination.

|
i
| | |
WC writes data in the *Directory l l @ l
Structure mentioned below l I l
| |
s | @ @ [
N —r————
|
[
|
|
|

|
|
|
|
|
|
|
| i
Ri
| MapR Cluster el
| | Maintain the *Directory Structure | |
Remote Server i | as mentioned below i i
| i i
| L P — - |
Warehouse : :
s
Connector (WC) ELE : i| Reporting Engine
| R i | I
- see_ |
| ! L
i N &
- ! | : :
s Man ualllerrogra mmatically 1 ‘ Reporting
N — e
SEIE < DAive/Cipy Slie Bata i MapR Cluster / Pivotal HD

| |
i Maintain the *Diractary Structure I
WC writes data in the *Directory j as mentioned below |
I |

Structure mentioned below

*Directory Structure: i
- [<staging folder>/rsasoc/vl/sessions/data/<year>/<month>/
<day=/<hour=|

- [<staging_folder>/rsasoc/vl/logs/data/<year>/<month>/<day>/
<hour>/

You can configure the Warehouse Connector service to write the collected data to a Hadoop-
based distributed computing system that supports WebHDFS.

Configure the Destination 14
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Configure the Destination Using NFS

Make sure that you have:
o Installed the Warehouse Connector service or virtual appliance in your network environment.

o Added the Warehouse Connector service to NetWitness. For more information, see "Add a

Service to a Host" in the Hosts and Services Getting Started Guide.

o Setup NFS on Warehouse Connector. For more information on how to set up NFS on
Warehouse Connector, see "Configure Warehouse Connector to Write to Warehouse" in the
Warehouse (MapR) Configuration Guide.

To configure the destination using NFS:

1. Log on to NetWitness.

2. Goto ADMIN > Services.

.ﬁ.v

3. Inthe Services view, select the Warehouse Connector service, and select
> Config.

> View

The Services Config View of Warehouse Connector is displayed.

nnector | Config

s Lockbox Settings ~ General  Appliance Service Configuration

[Source Configuration Destination Configuration

+ +

1| Adaress porc O name Type

I | 1031125245 56004 ] NFs nfs Iroot/test/kaushal

[ 1031125242 56002 0 sFp sfip Irootitest

NETWITNESS SUITE

4. On the Sources and Destinations tab, in the Destination Configuration section, click +.
5. Inthe Add Destination dialog, select NFS from the Type drop-down list.

6. Inthe Name field, enter a unique symbolic name for the destination.

15 Configure the Destination
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Note: The Name field does not support spaces or special characters except underscore

Q-

7. In the Local Mount Path field, enter the locally mounted directory for HDFS where you
want the Warehouse Connector to write the data. For example:
If /saw is the local mount point for HDFS that you have configured while mounting the
mapr NFS cluster on the host where you have installed the Warehouse Connector service to
write to RSA NetWitness Warehouse (MapR), create a directory
named Ionsaw01 under /saw and the corresponding Local Mount Path for the destination
would be /saw/Ionsaw01.

For more information, see "Mount the Warehouse on the Warehouse Connector" topic in the
Warehouse (MapR) Configuration Guide.

Add Destination

Type * NFS| v

Mame *

Local Mount Path *

Cancel Save

The /saw mount point implies to / as the root path for HDFS. The Warehouse Connector
writes the data to /Ilonsaw01 in HDFS.

8. Click Save.
9. (Optional) If you want to enable checksum validation, perform the following:

a. Goto ADMIN > Services.

b. Inthe Services view, select the added Warehouse Connector service, and select -
> View > Explore.
The Explore view of Warehouse Connector is displayed.

Configure the Destination 16
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c.

RSA RESPOND  INVESTIGATE MONITOR  CONFIGURE

Services

ADmMIN

& ChangeService | Warehouse Connector | Explore ©

= Warehouse Connect...

Ostats
B[] deviceappliance

| NETWITNESS SUITE

|? = Warehouse Connector (WAREHOUSE C...

undefined

connections

logs

In the options panel, navigate to warehouseconnector/destinations/nfs/config. This is
the name of the destination and is dynamic.

Set the parameter 1 sChecksumValidationRequired to 1.

RSA RESPOND  INVESTIGATE  MONITOR CONFIGURE

B[ Jdestinations
BN
[config
alasfe
B sources
Cstats
B[] deviceay ppliance

ADMIN

Restart the respective stream.

17
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Configure the Destination Using SFTP

Make sure that you have:

Installed the Warehouse Connector service or virtual appliance in your network environment.

Added the Warehouse Connector service to NetWitness. For more information, see the "Add

a Service to a Host" in the Hosts and Services Getting Started Guide.

For the SFTP destination type, the destination host should be listed in the /root/.ssh/known_

hosts file used by the ssh service (for example, sshd) running on the Warehouse Connector.

Add Destination from Warehouse Connector Host

To add the destination host to the /root/.ssh/known_hosts file, from the Warehouse Connector
host, initiate a secure connection to the destination host:

L.
2.

Login to the Warehouse Connector.
Enter ssh root@<SAWIP> or ssh username@<SAWIP>.
Select Yes and enter the password.

Add the host key in the /root/.ssh/known_hosts file

Note: After you upgrade Warehouse Connector to 11.0, you must make sure that the
destination host is listed in the /root/.ssh/known_hosts file used by the ssh service
(i.e. sshd) running on the Warehouse Connector. If you do not perform this action, the
streams configured with SFTP in Warehouse Connector will not start.

If you want to use SFTP to write data into the destination using SSH key-based access, you
need to configure SSH key-based access between the Warehouse Connector and the

Warehouse host or Hadoop node. For more information, see Configure SSH Keys below.

Note: If you want to enable checksum validation to validate the integrity of the AVRO files
that are transferred from the Warehouse Connector to the destinations, make sure that you
generate the keys without setting the passphrase and do a key exchange between
warehouse connector and the warehouse nodes.

Configure the Destination 18
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Configure Warehouse Connectorto use SFTP destination
To configure the destination:
1. Log on to NetWitness

2. Goto ADMIN > Services.
.ﬁ. -

3. Inthe Services view, select the added Warehouse Connector service, and select
> View > Config.

The Services Config view of Warehouse Connector is displayed.

angeservice | Warehouse Connector | Config

DAESRURL IR streams  LockboxSettings  General  Appliance Service Configuration

[Source Configuration Destination Configuration

+ +

[ acaress Port 0 Name Type Patn

|1 1031125245 56004 [ NFs nfs Iroot/test/kaushal
[0 1031425242 56002 O s sfp Iroot/test

NETWITNESS SUITE

4. On the Sources and Destinations tab, in the Destination Configuration section, click +.

5. Inthe Add Destination dialog, select SFTP from the Type drop-down list.

Add Destination

Type * SFTP v
Mame *

Host *

Port * 22 =
Usarname *

Password/Passphrase FkE kA

Remote Path *

Cancel Save

19 Configure the Destination
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10.

11.
12.
13.

In the Name field, enter a unique symbolic name for the destination.

Note: The Name field does not support spaces or special characters except underscore

0.

In the Host field, enter the remote server IP address.
In the Port field, retain the default port, 22.

In the Username fiecld, enter the SSH username.

Note: In the case of HortonWorks HD, ensure that the username is gpadmin and for
password based access the password for gpadmin should be used. For passphrase-based
access, the passphrase used to generate the keys for gpadmin user should be used.

In the Password/Passphrase field, enter one of the following:

m SSH password - If you are using SFTP to write data into the destination using password-

based access.

m SSH passphrase - If you are using SFTP to write data into the destination using SSH key-

based access.
In the Remote Path field, enter the path of the directory present on the SFTP server.
Click Save.
(Optional) If you want to enable checksum validation, perform the following:
a. Goto ADMIN > Services.
£ -

b. Inthe Services view, select the added Warehouse Connector service, and select

> View > Explore.

The Explore view of Warehouse Connector is displayed.

= Warehouse Connect...

|? = Warehouse Connector (WAREHOUSE C...
B[] connections.

BT10gs

B0 resc

| NETWITNESS SUITE
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c. In the options panel, navigate to warehouseconnector/destinations/sftp/config.

d. Set the parameter i sChecksumValidationRequired to 1.

D @ @aumn

e G services B

& Change Service |

rfdestinations/SFTP/config v Warehouse Connector (Warehouse Connector) &

= Warehouse Connect...

[F 5 Warehouse Connector (WAREHOUSE_CO...

host 10.31.204.4422
type hafs

subtype sfp

NETWITNESS SUITE

e. Restart the respective stream.

Configure SSH Keys

To configure SSH key-based access between the Warehouse Connector and the Warehouse
host or Hadoop node:

1. Generate SSH keys on the Warehouse Connector at the default location. Perform the
following:

a. Log on to the Warehouse Connector.

b. Type the following command and press ENTER:
$ OWB_FORCE FIPS MODE OFF=1 ssh-keygen -t dsa

¢. The command prompts you to enter the file in which to save the generated key.
Enter file in which to save the key (/root/.ssh/id dsa):

d. Enter the file in which you want to save the key and press ENTER.

The command prompts you to enter and confirm the passphrase.

Note: If you want to enable checksum validation to validate the integrity of the AVRO
files that are transferred from the Warehouse Connector to the destinations, make sure
that you do not set the passphrase. Then, the below steps e, f, g, and h are not
applicable.

21 Configure the Destination
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Enter passphrase (empty for no passphrase):

Enter same passphrase again:
The public key is generated and is saved in the location that you provided.
e. Change the directory by entering the following command:
cd /root/.ssh/
f. Move the generated key to the below location:
mv id dsa id dsa.old

g. Type the following command and press ENTER:

$ OWB_ FORCE FIPS MODE OFF=1 openssl pkcs8 -topk8 -v2 des3 -in id
dsa.old -out id dsa

The command prompts you to enter and confirm the passphrase.
h. Enter the encryption passphrase.
i. Run the following command to change the file permission:
chmod 600 id dsa

2. Append the generated public key to the remote Warehouse host or Hadoop node's authorized
keys list located at: ~/.ssh/authorized keys

Note: Make sure that you copy the public keys to the Hadoop node and while copying the
public key ensure that you provide the login details of the user using which the WebHDFS
destination would be added.

You can now securely communicate between Warehouse Connector and Warehouse nodes or
Hadoop nodes.

Configure the Destination 22
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Configure the Destination Using WebHDFS

Make sure that you have:

Installed the Warehouse Connector service or virtual appliance in your network environment.

Added the Warehouse Connector service to NetWitness. For more information, see the "Add

a Service to a Host" in the Hosts and Services Getting Started Guide.

Added the hostname (or FQDN) and IP address of the warehouse nodes and Warehouse
Connector to the DNS server. If the DNS server is not configured, add the hostname
(or FQDN) and IP address of the warchouse nodes and Warehouse Connector to the file in

the host on which the Warehouse Connector service is installed.

If you want Kerberos authentication between the warehouse connector and the

warehouse cluster, make sure that you perform the following:

o Kerberos Key Distribution Center (KDC) Server is configured in your network
environment and the Kerberos Keytab file is copied to the host on which you have installed

Warehouse Connector.
o Kerberos authentication is enabled in the warehouse cluster.

If you want to enable checksum validation to validate the integrity of the AVRO files that are
transferred from the Warehouse Connector to the destinations, make sure that you generate
the keys without setting the passphrase and do a key exchange between the Warehouse
Connector and the warehouse nodes. You need to configure SSH key-based access between
the Warehouse Connector and the Warehouse host or hadoop node. For more information, see

'Configure SSH Keys' in Configure the Destination Using SFTP.

23
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Configure Warehouse Connector to Write to
SFTP destination

To configure the destination:

1.
2.

4.

Log on to NetWitness.

Go to ADMIN > Services.

In the Services view, select the added Warehouse Connector service and select
> View > Config.

The Services Config view of Warehouse Connector is displayed.

INVESTIGATE MONITOR CONFIGURE  ADMIN

or |  Config

DMERIRDEENIIEN  streams  Lockbox Settings  General  Appliance Service Configuration

Source Configuration Destination Configuration

+ +

| ncaress port 0 Name Type Patn

|1 1031125245 56004 [ NFs nfs /Iroot/test/kaushal

|1 1031125248 56002 O sFe sty Iroot/test
P

NETWITNESS SUITE

On the Sources and Destinations tab, in the Destination Configuration section, click +.

Configure the Destination 24
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5. Inthe Add Destination dialog, select WebHDFS from the drop-down list.
Add Destination
Type * WebHDFS w
Mame *
Hadoop IP *
Hadoop Port * o
Username *
Hadoop Path *
Kerberos Authentication []
6. Inthe Name field, enter a unique symbolic name for the destination.
Note: The Name field does not support spaces or special characters except underscore
0.
7. Inthe Hadoop IP field, enter the namenode IP address of the warehouse cluster.
8. In the Hadoop Port field, enter the base port that is used by the namenode web user
interface.
9. Inthe Username field, enter the owner of the directory in the warehouse to which
Warehouse Connector should write the data.
10. In the Hadoop Path field, enter the path of the directory in the warehouse to which
Warehouse Connector should write the data.
11. Select the Kerberos Authentication checkbox, if you want the warehouse connector to
securely communicate with the warehouse using Kerberos authentication.
25 Configure the Destination
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Add Destination

Type * WebHDFS ~
Mame *
Hadoop IP *

Hadoop Port *

L

Username *
Hadoop Path *

Kerberos Authentication [+

Kerberos Principal *

Kerberos Keytab File
Path *

Cancel Cave

Perform the following:

a. Inthe Kerberos Principal field, enter the KDC Principal used

for Kerberos authentication.

b. Inthe Kerberos Keytab File Path ficld, enter the path of the Kerberos Keytab file in

the Warehouse Connector.
12. Click Save.
13. (Optional) If you want to enable checksum validation, perform the following:

a. Goto ADMIN > Services.

o RS

b. Inthe Services view, select the added Warehouse Connector service and select
> View > Explore.

The Explore view of Warehouse Connector is displayed.
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RSA RESPOND  INVESTIGATE MONITOR CONFIGURE  ADMIN

Services Eve

% Changeservice | Warehouse Comnector | Explore @

= Warehouse Connect...

|? = Warehouse Connector (WAREHOUSE C...

services
rese
= storedproc
Dservies o
&[T storedproc -

c. In the options panel, navigate to warehouseconnector/destinations/webhdfs/config.

d. Set the parameter i sChecksumValidationRequired to 1.

RSA RESPOND  INVESTIGATE MONITOR CONFIGURE

Se

# Change service | Warehouse Connector | Explore ©

_ e e
= Warehouse Connect... e
IsChecksumValidationRequired 1

= S Warehouse Connector (WAREHOUSE_CO...

B[] connections
subtype ofs

type hafs

B[] warehouseconnector
Ceonfig
B0 destinations
aINFs

e. Restart the respective stream.
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Configure a Stream

You can configure the data stream to define the data source and destination combinations.

Make sure that you have:
o Installed the Warehouse Connector service or virtual appliance in your network environment.

o Added the Warehouse Connector service to NetWitness. For more information, see the "Add

a Service to a Host" in the Hosts and Services Getting Started Guide.

o Configured the data source from which the Warehouse Connector service needs to collect

data. For more information, see Configure the Data Source for Warehouse Connector.

o Configured the destination to which the Warehouse Connector service needs to write the

collected data. For more information, see Configure the Destination.

To configure the stream:

1. Create a stream
2. Finalize the stream

3. Start the stream
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Create a Stream

To create a stream:

1. Goto ADMIN > Services.

2. In the Services view, select the added Warehouse Connector service and select -
> View > Config.
The Services Config view of Warehouse Connector is displayed.

3. Click the Streams tab.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN

Services

4 ChangeService | Warehouse Connector | Config

Sources and Destinations [ESUSSIEM Lockbox Settings ~ General  Appliance Service Configuration

2 Name Sources Destination Status

=] ° running

[To configure the alert mechanisms related to the Warehouse Connector navigate here.

NETWITNESS SU
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4. On the Streams tab, click +.

Add Stream

Stream Mame *
Select Destination *
Select Source *

L] MName

O
0

Choose Destination ...

Address Port
56004
56002

Session 1D

Enter Session

Enter Session

Cancel Save

5. Inthe Add Stream dialog, perform the following:

a. Inthe Stream Name ficld, enter a name for the stream.

underscore ().

Note: The Stream Name field does not support spaces or special characters except

b. Inthe Select Destination drop-down menu, select a destination from the list of

destinations added to the Warehouse Connector.

c. Inthe Select Source field, select sources from the list of sources displayed.

d. In the Session ID column, enter the last session id.

If you provide any session id, the Warehouse Connector will start the aggregation from

that session, whereas if this is left blank, the aggregation will start from the current

session.

e. Click Save.

Configure a Stream
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Finalize the Stream

Make sure that you have created a stream.

To finalize the stream:

L.

Go to ADMIN > Services.

o 08

In the Services view, select the added Warehouse Connector service and select
> View > Config.

The Services Config view of Warehouse Connector is displayed.

On the Streams tab, select the stream that you have created.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN

& ChangeService | Warehouse Connector | Config

Sources and Destinations [ESUFCIICM Lockbox Settings ~ General  Appliance Service Configuration

| Name Sources Destination Status

=] @ 150002 running

s related to the Warehouse Connector navigate here,

4. Click Finalize.
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Start the Stream

Note: If you have deployed a Warehouse Connector Virtual Appliance, make sure that you
change the default value of the Maximum Message Hold Count parameter to 800000. For
more information, see General Tab Settings.

To start the stream:

1. Goto ADMIN> Services.

2. In the Services view, select the added Warehouse Connector service and select o
> View > Config.

The Services Config view of Warehouse Connector is displayed.

3. On the Streams tab, select the stream that you have created.

RSA RESPOND INVESTIGATE MONITOR

os Services e S s
 changesenice | [ Rl | Config

Sources and Destinations [ESUCCCH Lockbox Settings ~ General  Appliance Service Configuration

4. Click Start.
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Monitor a Warehouse Connector

By monitoring a Warehouse Connector, you can automatically generate notifications when
critical thresholds concerning Warehouse Connector and its storage have been met.

To monitor a Warehouse Connector:

L.

Go to ADMIN > Services.

In the Services view, select the added Warehouse Connector service and select

& -

> View > Config.

The Services Config view of Warehouse Connector is displayed.

. Click the Streams tab.

At the bottom of the Streams tab, click To configure the alert mechanisms related to the

Warehouse Connector navigate here.

The Warehouse Connector Monitoring page is displayed.

Caution: This page is deprecated and will be removed in a future release.

5. Inthe Source or Destination Status section, select the number of minutes or hours in the
Notify After Failing For field.

You will receive a notification if the source or destination connection fails for the defined

number of minutes or hours.

6. In the Stream Status section, perform the following:

a. In the Notify Stopped For field, define the number of minutes or hours after which you
would like to receive a notification when the stream goes offline.

b. Inthe Disk Is field, define the limit on the percentage of disk usage after which you
would like to receive a notification.

c. Inthe Source is Behind field, define the number of sessions. A notification is raised if
the source goes behind the defined number of sessions.

d. Inthe Rejected Folder Size is field, define the limit on the percentage of folder usage
after which would like to receive a notification.

e. Inthe Number Of Files in Permanent Failure Folder field, define the limit on the
number of files in the permanent failure folder after which you would like to receive a
notification.

33 Monitor a Warehouse Connector



Warehouse Connector Configuration Guide

7. In the Notification Type field, perform the following:

a. Click Configure email or distribution list to configure email so that you can receive
notifications in NetWitness. For more information, see the "Configure Email Server and

Notification Account" topic in the System Configuration guide.

b. Click Configure Syslog and SNMP Trap servers to configure audit logs. For more
information, see the "Configure Syslog and SNMP Settings" topic in the System
Configuration guide.

c. Select the following notification mechanisms as per your requirement:
o NetWitness Console - To get notifications on the NetWitness Ul notification toolbar.
o Email - To get email notifications.
o Syslog Notification - To generate syslog events.

o« SNMP Trap Notifications - To get audit events as SNMP traps.
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Add Warehouse as a Data Source to Reporting

Engine

Y ou must add Warehouse as a data source to Reporting Engine to make this data source
available to reports against this Reporting Engine. For more information, see "Add Warehouse
as a Data Source to Reporting Engine" topic in the Reporting Engine Configuration Guide.
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Analyze a Warehouse Report

The Warehouse modules provide analysts with reports of early indicators of compromise. The
following Warehouse reports can be analyzed in NetWitness:

o Suspicious Domains report
o Suspicious DNS Activity report

o Host Profile report

For more information, see "Step 4. Analyze a Warehouse Report" topic in the Warehouse Guide.
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View the Warehouse Connector Service

While the information displayed in the Services System view is the same for all types of core
services, several options in the toolbar are relevant only for Warehouse Connector.

To access this view:

1. Goto ADMIN > Services.

2. In the Services view, select a Warehouse Connector and select - > View > System.
The Systems view for the selected Warehouse Connector is displayed.

RSA RESPOND INVESTIGATE MONITOR

CONFIGURE  ADMIN

Services

% ChangeService |  Warehouse Connector | System
B Host Tasks ) Shutdown Service (& Shutdown Appliance Service ) Reboot
~
Warehouse Connector Service Information Appliance Service Information
localhost.localdomain (Warehouse Connector) e localhost.localdomain (Host)
11.0.0.0-1932.1 (Rev null) 11.0.0.0 (Rev null)
sage 26416 KB (0.08% of 32176 MB) sage 24352 KB (0.07% of 32176 MB)
0% 0%
e 2017-May-10 11:37:19 e 2017-May-10 11:37:12
4 days 19 hours 26 minutes 11 seconds 4 days 19 hours 27 minutes 44 seconds
Current Time  2017-May-15 07:03:30 Current Time  2017-May-15 07:04:56
Warehouse Connector User Information Host User Information
admin admin
Administrators Administrators
connections.manage, logs.manage, services.manage, storedproc.execute, appliance.manage, connections.manage, | services.manag:
storedproc.manage, sys.manage, users.manage, warehouseconnector.manage storedproc.execute, storedproc.manage, sys.manage, users.manage
License Information
St D 29619063-ce24-4C7c-94c9-8f083aaad1b9
U
v
Soccinn Infarmatinn
< >

The following is an example of toolbar options for Warehouse Connectors.

B HostTasks (U Shutdown Service () Shutdown Appliance Service () Reboot

Host Tasks, Shutdown Service, Shutdown Appliance Service or (Shutdown Appliance), and

Reboot are common to all services and are described in the Hosts and Services Getting Started
Guide.
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Troubleshoot the Warehouse Connector

The following information suggests the possible issues that NetWitness users may encounter
when adding a Warehouse service to the Reporting Engine as a data source for
reporting in NetWitness. Look for explanations and solutions in this section.

While adding a Warehouse service to the Reporting Engine as a data source for reporting, you
may observe some of the errors listed in this document. Information is provided on how to
troubleshoot the errors and add the data source successfully.

The following figure shows the New Service dialog.

MNew Service

Source Type * WAREHOUSE w
Warehouse Source * HiveServer2 ~
Mame * PDHZ.0-DCA

HDFS Path * /

Advanced [l

Host *

Port * 10000

Username * gpadmin

Pa SSWGFd ThxEEEiAE

Kerberos Authentication [

Server Principal *
User Principal *
Kerberos Keytab File *

Enable Jobs O

Test Connection

Cancel Save

For more information, see "Add Warehouse as a Data Source to Reporting Engine" topic in the
Reporting Engine Configuration Guide.
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_ Possible Solutions

Could not open connection e Ensure that the HiveServer2 is running on the Host.

to HiveServer o Check if the port provided can be accessible from the

Reporting Engine server.

No Schema found in Ensure that meta avro data file(s) are available in the HDFS path
(<HDFS Path>/rsasoc/vl/sessions/meta) mentioned.

The following figure shows an example of the command to check
the files in hdfs.

HDEFS path

Could not open connection GSS initiate failed errors will be observed only in the case of

to HiveServer, GSS Kerberos enabled Hive.

initiate failed Ensure that the proper keytab file is provided and it should have
read options for the rsasoc user (user on which the Reporting
Engine Server runs).
Ensure that the system time is synchronized between KDC,

Hadoop (HortonWorks) server, and the Reporting Engine system.
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Manage a Stream and Lockbox

You can manage a stream using the following procedures:

Edit a Stream
Reload the Stream
Specify meta filters for a Stream

Define muti-valued metas

Edit a Stream

You can edit a stream to perform the following:

Add more data sources to the stream.

Delete existing data sources from the stream.

To edit a stream:

1.

3.

4.

Go to ADMIN > Services.

In the Services view, select the added Warehouse Connector service and select

> View > Config.

The Services Config view of Warehouse Connector is displayed.

INVESTIGATE MONITOR CONFIGURE  ADMIN

house Connector | Config

DMERIRDEENIIEN  streams  Lockbox Settings  General  Appliance Service Configuration

Source Configuration Destination Configuration

+ +

| ncaress port 0 Name Type Patn

|1 1031125245 56004 [ NFs nfs /Iroot/test/kaushal
|7 1031125208 seo02 O sae sfip Jroourese

NETWITNESS SUITE

On the Streams tab, click 4

In the Edit Stream dialog, you can perform the following:
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o On the Available Sources tab, you can select the available data sources to add to the

stream and click Save.

Edit Stream

Stream Mame

Destination

Available Sources

|:| Mame Address Port Session 1D

O 50004 50004 Enter Session

Cancel Save
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o On the Current Sources tab, you can delete an existing data source from the stream.

Select the data source and click = .

Edit Stream

Stream Mame

Destination

UGG El i {d= Current Sources

At least one source is required

|:| Mame Address Port

U :50002 50002

Cancel Save

Reload the Stream

When you reload the stream, the Warechouse Connector updates the schema file for the stream.
Y ou should reload the stream whenever you add a new custom meta to the Log Decoder or
Decoder.

To reload the stream:

1.

Go to ADMIN > Services.
ﬁ w

In the Services view, select the added Warehouse Connector service and select

> View > Config.

The Services Config view of Warehouse Connector is displayed.
On the Streams tab, select the stream that you want to reload.

Click Reload.

Manage a Stream and Lockbox
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Specify Meta Filters for a Stream

You need to specify the filter for each stream in the export.session.meta.fields
parameter in the Explore view of the Warehouse Connector.

The following table lists the values that you can provide as a filter:

* All the collected metas are written to SAW.

* metal, meta? All the metas except the defined metas are written to SAW.
For example,
Filter:*, ip.src

All the metas except ip.src is written to SAW.

metal, meta2, meta3 Only the defined metas are written to SAW.

Note: By default, the following metas are written to Warehouse even if you specify them in
the filter:

- ng_source

- unique_id

- time

To specify meta filters for a Stream:
1. Goto ADMIN > Services.
ﬂ v

2. In the Services view, select a Warehouse Connector services and select > View >

Explore.
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The Explore view of the Warehouse Connector service is displayed.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN

Se

& ChangeService | Warehouse Connector | Explore @

undefined Ware

= Warehouse Connect...

|/ © Warehouse Connector (WAREHOUSE C...

connections

logs
B[ connections :
a00egs services

b storedproc

se -
s users
805y warehouseconnector
B[ users deviceappliance
B[Jwarehouseconnector

[eenfi

[mES
E[Jdevicea) ppliance

NETWITNESS SUITE

3. Inthe options panel, select warehouseconnector > streams > <stream_name> > loader

> config.

4. Inthe export.session.meta.fields parameter, enter the filter.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN

Services i

& ChangeService | Warehouse Connector | Explore ©
- Warehouse C Connector)
= Warehouse Connect...
150002 10231
= & Warehouse Connector (WAREHOUSE C.
avroload.interval 3
bulk.copy 0
destination.online 1
yes
B senvices hour
B[ storedproc Jes
B sys
ETusers 100000
a0 wa hold.nterval 60
Bconfig « hold.size 512 M8
B[ destinations loader.stats.interval 1
8 sources page.size 200000
permrejected.number 0
0
- Jeesting
Cconfig 4
B Tloader 3
[eonfig deflats
e waitthread.pool 2
Osters

5. Restart the

stream.
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Define Multi-valued Metas

You can also define an existing meta or a custom meta to be treated as multi-valued meta.

To define multi-valued metas:

Caution: Defining an existing meta to be treated as multi-valued may change the data type of
the meta and cause the associated reports to fail.

1. Create a new file with the filename multivalue-users.xml in the /etc/netwitness/ng

directory.
2. Add the following entries:

<?xml version="1.0" encoding="utf-8"?>

<Netwitness>
<MultivValueMetas>

<Meta>NEWMETANAME</Meta>
</MultiValueMetas>

</Netwitness>

Where NEWMETANAME is the existing meta or a custom meta to be treated as multi-valued
meta.

Caution: Make sure that you do not add metas that are by default treated as non multi-

value.

3. Restart the stream.
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Manage a Lockbox

You can manage a lockbox using the following procedures:

o Change the Lockbox password

o Refresh the Lockbox

To change the Lockbox password:

1.
2.

Log on to NetWitness.

Go to ADMIN > Services.

In the Services view, select the added Warehouse Connector service, and select
> View > Config.

The Services Config view of Warehouse Connector is displayed.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN
Services

& ChangeService | Warehouse Connector | Config

DMEEFIRLIENIIEN  streams  LockboxSettings  General  Appliance Service Configuration

Source Configuration Destination Configuration

+ +

[ | adaress port 0 name Type Path

|1 1031125245 56004 [ nFs nfs /Iroot/test/kaushal
| 1031125248 56002 O sFp sftp. Iroot/test

NETWITNESS SUITE
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4. Click the Lockbox Settings tab.

TIGATE MONITOR CONFIGURE  ADMIN

4 Change Service | Warehouse Connector | Config

Sourcesand Destinations  Streams [RESSEALESN  General  Appliance Service Configuration

Create New Lockbox

fsec the The password will be required to enter thi d to perform any

Lockbox Password e

Jconfirm Lockbox Password FEEREERE

Apply

[Change Lockbox Password
JChange the lockbox password. You will be required to enter current password and new password.The password should satisfy lockbox password strength.
[Current Lockbox Password | #*##sas
[New Lockbox Password | FEEEERRE

JConfirm New Lockbox Password |

Apply

Refresh Lockbox
[Reset the lockbox.You will be required to enter current lockbox password.

JLockbox Password presser

NETWITNESS SUITE

5. Inthe Change Lockbox Password section, perform the following:
a. Inthe Current Lockbox Password ficld, enter the current lockbox password.

b. Inthe New Lockbox Password field, enter the new lockbox password.

Note: The lockbox password must be at least eight characters in length and it must
contain at least three of the following groups: one uppercase character [A-Z], one
lowercase character [a-z], one numeral [0-9], and one special character.

c. Inthe Confirm New Lockbox Password field, enter the new lockbox password to

confirm.
d. Click Apply.
The Lockbox password is successfully changed.
To refresh the Lockbox:

1. Log on to NetWitness.

2. Goto ADMIN > Services.

ﬁv

3. Inthe Services view, select the added Warehouse Connector service, and select

> View > Config.
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The Services Config view of Warehouse Connector is displayed.

RSA RESPOND  INVESTIGATE MONITOR CONFIGURE  ADMIN @ admin® @

& Change Service Warehouse Connector | Config

DAESRURL IR streams  LockboxSettings ~ General  Appliance Service Configuration

[Source Configuration Destination Configuration

+ +

[ adaress Port 0 Name Type Patn

|1 1031125245 56004 [ NFs nfs Iroot/test/kaushal
[0 1031425242 56002 O s sfp Iroot/test

4. Click the Lockbox Settings tab.

RSA RESPOND INVESTIGATE MONITOR CONFIGURE ADMIN @ admin
Services

& ChangeService | Warehouse Connector | Config

Sourcesand Destinations  Streams [IRNISENSUES General  Appliance Service Configuration

Create New Lockbox

et the The password will be required to enter th 4 5o perform any
L ockbox Password Frveeen
fcontirm Lockbox Password kit

Apply

[Change Lockbox Password
JChange the lockbox password. You will be required to enter current password and new password.The password should satisfy lockbox password strength.

Jcurrent Lockbox Password .

[New Lockbox Password

jConfirm New Lockbox Password | #+###+kx

Apply

Refresh Lockbox
[Reset the lockbox.You will be required to enter current lockbox password.

Lockbox Password prvever

Apply

5. Inthe Refresh Lockbox section, enter the current lockbox password in the Lockbox
Password field.

6. Click Apply.

The Lockbox is reset.
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Warehouse Connector Configuration References

This section contains descriptions of the user interface as well as other reference information.
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General Tab Settings

The General tab displays the general configuration settings for Warechouse Connector service.

Workflow

You are here

Add Warehouse as a Data
Source to Reporting
Engine

Install Warehouse Connector Configure a Warehouse Configure a Destination
Service on a Log Decoder or Connector Service
Decoder

Configure a Stream Analyze a Warehouse

Configure the Data Source

for Warehouse Connector Report

Menitor a Warehouse
Connector

Manage a Stream and
Lockbox

What do you want to do?

S T

Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid
Administrator Configure a Warehouse Configure a Warchouse Connector
Connector Service* Service
Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector
Administrator Configure the Destination using  Configure the Destination Using
NFS, SFTP, WebHDFS. NFS
Configure the Destination Using
SFTP

Configure the Destination Using
WebHDFS
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S T

Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
Administrator Add Warehouse as Data Source  For more information, see "Add
to Reporting Engine Warehouse as a Data Source to
Reporting Engine" in the
Reporting Engine Configuration
Guide.

Administrator Analyze a Warehouse Report For more information, see "Step
4. Analyze a Warehouse Report"
in the Warehouse Guide.

Administrator Manage a Stream and Lockbox*  Manage a Stream and Lockbox

*You can complete these tasks here.

Related topics

o Configure a Warehouse Connector Service

Quick Look

The following figure shows the General tab on the Warehouse Connector Services Config view.

The General tab displays the system configuration parameters for the Warehouse Connector
service.

GATE MONITOR

£ Change serviea |

Warehouse Connector | Config

Sources and Destinations ~ Streams  Lockbox Settings [ERGISCINM Appliance Service Configuration

System Configuration

Name Config Value
Compression 0

Port 50020
SSLFIPS Mode a
SSLPort 56020

Stat Update Interval 1000
Threads 20

NETWITNESS
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When you add a Warehouse Connector service, default values are in effect. RSA designed the
default values to accommodate most environments and recommends that you do not edit these
values because it may adversely affect performance.

The following table describes the System Configuration parameters:

m Config Value

Compression Determines the minimum amount of bytes before a message is compressed. If

set to zero, messages are not compressed.

Port Determines the port used by the service.

Note: If you change the port number, ensure that you restart the service.

SSL If enabled, all the data transferred in the network will be encrypted using SSL.

Stat Update  Determines how often (in milliseconds) statistic nodes are updated in the

Interval system.
Threads Determines the number of threads in the thread pool to handle incoming
requests.
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Appliance Service Configuration Tab Settings

The Appliance Service Configuration tab displays the appliance configuration settings for
Warehouse Connector service. For more information, see "Appliance Service Configuration"

topic in the Hosts and Services Getting Started Guide.

Workflow

You are here

Install Wareheuse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data

Service on a Log Decoder or Connector Service
Decoder

Configure the Data Source
for Warehouse Connector

Source to Reporting

Engine

Configure a Stream Analyze a Warehouse

Report

Menitor a Warehouse

Connector

Manage a Stream and
Lockbox

What do you want to do?

S T

Administrator Install Warehouse Connector
Service on a Log Decoder or

Decoder

Administrator Configure a Warehouse

Connector Service*

Administrator Configure the Data Source for

Warehouse Connector

Install Warehouse Connector Service

on a Log Decoder or Decoder or

Hybrid

Configure a Warehouse Connector

Service

Configure the Data Source for

Warehouse Connector
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S T T

Administrator Configure the Destination using  Configure the Destination Using
NEFS, SFTP, WebHDFS. NFS
Configure the Destination Using
SFTP
Configure the Destination Using
WebHDEFS
Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector Monitor a Warehouse Connector
Administrator Add Warehouse as Data Source  For more information, see "Add
to Reporting Engine Warehouse as a Data Source to

Reporting Engine" in the
Reporting Engine Configuration
Guide.

Administrator Analyze a Warehouse Report For more information, see "Step
4. Analyze a Warehouse Report"

in the Warehouse Guide.

Administrator Manage a Stream and Lockbox* Manage a Stream and Lockbox

*Y ou can complete these tasks here.

Related topics

o Configure a Warehouse Connector Service

Quick Look

The following figure shows the different settings on the Appliance Service Configuration tab.
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# ChangeService |  Warehouse Connector | Config

Sources and Destinations ~ Streams  Lockbox Settings ~ General  [EIEUN R L eX SIENIENT]

Name Config Value
Compression 0

Port 50006
SSLFIPS Mode [m)

SSL Port 56006

Stat Update Interval 1000

Threads 20

| NETWITNESS SUITE

When you add a Warehouse Connector service, default values are in effect. RSA designed the
default values to accommodate most environments and recommends that you do not edit these
values because it may adversely affect performance.

The following table describes the Appliance Service Configuration parameters:

m Configuration Value

Compression Determines the minimum amount of bytes before a message is compressed. If

set to zero, messages are not compressed.

Port Determines the port used by the service.

Note: If you change the port number, ensure that you restart the service.

SSL FIPS If enabled, all the data transferred in the network will be encrypted using SSL
Mode FIPS.

SSL Port Determines the SSL port used by the service.

Stat Update  Determines how often (in milliseconds) statistic nodes are updated in the

Interval system.
Threads Determines the number of threads in the thread pool to handle incoming
requests.
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Sources and Destinations Configuration

The Sources and Destinations tab for a Warehouse Connector in the Services Config view
provides a way to manage basic service configuration and configure source and destination.

Workflow

Install Warehouse Connector
Service on a Log Decoder or
Decoder

Configure a Warehouse
Connector Service

—

You are here

Configure the Data Source
| for Warehouse Connector

Configure a Destination

Configure a Stream

Add Warehouse as a Data
Source to Reporting
Engine

Analyze a Warehouse
Report

Menitor a Warehouse

Connector

Manage a Stream and

Lockbox

What do you want to do?

o T

Administrator Install Warehouse Connector
Service on a Log Decoder or
Decoder

Administrator Configure a Warehouse
Connector Service

Administrator Configure the Data Source for
Warehouse Connector*

Administrator Configure the Destination using

NEFS, SFTP, WebHDFS*

Install Warehouse Connector

Service on a Log Decoder or

Decoder or Hybrid

Configure a Warehouse Connector

Service

Configure the Data Source for

Warehouse Connector

Configure the Destination Using
NFS

Configure the Destination Using
SFTP

Configure the Destination Using
WebHDFS
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S T

Administrator Configure a Stream Configure a Stream
Administrator Monitor a Warehouse Connector ~Monitor a Warehouse Connector
Administrator Add Warehouse as Data Source  For more information, see "Add
to Reporting Engine Warehouse as a Data Source to
Reporting Engine" in the
Reporting Engine Configuration
Guide.

Administrator Analyze a Warehouse Report For more information, see "Step
4. Analyze a Warehouse Report"
in the Warehouse Guide.

Administrator Manage a Stream and Lockbox*  Manage a Stream and Lockbox

*You can complete these tasks here.

Related topics

o Configure the Data Source for Warehouse Connector

o Configure the Destination

Quick Look

The following figure shows the Sources and Destinations tab on the Warehouse Connector
Services Config view.

 Change Service | Warehouse Connector | Config

DOMISSEINLESEURIR  Stream: 1 Lockbox Settings ~ General  Appliance Service Configuration

Source Configuration
+

[ Address

8l

al

Destination Configuration
+
Port ) Name

56004 O s
56002 O sFp

Path

/root/testikaushal

Jroovtest

| NETWITNESS SU
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The Sources and Destinations tab includes the following two sections:

Source Configuration
Destination Configuration

Source Configuration

The Source Configuration section allows you to configure the data sources from which the
Warehouse Connector service needs to collect data.

The following is an example of the Source Configuration section.

Source Configuration

+
O address Port
| 56004
| 56002

The Source Configuration section allows you to perform the following:

TN,

Add the data source.

- Delete the data source.

Destination Configuration

The Destination Configuration section allows you to configure the destination to which the
Warehouse Connector service needs to write the collected data.

Destination Configuration
+
Ll Mame Type Path
[ mMFs nis /rootftest/|
[0 sFp sftp frootitest

The Destination Configuration section allows you to perform the following:

R

Add the destination.
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Delete the destination.

|ﬁ Edit the destination.

Note: You can only edit the SFTP destination
type.
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Add Stream Dialog

You can configure and add a stream to a Warehouse Connector in this dialog

Workflow

Install Warehouse Connector
Service on a Log Decoder or
Decoder

Configure a Warehouse Configure a Destination Add Warehouse as a Data

- Connector Service Source to Reporting

Engine

Configure the Data Source Analyze a Warehouse
for Warehouse Connector Report

Monitor a Warehouse

Connector

Manage a Stream and
Lockbox

What do you want to do?

o T

Administrator

Administrator

Administrator

Administrator

Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid

Configure a Warehouse Configure a Warehouse Connector
Connector Service Service

Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector

Configure the Destination using  Configure the Destination Using
NFS, SFTP, WebHDFS. NFS

Configure the Destination Using
SFTP

Configure the Destination Using
WebHDFS
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Administrator

Administrator

Administrator

Administrator

Administrator

Configure a Stream*

Monitor a Warehouse Connector

Add Warehouse as Data Source
to Reporting Engine

Analyze a Warehouse Report

Manage a Stream and Lockbox*

*You can complete these tasks here.

Related Topics

o Configure a Stream

Quick Look

Refer to...

Configure a Stream

Monitor a Warehouse Connector

For more information, see "Add
Warehouse as a Data Source to
Reporting Engine" in the
Reporting Engine Configuration
Guide.

For more information, see "Step

4. Analyze a Warehouse Report"

in the Warehouse Guide.

Manage a Stream and Lockbox

The following figure is an example with the important features labeled.

NVESTIGATE

MONITOR CONFIGUR

NETWITNESS

D LogDecoder

O o oo oo o0 oo o o oo
o e

Groups Services
+ o +o =@ |
ame u] Name Licensed | Host
= o ®  Event Stream Analysis @ localhostlocaldomain
@  Event Stream Analytics Server @ localhost localdomain
®  Investigate Server & localhost.localdomain
®  LogCollector @ localhost.localdomain
®  LogCollector & localhost.localdornain
®  LogCollector @ localhost.localdomain
Log Decoder & localhost.localdornain

localhost localdomain

@  Orchestration Server @ localhostlocaldomain

®  Reporting Engine @ localhostlocaldomain

@  Response Server @ localhostlocaldomain

®  Security Server @ localhostlocaldomain

®  Warehouse Connector @ localhostlocaldomain
™ @ Warehouse Connector @ localhost

of2 | } 1 C

| Page 1

F © |Filter x
Type Version Actions
Event Stream Analysis 110003734 e
~

Entity Behavior Analytics 11.0.00 L33
Investigate Server 11.0.00 &
Log Collector 11.00.0-14450.1.efda2ce S
Log Collector 11.00.0-144501.ebdaZee O
Log Collector 11.00.0-14450.1.efda2ce S
Log Decoder 11.0.0.0-0 #O
Log Decoder (1S
Orchestration Server 11,000 e
Reporting Engine 11.00.0-5618.1.020e60b e
Response Server 11.0.00 E- 28
Security Server 11.0.00 L33

|
Warchouse Connector System Evew 2

Delete
onnector = o v
Explore Start o5 of 28
Logs stop

Security

Restart
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CONFIGURE  ADMIN

General  Appliance Service Configuration

g = e e

Add Stream

Stream Mame *

SEIE":t DEStinEtiDn* ChDDSE‘ Destlnat'on . L

Select Source *

L] MName Address Port Session 1D
O 56004 Enter Session
O 56002 Enter Session

Cancel Save

Go to ADMIN > Services.

g3l |1 the services view, select a Warehouse Connector service and select g -

>view>config

In the Streams tab, click + to view the add stream dialog.

The following table describes the fields in the Add Stream dialog:

Stream Type the name of the stream. The stream name may only contain alphanumeric
Name characters and underscores. It cannot exceed 20 characters in length.

Select Select a destination from the drop-down list.

Destination
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Select a source from the grid at the bottom section of the dialog.

Select

Source

Name

Address

Port

Session ID

The name of the source.
The address of the source.

The port of the source.

The session ID of the source.
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Streams Configuration

The Streams tab for a Warehouse Connector in the Services Config view provides a way to
manage stream configuration.

Workflow

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data
Service on a Log Decoder or — Connector Service Source to Reporting
Decoder Engine

Configure the Data Source Configure a Stream Analyze a Warehouse
for Warehouse Connector Report

You are here

Menitor a Warehouse
| Connector

Manage a Stream and

Lockbox

What do you want to do?

S T

Administrator Install Warehouse Connector Install Warehouse Connector Service
Service on a Log Decoder or on a Log Decoder or Decoder or
Decoder Hybrid
Administrator Configure a Warehouse Configure a Warehouse Connector
Connector Service Service
Administrator Configure the Data Source for Configure the Data Source for
Warehouse Connector Warehouse Connector
Administrator Configure the Destination using  Configure the Destination Using
NEFS, SFTP, WebHDFS. NFS
Configure the Destination Using
SFTP

Configure the Destination Using
WebHDFS
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Administrator

Administrator

Administrator

Administrator

Administrator

Configure a Stream*

Monitor a Warehouse

Connector*

Add Warehouse as Data Source
to Reporting Engine

Analyze a Warehouse Report

Manage a Stream and Lockbox*

*You can complete these tasks here.

Related topics

Configure a Stream

Quick Look

Configure a Stream

Monitor a Warehouse Connector

For more information, see "Add
Warehouse as a Data Source to
Reporting Engine" in the
Reporting Engine Configuration
Guide.

For more information, see "Step

4. Analyze a Warehouse Report"

in the Warehouse Guide.

Manage a Stream and Lockbox

The following figure shows the Streams tab on the Warehouse Connector Services Config view.

Services

Warehouse Connector

£ Change Service |

Sources and Destinations [ESIZENCEN L ockbox Settings

| Config

General  Appliance Service Configuration

To configure the alert mechanisms related to the Warehouse Connector navigate here.

The Streams tab allows you to perform the following:
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o rewen
+

Add a stream.

Delete a stream.

4] Edit the stream.
Start Start the stream.
Stop Stop the stream.

Finalize Finalize the stream.

Reload Reload the stream.

If you have added a new meta or if a new meta is added as part of content
update to any of the sources, Log Decoder or Decoder, you need to reload the
stream for the meta to be visible in the schema for the Reporting Engine.
Reloading a stream does not have any impact on the data, but only the new meta

list is fetched from the sources.

The following table describes the fields in the Streams tab:
Name Name of the stream.
Sources The sources associated with the stream.
Destination ~ The destinations associated with the stream.

Status Status of the stream.

Stream Statistics

You can view the statistics of a configured stream. Click the ® icon next to the name of the
stream.
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ctor | Config

Lockbox Settings ~ General  Appliance Service Configuration
@ Stop  Reload | Change Configuration

Destination Status

1:50002 . running

The following parameters are displayed in the Stream Statistics:

tn e

Stream
Number of  Determines the number of files in the permanent rejected folder
files in the (named, permfail) in the Warehouse Connector. The permanent
permanent rejected folder contains the files that Warehouse Connector
rejected failed to write to the destination.
folder
Rejected Determines the disk usage of the rejected folder.
folder usage
in
percentage
Session Rate Determines the rate at which the session is processed by the
Warehouse Connector for the source.
Destination
Status Indicates the status of the destination.
Source
Status Indicate the status of the source.
Sessions Determines that number of sessions that needs to be processed
Behind by the Warehouse Connector.
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Last Session  Determines the last session id processed by the Warehouse

read Connector.

Change Stream Configuration

You can change configuration of a stream in runtime. In the Streams tab, click Change
Configuration to change the configuration of the selected stream.

Change Configuration :

Stream Configuration

Mame Config Value hd
=l Aggregation Configuration

Ageregate max sessions 1000

Ageregation Interval 10

=l Loader Settings

Compress files on disk. deflate
Export Rellup Interval hour
Maximum Message Hold Count 100000

Maximum Message Hold Interval (Seconds) a0

Maximum Message Hold Size 512 MB
Page Size 200000
Remote Export Path /
Session Meta Fields Exported *
Session Remote Export [

=l Stream Settings
Auto Startup [

You can change the following parameters of the Stream Configuration:

Note: If you change the value of any parameter in stream configuration, make sure that you
restart the stream.
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After upgrading, if the values of Maximum Message Hold Count, Maximum Message Hold
Interval and Maximum Message Hold Size are 3000000, 60 and 128 respectively, ensure that
you assign the following values to the streams:

o Maximum Message Hold Count - 2400000
o Maximum Message Hold Interval - 600

o Maximum Message Hold Size - 512

You can assign these values by modifying the existing Stream configuration.

stn e orpen

Aggregation Configuration

Aggregate max Determines the maximum number of sessions in a response

sessions for an aggregation request from the Warehouse Connector to
the source .

Aggregation Determines the time between the responses from the source.

Interval

Loader Settings

Compress files on  Enable to compress files on disk.
disk Supported values:
o Deflate - Provides smaller compressed files and good
performance while generating reports.

o Off
By default, the parameter is set to deflate.
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Export Rollup Determines the roll-up interval for export files and also the
Interval directory structure the Warehouse Connector writes to the
destination.

For example:

If the parameter is set to:

Value Directory Structure

hour  /rsasoc/vl/[logs | sessions]/data/

{year}/{month}/{day}/{hour}

minute /rsasoc/vl1/[logs | sessions]/data/
{year}/{month}/{day}/{hour}/

{minute }

day /rsasoc/v1/[logs | sessions]/data/
{year}/{month}/{day}
If you change the value of the parameter, ensure that you
restart the stream.

Recommended value is hour.

Maximum Determines the maximum number of sessions to store in the
Message Hold memory before processing.
Count

Note: If you have deployed a Warehouse Connector Virtual
Appliance, make sure that you change the default value of
the parameter to 800000.

Maximum Determines the maximum time (in seconds) to hold the
Message Hold sessions in memory before processing.

Interval (Seconds)

Maximum Determines the maximum size for the sessions to store in the
Message Hold memory before processing.
Size
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Remote Export Determines the remote local mount point for HDFS (nfs://)
Path and the location to export the data.
Page Size

Stream Settings

Auto Startup Enable to automatically start the stream whenever the
Warehouse connector process is restarted. By default, the

parameter is set to off.
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Lockbox Settings

The Lockbox Settings tab for a Warehouse Connector in the Services Config view provide a way

to manage the lockbox settings.

Workflow

Install Warehouse Connector Configure a Warehouse Configure a Destination Add Warehouse as a Data

Service on a Log Decoder or Connector Service
Decoder

Configure the Data Source
for Warehouse Connector

Source to Reporting
Engine

Configure a Stream Analyze a Warehouse
Report

Monitor a Warehouse

What do you want to do?

You are here

Connector

Manage a Stream and |

Lockbox

S T

Administrator Install Warehouse Connector
Service on a Log Decoder or

Decoder

Administrator Configure a Warehouse

Connector Service*

Administrator Configure the Data Source for

Warehouse Connector

Install Warehouse Connector Service

on a Log Decoder or Decoder or

Hybrid

Configure a Warehouse Connector

Service

Configure the Data Source for
Warehouse Connector
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Administrator

Administrator

Administrator

Administrator

Administrator

Administrator

Configure the Destination using
NFS, SFTP, WebHDFS.

Configure a Stream

Monitor a Warehouse Connector

Add Warehouse as Data Source
to Reporting Engine

Analyze a Warehouse Report

Manage a Stream and Lockbox*

*Y ou can complete these tasks here.

Related topics

o Configure a Warehouse Connector Service

e Manage a Stream and Lockbox

Quick Look

Configure the Destination Using
NES

Configure the Destination Using
SFTP

Configure the Destination Using
WebHDFS

Configure a Stream

Monitor a Warehouse Connector

For more information, see "Add
Warehouse as a Data Source to
Reporting Engine" in the
Reporting Engine Configuration
Guide.

For more information, see "Step

4. Analyze a Warehouse Report"

in the Warehouse Guide.

Manage a Stream and Lockbox

The following figure shows the Lockbox settings tab on the Warehouse Connector Services

Config view.
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RSA RESPOND INVESTIGATE MONITOR CONFIGURE  ADMIN G admin

& ChangeService | Warehouse Connector | Config

Sources and Destinations  Streams ISRl General  Appliance Service Configuration

Create New Lockbox
Set the lockbox password. The password should satisfy lockbox password strength.You will be required to enter this password to perform any lockbox management.
Lockbox Password ke

Confirm Lockbox Password i

Apply

Change Lockbox Password
[Change the lockbox password. You will be required to enter current password and new password.The passwerd should satisfy lockbox password strength.
Current Lockbox Password FRAEEIRR
[New Lockbox Password dekkikiokd

Confirm New Lockbox Password s

Refresh Lockbox

[Reset the lockbox.You will be required to enter current lockbox password.

Lockbox Password REER

Apply

The Lockbox Settings tab allows you to set, change, or refresh the lockbox password of the
Warehouse Connector.
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