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Solution Summary

Morphisec Endpoint Threat Prevention prevents in-memory cyber-attacks on user machines. Over 40% of
cyber-attacks are in-memory. 75% of breaches are caused by file less, in-memory attacks. Up to 80% of
attacks happen on the endpoint. Examples of such attacks are Ransomwares, such Locky, Trojans such
as Dridex, Miners such XMRigMiner, and other attacks such as CClear and NotPetya. When stopping an
attack, Morphisec ETP captures valuable attack information. All information captured by Morphisec ETP is
attack information, for an attack that was deterministically captured and prevented by Morphisec. The
attack information is integrated into RSA NetWitness, where it can be brought together and correlated
with additional information gathered by NetWitness. Having all attack information together in one place
allows the user to get a full picture of every attack prevented and detected on his machines. Sec/Ops
organization can be notified of the attack, and forensic analysts can further evaluate and analyze the

attack.
RSA NetWitness Features
Morphisec Endpoint Threat Prevention 2.7
Integration package name Common Event Format
Device display name within NetWitness morphisec_eptp
Event source class Analysis
Collection method Syslog
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RSA NetWitness Community

The RSA NetWitness Community is an online forum for customers and partners to exchange technical
information and best practices with each other. All NetWitness customers and partners are invited to
register and participate in the RSA NetWitness Community.

Release Notes

Release Date What’'s New In This Release
7/27/2018 | Initial support for Morphisec Endpoint Threat Prevention.

I Important: The RSA NetWitness CEF parser is dependent on the
partner adhering to the CEF Rules outlined in the ArcSight Common
Event Format (CEF) Guide. A copy of the Common Event Format guide
can be found on http://protect724.hp.com/.

Eg. Jan 18 11:07:53 host CEF:Version | Device Vendor | Device
Product|Device Version | Signature ID | Name | Severity | [Extension]

I Important: The time displayed in the CEF log header is parsed into
evt.time.str. No other time formats are parsed by default.
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Partner Product Configuration

Before You Begin

This section provides instructions for configuring the Morphisec Endpoint Threat Prevention with RSA
NetWitness. This document is not intended to suggest optimum installations or configurations.

It is assumed that the reader has both working knowledge of all products involved, and the ability to
perform the tasks outlined in this section. Administrators should have access to the product
documentation for all products in order to install the required components.

All Morphisec Endpoint Threat Prevention components must be installed and working prior to the
integration. Perform the necessary tests to confirm that this is true before proceeding.

I Important: The configuration shown in this Implementation Guide
is for example and testing purposes only. It is not intended to be the
optimal setup for the device. Itis recommended that customers make
sure Morphisec Endpoint Threat Prevention is properly configured and
secured before deploying to a production environment. For more
information, please refer to the Morphisec Endpoint Threat Prevention
documentation or website.

Morphisec Endpoint Threat Prevention Configuration

To enable the Morphisec integration with RSA NetWitness, you will need to configure the
related settings in the SIEM page of the Morphisec Dashboard.

MORPHISEC

DASHBOARD Il Connectto SIEM

ATTACKS

PROTECTORS =
PLANS Host*

SETTINGS

8]

ort*
MORPHISEC Format* el -

Dashboara URL https://192.36.27.1:44.

Events Attack Details

i Attack Attacked Module
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To configure a connection to a SIEM server:

1. Log into the Morphisec Dashboard.

2. In the Settings page, click SIEM in the top menu.

3. Select the Connect to SIEM checkbox.

4. From the Connection drop-down menu, select one of these options:

a. TCP — connect to RSA NetWitness via TCPIP.

b. UDP — connect to RSA NetWitness via UDP.

c. SSL - connect to RSA NetWitness via SSL. For this option, you'll need to enter a path to the
SSL certificate in the Certificate field.

5. If you selected the TCP, UDP or SSL connection type:

1. In the Host field, enter a hostname or IP address for the RSA NetWitness server.

2. In the Port field, enter 514.

3. In the Format drop-down menu, select the CEF security log format.

4. In the Dashboard URL field, enter the Morphisec Dashboard IP/hostname and port number in
the format <IP/hostname>:<port>.

e Important: This value is the Morphisec Dashboard URL as seen
from other machines. Therefore, it cannot be localhost or 127.0.0.1.

5. If you selected the SSL connection type, in the Certificate File field, browse to the SSL
certificate file.

6. To select advanced attack details you want to send to the RSA NetWitness server, click the
Advanced link. The Events pane is displayed.

7. Under the Events column, select the Attacks checkbox.

8. Under the Attack Details column, select the advanced attack details you want to send to the RSA
NetWitness server:

! = Important: Not all details are relevant to all attacks.

Attacked Module - the library or executable that was attacked.

Last Stack Function Call — the last function called before the attack.

Last Module Loaded - the last module loaded before the attack was identified.
Command Line — the text of the command line that launched the protected executable.
Parent Process Command Line — the text of the command line that launched the parent
of the protected executable.

Attack Signature - the unique signature of the attack.

Process Signature — the unique signature of the attacked executable.

Parent Signature - the unique signature of the parent of the attacked executable.
Morphisec Ver — the Morphisec Server version currently running.

9. Click the Save button.

Pan oo

L
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RSA NetWitness Configuration

Deploy the enVision Config File

In order to use the RSA Common Event Format, you must first deploy the enVision Config File from the
NetWitness Live module. Log into NetWitness and perform the following actions:

I Important: Using this procedure will overwrite the existing

table_map.xml.

From the NetWitness menu, select Live > Search.

In the keywords field, enter: enVision.

NetWitness will display the Envision Config File in Matching Resources.
Select the checkbox next to Envision Config File.

hwh=

@ Live < % Search 4 Configure M\ Feeds
Search Criteria Matching Resources
Keywords Show Results © | [& Details B[ Deploy 3 Subscribe | 3 Package ©
envision ™ Subscribed Name Created Updated Type Description
Relsolren Types ™ yes Envision Config File 2014-03-07 11:50 AM 2015-12-14 7:53 AM RSA Log Device This file is used to update the Log Device b

5. Click Deploy in the menu bar.

@ Live Q, search %€ Configure A Feeds
Search Criteria Matching Resources
Keywords Show Results = | Details B Deploy | 3 Subscribe | 3§ Package
envision ™ subscribed| Name Created Updated Type Description
Resharca Types ™ yes Envision Config File 2014-03-07 11:50 AM 2015-12-14 7:53 AM RSA Log Device This file is used to update the Log Device ba
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6. Select Next.

Deployment Wizard

Resources Services Review Deploy
Tortal resources : 1
Resource Names Resource Type Dependency of
Envision Config File R5A Log Device

Cancel Next

7. Select the Log Decoder and select Next.

Deployment Wizard

Resources Services Review
O Name Host Type
[J @ 5SA-IPDB Extractor 54 IPDB Extractor
™ @ wvm3099 log Decoder wm3099 _log Decoder Log Decoder
Cancel Previous Next

- Important: In an environment with multiple Log Decoders, deploy
the Envision Config File to each Log Decoder in your network.
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8. Select Deploy.

Deployment Wizard

Resources Services

Service Service Type Resource Name

vm3099 log De... LogDecoder Envision Config File

Review Deploy

Resource Type

R5A Log Device

Previous Deploy

9. Select Close, to complete the deployment of the Envision Config file.

Deployment Wizard

Resources Services

Live deployment task finished successfully

Service Name Resource Name

vm3099_log Dec...  Enwvision Config File

Review

Status Progress

1of1
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Next, you will need to deploy the Common Event Format file from the NetWitness Live module. Log

into NetWitness and perform the following actions:

1. From the NetWitness menu, select Live > Search.
2. In the keywords field, enter: CEF

Search Criteria

Heywords

| cef]

Resource Types

Tags

Required Meta Keys
Generated Meta Values
Resource Created Date:

e

Resource Maodified Date:

3. RSA NetWitness will display the Common Event Format in Matching Resources.

@ Live X Search %€ Configure N Feeds

Search Criteria Matching Resources

Keywords Show Results = | ‘ElDeploy 3 Subscribe | 3§ Package
cef O subscribed| Name Crested
ResoUrceTypes O no Common Event Format 2014-09-17 8:49 PM

Type Description

RSA Log Device 10.4 or higher.Log Device content for event s...

4, Select the checkbox next to Common Event Format.

Q, search ¥ Configure M Feeds

Search Criteria Matching Resources

Keywords Show Results | ‘B.Deploy I Subscribe | 3 Package
cef [0 subscribed| Name Created Updated Type Description
BesduceTynes ™ no Common Event Format 2014-09-17 8:49 PM 2015-05-08 7:46 PM RSA Log Device 10.4 or higher.Log Device content for event s...

5. Click Deploy in the menu bar.

Q, search & Configure M Feeds

Search Criteria Matching Resources

Updated

Keywords Shaw Results © | Bl Deploy ™ Subscribe | 3§ Package
cef [ subscribed Name created
Resource Types ¥ no Common Event Format 2014-09-17 8:49 PM

2015-05-08 7:46 PM

Type Description

RSA Log Device 10.4 or higher.Log Device content for event ...

RSA
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6. Select Next.

Deployment Wizard

Resources Services Review Deploy
Total resources ; 1
Resource Names Resource Type Dependency Of
Comman Event Format RSA Log Device

Cancel Next

7. Select the Log Decoder and Select Next.

Deployment Wizard

Resources Services Review Deploy
] Name Host Type
[0 @ SA-IPDBExtractor sS4 IPDB Extractor
¥ @ wvm3099 log Decoder wvm3099 log Decoder Log Decoder
Cancel Previous Next

! = Important: In an environment with multiple Log Decoders, deploy
the Common Event Format to each Log Decoder in your network.

READY
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8. Select Deploy.

Deployment Wizard

Resources Services Review Deploy
Service Service Type Resource Name Resource Type
vm3099_log De... LogDecoder (Common Everit Format R5A Log Device

Cancel Previous Deploy

9. Select Close, to complete the deployment of the Common Event Format.

Deployment Wizard

Resources Services Review

Live deployrnent task finished successfully

Service Name Resource Name Status Progress

vm3093 - Log D... Commaon Event Format 1 of1 [ -]

Close

READY

-11 -



Morphisec

Endpoint Threat Prevention 2.7 MORPH ISEC

Moving Target Defense

10. Ensure that the CEF Parser is enabled on the Log Decoder(s) by selecting Administration, Services
from the NetWitness Dashboard.

& Administration’ > = Hosts
@ Live , BB Services

M Event Sources
W Health & Wellness
= System

L Profile

M Sign Out

11. Locate the Log_Decoder and click the gear # to the right and select View, Config.

System View b
Stats Delete
Config Edit

12. Check the box next to the cef Parser within the Service Parsers Configuration and select Apply.

Service Parsers Configuration

Name Config Value
CasIErmmicet I
cef ™

13. Restart the Log Decoder services.

RSA
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Edit the Common Event Format to collect Morphisec event times

I Important: The cef.xml file is overwritten by NetWitness Live
during updates, it is important to maintain backups of the file in the
event of a typing error or unforeseen event.

1. Using WiInSCP or other application to access the RSA NetWitness Log Decoder open a connection and
locate the /etc/netwitness/ng/envision/etc/devices/cef folder. Backup cef.xml and edit the
existing CEF.XML file.

2. Locate the end of the <MESSAGE section and copy/paste the following lines below into the file after
the /> of the preceding <MESSAGE and contents;

Example.

<MESSAGE
idl="morphisec_eptp"
id2="morphisec_eptp"
eventcategory="1901000000"
functions="&1t;@starttime:*EVNTTIME($MSG, '%B<space>%F<space>%¥w<space>%zZ<space>%

L',param_starttime)&gt;"
content="&1t;param_starttime&gt;&lt;msghold&gt;" />

READY
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Edit the Common Event Format Custom to support custom fields

I Important: The cef-custom.xml file is not overwritten by
NetWitness Live during updates, however it is important to maintain
backups of the file in the event of a typing error or unforeseen event.

1. Using WiInSCP or other application to access the RSA NetWitness Log Decoder open a connection and
locate the /etc/netwitness/ng/envision/etc/devices/cef folder. If the cef-custom.xml file does
not exist create one. If the file exists create a backup cef-custom.xml and edit the file.

2. If this is a new cef-custom.xml file, copy the following into the file, otherwise copy only the
required sections.

Example.
<?xml version="1.0" encoding="UTF-8" standalone="yes"?7>
<DEVICEMESSAGES>
<!--
#

# cef-custom.xml Reference: https://community.rsa.com/docs/DOC-79189
#
--> cef-custom.xml Example

<MESSAGE
idl="morphisec_eptp"
id2="morphisec_eptp"
eventcategory="1901000000"

functions="&1t;@starttime:*EVNTTIME($MSG, '%B<space>%F<space>%¥w<space>%zZ<space>%
L',param_starttime)&gt;" )
content="&1t;param_starttime&gt;&1t;msghold&gt;" />

<vendorProducts>

<Vendor2Device vendor="Morphisec" product="Morphisec Endpoint Threat
Prevention" device="morphisec_eptp" group="Analysis"/>
</VendorProducts>

<ExtensionKeys>

<ExtensionKey cefName="start" metaName="param_starttime"/>
<ExtensionKey cefName="end" metaName="param_endtime"/>
<ExtensionKey cefName="rt" metaName="param_event_time"/>

<ExtensionKey cefName="AttackedModule" metaName="AttackedMmodule"/>

<ExtensionkKey cefName="LastStackFunctioncCall"
metaName="LastStackFunctionCall" />

<ExtensionKey cefName="LastModuleLoaded"
metaName="LastModuleLoaded" />

<ExtensionkKey cefName="CommandLine" metaName="CommandLine"/>

<ExtensionKey cefName="ParentProcessCommandLine"
metaName="ParentProcessCommandLine" />

<ExtensionKey cefName="CodeProcessed" metaName="CodeProcessed"/>

<ExtensionKey cefName="ParentSignature"
metaName="ParentSignature"/>

<ExtensionKey cefName="ProcessSignature"
metaName="ProcessSignature"/>

<ExtensionkKey cefName="msg" metaName="msg"> )
<device2meta device="trendmicrodsa" metaName="info"/>
<device2meta device="morphisec_eptp" metaName="1info"/>
</ExtensionKey>
</ExtensionKeys>
-—>

</DEVICEMESSAGES>

READY

-14 -



Morphisec
Endpoint Threat Prevention 2.7

MORPHISEC

Moving Target Defense

Edit the NetWtness Table-Map-Custom.xml file

I Important: The Table-Map-Custom.xml file is not overwritten by
NetWitness Live during updates, however it is important to maintain
backups of the file in the event of a typing error or unforeseen event.

1. Using WinSCP or other application to access the RSA Netwitness Log Decoder open a connection and

2.

3.

locate the /etc/netwitness/ng/envision/etc/ folder.
If one exists, backup the table-map-custom.xml and then edit the existing table-map-custom.xml

Copy and paste the entire section below into a new file or only the lines between the
<mappings>...</mappings> if the table-map-custom.xml file exists;
Example.

<?xml version="1.0" encoding="utf-8"7>

<!--

# attributes: . .
envisionName: The name of the column in the universal table

# nwName : The name of the Netwitness meta field

# format: Optional. The Tanguage key data type. See
LanguageManager. Defaults to "Text".

# flags: Ooptional. One of None|File|Duration|Transient.
Defaults to "None".

# failureKkey: optional. The name of the Nw key to write data if
conversion fails. Defaults to system generated "parse.error" meta.

# nullTokens: optional. The Tist of "null" tokens. Pipe separated.
Default is no null tokens.

-—>

<mappings>

<mapping envisionName="AttackedModule" nwName="Attackedmodule"
flags="None" />

<mapping envisionName="LastStackFunctionCall" nwName="LastStackFuncCall"
flags="None" />

<mapping envisionName="LastModuleLoaded" nwName="LastModuleLoaded"
flags="None" />

<mapping envisionName="CommandLine" nwName="CommandLine" flags="None"/>

<mapping envisionName="ParentProcessCommandLine" nwName='"ParentPrCmdLine"
flags="None" />

<mapping envisionName="CodeProcessed" nwName="CodeProcessed"
flags="None" />

<mapping envisionName="ParentSignature" nwName="ParentSignature"
flags="None" />

<mapping envisionName="ProcessSignature" nwName="ProcessSignature"
flags="None" />

<mapping envisionName="1info" nwName="index" flags="None"/>

<mapping envisionName="severity" nwName="severity" flags="None"
envisionDisplayName="Severity|SeverityLevel"/>

</mappings>

4. Restart the Log Decoder services to begin log collection.

READY
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[0 2018-07-19T10:58:34

Log

morphisec_eptp

<9 ip.src: 192.168.188.130
< sessionid : 1405
devicedp: 10.100.169.6
medium: 32

m®

[

devicetype : morphisec_eptp
device.class : Analysis

o

L

version : 3.0.0
eventaype : MORPHISEC_ATTACK

i E

o

severity : 10
user.src : DESKTOP-CLGEITR/admin
+ DESKTOP-CLEEITR

]

o

hostsr

[

netname : private src

o

index

eventdesc : Attack was detected and stopped by Morphisec

155.286:44

Atackedodule : Global GetAromName

i

o

FunCell: nedll.dll| <sp: P
0x764C¢ |<spe

0x76F50000

LostioduleLoaded : (7

dll<space>

®

[« dline : Cu/Proge space>(

[ 3

ParentPrCmdline : C = cernetesp

C ssed: Dx76MbF ET<sp
6eda2f5818967562301 Te5:

®

K

®

8dea6e51370e1

[ 3

starwime : 2018-Mar-06 13:25:37.000

®

msgid : morphisec_sptp

[ 3

event.cat.name : Other.Default
device.disc: 100

did : vm3112

rid: 1405

ipall: 10,100:169.6

user.all: DESKTOP-CLEEITR/zdmin

: DESKTOP-CLGEITR

ipasll: 192.162.182.130

= Hide Additional Meta  B) Evenc Analysis

[

EEE

[ 3

®

2347bbd3071130bd5ed

305ec0a0

ks/1220d6:

2cF77142067

-16 -
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Certification Checklist for RSA NetWitnhess

Date Tested: July 27, 2018

Certification Environment
Product Name Version Information Operating System

RSA NetWitness 11.1 Virtual Appliance
Morphisec Endpoint Threat Prevention | 2.7

NetWitness Test Case Result
Device Administration
Partner’s device name appears in Device Parsers Configuration
Device can be enabled from Device Parsers Configuration
Device can be disabled from Device Parsers Configuration
Device can be removed from Device Parsers Configuration

Investigation
Device name displays properly from Device Type
Displays Meta Data properly within Investigator

»/ = Pass - = Fail N/A = Non-Available Function

READY
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Appendix

NetWitness Disable the Common Event Format Parser
To disable the NetWitness Common Event Format Parser and not delete it perform the following:

1. Select the NetWitness Administration > Services menu.

X Administration

(D Dashboard
& Investigation
M- Incidents
[N Alerts

lead Reports

A Administration = Appliances

£ Services

@ Health & Wellness
== System

(@ Live

L Profile

2. Select the Log Decoder, then select View > Config.

¥ @ vm3093-Log Decoder vm3093 Log Decoder 10.4.0.1.3351 & -
@® vm3095- Concentrator 4 wm3095 Concentrator System View >
Stats Delete
Config Edit
Explore Start
Logs Stop
Security Restart

3. From the Service Parses Configuration window, scroll down to the cef parser and uncheck the
Config Value checkbox.

Service Parsers Configuration Enable All  Disable Al
Name Config Value

caitm ] i
casiteminder il =
cef v

4. Click Apply to save settings.

READY
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NetWitness Remove Device Parser
To remove the NetWitness Integration Package files from the environment, perform the following:

1. Connect to the NetWitness Log Decoder/Collector Server using SSH and open the
/etc/netwitness/ng/envision/etc/devices folder.

g@ root@vm3093:/etc/netwitness/ng/envision/etc/devices

= R

2. Search for and delete the CEF folder and its contents.

READY
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