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McAfee VirusScan Enterprise uses McAfee ePolicy Orchestrator as a management console. To
configure the event source to work with RSA NetWitness Platform, perform the following steps:

I. Set Up Event Filtering in ePolicy Orchestrator
II. Configure NetWitness Platform for ODBC Collection




Set Up Event Filtering in ePolicy Orchestrator

To configure McAfee VirusScan, you must set up event filtering in McAfee ePolicy Orchestrator.

Note: All events in ePolicy Orchestrator are supported by enVisionNetWitness Platform.

L.

Log on to the ePolicy Orchestrator web console.

2. Click Menu > Configuration > Server Settings.
3. Under Setting Categories, click Event Filtering.
4.
5

Click Edit.

. In the Edit Events Filtering window, select one of the following:

¢ All events to the server

¢ Only selected events to the server

Note: This option requires that you select the events you want.

Click Save.

Set Up Event Filtering in ePolicy Orchestrator




Configure NetWitness Platform for ODBC Collection

To configure McAfee VirusScan Enterprise for ODBC collection, perform the following tasks in
NetWitness Platform:

I. Ensure the Required Parser is Enabled
II. Configure a DSN
III. Add the ODBC Event Source Type

Ensure the Required Parser is Enabled

If you do not see your parser in the list while performing this procedure, you need to download it from
RSA NetWitness Platform Live.

Ensure that the parser for your event source is available:

Q4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Decoder, and from the Actions (* ) menu, choose View >
Config.

3. In the Service Parsers Configuration panel, search for your event source, and ensure that the
Config Value field for your event source is selected.

Note: The required parser is mcafeevirusscan.

Configure a DSN

Configure a DSN (Data Source Name):

4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Collector service and from the Actions (¥ ) menu, choose View >
Config > Event Sources.

3. In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
4. The DSNs panel is displayed with the existing DSNs, if any.

5. Click * to open the Add DSN dialog.

Note: To add a DSN template, see the Configure a DSN topic in the Log Collection Configuration
Guide, available in NetWitness Community.

6. Choose a DSN Template from the drop down menu and enter a name for the DSN. (Use this name

Configure NetWitness Platform for ODBC Collection 7
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when you set up the ODBC event source type.)

7. Fill in the parameters and click Save.

FadJowetpen

DSN Template Choose the correct template from the available choices.

DSN Name Enter a descriptive name for the DSN

Parameters section

Database Specify the database used by McAfee VirusScan

PortNumber Specify the Port Number. The default port number is 1433

HostName Specify the hostname or [P Address of McAfee VirusScan

Driver Depending on your NetWitness Log Collector version:

e For 10.6.2 and newer, use
/opt/netwitness/odbc/1ib/R3sqls27.so

e For 10.6.1 and older, use
/opt/netwitness/odbc/1ib/R3sqls26.s0

Add the ODBC Event Source Type

Add the ODBC Event Source Type:

1.
2.

<4
In the NetWitness menu, select (Admin) > Services.

In the Services grid, select a Log Collector service, and from the Actions (* ) menu, choose View
> Config.

. In the Log Collector Event Sources tab, select ODBC/Config from the drop-down menu.

The Event Categories panel is displayed with the existing sources, if any.

Click + to open the Available Event Source Types dialog.

Configure NetWitness Platform for ODBC Collection



Available Event Source Types

O Name ~
actividentity
asels

bigfix

bite
bmcremedyitsm
ciscolmsaudit
ciscolmsfault
cisconcm
ciscosecagent

ciscosecagenteventid

Oooooooooooadg

dbpinfoalerts

Cancel OK
5. Choose the log collector configuration type for your event source type and click OK.
Select mcafeevse from the Available Event Source Types dialog.

7. In the Event Categories panel, select the event source type that you just added.

8. In the Sources panel, click + to open the Add Source dialog.

Add Source

Basic
DSN *
Username *
Password
Enabled ~
Address *

Advanced
Max Cell Size 2048
Nil Value (null)
Polling Interval 180
Max Events Poll 5000
Debug Off
Initial Tracking Id
Filename

Cancel oK

9. Enter the DSN you configured during the Configure a DSN procedure.

10. For the other parameters, see the ODBC Event Source Configuration Parameters topic in the Log
Collection Configuration Guide, available in NetWitness Community.

Configure NetWitness Platform for ODBC Collection
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Configure NetWitness Platform for

Logstash Collection

Deploy Logstash JDBC Pipeline from NetWitness Live

Logstash JDBC Pipeline files require resources available in Live to collect logs.
To deploy Logstash JDBC Pipeline files from Live:

1. In the NetWitness Platform menu, select Configure > Live Content.

2. Type Jdbe into the Keywords text box and click Search to browse Live for Logstash JDBC Pipeline
files.

3. Select the item returned from the search based on the DB version.

4. Click Deploy to deploy the Logstash JDBC Pipeline files to the appropriate Log Collector in the
Deployment Wizard.

Search Criteria Matching Resources
Keywords 3 Show Results [ Details A Subscribe XK Package
jdbe Certain services are managed by Centralized Content Management(CCM). To manage content on those services, click here
Category Subscribed Name Created Updated Type Description
[CJFEATURED no Log Collector content for ...  2024-03-06 1:05 PM 2024-07-24 7:49 AM Log Collector Log Collector content for Logstash jdbc mssql auditing Pipeline
» CITHREAT no Log Collector content for L... ~ 2023-05-17 9:41 AM 2024-07-24 7:48 AM Log Collector Log Collector content for Logstash jdbc oracle 11g auditing Pipeline
» CJIDENTITY no Log Collector content for L...  2023-05-17 9:47 AM 2024-08-02 7:21 AM Log Collector Log Collector content for Logstash jdbc oracle 19¢ auditing Pipeline
» CIASSURANCE no Log Collector content for L.~ 2023-05-17 9:45 AM 2024-07-24 7:49 AM Log Collector Log Collector content for Logstash jdbc oracle 18c auditing Pipeline
» CJOPERATIONS no Log Collector content for L. ~ 2023-05-17 9:31 AM 2024-07-24 7:46 AM Log Collector Log Collector content for Logstash jdbc ibmdb2 auditing Pipeline
[IsPECTRUM no Log Collector content for L.~ 2023-05-17 9:43 AM 2024-07-24 7:48 AM Log Collector Log Collector content for Logstash jdbc oracle 12c auditing Pipeline

] MALWARE ANALYSIS no Log Collector content for L...  2023-05-17 9:38 AM 2024-07-24 7:48 AM Log Collector Log Collector content for Logstash jdbc custom Pipeline

Resource Types
Medium

Required Meta Keys

7 aingresources

Setup Logstash McAfee Virus Scan Enterprise JDBC Event

Sources (Pipelines) in NetWitness Platform

To setup the McAfee VSE JDBC Event Source:

Q
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Collector service and from the Actions (*# * ) menu, choose View >
Config > Event Sources.

3. Select Logstash/Config from the drop-down menu.

10 Configure NetWitness Platform for Logstash Collection



4.

7.

In the Event categories panel toolbar, click + )

% Change Service | [ logcollector - Log Collector |  Config ©

General Local Collectors Files Event Sources Settings

Logstash v Config v

Event Categories
+

Name

Appliance Service Configuration

Source Types

Name ~

jdbc_meafeevm
jdbe_mcafeevse
jdbe_oracle_12¢_auditing
jdbe_oracle_18c_auditing
jdbe_oracle_19¢_auditing

kubernetes

Cancel OK

&2 Event Source Configuration Guides

Select jdbc_mcafeevse from the Available Event Source Types list.

In the Sources panel, click +

The AddSource dialog box is displayed.

Define the Parameter described in the JDBC Collection Configuration Parameters.

P Y.
Add Source Add Source

Basic

Name *

Enabled 4

Description Enter description for Logstash pipeline
Host ID * Enter host id to be used for DB connection

Port Number * Enter port number to be used for DB connection

Database Name * Enter database name to be used for DB connection

User ID * Enter user id to be used for DB connection
Password * Enter password to be used for DB connection
Start From (In Days) * 0

Event Destination * loghybrid1

Advanced
(@ Configuration can be saved only when the test configuration is successful

Test Configuration

Host ID *

Port Number *
Database Name *
User ID *
Password *

start From (In Days) *

Event Destination *

Advanced
Debug

Polling Interval *
Destination SSL
Max Event Poll

Additional Custom
Configuration

Required Plugins
Required Ports

Pipeline Workers

Test Configuration

Enter host id to be used for DB connection

Enter port number to be used for DB connection
Enter database name to be used for DB connection
Enter user id to be used for DB connection

Enter password to be used for DB connection

0 <
loghybrid1 v
off v
3
~

150000 <

input { additional custom input configuration here } filter { additional custom filter
configuration here } output { additional custom output configuration here }

comma separated list of required plugins for this pipeline
Comma separated list of ports required for external access

0 <

(@ Configuration can be saved only when the test configuration is successful

cancel cancel

Click Test Configuration.

The result of the test is displayed in the dialog box. If the test is unsuccessful, edit the device or
service information based on message shown and retry.

Note: The log collector may take 1 to 3 minutes to return the test results. If it exceeds the time
limit, the test times out and NetWitness platform displays a Request Timed Out error.

If the test is successful, click OK. The new event source is displayed in the Sources panel.

Save the configuration. From the Actions menu, choose System and in the Collection drop-down
menu, select Logstash > Start to start the log collection, if it’s not started already.

Configure NetWitness Platform for Logstash Collection
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HOSTS SERVICES EVENT SOURCH

-+ Change Service | I logcollector - Log Cd

Collection v i Host Tasks () Shutdowr

File >
ODBC > ’rvice Informati

Check Point >
ector (Log Collector)
Windows >

0-15127.5.527ec7727 (F

VMware >
SDEE 5 KB (0.50% of 16005 MB
Syslog >
Netflow » Irs 14 seconds
Plugins > 1ep-03 04:49:07
Logstash M start |
Log Collector Usermmrormation

JDBC Collection Configuration Parameters

The tables below list the configuration parameters required for integrating different database event
source with NetWitness Platform through JDBC logstash pipeline.

Basic Parameters

e owmn

Name * Enter an alpha-numeric, descriptive name for the source. This value is only used
for displaying the name on this screen.

Enabled Select the check-box to enable the event source configuration to start collection.
The check-box is selected by default.

Description Enter a text description for the event source.

Host ID* Enter the IP address of the machine where the database server is installed.

Port Number* Enter the port number that you configured for your event source. The default value

of port number is 1433.

12 Configure NetWitness Platform for Logstash Collection



e o

Start Date*

Database Name*

User ID*

Password*

PollingInterval*®

Event
Destination*

Test
Configuration

Number of days before today to begin data collection (0-90, default: 0). For
example, if today is 2024-09-12 and startDate is set as 10, collection starts from
2024-09-02 00:00:00 (YYYY-MM-DD HH:MM:SS). If not set, it takes default
value ans starts collection from today 00:00:00.

Enter the name of the database where the audit table exists.

Enter the username of database.

Enter the password to log into the database.

Polling interval takes the input in minutes. Based on the minutes entered, the
pipeline will pull the data from the database.

For example, If the polling interval is 1, then the pipeline will pull the data from
the database for every 1 minute. If the polling interval is 2, then the pipeline will
pull the data from the database for every 2 minute. This filed takes the values
between 1 to 60.

Select the NetWitness Log Collector or Log Decoder to which event needs to be
sent from the drop-down list.

Checks the configuration parameters specified in this dialog to ensure they are
correct.

Advanced Parameters

Click = next to Advanced to view and edit the advanced parameters, if necessary.

T =

Debug

Caution: Only enable debugging (set this parameter to On or Verbose) if you
have a problem with an event source and you need to investigate this problem.
Enabling debugging will adversely affect the performance of the Log Collector.

Caution: Enables or disables debug logging for the event source. Valid values
are:

o Off = (default) disabled
¢ On = enabled

¢ Verbose = enabled in verbose mode - adds thread information and source
context information to the messages.

This parameter is designed to debug and monitor isolated event source collection
issues. If you change this value, the change takes effect immediately (no restart
required). The debug logging is verbose, so limit the number of event sources to
minimize performance impact.

Configure NetWitness Platform for Logstash Collection 13



e o

Polling Enter the polling interval in minutes (1-60). This determines how often data is
Interval* pulled from the database. The default value is set to 3.

Destination Select the checkbox to communicate using destination SSL.

SSL

Max Event Poll Specify the maximum number of events that can be collected during a polling
cycle. By default, this is set to 1,50,000 which is also the maximum value.

Custom SQL By default this field is empty. It accepts any valid custom SQL query (overriding

Statement* the default query) to run and collect data from the database.
Additional Use this text box for any additional configuration, in case you have multiple inputs
Custom or another set of outputs to send somewhere in addition to a NetWitness Log

Configuration  Collector or Log Decoder.

For example, you can configure the data to be sent to Elasticsearch. In this case
each event that is sent to Netwitness Platform will also be send to Elasticsearch.

Required Specify the required plugins in a comma separated list.
Plugins

Note:

- Backup and restore is not supported for custom plugins.

- If the test connection failed due to required plugin is not installed, you must
install the required plugin, for more information, see Install or Manage Logstash
Plugin.

Required Ports Enter the list of ports required for external access.

Pipeline Number of pipeline worker threads allocated for logstash pipeline.
Workers

Configure NetWitness Platform to Collect Events

To configure NetWitness platform to collect events:

You must start capture on the Log Decoder to which you are sending the Logstash data. To start or
restart network capture on a Log Decoder:

Q
In the NetWitness Platform menu, select (Admin) > Services. The Services view is displayed.

Select a Log Decoder service.

Under Actions, select View > System.

Sl

In the toolbar, click Start Capture.

Note: If the toolbar is displaying the Stop Capture () icon, then capture has already started.

14 Configure NetWitness Platform for Logstash Collection



Log Decoders can handle events up to 32 KB by default. If your events are being cut off, you need to
change the event size.

To change Event Size Limit:

l. Athttp://<LogDecoder IP>:50102/decoder/config (replace <LogDecoder IP> with
the IP address of your Log Decoder), change the Log Decoder REST configuration.

2. Set pool .packet.page.size to 64 KB.
3. Restart the Log Decoder to apply the changes.

Note: If you are collecting events larger than 64 KB, you can reduce the size of incoming data by
dropping unnecessary logs or fields from specific event sources.

Ensure the Required Parser is Enabled

Ensure that the parser for your event source is available:

a4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Decoder, and from the Actions (¥ *) menu, choose View >
Config.

3. In the Service Parsers Configuration panel, search for your event source, and ensure that the
Config Value field for your event source is selected.

Note: The required parser is mcafeevse.

Configure NetWitness Platform for Logstash Collection
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Getting Help with NetWitness Platform

Self-Help Resources

There are several options that provide you with help as you need it for installing and using NetWitness:

e See the documentation for all aspects of NetWitness here:
https://community.netwitness.com/t5/netwitness-platform/ct-p/netwitness-documentation.

» Use the Search and Create a Post fields in NetWitness Community portal to find specific
information here: https://community.netwitness.com/t5/netwitness-discussions/bd-p/netwitness-
discussions.

» See the NetWitness Knowledge Base: https://community.netwitness.com/t5/netwitness-knowledge-
base/tkb-p/netwitness-knowledge-base.

o See the documentation for Logstash JDBC input plugin here:
https://www.elastic.co/guide/en/logstash/current/plugins-inputs-jdbc.html.

» See Troubleshooting section in the guides.
* See also NetWitness® Platform Blog Posts.

e [f you need further assistance, Contact NetWitness Support.

Contact NetWitness Support

When you contact NetWitness Support, please provide the following information:
e The version number of the NetWitness Platform or application you are using.

o Logs information, even source version, and collection method.

» If you have problem with an event source, enable Debug parameter (set this parameter to On or
Verbose) and collect the debug logs to share with the NetWitness Support team.

Use the following contact information if you have any questions or need assistance.

NetWitness Community Portal https://community.netwitness.com
In the main menu, click Support > Case Portal > View My
Cases.
International Contacts (How to https://community.netwitness.com/t5/support/ct-p/support
Contact NetWitness Support)
Community https://community.netwitness.com/t5/netwitness-discussions/bd-

p/netwitness-discussions

16 Getting Help with NetWitness Platform
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Feedback on Product Documentation

You can send an email to feedbacknwdocs@netwitness.com to provide feedback on NetWitness Platform
documentation.

Getting Help with NetWitness Platform 17
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