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Configure IBM DB2

To configure file collection, see the instructions below for your platform. To configure ODBC collection
on the NetWitness Platform, see Configure NetWitness Platform for ODBC Collection.

I. Configure IBM DB2. Depending on your platform, do one of the following:
* Configure IBM DB2 UDB for Windows, or
¢ Configure IBM DB2 UDB for AIX
II. Configure RSA NetWitness Platform for SFTP and File Collection

For table reference, see Reference Tables below.

Configure IBM DB2
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Configure IBM DB2 UDB for Windows

To configure IBM DB2 UDB for Windows, you must complete these tasks:

1.
2.
3.

Download and Edit IBM DB2 Scripts
Configure the IBM DB2 Audit Facility
Set Up the Windows Task Scheduler

Download and Edit IBM DB2 Scripts

To download and edit IBM DB2 scripts:

1.
2.

On the IBM DB2 server, create a DB2_Audit folder on the C: drive.
To download the necessary scripts for IBM DB2, follow these steps:

a. Download the DB2GetAudit.vbs VBScript file and the DB2Audit.conf configuration file, and
paste the files into the DB2_Audit folder.

b. (Optional) If you want to enable DB Level Auditing, download the DatabaseList.conf file. Open
the file in a text editor, and add each database at the instance level you want audited, with one
database name per line and no special characters.

Note: For DB Level Auditing to function properly, you must create and activate all the necessary
policies for the required tables and databases.

. In the DB2_Audit folder, create a Data folder, an Archive folder, and an Archive_BackUp folder to

store, archive, and back up your raw log data.

In the DB2Audit.conf file, set the following parameters:
Bin Path=Bin Path

Data Path=Data Path
Archive BackUp Path=Archive BackUp Path
Archive Path=Archive Path

where:
e Bin_Path is the path to the IBM Bin folder.

e Data_Path is the path to the Data folder within the DB2_Audit folder on your C: drive, for
example, C:\DB2_Audit\Data.

e Archive BackUp_Path is the path to the Archive_BackUp folder within the DB2_Audit folder on
your C: drive, for example, C:\DB2_Audit\Archive BackUp.

e Archive Path is the path to the Archive folder within the DB2_Audit folder on your C: drive, for
example, C:\DB2_Audit\Archive.

Click File > Save.

Configure IBM DB2 UDB for Windows
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Configure the IBM DB2 Audit Facility

To configure the IBM DB2 audit facility:

1. On the IBM DB2 server, click Start > All Programs > IBM DB2 > RSADB2 > Command Line
Tools > Command Line Processor.

2. To update the database buffer sites, follow these steps:
a. In the command prompt, type:
update dbm cfg using AUDIT BUF SZ 100
b. In the command prompt, type:
quit
3. To enable the audit facility, follow these steps:
a. To reset the audit facility to the default settings, type:
db2audit configure reset
b. To activate auditing settings, on separate command prompts, type:
db2audit configure scope audit status both
db2audit configure scope checking status both
db2audit configure scope secmaint status both
db2audit configure scope sysadmin status both
db2audit configure scope objmaint status both
db2audit configure scope validate status both

db2audit configure scope context status both
4. To set the data and archive path, type:

db2audit configure datapath "Data Path" archivepath "Archive
Path"

where:

e Data_Path is the path to the Data folder within your DB2_Audit folder on the C:
drive.

e Archive Path is the path to the Archive folder within your DB2_Audit folder on the
C: drive.

5. To start the audit facility, type:
db2audit start

Configure IBM DB2 UDB for Windows 7
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Set Up the Windows Task Scheduler

To set up the Windows Task Scheduler:

1.

A S AN S o

_.
e

11.
12.

13.

On the IBM DB2 server, click Start > Settings > Control Panel.

Click Scheduled Task > Add Scheduled Task.

In the Scheduled Task Wizard, click Next.

Select any application from the list, and click Next.

In the Type a name for this task field, type IBMDB2_Audit.

Under the Perform this task field, select Daily, and click Next.

Select the start time and start date, and click Next.

In the user name and password fields, enter the server logon credentials, and click Next.
Select Open advanced properties for this task when I click Finish, and click Finish.

On the Task tab of the advanced properties window, complete the fields as follows.

Run Type "C:\WINDOWS\system32\wscript.exe DB2GetAudit.vbs"
Start Enter the path to the DB2_Audit folder.
On the Schedule tab, click Advanced.

Select Repeat task, and complete the fields as follows.

Every Select 6 hours as the frequency of time the RSA NetWitness
Platform uses to collect logs from IBM DB2.

Note: If the time increment for event collection is greater than 6
hours, the database buffer that is set to 100 when configuring the
audit facility must be increased.

Until Select Duration.

Hour(s) Type 24.

Click Apply.

Configure IBM DB2 UDB for Windows
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Configure IBM DB2 UDB for AIX

To configure IBM DB2 UDB for AIX, you must complete these tasks:

1.
2.
3.

Download and Edit IBM DB2 Scripts
Configure the IBM DB2 Audit Facility

Configure the DB2 Audit Script as a cron job

Download and Edit IBM DB2 Scripts

To download and edit IBM DB2 scripts:

1.

On the IBM DB2 server, create a DB2Audit directory in your home directory. Ensure that the
directory name contains no spaces or underscores, for example, /home/db2user/DB2Audit, where
db2user is your DB2 instance name.

Download the DB2AuditScript.sh shell script file and the DB2Audit.conf configuration file RSA
Link here: https://community.rsa.com/docs/DOC-45601.

. (Optional) If you want to enable DB Level Auditing, download the DatabaseList.conf file. Open the

file in a text editor, and add each database at the instance level you want audited, with one database
name per line and no special characters.

Note: For DB Level Auditing to function properly, you must create and activate all the necessary
policies for the required tables and databases.

Copy these files into the DB2Audit directory.

In the DB2Audit directory, create a Data directory, an Archive directory, and an Archive BackUp
directory to store, archive, and back up your raw log data.

Open the DB2Audit.conf file, and set the following parameters:

Bin Path=Bin Path
Data Path=Data Path
Archive BackUp Path=Archive BackUp Path
Archive Path=Archive Path

where:

e Bin_Path is the path to the IBM adm directory where the IBM db2audit script resides, for
example, /home/db2user/sqllib/adm.

e Data_Path is the path to the configured Data directory mentioned in the configuration file,
DB2Audit.conf, for example, /home/db2user/DB2AuditData/.

e Archive BackUp_Path is the path to the configured Archive_BackUp directory mentioned in the
DB2Audit.conf configuration file, for example, /home/db2user/DB2ArchiveBackup.

e Archive Path is the path to the configured Archive directory mentioned in the DB2Audit.conf
configuration file, for example, /home/db2user/DB2AuditArchive.

Configure IBM DB2 UDB for AIX
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Configure the IBM DB2 Audit Facility

To configure the IBM DB2 Audit Facility:

1.

On the IBM DB2 server, from the Terminal or Console, type:

db2

=>,

Note: If the path is set, the DB2 Command Line Processor opens with a prompt that looks like db2

If the Command Line Processor displays the message, "db2 not found", either set the system path
to include the DB2 Bin path, for example, /opt/IBM/db2/V9.X/bin, or you can change directories to
/opt/IBM/db2/V9.X/bin, and type ./db2.

To update the database buffer sites, follow these steps:

a. Open a command prompt, and type:

update dbm cfg using AUDIT BUF SZ 100

b. In the command prompt, type:

quit

To enable the audit facility, follow these steps:

a. To reset the audit facility to the default settings, open a command prompt, and type:

db2audit configure reset

b. To activate auditing settings, on separate command prompts, type:

db2audit
db2audit
db2audit
db2audit
db2audit
db2audit
db2audit

configure
configure
configure
configure
configure
configure
configure

scope
scope
scope
scope
scope
scope
scope

audit status both

checking
secmaint
sysadmin
objmaint
validate

status
status
status
status
status

both
both
both
both
both

context status both

To set the data and archive path, type:

db2audit configure datapath Data Path archivepath Archive Path

where:

e Data_Path is the path to the configured Data directory set in the DB2Audit.conf file.

e Archive Path is the path to the configured Archive directory set in the DB2Audit.conf file.

To start the audit facility, open a command prompt, and type:

db2audit start

10

Configure IBM DB2 UDB for AIX
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Configure the DB2 Audit Script as a cron Job

To configure the DB2 audit script as a cron job:
1. Add the following paths to your PATH environment variable:

/home/db2user/bin
/home/db2user/sqllib/bin
/home/db2user/sqllib/adm
/home/db2user/sqllib/misc
/home/db2user/sqllib/db2tss/bin

Note: You may want to edit the .profile file in your /home directory to add these to the PATH
environment variable so that the paths are sourced when you log on to the shell. This ensures that
the cron daemon has access to the files in these paths to execute your DB2 Audit commands.

A typical line in the .profile file in your /home directory looks like the following:
PATH=/home/db2user/bin:/home/db2user/sqllib/bin:/home/db2user/sqllib/adm:/home/db2use
r/sqllib/

misc:/home/db2user/sqllib/db2tss/bin

export PATH

2. Configure the cron job. For information on how to configure a cron job, go to:

http://publib.boulder.ibm.com/infocenter/aix/v6r1/index.jsp?topic=/com.ibm.aix.cmds/doc/aixcmds1/
crontab.htm

When you specify a line for running this script, the line should look like the following:
10 0-23 * * * , ~/.profile;command or script/ DB2AuditScript.sh_path

where:

e command or script is the command or script to be executed.

e DB2AuditScript.sh_path is the path of the DB2AuditScript.sh file.

Warning: The . ~/.profile; portion of this line is read as
<period><space><tilde><slash><period>profile<semicolon>.

All of the words denote their exact symbols, including space, so a line in your .cron file for this
script should look like the following:

10 10 * * * . ~/.profile;/home/db2user/DB2Audit/DB2AuditScript.sh

This line runs the script on the tenth minute of the tenth hour, every day.

Configure IBM DB2 UDB for AIX 11
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Configure NetWitness Platform for SFTP and File

Collection

Set up the SFTP Agent, and configure the Log Collector for File Collection.

Set Up the SFTP Agent

To set up the SFTP Agent Collector, download the appropriate PDF from NetWitness Link:
* To set up the SFTP agent on Windows, see [nstall and Update SFTP Agent
e To set up the SFTP agent on Linux, see Configure SETP Shell Script File Transfer

Configure the Log Collector for File Collection

Perform the following steps to configure the Log Collector for File collection.

To configure the Log Collector for file collection:

<4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Collector, and from the Actions (¥ ') menu, choose View >
Config > Event Sources.

3. Select File/Config from the drop-down menu.

The Event Categories panel displays the File event sources that are configured, if any.
4. In the Event Categories panel toolbar, click +.

The Available Event Source Types dialog is displayed.

NETWITNESS Investigate Respond Users Files Dashboard Reports

HOSTS SERVICES EVENT SOURCES ENDPOINT SOURCES HEA & WELLNESS SYSTEM SECURITY

& Change Service | LH4-Sreelakshmi - Log Collector | Config ©
General Remote Collectors Files {8 Event Destinations Settings Appliance Service Configuration

Event Categories

Name

aaaaaaaaa

aaaaa

1. Select the correct type from the list and click OK.

12 Configure NetWitness Platform for SFTP and File Collection
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Select ibmdb2 from the Available Event Source Types dialog.

The newly added event source type is displayed in the Event Categories panel.

Note: The image below uses Apache as an example only. Your screen will look
different, depending on which Event Source type you are configuring.

NETWITNESS

0STS  SERVICES

£ Change Service

General Remote Collectors Files Event Sources [EVRIeENIRENGIES

File

Event Categories

+ -
¥ Name

¥ apache

ES  ENDPOINT SOURCES

LH4-Sreelakshmi - Log Collector |

sources

+ & Import Source

File Directory

homeapache

A% UTES

Settings

true

Appliance Service Configuration

5 Event Source Configuration Guides

Filter by Name / Address X

Address  EventFilte File Spec ~ File Encod Enabled Ignore Ent File Disk C Sequentia Save OnE SaveOnS Manage E Error Files Error Files Error Files Manages Saved File Saved File Saved File Debug

true false  false  1024.. 65536 10 false  1024.. 65536 10 off

6. Select the new type in the Event Categories panel and click + in the Sources panel toolbar.

The Add Source dialog is displayed.

Note: Again, the image below uses Apache as an example only. Your screen will look different,
depending on which Event Source type you are configuring.

File Directory *
Address
File Spec

File Enceding

Enabled

| horreapachel

OK

File Directory * homeapache
Address

File Spec Axg

File Encoding UTF-8
Enabled v

Ignore Encoding

Conversion Errors

File Disk Quota 10 o}
Sequential Processing ¥
Save On Error o4
Save On Success
Eventsource 55H Key
Debug Off v
ManageError Files
Manage Saved Files
-
L3
Cancel 0K

Configure NetWitness Platform for SFTP and File Collection
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7. Add a File Directory name, modify any other parameters that require changes, and click OK.

8. Stop and Restart File Collection. After you add a new event source that uses file collection, you must

stop and restart the NetWitness File Collection service. This is necessary to add the key to the new
event source.

14

Configure NetWitness Platform for SFTP and File Collection
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Configure NetWitness Platform for ODBC Collection

To configure ODBC collection in [[[Undefined variable SAVariables.ProductName]]], perform the
following procedures:

I. Ensure the required parser is enabled
II. Configure a DSN
III. Add the Event Source Type

Ensure the Required Parser is Enabled

If you do not see your parser in the list while performing this procedure, you need to download it in RSA
NetWitness Platform Live.

Ensure that the parser for your event source is available:

Q4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Decoder, and from the Actions (* ) menu, choose View >
Config.

3. In the Service Parsers Configuration panel, search for your event source, and ensure that the
Config Value field for your event source is selected.

Note: The required parser is ibmdb2.

Configure a DSN

Configure a DSN (Data Source Name):

4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Collector service and from the Actions (¥ ) menu, choose View >
Config > Event Sources.

3. In the Log Collector Event Sources tab, select ODBC/DSNs from the drop-down menu.
4. The DSNs panel is displayed with the existing DSNs, if any.

5. Click * to open the Add DSN dialog.

Note: To add a DSN template, see the Configure a DSN topic in the Log Collection Configuration
Guide, available in NetWitness Community.

6. Choose a DSN Template from the drop down menu and enter a name for the DSN. (Use this name

Configure NetWitness Platform for ODBC Collection 15
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when you set up the ODBC event source type.)

7. Fill in the parameters and click Save.

Fed Joweipen

DSN Template Choose the correct template from the available choices.
DSN Name Enter a descriptive name for the DSN

Parameters section
Database Specify the database used by DB2
PortNumber Specify the Port Number. The default port number is 50000
HostName Specify the hostname or [P Address of DB2

Driver Depending on your NetWitness Log Collector version:

e For 10.6.2 and newer, use
/opt/netwitness/odbc/1ib/R3db227.s0

e For 10.6.1 and older, use
/opt/netwitness/odbc/1ib/R3db226.so

Add the Event Source Type

Add the ODBC Event Source Type:

<4
1. In the NetWitness menu, select (Admin) > Services.

2. In the Services grid, select a Log Collector service, and from the Actions (* ') menu, choose View
> Config.

3. In the Log Collector Event Sources tab, select ODBC/Config from the drop-down menu.

The Event Categories panel is displayed with the existing sources, if any.

4. Click + to open the Available Event Source Types dialog.

16 Configure NetWitness Platform for ODBC Collection
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Available Event Source Types

O Name ~
actividentity
asels

bigfix

bite
bmcremedyitsm
ciscolmsaudit
ciscolmsfault
cisconcm
ciscosecagent

ciscosecagenteventid

Oooooooooooadg

dbpinfoalerts

Cancel

5. Choose the log collector configuration type for your event source type and click OK.

In the Available Event Source Types dialog, select ibmdb2.

7. In the Event Categories panel, select the event source type that you just added.

8. In the Sources panel, click + to open the Add Source dialog.

Add Source

Basic
DSN *
Username *
Password
Enabled
Address *
Advanced
Max Cell Size
Nil Value
Polling Interval
Max Events Poll
Debug
Initial Tracking Id

Filename

[«

2048
(rull)
180

5000

oK

9. Enter the DSN you configured during the Configure a DSN procedure.

10. For the other parameters, see the ODBC Event Source Configuration Parameters topic in the Log
Collection Configuration Guide, available in NetWitness Community.

Reference Tables

This event source collects data from the ibmdb2.xml table, using the following typespec files:

Configure NetWitness Platform for ODBC Collection 17
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AUDIT.AUDIT

AUDIT.SYSADMIN
AUDIT.VALIDATE
AUDIT.OBJMAINT
AUDIT.SECMAINT

18 Configure NetWitness Platform for ODBC Collection
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Getting Help with NetWitness Platform

Self-Help Resources

There are several options that provide you with help as you need it for installing and using NetWitness:

See the documentation for all aspects of NetWitness here:
https://community.netwitness.com/t5/netwitness-platform/ct-p/netwitness-documentation.

Use the Search and Create a Post fields in NetWitness Community portal to find specific
information here: https://community.netwitness.com/t5/netwitness-discussions/bd-p/netwitness-
discussions.

See the NetWitness Knowledge Base: https://community.netwitness.com/t5/netwitness-knowledge-
base/tkb-p/netwitness-knowledge-base.

See the documentation for Logstash JDBC input plugin here:
https://www.elastic.co/guide/en/logstash/current/plugins-inputs-jdbc.html.

See Troubleshooting section in the guides.
See also NetWitness® Platform Blog Posts.

If you need further assistance, Contact NetWitness Support.

Contact NetWitness Support

When you contact NetWitness Support, please provide the following information:

The version number of the NetWitness Platform or application you are using.

Logs information, even source version, and collection method.

If you have problem with an event source, enable Debug parameter (set this parameter to On or
Verbose) and collect the debug logs to share with the NetWitness Support team.

Use the following contact information if you have any questions or need assistance.

NetWitness Community Portal https://community.netwitness.com
In the main menu, click Support > Case Portal > View My
Cases.
International Contacts (How to https://community.netwitness.com/t5/support/ct-p/support
Contact NetWitness Support)
Community https://community.netwitness.com/t5/netwitness-discussions/bd-

p/netwitness-discussions

Getting Help with NetWitness Platform
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Feedback on Product Documentation

You can send an email to feedbacknwdocs@netwitness.com to provide feedback on NetWitness Platform

documentation.

20 Getting Help with NetWitness Platform
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